gnu: Replace uses of 'libjpeg' with 'libjpeg-turbo'.
[jackhill/guix/guix.git] / gnu / packages / gnustep.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages gnustep)
23 #:use-module (guix download)
24 #:use-module (guix packages)
25 #:use-module (guix build-system gnu)
26 #:use-module (guix licenses)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages base)
29 #:use-module (gnu packages xorg)
30 #:use-module (gnu packages libffcall)
31 #:use-module (gnu packages gnome)
32 #:use-module (gnu packages gtk)
33 #:use-module (gnu packages texinfo)
34 #:use-module (gnu packages autotools)
35 #:use-module (gnu packages glib)
36 #:use-module (gnu packages fontutils)
37 #:use-module (gnu packages image)
38 #:use-module (gnu packages pkg-config)
39 #:use-module (gnu packages xml)
40 #:use-module (ice-9 match))
41
42 (define-public gnustep-make
43 (package
44 (name "gnustep-make")
45 (version "2.7.0")
46 (source (origin
47 (method url-fetch)
48 (uri (string-append "ftp://ftp.gnustep.org/pub/gnustep/core/"
49 name "-" version ".tar.gz"))
50 (sha256
51 (base32
52 "1khiygfkz0zhh9b5nybn40g0xnnjxchk24n49hff1bwanszir84h"))))
53 (build-system gnu-build-system)
54 (arguments
55 '(#:tests? #f)) ; no check target
56 (native-inputs
57 `(("which" ,which)))
58 (home-page "http://gnustep.org")
59 (synopsis "GNUstep make package")
60 (description "The makefile package is a simple, powerful and extensible way
61 to write makefiles for a GNUstep-based project. It allows the user to write a
62 project without having to deal with the complex issues associated with
63 configuration, building, installation, and packaging. It also allows the user
64 to easily create cross-compiled binaries.")
65 (license gpl3+)))
66
67 (define-public windowmaker
68 (package
69 (name "windowmaker")
70 (version "0.95.8")
71 (synopsis "NeXTSTEP-like window manager")
72 (source (origin
73 (method url-fetch)
74 (uri (string-append
75 "http://windowmaker.org/pub/source/release/WindowMaker-"
76 version ".tar.gz"))
77 (sha256
78 (base32
79 "12p8kljqgx5hnic0zvs5mxwp7kg21sb6qjagb2qw8ydvf5amrgwx"))))
80 (build-system gnu-build-system)
81 (arguments
82 `(#:modules ((guix build gnu-build-system)
83 (guix build utils)
84 (ice-9 match))
85 #:phases
86 (modify-phases %standard-phases
87 (add-before 'configure 'pre-configure
88 (lambda* (#:key outputs #:allow-other-keys)
89 ;; 'wmaker' wants to invoke 'wmaker.inst' the first time,
90 ;; and the 'wmsetbg', so make sure it uses the right ones.
91 ;; We can't use a wrapper here because that would pollute
92 ;; $PATH in the whole session.
93 (let* ((out (assoc-ref outputs "out"))
94 (bin (string-append out "/bin")))
95 (substitute* "src/main.c"
96 (("\"wmaker\\.inst")
97 (string-append "\"" bin "/wmaker.inst")))
98 (substitute* '("src/defaults.c" "WPrefs.app/Menu.c")
99 (("\"wmsetbg")
100 (string-append "\"" bin "/wmsetbg")))
101 ;; Add enough cells to the command character array to
102 ;; allow passing our large path to the wmsetbg binary.
103 ;; The path to wmsetbg in Guix requires 67 extra characters.
104 (substitute* "src/defaults.c"
105 (("len = strlen\\(text\\) \\+ 40;")
106 (string-append "len = strlen(text) + 107;")))
107 #t)))
108 (add-after 'install 'install-xsession
109 (lambda* (#:key outputs #:allow-other-keys)
110 (let* ((out (assoc-ref outputs "out"))
111 (xsessions (string-append out "/share/xsessions")))
112 (mkdir-p xsessions)
113 (call-with-output-file
114 (string-append xsessions "/windowmaker.desktop")
115 (lambda (port)
116 (format port "~
117 [Desktop Entry]~@
118 Name=Window Maker~@
119 Comment=~a~@
120 Exec=~a/bin/wmaker~@
121 Type=Application~%"
122 (string-map (match-lambda
123 (#\newline #\space)
124 (chr chr))
125 ,synopsis) out))))
126 #t))
127 (add-after 'install-xsession 'wrap
128 (lambda* (#:key outputs #:allow-other-keys)
129 (let* ((out (assoc-ref outputs "out"))
130 (bin (string-append out "/bin")))
131 ;; In turn, 'wmaker.inst' wants to invoke 'wmmenugen'
132 ;; etc., so make sure everything is in $PATH.
133 (wrap-program (string-append bin "/wmaker.inst")
134 `("PATH" ":" prefix (,bin)))
135 #t))))))
136 (inputs
137 `(("libxmu" ,libxmu)
138 ("libxft" ,libxft)
139 ("libx11" ,libx11)
140 ("libxinerama" ,libxinerama)
141 ("fontconfig" ,fontconfig)
142 ("libjpeg" ,libjpeg-turbo)
143 ("giflib" ,giflib)
144 ("libpng" ,libpng)
145 ("libtiff" ,libtiff)))
146 (native-inputs
147 `(("pkg-config" ,pkg-config)))
148 (home-page "http://windowmaker.org/")
149 (description
150 "Window Maker is an X11 window manager originally designed to provide
151 integration support for the GNUstep Desktop Environment. In every way
152 possible, it reproduces the elegant look and feel of the NeXTSTEP user
153 interface. It is fast, feature rich, easy to configure, and easy to use.")
154
155 ;; Artwork is distributed under the WTFPL.
156 (license gpl2+)))
157
158 (define-public wmbattery
159 (package
160 (name "wmbattery")
161 (version "2.51")
162 (source (origin
163 (method url-fetch)
164 (uri (string-append
165 "mirror://debian/pool/main/w/wmbattery/wmbattery_"
166 version ".orig.tar.gz"))
167 (sha256
168 (base32
169 "084a3irxbmgms4bqaga80mlx9wgvlkx6d2w0ns939yrpfzg87laj"))))
170 (build-system gnu-build-system)
171 (arguments '(#:tests? #f)) ; no "check" target
172 (inputs
173 `(("glib" ,glib)
174 ("libx11" ,libx11)
175 ("libxext" ,libxext)
176 ("libxpm" ,libxpm)
177 ("upower" ,upower)))
178 (native-inputs
179 `(("autoconf" ,autoconf)
180 ("automake" ,automake)
181 ("pkg-config" ,pkg-config)))
182 (home-page "http://www.dockapps.net/wmbattery")
183 (synopsis "Display laptop battery info")
184 (description
185 "Wmbattery displays the status of your laptop's battery in a small icon.
186 This includes if it is plugged in, if the battery is charging, how many minutes
187 of battery life remain, battery life remaining (with both a percentage and a
188 graph), and battery status (high - green, low - yellow, or critical - red).")
189 (license gpl2)))
190
191 (define-public wmnd
192 (package
193 (name "wmnd")
194 (version "0.4.17")
195 (source (origin
196 (method url-fetch)
197 (uri (string-append
198 "http://www.thregr.org/~wavexx/software/wmnd/releases/"
199 name "-" version ".tar.gz"))
200 (sha256
201 (base32
202 "1amkbiwgr31gwkcp7wrjsr7aj1kns8bpmjpv70n86wb8v9mpm828"))))
203 (build-system gnu-build-system)
204 (inputs
205 `(("libx11" ,libx11)
206 ("libxext" ,libxext)
207 ("libxpm" ,libxpm)))
208 (native-inputs
209 `(("pkg-config" ,pkg-config)))
210 (home-page "http://www.thregr.org/~wavexx/software/wmnd/")
211 (synopsis "Network interface monitor")
212 (description
213 "WMND is a dockapp for monitoring network interfaces under WindowMaker and
214 other compatible window managers.")
215 (license gpl2+)))
216
217 (define-public wmcpuload
218 (package
219 (name "wmcpuload")
220 (version "1.1.1")
221 (source (origin
222 (method url-fetch)
223 (uri (string-append
224 "mirror://debian/pool/main/w/wmcpuload/"
225 name "_" version ".orig.tar.gz"))
226 (sha256
227 (base32
228 "1334y0axnxydwv05d172f405iljrfakg4kcyg9kmn46v6ywv424g"))))
229 (build-system gnu-build-system)
230 (inputs
231 `(("libx11" ,libx11)
232 ("libxext" ,libxext)
233 ("libxpm" ,libxpm)))
234 (native-inputs
235 `(("pkg-config" ,pkg-config)))
236 (home-page "http://www.dockapps.net/wmcpuload")
237 (synopsis "Monitor CPU usage")
238 (description
239 "Wmcpuload displays the current CPU usage, expressed as a percentile and a
240 chart, and has an LCD look-alike user interface. The back-light may be turned
241 on and off by clicking the mouse button over the application. If the CPU usage
242 hits a certain threshold, an alarm-mode will alert you by turning back-light
243 on.")
244 (license gpl2+)))
245
246 (define-public wmclock
247 (package
248 (name "wmclock")
249 (version "1.0.16")
250 (source (origin
251 (method url-fetch)
252 (uri (string-append
253 "mirror://debian/pool/main/w/wmclock/"
254 name "_" version ".orig.tar.gz"))
255 (sha256
256 (base32
257 "1lx276ba8r2yydhmwj1g586jdqg695ad89ng36fr3mb067gvb2rz"))))
258 (build-system gnu-build-system)
259 (inputs
260 `(("libx11" ,libx11)
261 ("libxext" ,libxext)
262 ("libxpm" ,libxpm)))
263 ;; wmclock requires autoreconf to generate its configure script.
264 (native-inputs
265 `(("autoconf" ,autoconf)
266 ("automake" ,automake)
267 ("pkg-config" ,pkg-config)))
268 (home-page "http://www.dockapps.net/wmclock")
269 (synopsis "Display the date and time")
270 (description
271 "wmclock is an applet for Window Maker which displays the date and time in
272 a dockable tile. It features multiple language support, 24h or 12h time
273 display, and can run a user-specified program on mouse click.")
274 (license gpl2+)))
275
276 (define-public wmfire
277 (package
278 (name "wmfire")
279 (version "1.2.4")
280 (source (origin
281 (method url-fetch)
282 (uri (string-append "http://www.improbability.net/"
283 name "/" name "-" version ".tar.gz"))
284 (sha256
285 (base32
286 "101grahd80n97y2dczb629clmcgiavdpbbwy78kk5wgs362m12z3"))
287 (patches
288 (search-patches "wmfire-update-for-new-gdk-versions.patch"))))
289 (build-system gnu-build-system)
290 (inputs
291 `(("gtk+" ,gtk+-2)
292 ("libgtop" ,libgtop)))
293 (native-inputs
294 `(("pkg-config" ,pkg-config)))
295 (home-page "http://www.improbability.net/")
296 (synopsis "Display flames to represent resource usage")
297 (description
298 "wmfire is an applet for Window Maker that can monitor the average cpu
299 load, or individual cpu load on SMP computers. Additionally it can monitor the
300 memory, network load, a file or just be set to show a pretty flame. On
301 entering the dock a burning spot replaces the cursor, and after two seconds
302 symbols to represent the current monitor are \"burnt\" onscreen. The flame
303 colour can also be changed.")
304 (license gpl2+)))