gnu: acme-client: Update to 0.1.15.
[jackhill/guix/guix.git] / gnu / packages / aidc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darringon <jmd@gnu.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages aidc)
21 #:use-module (gnu packages)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (gnu packages pkg-config)
26 #:use-module (gnu packages image)
27 #:use-module (guix build-system gnu))
28
29
30 (define-public barcode
31 (package
32 (name "barcode")
33 (version "0.99")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append "mirror://gnu/barcode/barcode-"
37 version ".tar.xz"))
38 (sha256
39 (base32
40 "1indapql5fjz0bysyc88cmc54y8phqrbi7c76p71fgjp45jcyzp8"))))
41 (build-system gnu-build-system)
42 (synopsis "Convert text strings to printed bars in various standards")
43 (description "GNU Barcode is a flexible tool to produce printed barcodes
44 from text strings. It supports a variety of encoding standards and sizing
45 measurements. Barcodes can be output in PostScript or Encapsulated PostScript
46 formats.")
47 (license license:gpl3+)
48 (home-page "http://www.gnu.org/software/barcode/")))
49
50 (define-public qrencode
51 (package
52 (name "qrencode")
53 (version "3.4.4")
54 (source (origin
55 (method url-fetch)
56 (uri (string-append
57 "https://fukuchi.org/works/qrencode/qrencode-" version
58 ".tar.gz"))
59 (sha256
60 (base32
61 "0wiagx7i8p9zal53smf5abrnh9lr31mv0p36wg017401jrmf5577"))))
62 (build-system gnu-build-system)
63 (inputs `(("libpng" ,libpng)))
64 (native-inputs `(("pkg-config" ,pkg-config)))
65 (synopsis "Encode data into a QR Code symbol")
66 (description "Libqrencode is a C library for encoding data in a QR Code
67 symbol, a kind of 2D symbology that can be scanned by handy terminals such as
68 a mobile phone with CCD. The capacity of QR Code is up to 7000 digits or 4000
69 characters, and is highly robust.")
70 (license license:lgpl2.1+)
71 (home-page "https://fukuchi.org/works/qrencode")))