gnu: qsyncthingtray: Update to 0.5.7.
[jackhill/guix/guix.git] / gnu / packages / sync.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages sync)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix build-system cmake)
22 #:use-module (guix download)
23 #:use-module (guix packages)
24 #:use-module (gnu packages check)
25 #:use-module (gnu packages compression)
26 #:use-module (gnu packages databases)
27 #:use-module (gnu packages linux)
28 #:use-module (gnu packages perl)
29 #:use-module (gnu packages pkg-config)
30 #:use-module (gnu packages qt)
31 #:use-module (gnu packages tls))
32
33 (define-public owncloud-client
34 (package
35 (name "owncloud-client")
36 (version "2.2.4")
37 (source
38 (origin
39 (method url-fetch)
40 (uri (string-append "https://download.owncloud.com/desktop/stable/"
41 "owncloudclient-" version ".tar.xz"))
42 (sha256
43 (base32 "1lz7v5sscj5489panz5ng372g9l66ng0srx6xaz8drnsgi7m64zk"))
44 (modules '((guix build utils)))
45 (snippet
46 '(begin
47 ;; only allows bundled libcrashreporter-qt
48 (delete-file-recursively "src/3rdparty/libcrashreporter-qt")
49 ;; we already package qtkeychain and sqlite
50 (delete-file-recursively "src/3rdparty/qtkeychain")
51 (delete-file-recursively "src/3rdparty/sqlite3")
52 ;; qjson is packaged, qprogessindicator, qlockedfile, qtokenizer and
53 ;; qtsingleapplication have not yet been packaged, but all are
54 ;; explicitly used from the 3rdparty folder during build.
55 ;; We can also remove the macgoodies folder
56 (delete-file-recursively "src/3rdparty/qtmacgoodies")))))
57 (build-system cmake-build-system)
58 (arguments
59 `(#:phases
60 (modify-phases %standard-phases
61 (add-after 'unpack 'change-rpath-dirs
62 (lambda _
63 (substitute* '("src/libsync/CMakeLists.txt"
64 "csync/src/CMakeLists.txt")
65 ;; We store the libs in out/lib and not /usr/lib/appname, so we
66 ;; need the executable to point to the libraries in /lib and not
67 ;; in /lib/appname.
68 (("\\/\\$\\{APPLICATION_EXECUTABLE\\}") ""))
69 (substitute* '("src/cmd/CMakeLists.txt"
70 "src/crashreporter/CMakeLists.txt"
71 "src/gui/CMakeLists.txt")
72 ;; This has the same issue as the substitution above.
73 (("\\/\\$\\{APPLICATION_EXECUTABLE\\}\\\"") "\""))
74 #t))
75 (add-after 'unpack 'delete-failing-tests
76 ;; These tests fail for no apparent reason
77 (lambda _
78 (substitute* "test/CMakeLists.txt"
79 (("owncloud_add_test\\(FileSystem \"\"\\)" test)
80 (string-append "#" test))
81 (("owncloud_add_test\\(Utility \"\"\\)" test)
82 (string-append "#" test)))
83 #t)))
84 #:configure-flags '("-DUNIT_TESTING=ON")))
85 (native-inputs
86 `(("cmocka" ,cmocka)
87 ("perl" ,perl)
88 ("pkg-config" ,pkg-config)
89 ("qtlinguist" ,qttools)))
90 (inputs
91 `(("inotify-tools" ,inotify-tools)
92 ("openssl" ,openssl)
93 ("qtbase" ,qtbase)
94 ("qtkeychain" ,qtkeychain)
95 ("qtwebkit" ,qtwebkit)
96 ("sqlite" ,sqlite)
97 ("zlib" ,zlib)))
98 (home-page "https://owncloud.org")
99 (synopsis "Folder synchronization with an ownCloud server")
100 (description "The ownCloudSync system lets you always have your latest
101 files wherever you are. Just specify one or more folders on the local machine
102 to and a server to synchronize to. You can configure more computers to
103 synchronize to the same server and any change to the files on one computer will
104 silently and reliably flow across to every other.")
105 (license license:gpl2+)))
106
107 (define-public qsyncthingtray
108 (package
109 (name "qsyncthingtray")
110 (version "0.5.7")
111 (source
112 (origin
113 (method url-fetch)
114 (uri (string-append
115 "https://github.com/sieren/QSyncthingTray/archive/"
116 version ".tar.gz"))
117 (file-name (string-append name "-" version ".tar.gz"))
118 (sha256
119 (base32
120 "1qzlxgq36sb1dk621nkbjw9k6y3css6q3z8xzx6nv7f327vanvp6"))))
121 (build-system cmake-build-system)
122 (arguments
123 `(#:configure-flags '("-DQST_BUILD_WEBKIT=1")
124 #:phases
125 (modify-phases %standard-phases
126 ;; The program is meant to be run from the git repo or source tarball.
127 (replace 'install
128 (lambda* (#:key outputs #:allow-other-keys)
129 (let* ((out (assoc-ref outputs "out"))
130 (bin (string-append out "/bin")))
131 (install-file "QSyncthingTray" bin)
132 (install-file (string-append
133 "../QSyncthingTray-"
134 ,(package-version qsyncthingtray)
135 "/resources/images/Icon1024.png")
136 (string-append
137 out "/share/pixmaps/QSyncthingTray.png"))
138 #t))))
139 #:tests? #f)) ; no test target
140 (inputs
141 `(("qtbase" ,qtbase)
142 ("qtwebkit" ,qtwebkit)))
143 (home-page "https://github.com/sieren/QSyncthingTray")
144 (synopsis "Traybar Application for Syncthing")
145 (description
146 "A traybar application for syncthing.
147 @enumerate
148 @item Shows number of connections at a glance.
149 @item Traffic statistics about incoming, outgoing and total throughput.
150 @item Launches Syncthing and Syncthing-iNotifier if specified.
151 @item Quickly pause Syncthing with one click.
152 @item Last Synced Files - Quickly see the recently synchronised files and open
153 their folder.
154 @item Quick Access to all shared folders.
155 @item Presents Syncthing UI in a separate view instead of using the browser.
156 @item Supports authenticated HTTPS connections.
157 @item Uses System Notifications about current connection status.
158 @item Toggle for monochrome icon.
159 @end enumerate\n")
160 (license license:lgpl3+)))