Correct name and Email for ng0.
[jackhill/guix/guix.git] / gnu / packages / suckless.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2015 Amirouche Boubekki <amirouche@hypermove.net>
4 ;;; Copyright © 2016 Al McElrath <hello@yrns.org>
5 ;;; Copyright © 2016, 2017 Nils Gillmann <ng0@n0.is>
6 ;;; Copyright © 2015 Dmitry Bogatov <KAction@gnu.org>
7 ;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
8 ;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
9 ;;; Copyright © 2017 Alex Griffin <a@ajgrf.com>
10 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
11 ;;;
12 ;;; This file is part of GNU Guix.
13 ;;;
14 ;;; GNU Guix is free software; you can redistribute it and/or modify it
15 ;;; under the terms of the GNU General Public License as published by
16 ;;; the Free Software Foundation; either version 3 of the License, or (at
17 ;;; your option) any later version.
18 ;;;
19 ;;; GNU Guix is distributed in the hope that it will be useful, but
20 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
21 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
22 ;;; GNU General Public License for more details.
23 ;;;
24 ;;; You should have received a copy of the GNU General Public License
25 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
26
27 (define-module (gnu packages suckless)
28 #:use-module ((guix licenses) #:prefix license:)
29 #:use-module (guix packages)
30 #:use-module (guix download)
31 #:use-module (guix git-download)
32 #:use-module (guix build-system gnu)
33 #:use-module (guix build-system glib-or-gtk)
34 #:use-module (gnu packages)
35 #:use-module (gnu packages gnome)
36 #:use-module (gnu packages image)
37 #:use-module (gnu packages xorg)
38 #:use-module (gnu packages fonts)
39 #:use-module (gnu packages pkg-config)
40 #:use-module (gnu packages webkit)
41 #:use-module (gnu packages fontutils)
42 #:use-module (gnu packages mpd)
43 #:use-module (gnu packages linux)
44 #:use-module (gnu packages compression)
45 #:use-module (gnu packages cups)
46 #:use-module (gnu packages ncurses)
47 #:use-module (gnu packages gawk)
48 #:use-module (gnu packages base)
49 #:use-module (gnu packages libbsd))
50
51 (define-public blind
52 (package
53 (name "blind")
54 (version "1.1")
55 (source (origin
56 (method url-fetch)
57 (uri (string-append "https://dl.suckless.org/tools/blind-"
58 version ".tar.gz"))
59 (sha256
60 (base32
61 "0nncvzyipvkkd7zlgzwbjygp82frzs2hvbnk71gxf671np607y94"))))
62 (build-system gnu-build-system)
63 (arguments
64 '(#:tests? #f ; no check target
65 #:make-flags (list
66 "CC=gcc"
67 (string-append "PREFIX=" %output))
68 #:phases
69 (modify-phases %standard-phases
70 (delete 'configure)))) ; no configure script
71 (synopsis "Command line video editing utilities")
72 (home-page "https://tools.suckless.org/blind/")
73 (description
74 "Blind is a collection of command line video editing utilities. It uses
75 a custom raw video format with a simple container.")
76 (license license:isc)))
77
78 (define-public dwm
79 (package
80 (name "dwm")
81 (version "6.1")
82 (source (origin
83 (method url-fetch)
84 (uri (string-append "https://dl.suckless.org/dwm/dwm-"
85 version ".tar.gz"))
86 (sha256
87 (base32 "1zkmwb6df6m254shx06ly90c0q4jl70skk1pvkixpb7hcxhwbxn2"))))
88 (build-system gnu-build-system)
89 (arguments
90 `(#:tests? #f
91 #:make-flags (list (string-append "FREETYPEINC="
92 (assoc-ref %build-inputs "freetype")
93 "/include/freetype2"))
94 #:phases
95 (modify-phases %standard-phases
96 (replace 'configure
97 (lambda _
98 (substitute* "Makefile" (("\\$\\{CC\\}") "gcc"))
99 #t))
100 (replace 'install
101 (lambda* (#:key outputs #:allow-other-keys)
102 (let ((out (assoc-ref outputs "out")))
103 (zero?
104 (system* "make" "install"
105 (string-append "DESTDIR=" out) "PREFIX=")))))
106 (add-after 'build 'install-xsession
107 (lambda* (#:key outputs #:allow-other-keys)
108 ;; Add a .desktop file to xsessions.
109 (let* ((output (assoc-ref outputs "out"))
110 (xsessions (string-append output "/share/xsessions")))
111 (mkdir-p xsessions)
112 (with-output-to-file
113 (string-append xsessions "/dwm.desktop")
114 (lambda _
115 (format #t
116 "[Desktop Entry]~@
117 Name=dwm~@
118 Comment=Dynamic Window Manager~@
119 Exec=~a/bin/dwm~@
120 TryExec=~@*~a/bin/dwm~@
121 Icon=~@
122 Type=Application~%"
123 output)))
124 #t))))))
125 (inputs
126 `(("freetype" ,freetype)
127 ("libx11" ,libx11)
128 ("libxft" ,libxft)
129 ("libxinerama" ,libxinerama)))
130 (home-page "https://dwm.suckless.org/")
131 (synopsis "Dynamic window manager")
132 (description
133 "dwm is a dynamic window manager for X. It manages windows in tiled,
134 monocle and floating layouts. All of the layouts can be applied dynamically,
135 optimising the environment for the application in use and the task performed.")
136 (license license:x11)))
137
138 (define-public dmenu
139 (package
140 (name "dmenu")
141 (version "4.8")
142 (source (origin
143 (method url-fetch)
144 (uri (string-append "https://dl.suckless.org/tools/dmenu-"
145 version ".tar.gz"))
146 (sha256
147 (base32
148 "0qfvfrj10xlwd9hkvb57wshryan65bl6423h0qhiw1h76rf5lqgy"))))
149 (build-system gnu-build-system)
150 (arguments
151 '(#:tests? #f ; no tests
152 #:make-flags (list "CC=gcc"
153 (string-append "PREFIX=" %output)
154 (string-append "FREETYPEINC="
155 (assoc-ref %build-inputs "freetype")
156 "/include/freetype2"))
157 #:phases
158 (modify-phases %standard-phases (delete 'configure))))
159 (inputs
160 `(("freetype" ,freetype)
161 ("libxft" ,libxft)
162 ("libx11" ,libx11)
163 ("libxinerama" ,libxinerama)))
164 (home-page "https://tools.suckless.org/dmenu/")
165 (synopsis "Dynamic menu")
166 (description
167 "A dynamic menu for X, originally designed for dwm. It manages large
168 numbers of user-defined menu items efficiently.")
169 (license license:x11)))
170
171 (define-public spoon
172 (package
173 (name "spoon")
174 (version "0.3")
175 (source
176 (origin
177 (method url-fetch)
178 (uri (string-append "https://dl.2f30.org/releases/"
179 name "-" version ".tar.gz"))
180 (sha256
181 (base32
182 "10c5i7ykpy7inzzfiw1dh0srpkljycr3blxhvd8160wsvplbws48"))))
183 (build-system gnu-build-system)
184 (arguments
185 `(#:tests? #f ; No tests
186 #:make-flags (list "CC=gcc"
187 (string-append "PREFIX=" %output))))
188 (inputs
189 `(("libx11" ,libx11)
190 ("libxkbfile" ,libxkbfile)
191 ("alsa-lib" ,alsa-lib)
192 ("libmpdclient" ,libmpdclient)))
193 (home-page "https://git.2f30.org/spoon/")
194 (synopsis "Set dwm status")
195 (description
196 "Spoon can be used to set the dwm status.")
197 (license license:isc)))
198
199 (define-public slock
200 (package
201 (name "slock")
202 (version "1.4")
203 (source (origin
204 (method url-fetch)
205 (uri (string-append "https://dl.suckless.org/tools/slock-"
206 version ".tar.gz"))
207 (sha256
208 (base32
209 "0sif752303dg33f14k6pgwq2jp1hjyhqv6x4sy3sj281qvdljf5m"))))
210 (build-system gnu-build-system)
211 (arguments
212 '(#:tests? #f ; no tests
213 #:make-flags (list "CC=gcc"
214 (string-append "PREFIX=" %output))
215 #:phases (modify-phases %standard-phases (delete 'configure))))
216 (inputs
217 `(("libx11" ,libx11)
218 ("libxext" ,libxext)
219 ("libxinerama" ,libxinerama)
220 ("libxrandr" ,libxrandr)))
221 (home-page "https://tools.suckless.org/slock/")
222 (synopsis "Simple X session lock")
223 (description
224 "Simple X session lock with trivial feedback on password entry.")
225 (license license:x11)))
226
227 (define-public st
228 (package
229 (name "st")
230 (version "0.7")
231 (source
232 (origin
233 (method url-fetch)
234 (uri (string-append "https://dl.suckless.org/st/st-"
235 version ".tar.gz"))
236 (sha256
237 (base32
238 "00309qiw20rc89696pk8bdr7ik4r1aarik7jxqk8k66cdj80v1zp"))))
239 (build-system gnu-build-system)
240 (arguments
241 '(#:tests? #f ; no tests
242 #:make-flags (list "CC=gcc"
243 (string-append "PREFIX=" %output))
244 #:phases
245 (modify-phases %standard-phases
246 (delete 'configure)
247 (add-after 'unpack 'inhibit-terminfo-install
248 (lambda _
249 (substitute* "Makefile"
250 (("\t@tic -s st.info") ""))
251 #t)))))
252 (inputs
253 `(("libx11" ,libx11)
254 ("libxft" ,libxft)
255 ("fontconfig" ,fontconfig)
256 ("freetype" ,freetype)))
257 (native-inputs `(("pkg-config" ,pkg-config)))
258 (home-page "https://st.suckless.org/")
259 (synopsis "Simple terminal emulator")
260 (description
261 "St implements a simple and lightweight terminal emulator. It
262 implements 256 colors, most VT10X escape sequences, utf8, X11 copy/paste,
263 antialiased fonts (using fontconfig), fallback fonts, resizing, and line
264 drawing.")
265 (license license:x11)))
266
267 (define-public surf
268 (package
269 (name "surf")
270 (version "2.0")
271 (source
272 (origin
273 (method url-fetch)
274 (uri (string-append "https://dl.suckless.org/surf/surf-"
275 version ".tar.gz"))
276 (sha256
277 (base32
278 "07cmajyafljigy10d21kkyvv5jf3hxkx06pz3rwwk3y3c9x4rvps"))))
279 (build-system glib-or-gtk-build-system)
280 (arguments
281 '(#:tests? #f ; no tests
282 #:make-flags (list "CC=gcc"
283 (string-append "PREFIX=" %output))
284 #:phases
285 (modify-phases %standard-phases
286 (delete 'configure)
287 ;; Use the right file name for dmenu and xprop.
288 (add-before 'build 'set-dmenu-and-xprop-file-name
289 (lambda* (#:key inputs #:allow-other-keys)
290 (substitute* "config.def.h"
291 (("dmenu") (string-append (assoc-ref inputs "dmenu") "/bin/dmenu"))
292 (("xprop") (string-append (assoc-ref inputs "xprop") "/bin/xprop")))
293 #t)))))
294 (inputs
295 `(("dmenu" ,dmenu)
296 ("glib-networking" ,glib-networking)
297 ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
298 ("webkitgtk" ,webkitgtk)
299 ("xprop" ,xprop)))
300 (native-inputs
301 `(("pkg-config" ,pkg-config)))
302 (home-page "https://surf.suckless.org/")
303 (synopsis "Simple web browser")
304 (description
305 "Surf is a simple web browser based on WebKit/GTK+. It is able to
306 display websites and follow links. It supports the XEmbed protocol which
307 makes it possible to embed it in another application. Furthermore, one can
308 point surf to another URI by setting its XProperties.")
309 (license license:x11)))
310
311 (define-public sent
312 (package
313 (name "sent")
314 (version "0.2")
315 (source (origin
316 (method url-fetch)
317 (uri (string-append "https://dl.suckless.org/tools/sent-"
318 version ".tar.gz"))
319 (sha256
320 (base32
321 "0xhh752hwaa26k4q6wvrb9jnpbnylss2aw6z11j7l9rav7wn3fak"))))
322 (build-system gnu-build-system)
323 (arguments
324 `(#:phases (modify-phases %standard-phases
325 (delete 'configure)) ;no configuration
326 #:tests? #f ;no test suite
327 #:make-flags (let ((pkg-config (lambda (flag)
328 (string-append
329 "$(shell pkg-config " flag " "
330 "xft fontconfig x11 libpng)"))))
331 (list
332 "CC=gcc"
333 (string-append "PREFIX=" %output)
334 (string-append "INCS=-I. " (pkg-config "--cflags"))
335 (string-append "LIBS=" (pkg-config "--libs") " -lm")))))
336 (native-inputs
337 `(("pkg-config" ,pkg-config)))
338 (inputs
339 `(("libpng" ,libpng)
340 ("libx11" ,libx11)
341 ("libxft" ,libxft)
342 ("fontconfig" ,fontconfig)))
343 (synopsis "Plaintext presentation tool")
344 (description "Sent uses plaintext files and PNG images to create slideshow
345 presentations. Each paragraph represents a slide in the presentation.
346 Especially for presentations using the Takahashi method this is very nice and
347 allows you to write down the presentation for a quick lightning talk within a
348 few minutes.")
349 (home-page "https://tools.suckless.org/sent")
350 (license license:x11)))
351
352 (define-public xbattmon
353 (package
354 (name "xbattmon")
355 (version "1.1")
356 (source
357 (origin
358 (method url-fetch)
359 (uri (string-append "https://dl.2f30.org/releases/"
360 name "-" version ".tar.gz"))
361 (sha256
362 (base32
363 "1zr6y8lml9xkx0a3dbbsds2qz1bjxvskp7wsckkf8mlsqrbb3xsg"))))
364 (build-system gnu-build-system)
365 (arguments
366 `(#:tests? #f ; No tests
367 #:make-flags (list "CC=gcc"
368 (string-append "PREFIX=" %output))))
369 (inputs
370 `(("libx11" ,libx11)))
371 (home-page "https://git.2f30.org/xbattmon/")
372 (synopsis "Simple battery monitor for X")
373 (description
374 "Xbattmon is a simple battery monitor for X.")
375 (license license:isc)))
376
377 (define-public wificurse
378 (package
379 (name "wificurse")
380 (version "0.3.9")
381 (source
382 (origin
383 (method url-fetch)
384 (uri (string-append "https://dl.2f30.org/releases/"
385 name "-" version ".tar.gz"))
386 (sha256
387 (base32
388 "067ghr1xly5ca41kc83xila1p5hpq0bxfcmc8jvxi2ggm6wrhavn"))))
389 (build-system gnu-build-system)
390 (arguments
391 `(#:tests? #f ; No tests
392 #:make-flags (list
393 (string-append "PREFIX=" %output))
394 #:phases
395 (modify-phases %standard-phases
396 (delete 'configure)))) ; No configure script
397 (home-page "https://git.2f30.org/wificurse/")
398 (synopsis "Wifi DoS attack tool")
399 (description
400 "Wificurses listens for beacons sent from wireless access points
401 in the range of your wireless station. Once received the program
402 extracts the BSSID of the AP and transmits deauthentication packets
403 using the broadcast MAC address. This results to the disconnection
404 of all clients connected to the AP at the time of the attack. This
405 is essencially a WiFi DoS attack tool created for educational
406 purposes only. It works only in Linux and requires wireless card
407 drivers capable of injecting packets in wireless networks.")
408 (license license:gpl3+)))
409
410 (define-public skroll
411 (package
412 (name "skroll")
413 (version "0.6")
414 (source
415 (origin
416 (method url-fetch)
417 (uri (string-append "https://dl.2f30.org/releases/"
418 name "-" version ".tar.gz"))
419 (sha256
420 (base32
421 "0km6bjfz4ssb1z0xwld6iiixnn7d255ax8yjs3zkdm42z8q9yl0f"))))
422 (build-system gnu-build-system)
423 (arguments
424 `(#:tests? #f ; No tests
425 #:make-flags (list "CC=gcc"
426 (string-append "PREFIX=" %output))
427 #:phases
428 (modify-phases %standard-phases
429 (delete 'configure)))) ; No configure script
430 (home-page "https://2f30.org/")
431 (synopsis "Commandline utility which scrolls text")
432 (description
433 "Skroll is a small utility that you can use to make a text scroll.
434 Pipe text to it, and it will scroll a given number of letters from right to
435 left.")
436 (license license:wtfpl2)))
437
438 (define-public sbm
439 (package
440 (name "sbm")
441 (version "0.9")
442 (source
443 (origin
444 (method url-fetch)
445 (uri (string-append "https://dl.2f30.org/releases/"
446 name "-" version ".tar.gz"))
447 (sha256
448 (base32
449 "1nks5mkh5wn30kyjzlkjlgi31bv1wq52kbp0r6nzbyfnvfdlywik"))))
450 (build-system gnu-build-system)
451 (arguments
452 `(#:tests? #f ; No tests
453 #:make-flags (list "CC=gcc"
454 (string-append "PREFIX=" %output))
455 #:phases
456 (modify-phases %standard-phases
457 (delete 'configure)))) ; No configure script
458 (home-page "https://git.2f30.org/sbm/")
459 (synopsis "Simple bandwidth monitor")
460 (description
461 "Sbm is a simple bandwidth monitor.")
462 (license license:isc)))
463
464 (define-public prout
465 (package
466 (name "prout")
467 (version "0.2")
468 (source
469 (origin
470 (method url-fetch)
471 (uri (string-append "https://dl.2f30.org/releases/"
472 name "-" version ".tar.gz"))
473 (sha256
474 (base32
475 "1s6c3ygg1h1fyxkh8gd7nzjk6qhnwsb4535d2k780kxnwns5fzas"))))
476 (build-system gnu-build-system)
477 (arguments
478 `(#:tests? #f ; No tests
479 #:make-flags (list "CC=gcc"
480 (string-append "PREFIX=" %output))
481 #:phases
482 (modify-phases %standard-phases
483 (delete 'configure)))) ; No configure script
484 (inputs
485 `(("cups-minimal" ,cups-minimal)
486 ("zlib" ,zlib)))
487 (home-page "https://git.2f30.org/prout/")
488 (synopsis "Smaller lp command")
489 (description
490 "Prout (PRint OUT) is a small utility one can use to send
491 documents to a printer.
492 It has no feature, and does nothing else. Just set your default
493 printer in client.conf(5) and start printing. No need for a local
494 cups server to be installed.")
495 (license license:wtfpl2)))
496
497 (define-public noice
498 (package
499 (name "noice")
500 (version "0.6")
501 (source
502 (origin
503 (method url-fetch)
504 (uri (string-append "https://dl.2f30.org/releases/"
505 name "-" version ".tar.gz"))
506 (sha256
507 (base32
508 "0ldkbb71z6k4yzj4kpg3s94ijj1c1kx9dfcjz393py09scfyg5hr"))))
509 (build-system gnu-build-system)
510 (arguments
511 `(#:tests? #f ; No tests
512 #:make-flags (list "CC=gcc"
513 (string-append "PREFIX=" %output))
514 #:phases
515 (modify-phases %standard-phases
516 (delete 'configure) ; No configure script
517 (add-before 'build 'curses
518 (lambda _
519 (substitute* "Makefile"
520 (("lcurses") "lncurses")))))))
521 (inputs
522 `(("ncurses" ,ncurses)))
523 (home-page "https://git.2f30.org/noice/")
524 (synopsis "Small file browser")
525 (description
526 "Noice is a small curses-based file browser.")
527 (license license:bsd-2)))
528
529 ;;; We want some commits that are more recent than the latest release, 0.2
530 (define-public human
531 (let ((commit "50c80e6ba12823184b6866e06b955dbd2ccdc5d7")
532 (revision "1"))
533 (package
534 (name "human")
535 (version (string-append "0.2-" revision "." (string-take commit 7)))
536 (source
537 (origin
538 (method git-fetch)
539 (uri (git-reference
540 (url "git://git.2f30.org/human.git")
541 (commit commit)))
542 (file-name (string-append name "-" version "-checkout"))
543 (sha256
544 (base32
545 "18xngm4h9vsyip52zwd79rrp1irzg6rs462lpbp61amf7hj955gn"))))
546 (build-system gnu-build-system)
547 (arguments
548 `(#:tests? #f ; No tests
549 #:make-flags (list "CC=gcc"
550 (string-append "PREFIX=" %output))
551 #:phases
552 (modify-phases %standard-phases
553 (delete 'configure)))) ; No configure script
554 (home-page "https://git.2f30.org/human/")
555 (synopsis "Convert bytes to human readable formats")
556 (description
557 "Human is a small program which translate numbers into a
558 human readable format. By default, it tries to detect the best
559 factorisation, but you can force its output.
560 You can adjust the number of decimals with the @code{SCALE}
561 environment variable.")
562 (license license:wtfpl2))))
563
564 (define-public fortify-headers
565 (package
566 (name "fortify-headers")
567 (version "0.9")
568 (source
569 (origin
570 (method url-fetch)
571 (uri (string-append "https://dl.2f30.org/releases/"
572 name "-" version ".tar.gz"))
573 (sha256
574 (base32
575 "1z517ajy34l2k5lz2gvhbmia9xjgagffi4s22azqxnlmgb1g2xfg"))))
576 (build-system gnu-build-system)
577 (arguments
578 `(#:tests? #f ; No tests
579 #:make-flags (list "CC=gcc"
580 (string-append "PREFIX=" %output))
581 #:phases
582 (modify-phases %standard-phases
583 (delete 'configure)))) ; No configure script
584 (home-page "https://git.2f30.org/fortify-headers/")
585 (synopsis "Standalone fortify-source implementation")
586 (description
587 "This is a standalone implementation of fortify source. It provides
588 compile time buffer checks. It is libc-agnostic and simply overlays the
589 system headers by using the @code{#include_next} extension found in GCC. It was
590 initially intended to be used on musl-based Linux distributions.
591
592 @itemize
593 @item It is portable, works on *BSD, Linux, Solaris and possibly others.
594 @item It will only trap non-conformant programs. This means that fortify
595 level 2 is treated in the same way as level 1.
596 @item Avoids making function calls when undefined behaviour has already been
597 invoked. This is handled by using @code{__builtin_trap()}.
598 @item Support for out-of-bounds read interfaces, such as @code{send()},
599 @code{write()}, @code{fwrite()}, etc.
600 @item No ABI is enforced. All of the fortify check functions are inlined
601 into the resulting binary.
602 @end itemize\n")
603 (license license:isc)))
604
605 (define-public colors
606 (package
607 (name "colors")
608 (version "0.3")
609 (source
610 (origin
611 (method url-fetch)
612 (uri (string-append "https://dl.2f30.org/releases/"
613 name "-" version ".tar.gz"))
614 (sha256
615 (base32
616 "1lckmqpgj89841splng0sszbls2ag71ggkgr1wsv9y3v6y87589z"))))
617 (build-system gnu-build-system)
618 (arguments
619 `(#:tests? #f ; No tests
620 #:make-flags (list "CC=gcc"
621 (string-append "PREFIX=" %output))
622 #:phases
623 (modify-phases %standard-phases
624 (delete 'configure)))) ; No configure script
625 (inputs
626 `(("libpng" ,libpng)))
627 (home-page "https://git.2f30.org/colors/")
628 (synopsis "Extract colors from pictures")
629 (description
630 "Extract colors from PNG files. It is similar to
631 strings(1) but for pictures. For a given input file it outputs a
632 colormap to stdout.")
633 (license license:isc)))
634
635 ;; No new releases were made at github, this repository is more active than
636 ;; the one at http://git.suckless.org/libutf/ and it is
637 ;; done by the same developer.
638 (define-public libutf
639 (let ((revision "1")
640 (commit "ff4c60635e1f455b0a0b4200f8183fbd5a88225b"))
641 (package
642 (name "libutf")
643 (version (string-append "0.0.0-" revision "." (string-take commit 7)))
644 (source
645 (origin
646 (method git-fetch)
647 (uri (git-reference
648 (url "https://github.com/cls/libutf")
649 (commit commit)))
650 (file-name (string-append name "-" version "-checkout"))
651 (sha256
652 (base32
653 "1ih5vjavilzggyr1j1z6w1z12c2fs5fg77cfnv7ami5ivsy3kg3d"))))
654 (build-system gnu-build-system)
655 (arguments
656 `(#:tests? #f ; No tests
657 #:make-flags (list "CC=gcc"
658 (string-append "PREFIX=" %output))
659 #:phases
660 (modify-phases %standard-phases
661 (delete 'configure)))) ; No configure script
662 (inputs
663 `(("gawk" ,gawk)))
664 (home-page "https://github.com/cls/libutf")
665 (synopsis "Plan 9 compatible UTF-8 library")
666 (description
667 "This is a C89 UTF-8 library, with an API compatible with that of
668 Plan 9's libutf, but with a number of improvements:
669
670 @itemize
671 @item Support for runes beyond the Basic Multilingual Plane.
672 @item utflen and utfnlen cannot overflow on 32- or 64-bit machines.
673 @item chartorune treats all invalid codepoints as though Runeerror.
674 @item fullrune, utfecpy, and utfnlen do not overestimate the length
675 of malformed runes.
676 @item An extra function, charntorune(p,s,n), equivalent to
677 fullrune(s,n) ? chartorune(p,s): 0.
678 @item Runeerror may be set to an alternative replacement value, such
679 as -1, to be used instead of U+FFFD.
680 @end itemize\n")
681 (license license:expat))))
682
683 ;; No release tarballs so far.
684 (define-public lchat
685 (let ((revision "2")
686 (commit "25d90f4630b45e2b609d2e3daecb32cf5ff065fd"))
687 (package
688 (name "lchat")
689 (version (string-append "0.0.0-" revision "." (string-take commit 7)))
690 (source
691 (origin
692 (method git-fetch)
693 (uri (git-reference
694 (url "https://github.com/younix/lchat")
695 (commit commit)))
696 (file-name (string-append name "-" version "-checkout"))
697 (sha256
698 (base32
699 "0dvljyq3m7rxxkqv7rkmijak6vj8i4db3iq2z988bvf76chz268b"))))
700 (build-system gnu-build-system)
701 (arguments
702 `(#:tests? #f ; No tests
703 #:make-flags (list "CC=gcc"
704 (string-append "PREFIX=" %output))
705 #:phases
706 (modify-phases %standard-phases
707 (delete 'configure) ; No configure script
708 (add-before 'build 'libbsd
709 (lambda _
710 (substitute* "Makefile"
711 (("-lutf") "-lutf -lbsd"))))
712 (replace 'install
713 (lambda* (#:key outputs #:allow-other-keys)
714 (let* ((out (assoc-ref outputs "out"))
715 (bin (string-append out "/bin")))
716 (install-file "lchat" bin)
717 #t))))))
718 (inputs
719 `(("grep" ,grep)
720 ("ncurses" ,ncurses)
721 ("libutf" ,libutf)
722 ("libbsd" ,libbsd)))
723 (home-page "https://github.com/younix/lchat")
724 (synopsis "Line chat is a frontend for the irc client ii from suckless")
725 (description
726 "Lchat (line chat) is the little and small brother of cii.
727 It is a front end for ii-like chat programs. It uses tail(1) -f to get the
728 chat output in background.")
729 (license license:isc))))