Correct name and Email for ng0.
[jackhill/guix/guix.git] / gnu / packages / ssh.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
5 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
7 ;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
8 ;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
9 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
10 ;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
11 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
12 ;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
13 ;;;
14 ;;; This file is part of GNU Guix.
15 ;;;
16 ;;; GNU Guix is free software; you can redistribute it and/or modify it
17 ;;; under the terms of the GNU General Public License as published by
18 ;;; the Free Software Foundation; either version 3 of the License, or (at
19 ;;; your option) any later version.
20 ;;;
21 ;;; GNU Guix is distributed in the hope that it will be useful, but
22 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
23 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
24 ;;; GNU General Public License for more details.
25 ;;;
26 ;;; You should have received a copy of the GNU General Public License
27 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
28
29 (define-module (gnu packages ssh)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages autotools)
32 #:use-module (gnu packages base)
33 #:autoload (gnu packages boost) (boost)
34 #:use-module (gnu packages compression)
35 #:use-module (gnu packages crypto)
36 #:use-module (gnu packages elf)
37 #:use-module (gnu packages gnupg)
38 #:use-module (gnu packages gperf)
39 #:use-module (gnu packages groff)
40 #:use-module (gnu packages guile)
41 #:use-module (gnu packages linux)
42 #:use-module (gnu packages logging)
43 #:use-module (gnu packages m4)
44 #:use-module (gnu packages multiprecision)
45 #:use-module (gnu packages ncurses)
46 #:use-module (gnu packages nettle)
47 #:use-module (gnu packages kerberos)
48 #:use-module (gnu packages perl)
49 #:use-module (gnu packages pkg-config)
50 #:use-module (gnu packages popt)
51 #:autoload (gnu packages protobuf) (protobuf)
52 #:use-module (gnu packages readline)
53 #:use-module (gnu packages texinfo)
54 #:use-module (gnu packages tls)
55 #:use-module (gnu packages xorg)
56 #:use-module (guix build-system cmake)
57 #:use-module (guix build-system gnu)
58 #:use-module (guix download)
59 #:use-module (guix git-download)
60 #:use-module ((guix licenses) #:prefix license:)
61 #:use-module (guix packages)
62 #:use-module (srfi srfi-1))
63
64 (define-public libssh
65 ;; This commit from the 'v0-7' branch contains 7 memory-management-related
66 ;; bug fixes that we'd rather have.
67 (let ((commit "239d0f75b5f909174c2ef7fb08d23bcfa6b20ba0")
68 (revision "0"))
69 (package
70 (name "libssh")
71 (version (git-version "0.7.5" revision commit))
72 (source (origin
73 (method git-fetch)
74 (uri (git-reference
75 (url "https://git.libssh.org/projects/libssh.git")
76 (commit commit)))
77 (sha256
78 (base32
79 "01w72w1jsgs9ilj3n1gp6qkmdxr9n74i5h2nipi3x1vzm7bv8na1"))
80 (patches (search-patches "libssh-hostname-parser-bug.patch"))
81 (file-name (git-file-name name version))))
82 (build-system cmake-build-system)
83 (outputs '("out" "debug"))
84 (arguments
85 '(#:configure-flags '("-DWITH_GCRYPT=ON")
86
87 ;; TODO: Add 'CMockery' and '-DWITH_TESTING=ON' for the test suite.
88 #:tests? #f))
89 (inputs `(("zlib" ,zlib)
90 ("libgcrypt" ,libgcrypt)))
91 (synopsis "SSH client library")
92 (description
93 "libssh is a C library implementing the SSHv2 and SSHv1 protocol for
94 client and server implementations. With libssh, you can remotely execute
95 programs, transfer files, and use a secure and transparent tunnel for your
96 remote applications.")
97 (home-page "https://www.libssh.org")
98 (license license:lgpl2.1+))))
99
100 (define-public libssh2
101 (package
102 (name "libssh2")
103 (version "1.8.0")
104 (source (origin
105 (method url-fetch)
106 (uri (string-append
107 "https://www.libssh2.org/download/libssh2-"
108 version ".tar.gz"))
109 (sha256
110 (base32
111 "1m3n8spv79qhjq4yi0wgly5s5rc8783jb1pyra9bkx1md0plxwrr"))
112 (patches
113 (search-patches "libssh2-fix-build-failure-with-gcrypt.patch"))))
114 (build-system gnu-build-system)
115 ;; The installed libssh2.pc file does not include paths to libgcrypt and
116 ;; zlib libraries, so we need to propagate the inputs.
117 (propagated-inputs `(("libgcrypt" ,libgcrypt)
118 ("zlib" ,zlib)))
119 (arguments '(#:configure-flags `("--with-libgcrypt")
120 #:phases (modify-phases %standard-phases
121 (add-before 'configure 'autoreconf
122 (lambda _
123 (zero? (system* "autoreconf" "-v")))))))
124 (native-inputs `(("autoconf" ,autoconf)
125 ("automake" ,automake)))
126 (synopsis "Client-side C library implementing the SSH2 protocol")
127 (description
128 "libssh2 is a library intended to allow software developers access to
129 the SSH-2 protocol in an easy-to-use self-contained package. It can be built
130 into an application to perform many different tasks when communicating with
131 a server that supports the SSH-2 protocol.")
132 (license license:bsd-3)
133 (home-page "http://www.libssh2.org/")))
134
135 (define-public openssh
136 (package
137 (name "openssh")
138 (version "7.6p1")
139 (source (origin
140 (method url-fetch)
141 (uri (string-append "mirror://openbsd/OpenSSH/portable/"
142 name "-" version ".tar.gz"))
143 (sha256
144 (base32
145 "08qpsb8mrzcx8wgvz9insiyvq7sbg26yj5nvl2m5n57yvppcl8x3"))))
146 (build-system gnu-build-system)
147 (native-inputs `(("groff" ,groff)))
148 (inputs `(("openssl" ,openssl)
149 ("pam" ,linux-pam)
150 ("mit-krb5" ,mit-krb5)
151 ("zlib" ,zlib)
152 ("xauth" ,xauth))) ;for 'ssh -X' and 'ssh -Y'
153 (arguments
154 `(#:test-target "tests"
155 #:configure-flags `("--sysconfdir=/etc/ssh"
156
157 ;; Default value of 'PATH' used by sshd.
158 "--with-default-path=/run/current-system/profile/bin"
159
160 ;; configure needs to find krb5-config
161 ,(string-append "--with-kerberos5="
162 (assoc-ref %build-inputs "mit-krb5")
163 "/bin")
164
165 ;; Enable PAM support in sshd.
166 "--with-pam")
167
168 #:phases
169 (modify-phases %standard-phases
170 (add-after 'configure 'reset-/var/empty
171 (lambda* (#:key outputs #:allow-other-keys)
172 (let ((out (assoc-ref outputs "out")))
173 (substitute* "Makefile"
174 (("PRIVSEP_PATH=/var/empty")
175 (string-append "PRIVSEP_PATH=" out "/var/empty")))
176 #t)))
177 (add-before 'check 'patch-tests
178 (lambda _
179 ;; remove 't-exec' regress target which requires user 'sshd'
180 (substitute* "regress/Makefile"
181 (("^(REGRESS_TARGETS=.*) t-exec(.*)" all pre post)
182 (string-append pre post)))
183 #t))
184 (replace 'install
185 (lambda* (#:key outputs (make-flags '()) #:allow-other-keys)
186 ;; install without host keys and system configuration files
187 (and (zero? (apply system* "make" "install-nosysconf" make-flags))
188 (begin
189 (install-file "contrib/ssh-copy-id"
190 (string-append (assoc-ref outputs "out")
191 "/bin/"))
192 (chmod (string-append (assoc-ref outputs "out")
193 "/bin/ssh-copy-id") #o555)
194 (install-file "contrib/ssh-copy-id.1"
195 (string-append (assoc-ref outputs "out")
196 "/share/man/man1/"))
197 #t)))))))
198 (synopsis "Client and server for the secure shell (ssh) protocol")
199 (description
200 "The SSH2 protocol implemented in OpenSSH is standardised by the
201 IETF secsh working group and is specified in several RFCs and drafts.
202 It is composed of three layered components:
203
204 The transport layer provides algorithm negotiation and a key exchange.
205 The key exchange includes server authentication and results in a
206 cryptographically secured connection: it provides integrity, confidentiality
207 and optional compression.
208
209 The user authentication layer uses the established connection and relies on
210 the services provided by the transport layer. It provides several mechanisms
211 for user authentication. These include traditional password authentication
212 as well as public-key or host-based authentication mechanisms.
213
214 The connection layer multiplexes many different concurrent channels over the
215 authenticated connection and allows tunneling of login sessions and
216 TCP-forwarding. It provides a flow control service for these channels.
217 Additionally, various channel-specific options can be negotiated.")
218 (license (license:non-copyleft "file://LICENSE"
219 "See LICENSE in the distribution."))
220 (home-page "http://www.openssh.org/")))
221
222 (define-public guile-ssh
223 (package
224 (name "guile-ssh")
225 (version "0.11.2")
226 (home-page "https://github.com/artyom-poptsov/guile-ssh")
227 (source (origin
228 ;; ftp://memory-heap.org/software/guile-ssh/guile-ssh-VERSION.tar.gz
229 ;; exists, but the server appears to be too slow and unreliable.
230 ;; Also, using this URL allows the GitHub updater to work.
231 (method url-fetch)
232 (uri (string-append home-page "/archive/v"
233 version ".tar.gz"))
234 (file-name (string-append name "-" version ".tar.gz"))
235 (sha256
236 (base32
237 "1w0k5s09xj5xycb7lbp5b7rm0xncclms3jwl98lwj8fxwngi1s90"))))
238 (build-system gnu-build-system)
239 (outputs '("out" "debug"))
240 (arguments
241 '(#:phases (modify-phases %standard-phases
242 (add-after 'unpack 'autoreconf
243 (lambda* (#:key inputs #:allow-other-keys)
244 (zero? (system* "autoreconf" "-vfi"))))
245 (add-before 'build 'fix-libguile-ssh-file-name
246 (lambda* (#:key outputs #:allow-other-keys)
247 ;; Build and install libguile-ssh.so so that we can use
248 ;; its absolute file name in .scm files, before we build
249 ;; the .go files.
250 (and (zero? (system* "make" "install"
251 "-C" "libguile-ssh"
252 "-j" (number->string
253 (parallel-job-count))))
254 (let* ((out (assoc-ref outputs "out"))
255 (libdir (string-append out "/lib")))
256 (substitute* (find-files "." "\\.scm$")
257 (("\"libguile-ssh\"")
258 (string-append "\"" libdir "/libguile-ssh\"")))
259 #t)))))
260
261 ;; Tests are not parallel-safe.
262 #:parallel-tests? #f))
263 (native-inputs `(("autoconf" ,autoconf)
264 ("automake" ,automake)
265 ("libtool" ,libtool)
266 ("texinfo" ,texinfo)
267 ("pkg-config" ,pkg-config)
268 ("which" ,which)))
269 (inputs `(("guile" ,guile-2.2)
270 ("libssh" ,libssh)
271 ("libgcrypt" ,libgcrypt)))
272 (synopsis "Guile bindings to libssh")
273 (description
274 "Guile-SSH is a library that provides access to the SSH protocol for
275 programs written in GNU Guile interpreter. It is a wrapper to the underlying
276 libssh library.")
277 (license license:gpl3+)))
278
279 (define-public guile2.2-ssh
280 (deprecated-package "guile2.2-ssh" guile-ssh))
281
282 (define-public guile2.0-ssh
283 (package
284 (inherit guile-ssh)
285 (name "guile2.0-ssh")
286 (inputs `(("guile" ,guile-2.0)
287 ,@(alist-delete "guile" (package-inputs guile-ssh))))))
288
289 (define-public corkscrew
290 (package
291 (name "corkscrew")
292 (version "2.0")
293 (source
294 (origin
295 (method url-fetch)
296 ;; The agroman.net domain name expired on 2017-03-23, and the original
297 ;; "http://www.agroman.net/corkscrew/corkscrew-2.0.tar.gz" now returns
298 ;; bogus HTML. Perhaps it will yet return. Until then, use a mirror.
299 (uri (string-append "https://downloads.openwrt.org/sources/"
300 "corkscrew-" version ".tar.gz"))
301 (sha256 (base32
302 "1gmhas4va6gd70i2x2mpxpwpgww6413mji29mg282jms3jscn3qd"))))
303 (build-system gnu-build-system)
304 (arguments
305 ;; Replace configure phase as the ./configure script does not link
306 ;; CONFIG_SHELL and SHELL passed as parameters
307 '(#:phases
308 (modify-phases %standard-phases
309 (replace 'configure
310 (lambda* (#:key outputs inputs system build target
311 #:allow-other-keys #:rest args)
312 (let* ((configure (assoc-ref %standard-phases 'configure))
313 (prefix (assoc-ref outputs "out"))
314 (bash (which "bash"))
315 ;; Set --build and --host flags as the provided config.guess
316 ;; is not able to detect them
317 (flags `(,(string-append "--prefix=" prefix)
318 ,(string-append "--build=" build)
319 ,(string-append "--host=" (or target build)))))
320 (setenv "CONFIG_SHELL" bash)
321 (zero? (apply system* bash
322 (string-append "." "/configure")
323 flags)))))
324 (add-after 'install 'install-documentation
325 (lambda* (#:key outputs #:allow-other-keys)
326 (let* ((out (assoc-ref outputs "out"))
327 (doc (string-append out "/share/doc/corkscrew")))
328 (install-file "README" doc)
329 #t))))))
330 (home-page "http://www.agroman.net/corkscrew")
331 (synopsis "SSH tunneling through HTTP(S) proxies")
332 (description
333 "Corkscrew tunnels SSH connections through most HTTP and HTTPS proxies.
334 Proxy authentication is only supported through the plain-text HTTP basic
335 authentication scheme.")
336 (license license:gpl2+)))
337
338 (define-public mosh
339 (package
340 (name "mosh")
341 (version "1.3.2")
342 (source (origin
343 (method url-fetch)
344 (uri (string-append "https://mosh.org/mosh-" version ".tar.gz"))
345 (sha256
346 (base32
347 "05hjhlp6lk8yjcy59zywpf0r6s0h0b9zxq0lw66dh9x8vxrhaq6s"))))
348 (build-system gnu-build-system)
349 (arguments
350 '(#:phases
351 (modify-phases %standard-phases
352 (add-after 'install 'wrap
353 (lambda* (#:key outputs #:allow-other-keys)
354 ;; Make sure 'mosh' can find 'mosh-client' and
355 ;; 'mosh-server'.
356 (let* ((out (assoc-ref outputs "out"))
357 (bin (string-append out "/bin")))
358 (wrap-program (string-append bin "/mosh")
359 `("PATH" ":" prefix (,bin)))))))))
360 (native-inputs
361 `(("pkg-config" ,pkg-config)))
362 (inputs
363 `(("openssl" ,openssl)
364 ("perl" ,perl)
365 ("perl-io-tty" ,perl-io-tty)
366 ("zlib" ,zlib)
367 ("ncurses" ,ncurses)
368 ("protobuf" ,protobuf)
369 ("boost-headers" ,boost)))
370 (home-page "https://mosh.org/")
371 (synopsis "Remote shell tolerant to intermittent connectivity")
372 (description
373 "Remote terminal application that allows roaming, supports intermittent
374 connectivity, and provides intelligent local echo and line editing of user
375 keystrokes. Mosh is a replacement for SSH. It's more robust and responsive,
376 especially over Wi-Fi, cellular, and long-distance links.")
377 (license license:gpl3+)))
378
379 (define-public et
380 (package
381 (name "et")
382 (version "3.1.0")
383 (source
384 (origin
385 (method url-fetch)
386 (uri (string-append
387 "https://github.com/MisterTea/EternalTCP/archive/et-v"
388 version ".tar.gz"))
389 (sha256
390 (base32 "1n2w2kqbshdmbb0gz4yizyw9gqfls6qm2dnwx1d9c2hz7hmi7521"))))
391 (build-system cmake-build-system)
392 (arguments `(#:tests? #f))
393 (native-inputs
394 `(("pkg-config" ,pkg-config)))
395 (inputs `(("glog" ,glog)
396 ("gflags" ,gflags)
397 ("libsodium" ,libsodium)
398 ("protobuf" ,protobuf)))
399 (synopsis "Remote shell that automatically reconnects")
400 (description
401 "Eternal Terminal (ET) is a remote shell that automatically reconnects
402 without interrupting the session. Unlike SSH sessions, ET sessions will
403 survive even network outages and IP changes. ET uses a custom protocol over
404 TCP, not the SSH protocol.")
405 (home-page "https://mistertea.github.io/EternalTCP/")
406 (license license:asl2.0)))
407
408 (define-public dropbear
409 (package
410 (name "dropbear")
411 (version "2018.76")
412 (source (origin
413 (method url-fetch)
414 (uri (string-append
415 "https://matt.ucc.asn.au/" name "/releases/"
416 name "-" version ".tar.bz2"))
417 (sha256
418 (base32
419 "0rgavbzw7jrs5wslxm0dnwx2m409yzxd9hazd92r7kx8xikr3yzj"))))
420 (build-system gnu-build-system)
421 (arguments `(#:tests? #f)) ; there is no "make check" or anything similar
422 (inputs `(("zlib" ,zlib)))
423 (synopsis "Small SSH server and client")
424 (description "Dropbear is a relatively small SSH server and
425 client. It runs on a variety of POSIX-based platforms. Dropbear is
426 particularly useful for embedded systems, such as wireless routers.")
427 (home-page "https://matt.ucc.asn.au/dropbear/dropbear.html")
428 (license (license:x11-style "" "See file LICENSE."))))
429
430 (define-public liboop
431 (package
432 (name "liboop")
433 (version "1.0")
434 (source
435 (origin
436 (method url-fetch)
437 (uri (string-append "http://download.ofb.net/liboop/liboop-"
438 version ".tar.gz"))
439 (sha256
440 (base32
441 "0z6rlalhvfca64jpvksppc9bdhs7jwhiw4y35g5ibvh91xp3rn1l"))
442 (patches (search-patches "liboop-mips64-deplibs-fix.patch"))))
443 (build-system gnu-build-system)
444 (home-page "http://www.lysator.liu.se/liboop/")
445 (synopsis "Event loop library")
446 (description "Liboop is a low-level event loop management library for
447 POSIX-based operating systems. It supports the development of modular,
448 multiplexed applications which may respond to events from several sources. It
449 replaces the \"select() loop\" and allows the registration of event handlers
450 for file and network I/O, timers and signals. Since processes use these
451 mechanisms for almost all external communication, liboop can be used as the
452 basis for almost any application.")
453 (license license:lgpl2.1+)))
454
455 (define-public lsh
456 (package
457 (name "lsh")
458 (version "2.1")
459 (source (origin
460 (method url-fetch)
461 (uri (string-append "mirror://gnu/lsh/lsh-"
462 version ".tar.gz"))
463 (sha256
464 (base32
465 "1qqjy9zfzgny0rkb27c8c7dfsylvb6n0ld8h3an2r83pmaqr9gwb"))
466 (modules '((guix build utils)))
467 (snippet
468 '(begin
469 (substitute* "src/testsuite/functions.sh"
470 (("localhost")
471 ;; Avoid host name lookups since they don't work in
472 ;; chroot builds.
473 "127.0.0.1")
474 (("set -e")
475 ;; Make tests more verbose.
476 "set -e\nset -x"))
477
478 (substitute* (find-files "src/testsuite" "-test$")
479 (("localhost") "127.0.0.1"))
480
481 (substitute* "src/testsuite/login-auth-test"
482 (("/bin/cat") "cat"))))))
483 (build-system gnu-build-system)
484 (native-inputs
485 `(("m4" ,m4)
486 ("guile" ,guile-2.0)
487 ("gperf" ,gperf)
488 ("psmisc" ,psmisc))) ; for `killall'
489 (inputs
490 `(("nettle" ,nettle-2)
491 ("linux-pam" ,linux-pam)
492
493 ;; 'rl.c' uses the 'CPPFunction' type, which is no longer in
494 ;; Readline 6.3.
495 ("readline" ,readline-6.2)
496
497 ("liboop" ,liboop)
498 ("zlib" ,zlib)
499 ("gmp" ,gmp)
500
501 ;; The server (lshd) invokes xauth when X11 forwarding is requested.
502 ;; This adds 24 MiB (or 27%) to the closure of lsh.
503 ("xauth" ,xauth)))
504 (arguments
505 '(;; Skip the `configure' test that checks whether /dev/ptmx &
506 ;; co. work as expected, because it relies on impurities (for
507 ;; instance, /dev/pts may be unavailable in chroots.)
508 #:configure-flags '("lsh_cv_sys_unix98_ptys=yes"
509
510 ;; Use glibc's argp rather than the bundled one.
511 "--with-system-argp"
512
513 ;; 'lsh_argp.h' checks HAVE_ARGP_PARSE but nothing
514 ;; defines it.
515 "CPPFLAGS=-DHAVE_ARGP_PARSE")
516
517 ;; FIXME: Tests won't run in a chroot, presumably because
518 ;; /etc/profile is missing, and thus clients get an empty $PATH
519 ;; and nothing works.
520 #:tests? #f
521
522 #:phases
523 (modify-phases %standard-phases
524 (add-before 'configure 'pre-configure
525 (lambda* (#:key inputs #:allow-other-keys)
526 (let* ((nettle (assoc-ref inputs "nettle"))
527 (sexp-conv (string-append nettle "/bin/sexp-conv")))
528 ;; Remove argp from the list of sub-directories; we don't want
529 ;; to build it, really.
530 (substitute* "src/Makefile.in"
531 (("^SUBDIRS = argp")
532 "SUBDIRS ="))
533
534 ;; Make sure 'lsh' and 'lshd' pick 'sexp-conv' in the right place
535 ;; by default.
536 (substitute* "src/environ.h.in"
537 (("^#define PATH_SEXP_CONV.*")
538 (string-append "#define PATH_SEXP_CONV \""
539 sexp-conv "\"\n")))
540
541 ;; Same for the 'lsh-authorize' script.
542 (substitute* "src/lsh-authorize"
543 (("=sexp-conv")
544 (string-append "=" sexp-conv)))
545
546 ;; Tell lshd where 'xauth' lives. Another option would be to
547 ;; hardcode "/run/current-system/profile/bin/xauth", thereby
548 ;; reducing the closure size, but that wouldn't work on foreign
549 ;; distros.
550 (with-fluids ((%default-port-encoding "ISO-8859-1"))
551 (substitute* "src/server_x11.c"
552 (("define XAUTH_PROGRAM.*")
553 (string-append "define XAUTH_PROGRAM \""
554 (assoc-ref inputs "xauth")
555 "/bin/xauth\"\n")))))
556
557 ;; Tests rely on $USER being set.
558 (setenv "USER" "guix"))))))
559 (home-page "http://www.lysator.liu.se/~nisse/lsh/")
560 (synopsis "GNU implementation of the Secure Shell (ssh) protocols")
561 (description
562 "GNU lsh is a free implementation of the SSH version 2 protocol. It is
563 used to create a secure line of communication between two computers,
564 providing shell access to the server system from the client. It provides
565 both the server daemon and the client application, as well as tools for
566 manipulating key files.")
567 (license license:gpl2+)))
568
569 (define-public sshpass
570 (package
571 (name "sshpass")
572 (version "1.06")
573 (synopsis "Non-interactive password authentication with SSH")
574 (home-page "https://sourceforge.net/projects/sshpass/")
575 (source
576 (origin
577 (method url-fetch)
578 (uri (string-append "mirror://sourceforge/sshpass/sshpass/"
579 version "/sshpass-" version ".tar.gz"))
580 (sha256
581 (base32
582 "0q7fblaczb7kwbsz0gdy9267z0sllzgmf0c7z5c9mf88wv74ycn6"))))
583 (build-system gnu-build-system)
584 (description "sshpass is a tool for non-interactivly performing password
585 authentication with SSH's so-called @dfn{interactive keyboard password
586 authentication}.")
587 (license license:gpl2+)))
588
589 (define-public autossh
590 (package
591 (name "autossh")
592 (version "1.4e")
593 (source
594 (origin
595 (method url-fetch)
596 (uri (string-append
597 "http://www.harding.motd.ca/autossh/autossh-"
598 version ".tgz"))
599 (sha256
600 (base32 "0mlicw28vq2jxa0jf0dys5ja75v0fxpjavlq9dpif6bnknji13ly"))))
601 (build-system gnu-build-system)
602 (arguments `(#:tests? #f)) ; There is no "make check" or anything similar
603 (inputs `(("openssh" ,openssh)))
604 (synopsis "Automatically restart SSH sessions and tunnels")
605 (description "autossh is a program to start a copy of @command{ssh} and
606 monitor it, restarting it as necessary should it die or stop passing traffic.")
607 (home-page "http://www.harding.motd.ca/autossh/")
608 (license
609 ;; Why point to a source file? Well, all the individual files have a
610 ;; copy of this license in their headers, but there's no separate file
611 ;; with that information.
612 (license:non-copyleft "file://autossh.c"))))
613
614 (define-public pdsh
615 (package
616 (name "pdsh")
617 (version "2.33")
618 (source
619 (origin
620 (method url-fetch)
621 (uri (string-append "https://github.com/chaos/pdsh/"
622 "releases/download/pdsh-" version
623 "/pdsh-" version ".tar.gz"))
624 (file-name (string-append name "-" version ".tar.gz"))
625 (sha256
626 (base32 "0bwlkl9inj66iwvafg00pi3sk9n673phdi0kcc59y9nn55s0hs3k"))))
627 (build-system gnu-build-system)
628 (arguments
629 `(#:configure-flags
630 (list "--with-ssh")
631 #:phases
632 (modify-phases %standard-phases
633 (add-after 'unpack 'patch-/bin/sh
634 (lambda _
635 (substitute* '("tests/t0006-pdcp.sh"
636 "tests/t0004-module-loading.sh"
637 "tests/t2001-ssh.sh"
638 "tests/t1003-slurm.sh"
639 "tests/t6036-long-output-lines.sh"
640 "tests/aggregate-results.sh"
641 "tests/t2000-exec.sh"
642 "tests/t0002-internal.sh"
643 "tests/t1002-dshgroup.sh"
644 "tests/t5000-dshbak.sh"
645 "tests/t0001-basic.sh"
646 "tests/t0005-rcmd_type-and-user.sh"
647 "tests/test-lib.sh"
648 "tests/t2002-mrsh.sh"
649 "tests/t0003-wcoll.sh"
650 "tests/test-modules/pcptest.c")
651 (("/bin/sh") (which "bash")))
652 #t))
653 (add-after 'unpack 'patch-tests
654 (lambda _
655 (substitute* "tests/t6036-long-output-lines.sh"
656 (("which") (which "which")))
657 #t)))))
658 (inputs
659 `(("openssh" ,openssh)
660 ("mit-krb5" ,mit-krb5)
661 ("perl" ,perl)))
662 (native-inputs
663 `(("which" ,which)))
664 (home-page "https://github.com/chaos/pdsh")
665 (synopsis "Parallel distributed shell")
666 (description "Pdsh is a an efficient, multithreaded remote shell client
667 which executes commands on multiple remote hosts in parallel. Pdsh implements
668 dynamically loadable modules for extended functionality such as new remote
669 shell services and remote host selection.")
670 (license license:gpl2+)))