gnu: libtasn1: Remove obsolete patch.
[jackhill/guix/guix.git] / gnu / packages / gnustep.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016, 2017 Kei Kebreau <kei@openmailbox.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages gnustep)
21 #:use-module (guix download)
22 #:use-module (guix packages)
23 #:use-module (guix build-system gnu)
24 #:use-module (guix licenses)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages base)
27 #:use-module (gnu packages xorg)
28 #:use-module (gnu packages libffcall)
29 #:use-module (gnu packages gnome)
30 #:use-module (gnu packages gtk)
31 #:use-module (gnu packages texinfo)
32 #:use-module (gnu packages autotools)
33 #:use-module (gnu packages glib)
34 #:use-module (gnu packages fontutils)
35 #:use-module (gnu packages image)
36 #:use-module (gnu packages pkg-config)
37 #:use-module (gnu packages xml))
38
39 (define-public gnustep-make
40 (package
41 (name "gnustep-make")
42 (version "2.7.0")
43 (source (origin
44 (method url-fetch)
45 (uri (string-append "ftp://ftp.gnustep.org/pub/gnustep/core/"
46 name "-" version ".tar.gz"))
47 (sha256
48 (base32
49 "1khiygfkz0zhh9b5nybn40g0xnnjxchk24n49hff1bwanszir84h"))))
50 (build-system gnu-build-system)
51 (arguments
52 '(#:tests? #f)) ; no check target
53 (native-inputs
54 `(("which" ,which)))
55 (home-page "http://gnustep.org")
56 (synopsis "GNUstep make package")
57 (description "The makefile package is a simple, powerful and extensible way
58 to write makefiles for a GNUstep-based project. It allows the user to write a
59 project without having to deal with the complex issues associated with
60 configuration, building, installation, and packaging. It also allows the user
61 to easily create cross-compiled binaries.")
62 (license gpl3+)))
63
64 (define-public windowmaker
65 (package
66 (name "windowmaker")
67 (version "0.95.8")
68 (source (origin
69 (method url-fetch)
70 (uri (string-append
71 "http://windowmaker.org/pub/source/release/WindowMaker-"
72 version ".tar.gz"))
73 (sha256
74 (base32
75 "12p8kljqgx5hnic0zvs5mxwp7kg21sb6qjagb2qw8ydvf5amrgwx"))))
76 (build-system gnu-build-system)
77 (arguments
78 '(#:phases
79 (modify-phases %standard-phases
80 (add-before 'configure 'pre-configure
81 (lambda* (#:key outputs #:allow-other-keys)
82 ;; 'wmaker' wants to invoke 'wmaker.inst' the first time,
83 ;; and the 'wmsetbg', so make sure it uses the right ones.
84 ;; We can't use a wrapper here because that would pollute
85 ;; $PATH in the whole session.
86 (let* ((out (assoc-ref outputs "out"))
87 (bin (string-append out "/bin")))
88 (substitute* "src/main.c"
89 (("\"wmaker\\.inst")
90 (string-append "\"" bin "/wmaker.inst")))
91 (substitute* '("src/defaults.c" "WPrefs.app/Menu.c")
92 (("\"wmsetbg")
93 (string-append "\"" bin "/wmsetbg")))
94 ;; Add enough cells to the command character array to
95 ;; allow passing our large path to the wmsetbg binary.
96 ;; The path to wmsetbg in Guix requires 67 extra characters.
97 (substitute* "src/defaults.c"
98 (("len = strlen\\(text\\) \\+ 40;")
99 (string-append "len = strlen(text) + 107;"))))))
100 (add-after 'install 'wrap
101 (lambda* (#:key outputs #:allow-other-keys)
102 (let* ((out (assoc-ref outputs "out"))
103 (bin (string-append out "/bin")))
104 ;; In turn, 'wmaker.inst' wants to invoke 'wmmenugen'
105 ;; etc., so make sure everything is in $PATH.
106 (wrap-program (string-append bin "/wmaker.inst")
107 `("PATH" ":" prefix (,bin)))))))))
108 (inputs
109 `(("libxmu" ,libxmu)
110 ("libxft" ,libxft)
111 ("libx11" ,libx11)
112 ("fontconfig" ,fontconfig)
113 ("libjpeg" ,libjpeg)
114 ("giflib" ,giflib)
115 ("libpng" ,libpng)
116 ("libtiff" ,libtiff)))
117 (native-inputs
118 `(("pkg-config" ,pkg-config)))
119 (home-page "http://windowmaker.org/")
120 (synopsis "NeXTSTEP-like window manager")
121 (description
122 "Window Maker is an X11 window manager originally designed to provide
123 integration support for the GNUstep Desktop Environment. In every way
124 possible, it reproduces the elegant look and feel of the NeXTSTEP user
125 interface. It is fast, feature rich, easy to configure, and easy to use.")
126
127 ;; Artwork is distributed under the WTFPL.
128 (license gpl2+)))
129
130 (define-public wmbattery
131 (package
132 (name "wmbattery")
133 (version "2.50")
134 (source (origin
135 (method url-fetch)
136 (uri (string-append
137 "mirror://debian/pool/main/w/wmbattery/wmbattery_"
138 version ".orig.tar.gz"))
139 (sha256
140 (base32
141 "0hi6bivv3xd2k68w08krndfl68wdx7nmc2wjzsmcd4q3qgwgyk44"))
142 (modules '((guix build utils)))
143 (snippet
144 ;; Fix memory leak:
145 ;; <https://lists.gnu.org/archive/html/guix-devel/2016-05/msg00466.html>.
146 '(substitute* "upower.c"
147 (("up = up_client_new\\(\\);")
148 (string-append "if (!up)\n"
149 " up = up_client_new();"))))))
150 (build-system gnu-build-system)
151 (arguments
152 `(#:tests? #f ; no "check" target
153 #:phases
154 (modify-phases %standard-phases
155 (add-after 'unpack 'autoconf
156 (lambda _ (zero? (system* "autoreconf" "-vfi")))))))
157 (inputs
158 `(("glib" ,glib)
159 ("libx11" ,libx11)
160 ("libxext" ,libxext)
161 ("libxpm" ,libxpm)
162 ("upower" ,upower)))
163 (native-inputs
164 `(("autoconf" ,autoconf)
165 ("automake" ,automake)
166 ("pkg-config" ,pkg-config)))
167 (home-page "http://windowmaker.org/dockapps/?name=wmbattery")
168 (synopsis "Display laptop battery info")
169 (description
170 "Wmbattery displays the status of your laptop's battery in a small icon.
171 This includes if it is plugged in, if the battery is charging, how many minutes
172 of battery life remain, battery life remaining (with both a percentage and a
173 graph), and battery status (high - green, low - yellow, or critical - red).")
174 (license gpl2)))
175
176 (define-public wmnd
177 (package
178 (name "wmnd")
179 (version "0.4.17")
180 (source (origin
181 (method url-fetch)
182 (uri (string-append
183 "http://www.thregr.org/~wavexx/software/wmnd/releases/"
184 name "-" version ".tar.gz"))
185 (sha256
186 (base32
187 "1amkbiwgr31gwkcp7wrjsr7aj1kns8bpmjpv70n86wb8v9mpm828"))))
188 (build-system gnu-build-system)
189 (inputs
190 `(("libx11" ,libx11)
191 ("libxext" ,libxext)
192 ("libxpm" ,libxpm)))
193 (native-inputs
194 `(("pkg-config" ,pkg-config)))
195 (home-page "http://www.thregr.org/~wavexx/software/wmnd/")
196 (synopsis "Network interface monitor")
197 (description
198 "WMND is a dockapp for monitoring network interfaces under WindowMaker and
199 other compatible window managers.")
200 (license gpl2+)))
201
202 (define-public wmcpuload
203 (package
204 (name "wmcpuload")
205 (version "1.0.1")
206 (source (origin
207 (method url-fetch)
208 (uri (string-append
209 "mirror://debian/pool/main/w/wmcpuload/"
210 name "_" version ".orig.tar.gz"))
211 (sha256
212 (base32
213 "0irlns4cvxy2mnicx75bya166hdxq7h8bphds3ligijcl9fzgs6n"))))
214 (build-system gnu-build-system)
215 (inputs
216 `(("libx11" ,libx11)
217 ("libxext" ,libxext)
218 ("libxpm" ,libxpm)))
219 (native-inputs
220 `(("pkg-config" ,pkg-config)))
221 (home-page "http://windowmaker.org/dockapps/?name=wmcpuload")
222 (synopsis "Monitor CPU usage")
223 (description
224 "Wmcpuload displays the current CPU usage, expressed as a percentile and a
225 chart, and has an LCD look-alike user interface. The back-light may be turned
226 on and off by clicking the mouse button over the application. If the CPU usage
227 hits a certain threshold, an alarm-mode will alert you by turning back-light
228 on.")
229 (license gpl2+)))
230
231 (define-public wmclock
232 (package
233 (name "wmclock")
234 (version "1.0.16")
235 (source (origin
236 (method url-fetch)
237 (uri (string-append
238 "mirror://debian/pool/main/w/wmclock/"
239 name "_" version ".orig.tar.gz"))
240 (sha256
241 (base32
242 "1lx276ba8r2yydhmwj1g586jdqg695ad89ng36fr3mb067gvb2rz"))))
243 (build-system gnu-build-system)
244 (arguments
245 `(#:phases
246 (modify-phases %standard-phases
247 (add-after 'unpack 'autoconf
248 (lambda _ (zero? (system* "autoreconf" "-vfi")))))))
249 ;; wmclock requires autoreconf to generate its configure script.
250 (inputs
251 `(("libx11" ,libx11)
252 ("libxext" ,libxext)
253 ("libxpm" ,libxpm)))
254 (native-inputs
255 `(("autoconf" ,autoconf)
256 ("automake" ,automake)
257 ("pkg-config" ,pkg-config)))
258 (home-page "http://windowmaker.org/dockapps/?name=wmclock")
259 (synopsis "Display the date and time")
260 (description
261 "wmclock is an applet for Window Maker which displays the date and time in
262 a dockable tile. It features multiple language support, 24h or 12h time
263 display, and can run a user-specified program on mouse click.")
264 (license gpl2+)))
265
266 (define-public wmfire
267 (package
268 (name "wmfire")
269 (version "1.2.4")
270 (source (origin
271 (method url-fetch)
272 (uri (string-append "http://www.improbability.net/"
273 name "/" name "-" version ".tar.gz"))
274 (sha256
275 (base32
276 "101grahd80n97y2dczb629clmcgiavdpbbwy78kk5wgs362m12z3"))
277 (patches
278 (search-patches "wmfire-update-for-new-gdk-versions.patch"))))
279 (build-system gnu-build-system)
280 (inputs
281 `(("gtk+" ,gtk+-2)
282 ("libgtop" ,libgtop)))
283 (native-inputs
284 `(("pkg-config" ,pkg-config)))
285 (home-page "http://www.improbability.net/")
286 (synopsis "Display flames to represent resource usage")
287 (description
288 "wmfire is an applet for Window Maker that can monitor the average cpu
289 load, or individual cpu load on SMP computers. Additionally it can monitor the
290 memory, network load, a file or just be set to show a pretty flame. On
291 entering the dock a burning spot replaces the cursor, and after two seconds
292 symbols to represent the current monitor are \"burnt\" onscreen. The flame
293 colour can also be changed.")
294 (license gpl2+)))