linux-initrd: Add USB kernel modules to the default initrd.
[jackhill/guix/guix.git] / gnu / packages / vim.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages vim)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages gawk)
26 #:use-module (gnu packages ncurses)
27 #:use-module (gnu packages perl)
28 #:use-module (gnu packages admin) ; For GNU hostname
29 #:use-module (gnu packages tcsh))
30
31 (define-public vim
32 (package
33 (name "vim")
34 (version "7.4")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "ftp://ftp.vim.org/pub/vim/unix/vim-"
38 version ".tar.bz2"))
39 (sha256
40 (base32
41 "1pjaffap91l2rb9pjnlbrpvb3ay5yhhr3g91zabjvw1rqk9adxfh"))))
42 (build-system gnu-build-system)
43 (arguments
44 `(#:test-target "test"
45 #:parallel-tests? #f
46 #:phases
47 (alist-cons-after
48 'configure 'patch-config-files
49 (lambda _
50 (substitute* "runtime/tools/mve.awk"
51 (("/usr/bin/nawk") (which "gawk")))
52 (substitute* "src/testdir/Makefile"
53 (("/bin/sh") (which "sh"))))
54 %standard-phases)))
55 (inputs
56 `(("gawk", gawk)
57 ("inetutils", inetutils)
58 ("ncurses", ncurses)
59 ("perl", perl)
60 ("tcsh" ,tcsh))) ; For runtime/tools/vim32
61 (home-page "http://www.vim.org/")
62 (synopsis "Text editor based on vi")
63 (description
64 "Vim is a highly configurable text editor built to enable efficient text
65 editing. It is an improved version of the vi editor distributed with most UNIX
66 systems.
67
68 Vim is often called a \"programmer's editor,\" and so useful for programming
69 that many consider it an entire IDE. It's not just for programmers, though.
70 Vim is perfect for all kinds of text editing, from composing email to editing
71 configuration files.")
72 (license license:vim)))