linux-initrd: Add USB kernel modules to the default initrd.
[jackhill/guix/guix.git] / gnu / packages / skribilo.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages skribilo)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix licenses)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages guile)
25 #:use-module (gnu packages lout)
26 #:use-module (gnu packages imagemagick)
27 #:use-module (gnu packages ghostscript))
28
29 (define-public skribilo
30 (package
31 (name "skribilo")
32 (version "0.9.2")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append "mirror://savannah/skribilo/skribilo-"
36 version ".tar.gz"))
37 (sha256
38 (base32
39 "0wwi996403wzcp8s8iyc2p6w7f9v39lwmy35ysdd3wc31i5dy19q"))))
40 (build-system gnu-build-system)
41 (arguments
42 ;; Make the modules available under the usual location.
43 '(#:configure-flags (list (string-append "--with-guilemoduledir="
44 (assoc-ref %outputs "out")
45 "/share/guile/site/2.0"))
46
47 #:phases (alist-cons-before
48 'configure 'pre-configure
49 (lambda* (#:key inputs #:allow-other-keys)
50 ;; Make sure the 'skribilo' command gets to see
51 ;; Guile-Reader, even if Guile-Reader is not in the search
52 ;; path.
53 (let ((reader (assoc-ref inputs "guile-reader")))
54 (substitute* "src/skribilo.in"
55 (("^exec (.*) -c" _ things)
56 (string-append "exec " things
57 " -L " reader "/share/guile/site/2.0"
58 " -C " reader "/share/guile/site/2.0"
59 " -c")))))
60 %standard-phases)
61
62 #:parallel-build? #f))
63 ;; TODO: Add Ploticus.
64 (inputs `(("guile" ,guile-2.0)
65 ("imagemagick" ,imagemagick)
66 ("ghostscript" ,ghostscript) ; for 'convert'
67 ("lout" ,lout)))
68
69 ;; The 'skribilo' command needs them, and for people using Skribilo as a
70 ;; library, these inputs are needed as well.
71 (propagated-inputs `(("guile-reader" ,guile-reader/guile-2.0)
72 ("guile-lib" ,guile-lib)))
73
74 (home-page "http://www.nongnu.org/skribilo/")
75 (synopsis "Document production tool written in Guile Scheme")
76 (description
77 "Skribilo is a free document production tool that takes a structured
78 document representation as its input and renders that document in a variety of
79 output formats: HTML and Info for on-line browsing, and Lout and LaTeX for
80 high-quality hard copies.
81
82 The input document can use Skribilo's markup language to provide information
83 about the document's structure, which is similar to HTML or LaTeX and does not
84 require expertise. Alternatively, it can use a simpler, “markup-less” format
85 that borrows from Emacs' outline mode and from other conventions used in
86 emails, Usenet and text.
87
88 Lastly, Skribilo provides Guile Scheme APIs.")
89 (license gpl3+)))