linux-initrd: Add USB kernel modules to the default initrd.
[jackhill/guix/guix.git] / gnu / packages / ratpoison.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages ratpoison)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module ((guix licenses) #:select (gpl2+))
24 #:use-module (gnu packages)
25 #:use-module (gnu packages xorg)
26 #:use-module (gnu packages perl)
27 #:use-module (gnu packages readline)
28 #:use-module (gnu packages pkg-config)
29 #:use-module (gnu packages fontutils))
30
31 (define-public ratpoison
32 (package
33 (name "ratpoison")
34 (version "1.4.6")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "mirror://savannah/ratpoison/ratpoison-"
38 version ".tar.xz"))
39 (sha256
40 (base32
41 "0v4mh8d3vsh5xbbycfdl3g8zfygi1rkslh1x7k5hi1d05bfq3cdr"))
42 (patches (list (search-patch "ratpoison-shell.patch")))))
43 (build-system gnu-build-system)
44 (inputs
45 `(("libXi" ,libxi)
46 ("readline" ,readline)
47 ("xextproto" ,xextproto)
48 ("libXtst" ,libxtst)
49 ("freetype" ,freetype)
50 ("fontconfig" ,fontconfig)
51 ("libXft" ,libxft)
52 ("libXpm" ,libxpm)
53 ("libXt" ,libxt)
54 ("inputproto" ,inputproto)
55 ("libX11" ,libx11)))
56 (native-inputs
57 `(("perl" ,perl)
58 ("pkg-config" ,pkg-config)))
59 (home-page "http://www.nongnu.org/ratpoison/")
60 (synopsis "Simple mouse-free tiling window manager")
61 (description
62 "Ratpoison is a simple window manager with no fat library
63 dependencies, no fancy graphics, no window decorations, and no
64 rodent dependence. It is largely modelled after GNU Screen which
65 has done wonders in the virtual terminal market.
66
67 The screen can be split into non-overlapping frames. All windows
68 are kept maximized inside their frames to take full advantage of
69 your precious screen real estate.
70
71 All interaction with the window manager is done through keystrokes.
72 Ratpoison has a prefix map to minimize the key clobbering that
73 cripples Emacs and other quality pieces of software.")
74 (license gpl2+)))