linux-initrd: Add USB kernel modules to the default initrd.
[jackhill/guix/guix.git] / gnu / packages / plotutils.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages plotutils)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages xorg)
25 #:use-module (gnu packages image)
26 #:use-module (gnu packages guile)
27 #:use-module (gnu packages gtk)
28 #:use-module (gnu packages pkg-config)
29 #:use-module (gnu packages))
30
31 (define-public plotutils
32 (package
33 (name "plotutils")
34 (version "2.6")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "mirror://gnu/plotutils/plotutils-"
38 version ".tar.gz"))
39 (sha256
40 (base32
41 "1arkyizn5wbgvbh53aziv3s6lmd3wm9lqzkhxb3hijlp1y124hjg"))
42 (patches (list (search-patch "plotutils-libpng-jmpbuf.patch")))
43 (modules '((guix build utils)))
44 (snippet
45 ;; Force the use of libXaw7 instead of libXaw. When not doing
46 ;; that, libplot.la ends up containing just "-lXaw" (without
47 ;; "-L/path/to/Xaw"), due to the fact that there is no
48 ;; libXaw.la, which forces us to propagate libXaw.
49 '(substitute* "configure"
50 (("-lXaw")
51 "-lXaw7")))))
52 (build-system gnu-build-system)
53 (inputs `(("libpng" ,libpng)
54 ("libx11" ,libx11)
55 ("libxt" ,libxt)
56 ("libxaw" ,libxaw)))
57
58 (home-page
59 "http://www.gnu.org/software/plotutils/")
60 (synopsis "Plotting utilities and library")
61 (description
62 "GNU Plotutils is a package for plotting and working with 2D graphics.
63 It includes a library, \"libplot\", for C and C++ for exporting 2D vector
64 graphics in many file formats. It also has support for 2D vector graphics
65 animations. The package also contains command-line programs for plotting
66 scientific data.")
67 (license gpl2+)))
68
69 (define-public guile-charting
70 (package
71 (name "guile-charting")
72 (version "0.2.0")
73 (source (origin
74 (method url-fetch)
75 (uri (string-append "http://wingolog.org/pub/guile-charting/"
76 "guile-charting-" version ".tar.gz"))
77 (sha256
78 (base32
79 "0w5qiyv9v0ip5li22x762bm48g8xnw281w66iyw094zdw611pb2m"))
80 (modules '((guix build utils)))
81 (snippet
82 '(begin
83 ;; Use the standard location for modules.
84 (substitute* "Makefile.in"
85 (("godir = .*$")
86 "godir = $(moddir)\n"))))))
87 (build-system gnu-build-system)
88 (native-inputs `(("pkg-config" ,pkg-config)))
89 (inputs `(("guile" ,guile-2.0)))
90 (propagated-inputs `(("guile-cairo" ,guile-cairo)))
91 (home-page "http://wingolog.org/software/guile-charting/")
92 (synopsis "Create charts and graphs in Guile")
93 (description
94 "Guile-Charting is a Guile Scheme library to create bar charts and graphs
95 using the Cairo drawing library.")
96 (license lgpl2.1+)))