linux-initrd: Add USB kernel modules to the default initrd.
[jackhill/guix/guix.git] / gnu / packages / gps.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gps)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix git-download)
23 #:use-module (guix build-system gnu)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (gnu packages which)
26 #:use-module (gnu packages pkg-config)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages docbook)
29 #:use-module (gnu packages geeqie) ;exiv2
30 #:use-module (gnu packages xml)
31 #:use-module (gnu packages gtk)
32 #:use-module (gnu packages qt))
33
34 (define-public gpsbabel
35 (package
36 (name "gpsbabel")
37 (version "1.5.0")
38 (source (origin
39 (method url-fetch)
40 ;; XXX: Downloads from gpsbabel.org are hidden behind a POST, so
41 ;; get it from elsewhere.
42 (uri (string-append
43 "mirror://debian/pool/main/g/gpsbabel/gpsbabel_"
44 version ".orig.tar.gz"))
45 (sha256
46 (base32
47 "1pd01kra9l5ihy1by87qia0mpbpcif7g5yg7r9z2bnw7711jm3yb"))))
48 (build-system gnu-build-system)
49 (arguments
50 `(#:configure-flags '("--with-zlib=system")
51 #:phases (alist-cons-before
52 'configure 'pre-configure
53 (lambda _
54 (chdir "gpsbabel"))
55 ;; TODO: "make doc" requires Docbook & co.
56 %standard-phases)
57
58 ;; On i686, 'raymarine.test' fails because of a rounding error:
59 ;; <http://hydra.gnu.org/build/133040>. As a workaround, disable tests
60 ;; on these platforms.
61 #:tests? ,(not (string-prefix? "i686" (%current-system)))))
62 (inputs
63 `(("expat" ,expat)
64 ("zlib" ,zlib)
65 ("qt4" ,qt-4)))
66 (native-inputs
67 `(("which" ,which)
68 ("libxml2" ,libxml2))) ;'xmllint' needed for the KML tests
69 (home-page "http://www.gpsbabel.org/")
70 (synopsis "Convert and exchange data with GPS and map programs")
71 (description
72 "GPSBabel converts waypoints, tracks, and routes between hundreds of
73 popular GPS receivers and mapping programs. It contains extensive data
74 manipulation abilities making it a convenient for server-side processing or as
75 the back-end for other tools. It does not convert, transfer, send, or
76 manipulate maps.")
77 (license license:gpl2+)))
78
79 (define-public gpscorrelate
80 ;; This program is "lightly maintained", so to speak, so we end up taking it
81 ;; directly from its Git repo.
82 (let ((commit "365f6e1b3f"))
83 (package
84 (name "gpscorrelate")
85 (version (string-append "1.6.1." commit))
86 (source (origin
87 (method git-fetch)
88 (uri (git-reference
89 (url "https://github.com/freefoote/gpscorrelate")
90 (commit commit)))
91 (sha256
92 (base32
93 "006a6l8p38a4h7y2959sqrmjjn29d8pd50zj9nypcp5ph18nybjb"))))
94 (build-system gnu-build-system)
95 (arguments
96 `(#:phases (alist-replace
97 'configure
98 (lambda* (#:key inputs outputs #:allow-other-keys)
99 ;; This is a rudimentary build system.
100 (substitute* "Makefile"
101 (("prefix[[:blank:]]*=.*$")
102 (string-append "prefix = " (assoc-ref outputs "out")
103 "\n"))))
104 %standard-phases)
105 #:tests? #f))
106 (inputs
107 `(("gtk+" ,gtk+-2)
108 ("libxml2" ,libxml2)
109 ("exiv2" ,exiv2)))
110 (native-inputs
111 `(("pkg-config" ,pkg-config)
112 ("docbook-xml" ,docbook-xml)
113 ("docbook-xsl" ,docbook-xsl)
114 ("libxslt" ,libxslt)))
115 (home-page "http://freefoote.dview.net/linux/gpscorrelate")
116 (synopsis "GPS photo correlation tool to geo-localize images")
117 (description
118 "GPS Correlate is a program to match a recorded GPS track with the EXIF
119 tags in digital camera photos, and update the EXIF tags with the location that
120 the photo was taken. It does this by using the timestamp in the photo and
121 finding a data point in the GPS track that matches, or interpolating a point
122 between two other data points.")
123 (license license:gpl2+))))