linux-initrd: Add USB kernel modules to the default initrd.
[jackhill/guix/guix.git] / gnu / packages / gd.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages gd)
21 #:use-module (guix packages)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix download)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages image)
26 #:use-module (gnu packages fontutils)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages pkg-config)
29 #:use-module ((guix licenses) #:select (bsd-style)))
30
31 (define-public gd
32 (package
33 (name "gd")
34
35 ;; Note: With libgd.org now pointing to bitbucket.org, genuine old
36 ;; tarballs are no longer available. Notably, versions 2.0.x are
37 ;; missing.
38 (version "2.1.1")
39
40 (source (origin
41 (method url-fetch)
42 (uri (string-append
43 "https://bitbucket.org/libgd/gd-libgd/downloads/"
44 "libgd-" version ".tar.xz"))
45 (sha256
46 (base32
47 "11djy9flzxczphigqgp7fbbblbq35gqwwhn9xfcckawlapa1xnls"))))
48 (build-system gnu-build-system)
49 (native-inputs
50 `(("pkg-config" ,pkg-config)))
51 (inputs
52 `(("freetype" ,freetype)
53 ("libpng" ,libpng)
54 ("zlib" ,zlib)))
55 (propagated-inputs
56 `(("fontconfig" ,fontconfig)
57 ("libjpeg" ,libjpeg)))
58 (home-page "http://www.libgd.org/")
59 (synopsis "Library for the dynamic creation of images by programmers")
60 (description
61 "GD is a library for the dynamic creation of images by programmers. GD
62 is written in C, and \"wrappers\" are available for Perl, PHP and other
63 languages. GD creates PNG, JPEG, GIF, WebP, XPM, BMP images, among other
64 formats. GD is commonly used to generate charts, graphics, thumbnails, and
65 most anything else, on the fly. While not restricted to use on the web, the
66 most common applications of GD involve website development.")
67 (license (bsd-style "file://COPYING"
68 "See COPYING file in the distribution."))))