linux-initrd: Add USB kernel modules to the default initrd.
[jackhill/guix/guix.git] / gnu / packages / games.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 John Darrington <jmd@gnu.org>
3 ;;; Copyright © 2014 David Thompson <dthompson2@worcester.edu>
4 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
5 ;;; Copyright © 2014 Cyrill Schenkel <cyrill.schenkel@gmail.com>
6 ;;; Copyright © 2014 Sylvain Beucler <beuc@beuc.net>
7 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
8 ;;; Copyright © 2014, 2015 Sou Bunnbu <iyzsong@gmail.com>
9 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
10 ;;;
11 ;;; This file is part of GNU Guix.
12 ;;;
13 ;;; GNU Guix is free software; you can redistribute it and/or modify it
14 ;;; under the terms of the GNU General Public License as published by
15 ;;; the Free Software Foundation; either version 3 of the License, or (at
16 ;;; your option) any later version.
17 ;;;
18 ;;; GNU Guix is distributed in the hope that it will be useful, but
19 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
20 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
21 ;;; GNU General Public License for more details.
22 ;;;
23 ;;; You should have received a copy of the GNU General Public License
24 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
25
26 (define-module (gnu packages games)
27 #:use-module ((guix licenses) #:prefix license:)
28 #:use-module (guix utils)
29 #:use-module (guix packages)
30 #:use-module (guix download)
31 #:use-module (gnu packages)
32 #:use-module (gnu packages base)
33 #:use-module (gnu packages admin)
34 #:use-module (gnu packages boost)
35 #:use-module (gnu packages gettext)
36 #:use-module (gnu packages gl)
37 #:use-module (gnu packages glib)
38 #:use-module (gnu packages gnome)
39 #:use-module (gnu packages gtk)
40 #:use-module (gnu packages guile)
41 #:use-module (gnu packages libcanberra)
42 #:use-module (gnu packages image)
43 #:use-module (gnu packages ncurses)
44 #:use-module (gnu packages python)
45 #:use-module (gnu packages readline)
46 #:use-module (gnu packages xorg)
47 #:use-module (gnu packages pkg-config)
48 #:use-module (gnu packages databases)
49 #:use-module (gnu packages sdl)
50 #:use-module (gnu packages texinfo)
51 #:use-module (gnu packages check)
52 #:use-module (gnu packages fontutils)
53 #:use-module (gnu packages bash)
54 #:use-module (gnu packages perl)
55 #:use-module (gnu packages qt)
56 #:use-module (gnu packages compression)
57 #:use-module (gnu packages pulseaudio)
58 #:use-module (gnu packages linux)
59 #:use-module (gnu packages zip)
60 #:use-module (gnu packages xiph)
61 #:use-module (gnu packages curl)
62 #:use-module (gnu packages lua)
63 #:use-module (gnu packages video)
64 #:use-module (gnu packages which)
65 #:use-module (gnu packages xml)
66 #:use-module (guix build-system trivial)
67 #:use-module (guix build-system gnu)
68 #:use-module (guix build-system cmake)
69 #:use-module (guix build-system trivial))
70
71 (define-public gnubg
72 (package
73 (name "gnubg")
74 (version "1.02")
75 (source
76 (origin
77 (method url-fetch)
78 (uri (string-append "http://files.gnubg.org/media/sources/gnubg-release-"
79 version ".000-sources." "tar.gz"))
80 (sha256
81 (base32
82 "015mvjk2iw1cg1kxwxfnvp2rxb9cylf6yc39i30fdy414k07zkky"))))
83 (build-system gnu-build-system)
84 (inputs `(("glib" ,glib)
85 ("readline" ,readline)
86 ("gtk+" ,gtk+-2)
87 ("mesa" ,mesa)
88 ("glu" ,glu)
89 ("gtkglext" ,gtkglext)
90 ("sqlite" ,sqlite)
91 ("libcanberra" ,libcanberra)))
92 (native-inputs `(("python-2" ,python-2)
93 ("pkg-config" ,pkg-config)))
94 (home-page "http://gnubg.org")
95 (synopsis "Backgammon game")
96 (description "The GNU backgammon application can be used for playing, analyzing and
97 teaching the game. It has an advanced evaluation engine based on artificial
98 neural networks suitable for both beginners and advanced players. In
99 addition to a command-line interface, it also features an attractive, 3D
100 representation of the playing board.")
101 (license license:gpl3+)))
102
103 (define-public gnubik
104 (package
105 (name "gnubik")
106 (version "2.4.1")
107 (source
108 (origin
109 (method url-fetch)
110 (uri (string-append "mirror://gnu/gnubik/gnubik-"
111 version ".tar.gz"))
112 (sha256
113 (base32
114 "0mfpwz341i1qpzi2qgslpc5i7d4fv7i01kv392m11pczqdc7i7m5"))))
115 (build-system gnu-build-system)
116 (inputs `(("gtk+" ,gtk+-2)
117 ("mesa" ,mesa)
118 ("glu" ,glu)
119 ("libx11" ,libx11)
120 ("guile" ,guile-2.0)
121 ("gtkglext" ,gtkglext)))
122 (native-inputs `(("gettext" ,gnu-gettext)
123 ("pkg-config" ,pkg-config)))
124 (home-page "https://www.gnu.org/software/gnubik/")
125 (synopsis "3d Rubik's cube game")
126 (description
127 "GNUbik is a puzzle game in which you must manipulate a cube to make
128 each of its faces have a uniform color. The game is customizable, allowing
129 you to set the size of the cube (the default is 3x3) or to change the colors.
130 You may even apply photos to the faces instead of colors. The game is
131 scriptable with Guile.")
132 (license license:gpl3+)))
133
134 (define-public abbaye
135 (package
136 (name "abbaye")
137 (version "1.13")
138 (source
139 (origin
140 (method url-fetch)
141 (uri (string-append "http://abbaye-for-linux.googlecode.com/files/abbaye-for-linux-src-"
142 version ".tar.gz"))
143 (sha256
144 (base32
145 "1wgvckgqa2084rbskxif58wbb83xbas8s1i8s7d57xbj08ryq8rk"))))
146 (build-system gnu-build-system)
147 (arguments
148 '(#:modules ((ice-9 match)
149 (guix build gnu-build-system)
150 (guix build utils))
151 #:phases (alist-cons-after
152 'set-paths 'set-sdl-paths
153 (lambda* (#:key inputs outputs (search-paths '()) #:allow-other-keys)
154 (define input-directories
155 (match inputs
156 (((_ . dir) ...)
157 dir)))
158 ;; This package does not use pkg-config, so modify CPATH
159 ;; variable to point to include/SDL for SDL header files.
160 (set-path-environment-variable "CPATH"
161 '("include/SDL")
162 input-directories))
163 (alist-cons-after
164 'patch-source-shebangs 'patch-makefile
165 (lambda* (#:key outputs #:allow-other-keys)
166 ;; Replace /usr with package output directory.
167 (for-each (lambda (file)
168 (substitute* file
169 (("/usr") (assoc-ref outputs "out"))))
170 '("makefile" "src/pantallas.c" "src/comun.h")))
171 (alist-cons-before
172 'install 'make-install-dirs
173 (lambda* (#:key outputs #:allow-other-keys)
174 (let ((prefix (assoc-ref outputs "out")))
175 ;; Create directories that the makefile assumes exist.
176 (mkdir-p (string-append prefix "/bin"))
177 (mkdir-p (string-append prefix "/share/applications"))
178 (mkdir-p (string-append prefix "/share/pixmaps"))))
179 ;; No configure script.
180 (alist-delete 'configure %standard-phases))))
181 #:tests? #f)) ;; No check target.
182 (native-inputs `(("pkg-config" ,pkg-config)))
183 (inputs `(("sdl" ,sdl)
184 ("sdl-gfx" ,sdl-gfx)
185 ("sdl-image" ,sdl-image)
186 ("sdl-mixer" ,sdl-mixer)
187 ("sdl-ttf" ,sdl-ttf)))
188 (home-page "http://code.google.com/p/abbaye-for-linux/")
189 (synopsis "GNU/Linux port of the indie game \"l'Abbaye des Morts\"")
190 (description "L'Abbaye des Morts is a 2D platform game set in 13th century
191 France. The Cathars, who preach about good Christian beliefs, were being
192 expelled by the Catholic Church out of the Languedoc region in France. One of
193 them, called Jean Raymond, found an old church in which to hide, not knowing
194 that beneath its ruins lay buried an ancient evil.")
195 (license license:gpl3+)))
196
197 (define-public pingus
198 (package
199 (name "pingus")
200 (version "0.7.6")
201 (source
202 (origin
203 (method url-fetch)
204 (uri (string-append "http://pingus.googlecode.com/files/pingus-"
205 version ".tar.bz2"))
206 (sha256
207 (base32
208 "0q34d2k6anzqvb0mf67x85q92lfx9jr71ry13dlp47jx0x9i573m"))
209 (patches (list (search-patch "pingus-sdl-libs-config.patch")))))
210 (build-system gnu-build-system)
211 (native-inputs `(("pkg-config" ,pkg-config)
212 ("scons" ,scons)))
213 (inputs `(("sdl" ,sdl)
214 ("sdl-image" ,sdl-image)
215 ("sdl-mixer" ,sdl-mixer)
216 ("mesa" ,mesa)
217 ("glu" ,glu)
218 ("libpng" ,libpng)
219 ("boost" ,boost)))
220 (arguments
221 '(#:tests? #f ;no check target
222 #:phases
223 (alist-delete
224 'configure
225 (alist-replace
226 'install
227 (lambda* (#:key outputs #:allow-other-keys)
228 (zero? (system* "make" "install"
229 (string-append "PREFIX="
230 (assoc-ref outputs "out")))))
231 %standard-phases))))
232 (home-page "http://pingus.seul.org/welcome.html")
233 (synopsis "Lemmings clone")
234 (description
235 "Pingus is a free Lemmings-like puzzle game in which the player takes
236 command of a bunch of small animals and has to guide them through levels.
237 Since the animals walk on their own, the player can only influence them by
238 giving them commands, like build a bridge, dig a hole, or redirect all animals
239 in the other direction. Multiple such commands are necessary to reach the
240 level's exit. The game is presented in a 2D side view.")
241 ;; Some source files are under bsd-3 and gpl2+ licenses.
242 (license license:gpl3+)))
243
244 (define-public talkfilters
245 (package
246 (name "talkfilters")
247 (version "2.3.8")
248 (source
249 (origin
250 (method url-fetch)
251 (uri (string-append "http://www.hyperrealm.com/" name "/"
252 name "-" version ".tar.gz"))
253 (sha256
254 (base32 "19nc5vq4bnkjvhk8srqddzhcs93jyvpm9r6lzjzwc1mgf08yg0a6"))))
255 (build-system gnu-build-system)
256 (home-page "http://www.gnu.org/software/talkfilters")
257 (synopsis "Convert English text to humorous dialects")
258 (description "The GNU Talk Filters are programs that convert English text
259 into stereotyped or otherwise humorous dialects. The filters are provided as
260 a C library, so they can easily be integrated into other programs.")
261 (license license:gpl2+)))
262
263 (define-public cmatrix
264 (package
265 (name "cmatrix")
266 (version "1.2a")
267 (source
268 (origin
269 (method url-fetch)
270 (uri (string-append "http://www.asty.org/cmatrix/dist/cmatrix-" version
271 ".tar.gz"))
272 (sha256
273 (base32
274 "0k06fw2n8nzp1pcdynhajp5prba03gfgsbj91bknyjr5xb5fd9hz"))))
275 (build-system gnu-build-system)
276 (arguments
277 '(#:phases
278 (alist-replace 'configure
279 (lambda* (#:key outputs #:allow-other-keys)
280 ;; This old `configure' script doesn't support
281 ;; variables passed as arguments.
282 (let ((out (assoc-ref outputs "out")))
283 (setenv "CONFIG_SHELL" (which "bash"))
284 (zero?
285 (system* "./configure"
286 (string-append "--prefix=" out)))))
287 %standard-phases)))
288 (inputs `(("ncurses" ,ncurses)))
289 (home-page "http://www.asty.org/cmatrix")
290 (synopsis "Simulate the display from \"The Matrix\"")
291 (description "CMatrix simulates the display from \"The Matrix\" and is
292 based on the screensaver from the movie's website. It works with terminal
293 settings up to 132x300 and can scroll lines all at the same rate or
294 asynchronously and at a user-defined speed.")
295 (license license:gpl2+)))
296
297 (define-public chess
298 (package
299 (name "chess")
300 (version "6.1.1")
301 (source
302 (origin
303 (method url-fetch)
304 (uri (string-append "mirror://gnu/chess/gnuchess-" version
305 ".tar.gz"))
306 (sha256
307 (base32
308 "1jckpg1qi1vjr3pqs0dnip3rmn0mgklx63xflrpqiv3cx2qlz8kn"))))
309 (build-system gnu-build-system)
310 (home-page "http://www.gnu.org/software/chess")
311 (synopsis "Full chess implementation")
312 (description "GNU Chess is a chess engine. It allows you to compete
313 against the computer in a game of chess, either through the default terminal
314 interface or via an external visual interface such as GNU XBoard.")
315 (license license:gpl3+)))
316
317 (define freedink-engine
318 (package
319 (name "freedink-engine")
320 (version "108.4")
321 (source (origin
322 (method url-fetch)
323 (uri (string-append "mirror://gnu/freedink/freedink-" version
324 ".tar.gz"))
325 (sha256
326 (base32
327 "08c51imfjfcydm7h0va09z8qfw5nc837bi2x754ni2z737hb5kw2"))))
328 (build-system gnu-build-system)
329 (arguments `(#:configure-flags '("--disable-embedded-resources")))
330 (native-inputs `(("gettext" ,gnu-gettext)
331 ("pkg-config" ,pkg-config)))
332 (inputs `(("sdl" ,sdl)
333 ("sdl-image" ,sdl-image)
334 ("sdl-mixer" ,sdl-mixer)
335 ("sdl-ttf" ,sdl-ttf)
336 ("sdl-gfx" ,sdl-gfx)
337 ("fontconfig" ,fontconfig)
338 ("check" ,check)))
339 (home-page "http://www.gnu.org/software/freedink/")
340 (synopsis "Twisted adventures of young pig farmer Dink Smallwood")
341 (description
342 "GNU FreeDink is a free and portable re-implementation of the engine
343 for the role-playing game Dink Smallwood. It supports not only the original
344 game data files but it also supports user-produced game mods or \"D-Mods\".
345 To that extent, it also includes a front-end for managing all of your D-Mods.")
346 (license license:gpl3+)))
347
348 (define freedink-data
349 (package
350 (name "freedink-data")
351 (version "1.08.20140901")
352 (source (origin
353 (method url-fetch)
354 (uri (string-append "mirror://gnu/freedink/freedink-data-"
355 version ".tar.gz"))
356 (sha256
357 (base32
358 "04f1aa8gfz30qkgv7chjz5n1s8v5hbqs01h2113cq1ylm3isd5sp"))))
359 (build-system gnu-build-system)
360 (arguments
361 `(#:phases (alist-delete 'configure (alist-delete 'check %standard-phases))
362 #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))))
363 (home-page "http://www.gnu.org/software/freedink/")
364 (synopsis "Game data for GNU Freedink")
365 (description
366 "This package contains the game data of GNU Freedink.")
367 (license license:gpl3+)))
368
369 ;; TODO: Add freedink-dfarc when there's a wxWidgets package.
370
371 (define-public freedink
372 ;; This is a wrapper that tells the engine where to find the data.
373 (package (inherit freedink-engine)
374 (name "freedink")
375 (build-system trivial-build-system)
376 (arguments
377 '(#:builder (begin
378 (use-modules (guix build utils))
379
380 (let* ((output (assoc-ref %outputs "out"))
381 (bin (string-append output "/bin"))
382 (executable (string-append bin "/freedink")))
383 (mkdir-p bin)
384 (call-with-output-file executable
385 (lambda (port)
386 (format port "#!~a/bin/sh
387 exec ~a/bin/freedink -refdir ~a/share/dink\n"
388 (assoc-ref %build-inputs "bash")
389 (assoc-ref %build-inputs "engine")
390 (assoc-ref %build-inputs "data"))
391 (chmod port #o777)))))
392 #:modules ((guix build utils))))
393 (inputs `(("engine" ,freedink-engine)
394 ("data" ,freedink-data)
395 ("bash" ,bash)))
396 (native-inputs '())))
397
398 (define-public xboard
399 (package
400 (name "xboard")
401 (version "4.7.3")
402 (source
403 (origin
404 (method url-fetch)
405 (uri (string-append "mirror://gnu/xboard/xboard-" version
406 ".tar.gz"))
407 (sha256
408 (base32
409 "1amy9krr0qkvcc7gnp3i9x9ma91fc5cq8hy3gdc7rmfsaczv1l3z"))))
410 (build-system gnu-build-system)
411 (arguments
412 '(#:phases
413 (alist-cons-before
414 'configure 'pre-conf
415 ;; This is GNU. So use gnuchess as the first choice of engine
416 (lambda _
417 (substitute* "xboard.conf.in"
418 (("-firstChessProgram fairymax") "-firstChessProgram gnuchess")))
419 %standard-phases)))
420 (inputs `(("cairo" ,cairo)
421 ("librsvg" ,librsvg)
422 ("libxt" ,libxt)
423 ("libxaw" ,libxaw)))
424 (native-inputs `(("texinfo" ,texinfo)
425 ("pkg-config" ,pkg-config)))
426 (home-page "http://www.gnu.org/software/xboard")
427 (synopsis "Graphical user interface for chess programs")
428 (description "GNU XBoard is a graphical board for all varieties of chess,
429 including international chess, xiangqi (Chinese chess), shogi (Japanese chess)
430 and Makruk. Several lesser-known variants are also supported. It presents a
431 fully interactive graphical interface and it can load and save games in the
432 Portable Game Notation.")
433 (license license:gpl3+)))
434
435
436 (define-public xboing
437 (package
438 (name "xboing")
439 (version "2.4")
440 (source
441 (origin
442 (method url-fetch)
443 (uri (string-append "http://www.techrescue.org/xboing/xboing"
444 version ".tar.gz"))
445 (sha256
446 (base32 "16m2si8wmshxpifk861vhpqviqxgcg8bxj6wfw8hpnm4r2w9q0b7"))))
447 (arguments
448 `(#:tests? #f
449 #:phases
450 (alist-replace
451 'configure
452 (lambda* (#:key outputs #:allow-other-keys)
453
454 (substitute* "Imakefile"
455 (("XPMINCLUDE[\t ]*= -I/usr/X11/include/X11")
456 (string-append "XPMINCLUDE = -I" (assoc-ref %build-inputs "libxpm")
457 "/include/X11")))
458
459 (substitute* "Imakefile"
460 (("XBOING_DIR = \\.") "XBOING_DIR=$(PROJECTROOT)"))
461
462 ;; FIXME: HIGH_SCORE_FILE should be set to somewhere writeable
463
464 (zero? (system* "xmkmf" "-a"
465 (string-append "-DProjectRoot="
466 (assoc-ref outputs "out")))))
467 (alist-replace 'install
468 (lambda* (#:key outputs #:allow-other-keys)
469 (and
470 (zero? (system* "make" "install.man"))
471 (zero? (system* "make" "install"))))
472 %standard-phases))))
473 (inputs `(("libx11" ,libx11)
474 ("libxext" ,libxext)
475 ("libxpm" ,libxpm)))
476 (native-inputs `(("imake" ,imake)
477 ("inetutils" ,inetutils)
478 ("makedepend" ,makedepend)))
479 (build-system gnu-build-system)
480 (home-page "http://www.techrescue.org/xboing")
481 (synopsis "Ball and paddle game")
482 (description "XBoing is a blockout type game where you have a paddle which
483 you control to bounce a ball around the game zone destroying blocks with a
484 proton ball. Each block carries a different point value. The more blocks you
485 destroy, the better your score. The person with the highest score wins.")
486 (license (license:x11-style "file://COPYING"
487 "Very similar to the X11 licence."))))
488
489 (define-public gtypist
490 (package
491 (name "gtypist")
492 (version "2.9.5")
493 (source (origin
494 (method url-fetch)
495 (uri (string-append "mirror://gnu/gtypist/gtypist-"
496 version ".tar.xz"))
497 (sha256
498 (base32
499 "0xzrkkmj0b1dw3yr0m9hml2y634cc4h61im6zwcq57s7285z8fn1"))
500 (modules '((guix build utils)))
501 (snippet
502 ;; We do not provide `ncurses.h' within an `ncursesw'
503 ;; sub-directory, so patch the source accordingly. See
504 ;; <http://bugs.gnu.org/19018>.
505 '(for-each (lambda (file)
506 (substitute* file
507 (("ncursesw/ncurses.h")
508 "ncurses.h")))
509 (find-files "." "configure$|\\.c$")))))
510 (build-system gnu-build-system)
511 (inputs `(("ncurses" ,ncurses)
512 ("perl" ,perl)))
513 (home-page "http://www.gnu.org/software/gtypist/")
514 (synopsis "Typing tutor")
515 (description
516 "GNU Typist is a universal typing tutor. It can be used to learn and
517 practice touch-typing. Several tutorials are included; in addition to
518 tutorials for the standard QWERTY layout, there are also tutorials for the
519 alternative layouts Dvorak and Colemak, as well as for the numpad. Tutorials
520 are primarily in English, however some in other languages are provided.")
521 (license license:gpl3+)))
522
523 (define-public openal
524 (package
525 (name "openal")
526 (version "1.15.1")
527 (source (origin
528 (method url-fetch)
529 (uri (string-append
530 "http://kcat.strangesoft.net/openal-releases/openal-soft-"
531 version ".tar.bz2"))
532 (sha256
533 (base32
534 "0mmhdqiyb3c9dzvxspm8h2v8jibhi8pfjxnf6m0wn744y1ia2a8f"))))
535 (build-system cmake-build-system)
536 (arguments
537 `(#:tests? #f)) ; no check target
538 (inputs
539 `(("alsa-lib" ,alsa-lib)
540 ("pulseaudio" ,pulseaudio)))
541 (synopsis "3D audio API")
542 (description
543 "OpenAL provides capabilities for playing audio in a virtual 3D
544 environment. Distance attenuation, doppler shift, and directional sound
545 emitters are among the features handled by the API. More advanced effects,
546 including air absorption, occlusion, and environmental reverb, are available
547 through the EFX extension. It also facilitates streaming audio, multi-channel
548 buffers, and audio capture.")
549 (home-page "http://kcat.strangesoft.net/openal.html")
550 (license license:lgpl2.0+)))
551
552 (define-public irrlicht
553 (package
554 (name "irrlicht")
555 (version "1.8.1")
556 (source (origin
557 (method url-fetch)
558 (uri (string-append
559 "mirror://sourceforge/irrlicht/Irrlicht%20SDK/"
560 (version-major+minor version)
561 "/" version "/irrlicht-" version ".zip"))
562 (sha256
563 (base32
564 "0yz9lvsc8aqk8wj4rnpanxrw90gqpwn9w5hxp94r8hnm2q0vjjw1"))))
565 (build-system gnu-build-system)
566 (arguments
567 '(#:phases (alist-cons-after
568 'unpack 'fix-build-env
569 (lambda* (#:key outputs #:allow-other-keys)
570 (let ((out (assoc-ref outputs "out")))
571 (substitute* "Makefile"
572 (("INSTALL_DIR = /usr/local/lib")
573 (string-append "INSTALL_DIR = " out "/lib")))
574 ;; The Makefile assumes these directories exist.
575 (mkdir-p (string-append out "/lib"))
576 (mkdir-p (string-append out "/include"))))
577 (alist-replace
578 'unpack
579 (lambda* (#:key source #:allow-other-keys)
580 (and (zero? (system* "unzip" source))
581 ;; The actual source is buried a few directories deep.
582 (chdir "irrlicht-1.8.1/source/Irrlicht/")))
583 (alist-cons-after
584 'unpack 'apply-patch/mesa-10-fix
585 (lambda* (#:key inputs #:allow-other-keys)
586 (zero? (system* "patch" "--force" "-p3" "-i"
587 (assoc-ref inputs "patch/mesa-10-fix"))))
588 ;; No configure script
589 (alist-delete 'configure %standard-phases))))
590 #:tests? #f ; no check target
591 #:make-flags '("CC=gcc" "sharedlib")))
592 (native-inputs
593 `(("patch/mesa-10-fix" ,(search-patch "irrlicht-mesa-10.patch"))
594 ("unzip" ,unzip)))
595 (inputs
596 `(("mesa" ,mesa)
597 ("glu" ,glu)))
598 (synopsis "3D game engine written in C++")
599 (description
600 "The Irrlicht Engine is a high performance realtime 3D engine written in
601 C++. Features include an OpenGL renderer, extensible materials, scene graph
602 management, character animation, particle and other special effects, support
603 for common mesh file formats, and collision detection.")
604 (home-page "http://irrlicht.sourceforge.net/")
605 (license license:zlib)))
606
607 (define minetest-data
608 (package
609 (name "minetest-data")
610 (version "0.4.11")
611 (source (origin
612 (method url-fetch)
613 (uri (string-append
614 "https://github.com/minetest/minetest_game/archive/"
615 version ".tar.gz"))
616 (sha256
617 (base32
618 "0hzb27srv6f2j84dpxx2p0p0aaq9vdp5jvbrfpklb5q5ssdjxvc6"))))
619 (build-system trivial-build-system)
620 (native-inputs
621 `(("source" ,source)
622 ("tar" ,tar)
623 ("gzip" ,(@ (gnu packages compression) gzip))))
624 (arguments
625 `(#:modules ((guix build utils))
626 #:builder (begin
627 (use-modules (guix build utils))
628 (let ((tar (string-append (assoc-ref %build-inputs "tar")
629 "/bin/tar"))
630 (install-dir (string-append
631 %output
632 "/share/minetest/games/minetest_game"))
633 (path (string-append (assoc-ref %build-inputs
634 "gzip")
635 "/bin")))
636 (setenv "PATH" path)
637 (system* tar "xvf" (assoc-ref %build-inputs "source"))
638 (chdir (string-append "minetest_game-" ,version))
639 (mkdir-p install-dir)
640 (copy-recursively "." install-dir)))))
641 (synopsis "Main game data for the Minetest game engine")
642 (description
643 "Game data for the Minetest infinite-world block sandox game.")
644 (home-page "http://minetest.net")
645 (license license:lgpl2.1+)))
646
647 (define-public minetest
648 (package
649 (name "minetest")
650 (version "0.4.11")
651 (source (origin
652 (method url-fetch)
653 (uri (string-append
654 "https://github.com/minetest/minetest/archive/"
655 version ".tar.gz"))
656 (sha256
657 (base32
658 "0h223svzkvp63b77nqfxy7k8whw4543gahs3kxd3x4myi5ax5z5f"))))
659 (build-system cmake-build-system)
660 (arguments
661 '(#:modules ((guix build utils)
662 (guix build cmake-build-system)
663 (ice-9 match))
664 #:phases (alist-cons-before
665 'configure 'set-cpath
666 (lambda* (#:key inputs #:allow-other-keys)
667 (use-modules (ice-9 match))
668 ;; Adjust the CPATH so that cmake can find irrlicht,
669 ;; openal, and curl headers.
670 (set-path-environment-variable "CPATH"
671 '("include/AL"
672 "include/irrlicht"
673 "include/curl"
674 "include")
675 (map (match-lambda
676 ((_ . dir) dir))
677 inputs)))
678 %standard-phases)
679 #:configure-flags '("-DRUN_IN_PLACE=0"
680 "-DENABLE_FREETYPE=1"
681 "-DENABLE_GETTEXT=1")
682 #:tests? #f)) ; no check target
683 (native-search-paths
684 (list (search-path-specification
685 (variable "MINETEST_SUBGAME_PATH")
686 (files '("share/minetest/games")))))
687 (native-inputs
688 `(("pkg-config" ,pkg-config)))
689 (inputs
690 `(("irrlicht" ,irrlicht)
691 ("libpng" ,libpng)
692 ("libjpeg-8" ,libjpeg-8)
693 ("libxxf86vm" ,libxxf86vm)
694 ("mesa" ,mesa)
695 ("libogg" ,libogg)
696 ("libvorbis" ,libvorbis)
697 ("openal" ,openal)
698 ("freetype" ,(@ (gnu packages fontutils) freetype))
699 ("curl" ,curl)
700 ("luajit" ,luajit)
701 ("gettext" ,gnu-gettext)
702 ("sqlite" ,sqlite)))
703 (propagated-inputs
704 `(("minetest-data" ,minetest-data)))
705 (synopsis "Infinite-world block sandbox game")
706 (description
707 "Minetest is a sandbox construction game. Players can create and destroy
708 various types of blocks in a three-dimensional open world. This allows
709 forming structures in every possible creation, on multiplayer servers or as a
710 single player. Mods and texture packs allow players to personalize the game
711 in different ways.")
712 (home-page "http://minetest.net")
713 (license license:lgpl2.1+)))
714
715 (define glkterm
716 (package
717 (name "glkterm")
718 (version "1.0.4")
719 (source
720 (origin
721 (method url-fetch)
722 (uri (string-append "http://www.ifarchive.org/if-archive/programming/"
723 "glk/implementations/glkterm-104.tar.gz"))
724 (sha256
725 (base32
726 "0zlj9nlnkdlvgbiliczinirqygiq8ikg5hzh5vgcmnpg9pvnwga7"))))
727 (build-system gnu-build-system)
728 (propagated-inputs `(("ncurses" ,ncurses))) ; required by Make.glkterm
729 (arguments
730 '(#:tests? #f ; no check target
731 #:phases
732 (alist-replace
733 'install
734 (lambda* (#:key outputs #:allow-other-keys)
735 (let* ((out (assoc-ref outputs "out"))
736 (inc (string-append out "/include")))
737 (mkdir-p inc)
738 (for-each
739 (lambda (file)
740 (copy-file file (string-append inc "/" file)))
741 '("glk.h" "glkstart.h" "gi_blorb.h" "gi_dispa.h" "Make.glkterm"))
742 (mkdir (string-append out "/lib"))
743 (copy-file "libglkterm.a" (string-append out "/lib/libglkterm.a"))))
744 (alist-delete 'configure %standard-phases))))
745 (home-page "http://www.eblong.com/zarf/glk/")
746 (synopsis "Curses Implementation of the Glk API")
747 (description
748 "Glk defines a portable API for applications with text UIs. It was
749 primarily designed for interactive fiction, but it should be suitable for many
750 interactive text utilities, particularly those based on a command line.
751 This is an implementation of the Glk library which runs in a terminal window,
752 using the curses.h library for screen control.")
753 (license (license:fsf-free "file://README"))))
754
755 (define-public glulxe
756 (package
757 (name "glulxe")
758 (version "0.5.2")
759 (source
760 (origin
761 (method url-fetch)
762 (uri (string-append "http://www.ifarchive.org/if-archive/programming/"
763 "glulx/interpreters/glulxe/glulxe-052.tar.gz"))
764 (sha256
765 (base32
766 "19iw6kl8ncqcy9pv4gsqfh3xsa1n94zd234rqavvmxccnf3nj19g"))))
767 (build-system gnu-build-system)
768 (inputs `(("glk" ,glkterm)))
769 (arguments
770 '(#:tests? #f ; no check target
771 #:make-flags
772 (let* ((glk (assoc-ref %build-inputs "glk")))
773 (list (string-append "GLKINCLUDEDIR=" glk "/include")
774 (string-append "GLKLIBDIR=" glk "/lib")
775 (string-append "GLKMAKEFILE=" "Make.glkterm")))
776 #:phases
777 (alist-replace
778 'install
779 (lambda* (#:key outputs #:allow-other-keys)
780 (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
781 (mkdir-p bin)
782 (copy-file "glulxe" (string-append bin "/glulxe"))))
783 (alist-delete 'configure %standard-phases))))
784 (home-page "http://www.eblong.com/zarf/glulx/")
785 (synopsis "Interpreter for Glulx VM")
786 (description
787 "Glulx is a 32-bit portable virtual machine intended for writing and
788 playing interactive fiction. It was designed by Andrew Plotkin to relieve
789 some of the restrictions in the venerable Z-machine format. This is the
790 reference interpreter, using Glk API.")
791 (license (license:fsf-free "file://README"))))
792
793 (define-public retroarch
794 (package
795 (name "retroarch")
796 (version "1.0.0.3-beta")
797 (source
798 (origin
799 (method url-fetch)
800 (uri (string-append "https://github.com/libretro/RetroArch/archive/"
801 version ".tar.gz"))
802 (sha256
803 (base32 "1iqcrb076xiih20sk8n1w79xsp4fb8pj4vkmdc1xn562h56y4nxx"))))
804 (build-system gnu-build-system)
805 (arguments
806 '(#:tests? #f ; no tests
807 #:phases
808 (alist-replace
809 'configure
810 (lambda _
811 (substitute* "qb/qb.libs.sh"
812 (("/bin/true") (which "true")))
813 (zero? (system*
814 "./configure"
815 (string-append "--prefix=" %output)
816 (string-append "--global-config-dir=" %output "/etc"))))
817 %standard-phases)))
818 (inputs
819 `(("alsa-lib" ,alsa-lib)
820 ("ffmpeg" ,ffmpeg)
821 ("freetype" ,freetype)
822 ("libxinerama" ,libxinerama)
823 ("libxkbcommon" ,libxkbcommon)
824 ("libxml2" ,libxml2)
825 ("libxv" ,libxv)
826 ("mesa" ,mesa)
827 ("openal" ,openal)
828 ("pulseaudio" ,pulseaudio)
829 ("python" ,python)
830 ("sdl" ,sdl2)
831 ("udev" ,eudev)
832 ("zlib" ,zlib)))
833 (native-inputs
834 `(("pkg-config" ,pkg-config)
835 ("which" ,which)))
836 (home-page "http://www.libretro.com/")
837 (synopsis "Reference frontend for the libretro API")
838 (description
839 "Libretro is a simple but powerful development interface that allows for
840 the easy creation of emulators, games and multimedia applications that can plug
841 straight into any libretro-compatible frontend. RetroArch is the official
842 reference frontend for the libretro API, currently used by most as a modular
843 multi-system game/emulator system.")
844 (license license:gpl3+)))