linux-initrd: Add USB kernel modules to the default initrd.
[jackhill/guix/guix.git] / gnu / packages / aspell.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages aspell)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses)
24 #:use-module (gnu packages perl)
25 #:use-module (gnu packages which))
26
27 (define-public aspell
28 (package
29 (name "aspell")
30 (version "0.60.6.1")
31 (source
32 (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/aspell/aspell-"
35 version ".tar.gz"))
36 (sha256
37 (base32
38 "1qgn5psfyhbrnap275xjfrzppf5a83fb67gpql0kfqv37al869gm"))))
39 (build-system gnu-build-system)
40 (inputs `(("perl" ,perl)))
41 (home-page "http://aspell.net/")
42 (synopsis "Spell checker")
43 (description
44 "Aspell is a spell-checker which can be used either as a library or as
45 a standalone program. Notable features of Aspell include its full support of
46 documents written in the UTF-8 encoding and its ability to use multiple
47 dictionaries, including personal ones.")
48 (license lgpl2.1+)))
49
50 \f
51 ;;;
52 ;;; Dictionaries.
53 ;;;
54 ;;; Use 'export ASPELL_CONF="dict-dir $HOME/.guix-profile/lib/aspell"' to use them.
55 ;;;
56
57 (define* (aspell-dictionary dict-name full-name
58 #:key version sha256 (prefix "aspell6-"))
59 (package
60 (name (string-append "aspell-dict-" dict-name))
61 (version version)
62 (source (origin
63 (method url-fetch)
64 (uri (string-append "mirror://gnu/aspell/dict/" dict-name
65 "/" prefix dict-name "-"
66 version ".tar.bz2"))
67 (sha256 sha256)))
68 (build-system gnu-build-system)
69 (arguments
70 `(#:phases (alist-replace
71 'configure
72 (lambda* (#:key outputs #:allow-other-keys)
73 (let ((out (assoc-ref outputs "out")))
74 (zero? (system* "./configure"))))
75 %standard-phases)
76 #:make-flags (let ((out (assoc-ref %outputs "out")))
77 (list (string-append "dictdir=" out "/lib/aspell")
78 (string-append "datadir=" out "/lib/aspell")))
79 #:tests? #f))
80 (native-inputs `(("aspell" ,aspell)
81 ("which" ,which)))
82 (synopsis (string-append full-name " dictionary for GNU Aspell")) ; XXX: i18n
83 (description
84 "This package provides a dictionary for the GNU Aspell spell checker.")
85 (license gpl2+)
86 (home-page "http://aspell.net/")))
87
88
89 (define-public aspell-dict-en
90 (aspell-dictionary "en" "English"
91 #:version "7.1-0"
92 #:sha256
93 (base32
94 "02ldfiny4iakgfgy4sdrzjqdzi7l1rmb6y30lv31kfy5x31g77gz")))
95
96 (define-public aspell-dict-eo
97 (aspell-dictionary "eo" "Esperanto"
98 #:version "2.1.20000225a-2"
99 #:sha256
100 (base32
101 "09vf0mbiicbmyb4bwb7v7lgpabnylg0wy7m3hlhl5rjdda6x3lj1")))
102
103 (define-public aspell-dict-es
104 (aspell-dictionary "es" "Spanish"
105 #:version "1.11-2"
106 #:sha256
107 (base32
108 "1k5g328ac1hdpp6fsg57d8md6i0aqcwlszp3gbmp5706wyhpydmd")))
109
110 (define-public aspell-dict-fr
111 (aspell-dictionary "fr" "French"
112 #:version "0.50-3"
113 #:prefix "aspell-"
114 #:sha256
115 (base32
116 "14ffy9mn5jqqpp437kannc3559bfdrpk7r36ljkzjalxa53i0hpr")))