gnu: perl: Return #t from all phases.
[jackhill/guix/guix.git] / gnu / packages / photo.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2015, 2017 Andreas Enge <andreas@enge.fr>
5 ;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
7 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages photo)
26 #:use-module (guix build-system cmake)
27 #:use-module (guix build-system gnu)
28 #:use-module (guix build-system perl)
29 #:use-module (guix download)
30 #:use-module ((guix licenses) #:prefix license:)
31 #:use-module (guix packages)
32 #:use-module (guix utils)
33 #:use-module (gnu packages)
34 #:use-module (gnu packages algebra)
35 #:use-module (gnu packages autotools)
36 #:use-module (gnu packages base)
37 #:use-module (gnu packages boost)
38 #:use-module (gnu packages compression)
39 #:use-module (gnu packages curl)
40 #:use-module (gnu packages databases)
41 #:use-module (gnu packages gettext)
42 #:use-module (gnu packages ghostscript)
43 #:use-module (gnu packages gl)
44 #:use-module (gnu packages gnome)
45 #:use-module (gnu packages glib)
46 #:use-module (gnu packages graphics)
47 #:use-module (gnu packages gtk)
48 #:use-module (gnu packages image)
49 #:use-module (gnu packages imagemagick)
50 #:use-module (gnu packages libcanberra)
51 #:use-module (gnu packages libusb)
52 #:use-module (gnu packages llvm)
53 #:use-module (gnu packages man)
54 #:use-module (gnu packages maths)
55 #:use-module (gnu packages perl)
56 #:use-module (gnu packages pkg-config)
57 #:use-module (gnu packages popt)
58 #:use-module (gnu packages python)
59 #:use-module (gnu packages readline)
60 #:use-module (gnu packages tex)
61 #:use-module (gnu packages web)
62 #:use-module (gnu packages wxwidgets)
63 #:use-module (gnu packages xfig)
64 #:use-module (gnu packages xorg)
65 #:use-module (gnu packages xml)
66 #:use-module ((srfi srfi-1) #:hide (zip))
67 #:use-module (srfi srfi-26))
68
69 (define-public libraw
70 (package
71 (name "libraw")
72 (version "0.19.0")
73 (source (origin
74 (method url-fetch)
75 (uri (string-append "https://www.libraw.org/data/LibRaw-"
76 version ".tar.gz"))
77 (sha256
78 (base32
79 "0nfj7s7qmgfy1cl8s3ck7dxjvprfq5glfi6iidmvmy8r7gl52gz8"))))
80 (build-system gnu-build-system)
81 (native-inputs
82 `(("pkg-config" ,pkg-config)))
83 (inputs
84 `(("libjpeg" ,libjpeg))) ;for lossy DNGs and old Kodak cameras
85 (propagated-inputs
86 `(("lcms" ,lcms))) ;for color profiles
87 (home-page "https://www.libraw.org")
88 (synopsis "Raw image decoder")
89 (description
90 "LibRaw is a library for reading RAW files obtained from digital photo
91 cameras (CRW/CR2, NEF, RAF, DNG, and others).")
92 ;; LibRaw is distributed under both LGPL2.1 and CDDL 1.0. From the README:
93 ;; "You may use one of these licensing modes and switch between them. If
94 ;; you modify LibRaw source and made your changes public, you should accept
95 ;; both two licensing modes for your changes/additions."
96 (license (list license:lgpl2.1 license:cddl1.0))))
97
98 (define-public libraw-0.18
99 (package (inherit libraw)
100 (name "libraw")
101 (version "0.18.12")
102 (source (origin
103 (method url-fetch)
104 (uri (string-append "https://www.libraw.org/data/LibRaw-"
105 version ".tar.gz"))
106 (sha256
107 (base32
108 "1m2khr2cij8z6lawgbmdksjn14fpnjsy8ad4qahnpqapm1slsxap"))))))
109
110 (define-public libexif
111 (package
112 (name "libexif")
113 (version "0.6.21")
114 (source (origin
115 (method url-fetch)
116 (uri (string-append "mirror://sourceforge/libexif/libexif/"
117 version "/libexif-" version ".tar.bz2"))
118 (patches (search-patches "libexif-CVE-2016-6328.patch"
119 "libexif-CVE-2017-7544.patch"))
120 (sha256
121 (base32
122 "06nlsibr3ylfwp28w8f5466l6drgrnydgxrm4jmxzrmk5svaxk8n"))))
123 (build-system gnu-build-system)
124 (home-page "https://libexif.github.io/")
125 (synopsis "Read and manipulate EXIF data in digital photographs")
126 (description
127 "The libexif C library allows applications to read, edit, and save EXIF
128 data as produced by digital cameras.")
129 (license license:lgpl2.1+)))
130
131 (define-public libgphoto2
132 (package
133 (name "libgphoto2")
134 (version "2.5.20")
135 (source (origin
136 (method url-fetch)
137 (uri (string-append "mirror://sourceforge/gphoto/libgphoto/"
138 version "/libgphoto2-" version ".tar.bz2"))
139 (sha256
140 (base32
141 "03wbwsb4v7yay8g5ni7pzmkbrh7qnqx977bddjpxsp9f1qag03z1"))))
142 (build-system gnu-build-system)
143 (native-inputs `(("pkg-config" ,pkg-config)))
144 (inputs
145 `(("libjpeg-turbo" ,libjpeg-turbo)
146 ("libltdl" ,libltdl)
147 ("libusb" ,libusb)
148 ("libxml2" ,libxml2)))
149 (propagated-inputs
150 `(;; The .pc refers to libexif.
151 ("libexif" ,libexif)))
152 (home-page "http://www.gphoto.org/proj/libgphoto2/")
153 (synopsis "Accessing digital cameras")
154 (description
155 "This is the library backend for gphoto2. It contains the code for PTP,
156 MTP, and other vendor specific protocols for controlling and transferring data
157 from digital cameras.")
158
159 ;; 'COPYING' says LGPLv2.1+, but in practices files are under LGPLv2+.
160 (license license:lgpl2.1+)))
161
162 (define-public gphoto2
163 (package
164 (name "gphoto2")
165 (version "2.5.17")
166 (source (origin
167 (method url-fetch)
168 (uri (string-append "mirror://sourceforge/gphoto/gphoto/" version
169 "/gphoto2-" version ".tar.bz2"))
170 (sha256
171 (base32
172 "0kslwclyyzvnxjw3gdzhlagj7l5f8lba833ipr9s0s0c4hwi0mxa"))))
173 (build-system gnu-build-system)
174 (native-inputs
175 `(("pkg-config" ,pkg-config)))
176 (inputs
177 `(("readline" ,readline)
178 ("libjpeg-turbo" ,libjpeg-turbo)
179 ("popt" ,popt)
180 ("libexif" ,libexif)
181 ("libgphoto2" ,libgphoto2)))
182 (arguments
183 '(#:phases
184 (modify-phases %standard-phases
185 (add-before 'check 'pre-check
186 (lambda* (#:key inputs #:allow-other-keys)
187 (substitute* (find-files "tests/data" "\\.param$")
188 (("/usr/bin/env")
189 (which "env")))
190 #t)))
191
192 ;; FIXME: There is 1 test failure, most likely related to the build
193 ;; environment.
194 #:tests? #f))
195
196 (home-page "http://www.gphoto.org/")
197 (synopsis "Command-line tools to access digital cameras")
198 (description
199 "Gphoto2 is a set of command line utilities for manipulating a large
200 number of different digital cameras. Through libgphoto2, it supports PTP,
201 MTP, and much more.")
202
203 ;; Files are typically under LGPLv2+, but 'COPYING' says GPLv2+.
204 (license license:gpl2+)))
205
206 (define-public perl-image-exiftool
207 (package
208 (name "perl-image-exiftool")
209 (version "11.11")
210 (source (origin
211 (method url-fetch)
212 (uri (string-append
213 "mirror://cpan/authors/id/E/EX/EXIFTOOL/Image-ExifTool-"
214 version ".tar.gz"))
215 (sha256
216 (base32
217 "1szg1k82nz88pp5n7lg71ja7q3hh5i5f9bcbb7m482dwrmsywkp6"))))
218 (build-system perl-build-system)
219 (arguments
220 '(#:phases
221 (modify-phases %standard-phases
222 (add-after 'install 'post-install
223 (lambda* (#:key outputs #:allow-other-keys)
224 ;; Make sure the 'exiftool' commands finds the library.
225 ;; XXX: Shouldn't it be handled by PERL-BUILD-SYSTEM?
226 (let* ((out (assoc-ref outputs "out"))
227 (pm (find-files out "^ExifTool\\.pm$"))
228 (lib (dirname (dirname (car pm)))))
229 (wrap-program (string-append out "/bin/exiftool")
230 `("PERL5LIB" prefix (,lib)))
231 #t))))))
232 (home-page "https://metacpan.org/release/Image-ExifTool")
233 (synopsis "Program and Perl library to manipulate EXIF and other metadata")
234 (description "This package provides the @code{exiftool} command and the
235 @code{Image::ExifTool} Perl library to manipulate EXIF tags of digital images
236 and a wide variety of other metadata.")
237 (license license:perl-license)))
238
239 (define-public libpano13
240 (package
241 (name "libpano13")
242 (version "2.9.19")
243 (source (origin
244 (method url-fetch)
245 (uri (string-append "mirror://sourceforge/panotools/libpano13/"
246 "libpano13-" version "/"
247 "libpano13-" version ".tar.gz"))
248 (sha256
249 (base32
250 "1a4m3plmfcrrplqs9zfzhc5apibn10m5sajpizm1sd3q74w5fwq3"))))
251 (build-system cmake-build-system)
252 (inputs
253 `(("libjpeg" ,libjpeg)
254 ("libpng" ,libpng)
255 ("libtiff" ,libtiff)
256 ("zlib" ,zlib)))
257 (home-page "http://panotools.sourceforge.net/")
258 (synopsis "Library for panoramic images")
259 (description
260 "The libpano13 package contains the backend library written by the
261 Panorama Tools project for building panoramic images from a set of
262 overlapping images, as well as some command line tools.")
263 (license license:gpl2+)))
264
265 (define-public enblend-enfuse
266 (package
267 (name "enblend-enfuse")
268 (version "4.2")
269 (source (origin
270 (method url-fetch)
271 (uri (string-append "mirror://sourceforge/enblend/"
272 name "/"
273 name "-" (version-major+minor version) "/"
274 name "-" version ".tar.gz"))
275 (sha256
276 (base32
277 "0j5x011ilalb47ssah50ag0a4phgh1b0wdgxdbbp1gcyjcjf60w7"))))
278 (build-system gnu-build-system)
279 (native-inputs
280 `(("pkg-config" ,pkg-config)
281 ("perl" ,perl)
282 ("perl-timedate" ,perl-timedate)
283 ;; for building the documentation
284 ("gnuplot" ,gnuplot)
285 ("help2man" ,help2man)
286 ("imagemagick" ,imagemagick)
287 ("libxml2" ,libxml2)
288 ("texlive-minimal" ,texlive-tiny)
289 ("tidy" ,tidy)
290 ("transfig" ,transfig)))
291 (inputs
292 `(("boost" ,boost)
293 ("gsl" ,gsl)
294 ("lcms" ,lcms)
295 ("libjpeg" ,libjpeg)
296 ("libpng" ,libpng)
297 ("libtiff" ,libtiff)
298 ("openexr" ,openexr)
299 ("vigra" ,vigra)
300 ("zlib" ,zlib)))
301 (arguments
302 `(#:configure-flags `("--enable-openmp")))
303 (home-page "http://enblend.sourceforge.net/")
304 (synopsis "Tools for combining and blending images")
305 (description
306 "Enblend blends away the seams in a panoramic image mosaic using a
307 multi-resolution spline. Enfuse merges different exposures of the same
308 scene to produce an image that looks much like a tone-mapped image.")
309 (license license:gpl2+)))
310
311 (define-public lensfun
312 (package
313 (name "lensfun")
314 (version "0.3.2")
315 (source (origin
316 (method url-fetch)
317 (uri (string-append
318 "mirror://sourceforge/lensfun/"
319 version "/lensfun-" version ".tar.gz"))
320 (sha256
321 (base32
322 "0cfk8jjhs9nbfjfdy98plrj9ayi59aph0nx6ppslgjhlcvacm2xf"))))
323 (build-system cmake-build-system)
324 (arguments
325 `(,@(if (any (cute string-prefix? <> (or (%current-system)
326 (%current-target-system)))
327 '("x86_64" "i686"))
328 ;; SSE and SSE2 are supported only on Intel processors.
329 '()
330 '(#:configure-flags '("-DBUILD_FOR_SSE=OFF" "-DBUILD_FOR_SSE2=OFF")))
331 #:tests? #f)) ; There are no tests to run.
332 (native-inputs
333 `(("pkg-config" ,pkg-config)))
334 (inputs
335 `(("glib" ,glib)))
336 (home-page "https://sourceforge.net/projects/lensfun/")
337 (synopsis "Library to correct optical lens defects with a lens database")
338 (description "Digital photographs are not ideal. Of course, the better is
339 your camera, the better the results will be, but in any case if you look
340 carefully at shots taken even by the most expensive cameras equipped with the
341 most expensive lenses you will see various artifacts. It is very hard to make
342 ideal cameras, because there are a lot of factors that affect the final image
343 quality, and at some point camera and lens designers have to trade one factor
344 for another to achieve the optimal image quality, within the given design
345 restrictions and budget. But we all want ideal shots, don't we? So that's
346 what's Lensfun is all about: rectifying the defects introduced by your
347 photographic equipment.")
348 ;; The libraries are licensed under the LGPL3, the programs are
349 ;; licensed GPL3, and the database is license CC-BY-SA 3.0. See the
350 ;; README.md file for this clarification.
351 (license (list license:lgpl3 license:gpl3 license:cc-by-sa3.0))))
352
353 (define-public darktable
354 (package
355 (name "darktable")
356 (version "2.4.4")
357 (source (origin
358 (method url-fetch)
359 (uri (string-append
360 "https://github.com/darktable-org/darktable/releases/"
361 "download/release-"
362 version "/darktable-" version ".tar.xz"))
363 (sha256
364 (base32
365 "0kdhmiw4wxk2w9v2hms9yk8nl4ymdshnqyj0l07nivzzr6w20hwn"))))
366 (build-system cmake-build-system)
367 (arguments
368 `(#:tests? #f ; There are no tests.
369 #:configure-flags '("-DBINARY_PACKAGE_BUILD=On")
370 #:make-flags
371 (list
372 (string-append "CPATH=" (assoc-ref %build-inputs "ilmbase")
373 "/include/OpenEXR:" (or (getenv "CPATH") "")))
374 #:phases
375 (modify-phases %standard-phases
376 (add-before 'configure 'set-ldflags
377 (lambda* (#:key outputs #:allow-other-keys)
378 (setenv "LDFLAGS"
379 (string-append
380 "-Wl,-rpath="
381 (assoc-ref outputs "out") "/lib/darktable"))
382 #t)))))
383 (native-inputs
384 `(("llvm" ,llvm-3.9.1)
385 ("clang" ,clang-3.9.1)))
386 (inputs
387 `(("libxslt" ,libxslt)
388 ("libxml2" ,libxml2)
389 ("pugixml" ,pugixml)
390 ("gtk+" ,gtk+)
391 ("sqlite" ,sqlite)
392 ("libjpeg" ,libjpeg)
393 ("libpng" ,libpng)
394 ("cairo" ,cairo)
395 ("lcms" ,lcms)
396 ("exiv2" ,exiv2)
397 ("libtiff" ,libtiff)
398 ("curl" ,curl)
399 ("libgphoto2" ,libgphoto2)
400 ("dbus-glib" ,dbus-glib)
401 ("openexr" ,openexr)
402 ("ilmbase" ,ilmbase)
403 ("libsoup" ,libsoup)
404 ("python-jsonschema" ,python-jsonschema)
405 ("intltool" ,intltool)
406 ("perl" ,perl)
407 ("pkg-config" ,pkg-config)
408 ("libwebp" ,libwebp)
409 ("lensfun" ,lensfun)
410 ("librsvg" ,librsvg)
411 ("json-glib" ,json-glib)
412 ("freeimage" ,freeimage)))
413 (home-page "https://www.darktable.org")
414 (synopsis "Virtual lighttable and darkroom for photographers")
415 (description "Darktable is a photography workflow application and RAW
416 developer. It manages your digital negatives in a database, lets you view
417 them through a zoomable lighttable and enables you to develop raw images
418 and enhance them.")
419 ;; see src/is_supported_platform.h for supported platforms
420 (supported-systems '("i686-linux" "x86_64-linux" "aarch64-linux"))
421 (license license:gpl3+)))
422
423 (define-public hugin
424 (package
425 (name "hugin")
426 (version "2016.2.0")
427 (source (origin
428 (method url-fetch)
429 (uri (string-append "mirror://sourceforge/hugin/hugin/hugin-"
430 (version-major+minor version)
431 "/hugin-" version ".tar.bz2"))
432 (sha256
433 (base32
434 "058zd63vx29yrx2pphbbll7kzcxkai22q26lpw13rn4lvp41pasl"))))
435 (build-system cmake-build-system)
436 (native-inputs
437 `(("gettext" ,gnu-gettext)
438 ("pkg-config" ,pkg-config)))
439 (inputs
440 `(("boost" ,boost)
441 ("enblend-enfuse" ,enblend-enfuse)
442 ("exiv2" ,exiv2)
443 ("fftw" ,fftw)
444 ("flann" ,flann)
445 ("freeglut" ,freeglut)
446 ("glew" ,glew)
447 ("lcms" ,lcms)
448 ("libjpeg" ,libjpeg)
449 ("libpano13" ,libpano13)
450 ("libpng" ,libpng)
451 ("libtiff" ,libtiff)
452 ("libxi" ,libxi)
453 ("libxmu" ,libxmu)
454 ("mesa" ,mesa)
455 ("openexr" ,openexr)
456 ("sqlite" ,sqlite)
457 ("vigra" ,vigra)
458 ("wxwidgets" ,wxwidgets)
459 ("zlib" ,zlib)))
460 (arguments
461 `(#:tests? #f ; no check target
462 #:configure-flags
463 (list
464 ;; The header files of ilmbase (propagated by openexr) are not found
465 ;; when included by the header files of openexr, and an explicit
466 ;; flag needs to be set.
467 (string-append "-DCMAKE_CXX_FLAGS=-I"
468 (assoc-ref %build-inputs "ilmbase")
469 "/include/OpenEXR")
470 ;; Disable installation of the Python scripting interface.
471 ;; It would require the additional inputs python and swig.
472 ;; Installation would need to be tweaked, as it tries to install
473 ;; into the python directory.
474 "-DBUILD_HSI=OFF")
475 #:phases
476 (modify-phases %standard-phases
477 (add-before 'configure 'substitute
478 (lambda _
479 (substitute* "src/hugin1/base_wx/StitchingExecutor.cpp"
480 (("wxT\\(\"enblend\"\\)")
481 (string-append "wxT(\"" (which "enblend") "\")"))
482 (("wxT\\(\"enfuse\"\\)")
483 (string-append "wxT(\"" (which "enfuse") "\")")))
484 #t)))))
485 (home-page "http://hugin.sourceforge.net/")
486 (synopsis "Panorama photo stitcher")
487 (description
488 "Hugin is an easy to use panoramic imaging toolchain with a graphical
489 user interface. It can be used to assemble a mosaic of photographs into
490 a complete panorama and stitch any series of overlapping pictures.")
491 (license license:gpl2+)))
492
493 (define-public rawtherapee
494 (package
495 (name "rawtherapee")
496 (version "5.4")
497 (source (origin
498 (method url-fetch)
499 (uri (string-append "http://rawtherapee.com/shared/source/"
500 "rawtherapee-" version ".tar.xz"))
501 (sha256
502 (base32
503 "1229hxqq824hcqg1hy2cfglsp7kjbhhis9m33ss39pgmrb1w227d"))))
504 (build-system cmake-build-system)
505 (arguments
506 '(#:tests? #f ; no test suite
507 #:build-type "release"
508 #:configure-flags
509 (list (string-append "-DLENSFUNDBDIR="
510 (assoc-ref %build-inputs "lensfun")
511 "/share/lensfun")
512 ; Don't optimize the build for the host machine. See the file
513 ; 'ProcessorTargets.cmake' in the source distribution for more
514 ; information.
515 "-DPROC_TARGET_NUMBER=1"
516 ; These flags are recommended by upstream for distributed packages.
517 ; See the file 'RELEASE_NOTES.txt' in the source distribution.
518 "-O3"
519 "-DCACHE_NAME_SUFFIX=\"\"")))
520 (native-inputs
521 `(("pkg-config" ,pkg-config)))
522 (inputs
523 `(("expat" ,expat)
524 ("fftw" ,fftwf)
525 ("glib" ,glib)
526 ("glibmm" ,glibmm)
527 ("gtk+" ,gtk+)
528 ("gtkmm" ,gtkmm)
529 ("lcms" ,lcms)
530 ("lensfun" ,lensfun)
531 ("libcanberra" ,libcanberra)
532 ("libiptcdata" ,libiptcdata)
533 ("libjpeg" ,libjpeg)
534 ("libpng" ,libpng)
535 ("libsigc++" ,libsigc++)
536 ("libtiff" ,libtiff)
537 ("zlib" ,zlib)))
538 (home-page "http://rawtherapee.com")
539 (synopsis "Raw image developing and processing")
540 (description "RawTherapee is a raw image processing suite. It comprises a
541 subset of image editing operations specifically aimed at non-destructive raw
542 photo post-production and is primarily focused on improving a photographer's
543 workflow by facilitating the handling of large numbers of images. Most raw
544 formats are supported, including Pentax Pixel Shift, Canon Dual-Pixel, and those
545 from Foveon and X-Trans sensors.")
546 (license license:gpl3+)))