Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / file.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages file)
23 #:use-module (gnu packages)
24 #:use-module (guix licenses)
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix build-system gnu))
28
29 (define-public file
30 (package
31 (name "file")
32 (version "5.33")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append "ftp://ftp.astron.com/pub/file/file-"
36 version ".tar.gz"))
37 (sha256
38 (base32
39 "1iipnwjkag7q04zjkaqic41r9nlw0ml6mhqian6qkkbisb1whlhw"))))
40 (build-system gnu-build-system)
41
42 ;; When cross-compiling, this package depends upon a native install of
43 ;; itself.
44 (self-native-input? #t)
45
46 (synopsis "File type guesser")
47 (description
48 "The file command is a file type guesser, a command-line tool that tells
49 you in words what kind of data a file contains. It does not rely on filename
50 extensions to tell you the type of a file, but looks at the actual contents
51 of the file. This package provides the libmagic library.")
52 (license bsd-2)
53 (home-page "https://www.darwinsys.com/file/")))