gnu: libetonyek: Propagate inputs.
[jackhill/guix/guix.git] / gnu / packages / libreoffice.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages libreoffice)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module ((guix licenses)
24 #:select (gpl2+ lgpl2.1+ mpl1.1 mpl2.0 non-copyleft))
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages boost)
27 #:use-module (gnu packages check)
28 #:use-module (gnu packages compression)
29 #:use-module (gnu packages curl)
30 #:use-module (gnu packages cyrus-sasl)
31 #:use-module (gnu packages doxygen)
32 #:use-module (gnu packages ghostscript)
33 #:use-module (gnu packages gperf)
34 #:use-module (gnu packages icu4c)
35 #:use-module (gnu packages openssl)
36 #:use-module (gnu packages perl)
37 #:use-module (gnu packages pkg-config)
38 #:use-module (gnu packages python)
39 #:use-module (gnu packages xml))
40
41 (define-public ixion
42 (package
43 (name "ixion")
44 (version "0.9.1")
45 (source
46 (origin
47 (method url-fetch)
48 (uri (string-append "http://kohei.us/files/ixion/src/libixion-"
49 version ".tar.xz"))
50 (sha256 (base32
51 "18g3nk29ljiqbyi0ml49j2x3f3xrqckdm9i66sw5fxnj7hb5rqvp"))))
52 (build-system gnu-build-system)
53 (native-inputs
54 `(("pkg-config" ,pkg-config)))
55 (inputs
56 `(("mdds" ,mdds)
57 ("python" ,python-2))) ; looks for python.pc, not python3.pc
58 (home-page "https://gitlab.com/ixion/ixion")
59 (synopsis "General purpose formula parser and interpreter")
60 (description "Ixion is a library for calculating the results of formula
61 expressions stored in multiple named targets, or \"cells\". The cells can
62 be referenced from each other, and the library takes care of resolving
63 their dependencies automatically upon calculation.")
64 (license mpl2.0)))
65
66 (define-public orcus
67 (package
68 (name "orcus")
69 (version "0.7.1")
70 (source
71 (origin
72 (method url-fetch)
73 (uri (string-append "http://kohei.us/files/" name "/src/lib"
74 name "-" version ".tar.xz"))
75 (sha256 (base32
76 "0hva4qalg3dk6n1118ncr5fy8cqnj2f7fwldw7aa04124rj6p104"))))
77 (build-system gnu-build-system)
78 (native-inputs
79 `(("pkg-config" ,pkg-config)))
80 (inputs
81 `(("ixion" ,ixion)
82 ("mdds" ,mdds)
83 ("zlib" ,zlib)))
84 (home-page "https://gitlab.com/orcus/orcus")
85 (synopsis "File import filter library for spreadsheet documents")
86 (description "Orcus is a library that provides a collection of standalone
87 file processing filters. It is currently focused on providing filters for
88 spreadsheet documents. The library includes import filters for
89 Microsoft Excel 2007 XML, Microsoft Excel 2003 XML, Open Document Spreadsheet,
90 Plain Text, Gnumeric XML, Generic XML. It also includes low-level parsers for
91 CSV, CSS and XML.")
92 (license mpl2.0)))
93
94 (define-public librevenge
95 (package
96 (name "librevenge")
97 (version "0.0.2")
98 (source
99 (origin
100 (method url-fetch)
101 (uri (string-append "mirror://sourceforge/libwpd/" name "/" name "-"
102 version ".tar.xz"))
103 (sha256 (base32
104 "03ygxyb0vfjv8raif5q62sl33b54wkr5rzgadb8slijm6k281wpn"))))
105 (build-system gnu-build-system)
106 (native-inputs
107 `(("boost" ,boost)
108 ("cppunit" ,cppunit)
109 ("doxygen" ,doxygen)
110 ("pkg-config" ,pkg-config)))
111 (inputs
112 `(("zlib" ,zlib)))
113 (arguments
114 ;; avoid triggering configure errors by simple inclusion of boost headers
115 `(#:configure-flags '("--disable-werror")))
116 (home-page "http://sourceforge.net/p/libwpd/wiki/librevenge/")
117 (synopsis "Document importer for office suites")
118 (description "Librevenge is a base library for writing document import
119 filters. It has interfaces for text documents, vector graphics,
120 spreadsheets and presentations.")
121 (license (list mpl2.0 lgpl2.1+)))) ;dual licensed
122
123 (define-public libwpd
124 (package
125 (name "libwpd")
126 (version "0.10.0")
127 (source
128 (origin
129 (method url-fetch)
130 (uri (string-append "mirror://sourceforge/libwpd/" name "/" name "-"
131 version ".tar.xz"))
132 (sha256 (base32
133 "0b6krzr6kxzm89g6bapn805kdayq70hn16n5b5wfs2lwrf0ag2wx"))))
134 (build-system gnu-build-system)
135 (native-inputs
136 `(("doxygen" ,doxygen)
137 ("pkg-config" ,pkg-config)))
138 (propagated-inputs
139 `(("librevenge" ,librevenge))) ; in Requires field of .pkg
140 (inputs
141 `(("zlib" ,zlib)))
142 (home-page "http://libwpd.sourceforge.net/")
143 (synopsis "Library for importing WordPerfect documents")
144 (description "Libwpd is a C++ library designed to help process
145 WordPerfect documents. It is most commonly used to import such documents
146 into other word processors.")
147 (license (list mpl2.0 lgpl2.1+)))) ;dual licensed
148
149 (define-public libe-book
150 (package
151 (name "libe-book")
152 (version "0.1.2")
153 (source
154 (origin
155 (method url-fetch)
156 (uri (string-append "mirror://sourceforge/libebook/libe-book-"
157 version "/libe-book-" version ".tar.xz"))
158 (sha256
159 (base32
160 "1v48pd32r2pfysr3a3igc4ivcf6vvb26jq4pdkcnq75p70alp2bz"))))
161 (build-system gnu-build-system)
162 (native-inputs
163 `(("cppunit" ,cppunit)
164 ("gperf" ,gperf)
165 ("pkg-config" ,pkg-config)))
166 (propagated-inputs ; in Requires or Requires.private field of .pkg
167 `(("icu4c" ,icu4c)
168 ("librevenge" ,librevenge)
169 ("libxml2" ,libxml2)))
170 (inputs
171 `(("boost" ,boost)))
172 (arguments
173 ;; avoid triggering configure errors by simple inclusion of boost headers
174 `(#:configure-flags '("--disable-werror")))
175 (home-page "http://libebook.sourceforge.net")
176 (synopsis "Library for import of reflowable e-book formats")
177 (description "Libe-book is a library and a set of tools for reading and
178 converting various reflowable e-book formats. Currently supported are:
179 Broad Band eBook, eReader .pdb, FictionBook v. 2 (including zipped files),
180 PalmDoc Ebook, Plucker .pdb, QiOO (mobile format, for java-enabled
181 cellphones), TCR (simple compressed text format), TealDoc, zTXT,
182 ZVR (simple compressed text format).")
183 (license mpl2.0)))
184
185 (define-public libwpg
186 (package
187 (name "libwpg")
188 (version "0.3.0")
189 (source
190 (origin
191 (method url-fetch)
192 (uri (string-append "mirror://sourceforge/libwpg/" name "/" name "-"
193 version ".tar.xz"))
194 (sha256 (base32
195 "097jx8a638fwwfrzf6v29r1yhc34rq9526py7wf0ck2z4fcr2w3g"))))
196 (build-system gnu-build-system)
197 (native-inputs
198 `(("doxygen" ,doxygen)
199 ("pkg-config" ,pkg-config)))
200 (propagated-inputs
201 `(("libwpd" ,libwpd))) ; in Requires field of .pkg
202 (inputs
203 `(("perl" ,perl)
204 ("zlib" ,zlib)))
205 (home-page "http://libwpg.sourceforge.net/")
206 (synopsis "Library and tools for the WordPerfect Graphics format")
207 (description "The libwpg project provides a library and tools for
208 working with graphics in the WPG (WordPerfect Graphics) format.")
209 (license (list mpl2.0 lgpl2.1+)))) ;dual licensed
210
211 (define-public libcmis
212 (package
213 (name "libcmis")
214 (version "0.5.0")
215 (source
216 (origin
217 (method url-fetch)
218 (uri (string-append "mirror://sourceforge/" name "/" name "-"
219 version ".tar.gz"))
220 (sha256 (base32
221 "1dprvk4fibylv24l7gr49gfqbkfgmxynvgssvdcycgpf7n8h4zm8"))))
222 (build-system gnu-build-system)
223 (native-inputs
224 `(("cppunit" ,cppunit)
225 ("pkg-config" ,pkg-config)))
226 (propagated-inputs ; in Requires field of .pkg
227 `(("curl" ,curl)
228 ("libxml2" ,libxml2)))
229 (inputs
230 `(("boost" ,boost)
231 ("cyrus-sasl" ,cyrus-sasl)
232 ("openssl" ,openssl)))
233 (arguments
234 `(#:configure-flags
235 (list
236 ;; FIXME: Man pages generation requires docbook-to-man; reenable
237 ;; it once this is available.
238 "--without-man"
239 ;; avoid triggering configure errors by simple inclusion of
240 ;; boost headers
241 "--disable-werror"
242 ;; During configure, the boost headers are found, but linking
243 ;; fails without the following flag.
244 (string-append "--with-boost="
245 (assoc-ref %build-inputs "boost")))))
246 (home-page "http://sourceforge.net/projects/libcmis/")
247 (synopsis "CMIS client library")
248 (description "LibCMIS is a C++ client library for the CMIS interface. It
249 allows C++ applications to connect to any ECM behaving as a CMIS server such
250 as Alfresco or Nuxeo.")
251 (license (list mpl1.1 gpl2+ lgpl2.1+)))) ; triple license
252
253 (define-public libabw
254 (package
255 (name "libabw")
256 (version "0.1.1")
257 (source
258 (origin
259 (method url-fetch)
260 (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
261 name "-" version ".tar.xz"))
262 (sha256 (base32
263 "0zi1zj4fpxgpglbbb5n1kg3dmhqq5rpf46lli89r5daavp19iing"))))
264 (build-system gnu-build-system)
265 (native-inputs
266 `(("doxygen" ,doxygen)
267 ("gperf" ,gperf)
268 ("perl" ,perl)
269 ("pkg-config" ,pkg-config)))
270 (propagated-inputs ; in Requires or Requires.private field of .pkg
271 `(("librevenge" ,librevenge)
272 ("libxml2" ,libxml2)))
273 (inputs
274 `(("boost" ,boost)))
275 (arguments
276 ;; avoid triggering configure errors by simple inclusion of boost headers
277 `(#:configure-flags '("--disable-werror")))
278 (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libabw")
279 (synopsis "Library for parsing the AbiWord format")
280 (description "Libabw is a library that parses the file format of
281 AbiWord documents.")
282 (license mpl2.0)))
283
284 (define-public libcdr
285 (package
286 (name "libcdr")
287 (version "0.1.1")
288 (source
289 (origin
290 (method url-fetch)
291 (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
292 name "-" version ".tar.xz"))
293 (sha256 (base32
294 "07yzb1yr5kzv0binzj5swz3zzay2gw3xb0fbkc2zwdssgrkf19nh"))))
295 (build-system gnu-build-system)
296 (native-inputs
297 `(("doxygen" ,doxygen)
298 ("pkg-config" ,pkg-config)))
299 (propagated-inputs ; in Requires or Requires.private field of .pkg
300 `(("icu4c" ,icu4c)
301 ("lcms" ,lcms)
302 ("librevenge" ,librevenge)
303 ("zlib" ,zlib)))
304 (inputs
305 `(("boost" ,boost)))
306 (arguments
307 ;; avoid triggering a build failure due to warnings
308 `(#:configure-flags '("--disable-werror")))
309 (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libcdr")
310 (synopsis "Library for parsing the CorelDRAW format")
311 (description "Libcdr is a library that parses the file format of
312 CorelDRAW documents of all versions.")
313 (license mpl2.0)))
314
315 (define-public libetonyek
316 (package
317 (name "libetonyek")
318 (version "0.1.1")
319 (source
320 (origin
321 (method url-fetch)
322 (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
323 name "-" version ".tar.xz"))
324 (sha256 (base32
325 "0gn8v24jb9r9kxppbws6xlc7knpd9mk2n9xjvziccv5f2l7mlslw"))))
326 (build-system gnu-build-system)
327 (native-inputs
328 `(("cppunit" ,cppunit)
329 ("doxygen" ,doxygen)
330 ("gperf" ,gperf)
331 ("pkg-config" ,pkg-config)))
332 (propagated-inputs ; in Requires or Requires.private field of .pkg
333 `(("librevenge" ,librevenge)
334 ("libxml2" ,libxml2)))
335 (inputs
336 `(("boost" ,boost)))
337 (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libetonyek")
338 (synopsis "Library for parsing the Apple Keynote format")
339 (description "Libetonyek is a library that parses the file format of
340 Apple Keynote documents. It currently supports Keynote versions 2 to 5.")
341 (license mpl2.0)))
342
343 (define-public libexttextcat
344 (package
345 (name "libexttextcat")
346 (version "3.4.4")
347 (source
348 (origin
349 (method url-fetch)
350 (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
351 name "-" version ".tar.xz"))
352 (sha256 (base32
353 "14v2hkygnmf1zgahfm1fha47cr67iikrz2ymiqi28d2jydn0hk7j"))))
354 (build-system gnu-build-system)
355 (home-page "http://www.freedesktop.org/wiki/Software/libexttextcat/")
356 (synopsis "Text Categorization library")
357 (description "Libexttextcat is an N-Gram-Based Text Categorization
358 library primarily intended for language guessing.")
359 (license (non-copyleft "file://LICENSE"
360 "See LICENSE in the distribution."))))
361
362 (define-public libfreehand
363 (package
364 (name "libfreehand")
365 (version "0.1.0")
366 (source
367 (origin
368 (method url-fetch)
369 (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
370 name "-" version ".tar.xz"))
371 (sha256 (base32
372 "01j7mxi4lmf72w1mv2r098p8l0csdd94w2gq0ncp93djn34al6ai"))))
373 (build-system gnu-build-system)
374 (native-inputs
375 `(("doxygen" ,doxygen)
376 ("gperf" ,gperf)
377 ("perl" ,perl)
378 ("pkg-config" ,pkg-config)))
379 (inputs
380 `(("librevenge" ,librevenge)
381 ("zlib" ,zlib)))
382 (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libfreehand")
383 (synopsis "Library for parsing the FreeHand format")
384 (description "Libfreehand is a library that parses the file format of
385 Aldus/Macromedia/Adobe FreeHand documents.")
386 (license mpl2.0)))
387
388 (define-public libmspub
389 (package
390 (name "libmspub")
391 (version "0.1.2")
392 (source
393 (origin
394 (method url-fetch)
395 (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
396 name "-" version ".tar.xz"))
397 (sha256 (base32
398 "03sn6lxpr49sdq6j8q7fw7yjybyfahhs03z80388mh105pwapfmh"))))
399 (build-system gnu-build-system)
400 (native-inputs
401 `(("doxygen" ,doxygen)
402 ("pkg-config" ,pkg-config)))
403 (inputs
404 `(("boost" ,boost)
405 ("icu4c" ,icu4c)
406 ("librevenge" ,librevenge)
407 ("zlib" ,zlib)))
408 (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libmspub")
409 (synopsis "Library for parsing the Microsoft Publisher format")
410 (description "Libmspub is a library that parses the file format of
411 Microsoft Publisher documents of all versions.")
412 (license mpl2.0)))
413
414 (define-public libpagemaker
415 (package
416 (name "libpagemaker")
417 (version "0.0.2")
418 (source
419 (origin
420 (method url-fetch)
421 (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
422 name "-" version ".tar.xz"))
423 (sha256 (base32
424 "05zgj5ngg9z4b7dnrfs59nm0macm99lzyxv4mg53jcvp0mkgigfd"))))
425 (build-system gnu-build-system)
426 (native-inputs
427 `(("doxygen" ,doxygen)
428 ("pkg-config" ,pkg-config)))
429 (inputs
430 `(("boost" ,boost)
431 ("librevenge" ,librevenge)
432 ("zlib" ,zlib)))
433 (arguments
434 ;; avoid triggering a build failure due to warnings
435 `(#:configure-flags '("--disable-werror")))
436 (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libpagemaker")
437 (synopsis "Library for parsing the PageMaker format")
438 (description "Libpagemaker is a library that parses the file format of
439 Aldus/Adobe PageMaker documents. Currently it only understands documents
440 created by PageMaker version 6.x and 7.")
441 (license mpl2.0)))
442
443 (define-public libvisio
444 (package
445 (name "libvisio")
446 ;; FIXME: The newer version 0.1.1 fails its tests.
447 (version "0.1.0")
448 (source
449 (origin
450 (method url-fetch)
451 (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
452 name "-" version ".tar.xz"))
453 (sha256 (base32
454 "0vvd2wyp4rw6s9xnj1dc9vgdpfvm45gnb5b9hhzif0fdnx4iskqf"))))
455 (build-system gnu-build-system)
456 (native-inputs
457 `(("cppunit" ,cppunit)
458 ("doxygen" ,doxygen)
459 ("gperf" ,gperf)
460 ("perl" ,perl)
461 ("pkg-config" ,pkg-config)))
462 (inputs
463 `(("boost" ,boost)
464 ("icu4c" ,icu4c)
465 ("librevenge" ,librevenge)
466 ("libxml2" ,libxml2)))
467 ;; FIXME: Not needed any more for newer version 0.1.1.
468 (arguments
469 ;; avoid triggering a build failure due to warnings
470 `(#:configure-flags '("--disable-werror")))
471 (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libvisio")
472 (synopsis "Library for parsing the Microsoft Visio format")
473 (description "Libvisio is a library that parses the file format of
474 Microsoft Visio documents of all versions.")
475 (license mpl2.0)))
476
477 (define-public libodfgen
478 (package
479 (name "libodfgen")
480 (version "0.1.3")
481 (source
482 (origin
483 (method url-fetch)
484 (uri (string-append "http://dev-www.libreoffice.org/src/"
485 name "-" version ".tar.bz2"))
486 (sha256 (base32
487 "074qsav86ixwi9zm1f77g9vxdf1ihm6n930vxjg8q3lwzd8g7lb6"))))
488 (build-system gnu-build-system)
489 (native-inputs
490 `(("doxygen" ,doxygen)
491 ("pkg-config" ,pkg-config)))
492 (inputs
493 `(("boost" ,boost)
494 ("librevenge" ,librevenge)
495 ("zlib" ,zlib)))
496 (arguments
497 ;; avoid triggering configure errors by simple inclusion of boost headers
498 `(#:configure-flags '("--disable-werror")))
499 (home-page "http://sourceforge.net/p/libwpd/wiki/libodfgen/")
500 (synopsis "ODF (Open Document Format) library")
501 (description "Libodfgen is a library for generating documents in the
502 Open Document Format (ODF). It provides generator implementations for all
503 document interfaces supported by librevenge:
504 text documents, vector drawings, presentations and spreadsheets.")
505 (license (list mpl2.0 lgpl2.1+)))) ; dual license
506
507 (define-public libmwaw
508 (package
509 (name "libmwaw")
510 (version "0.3.4")
511 (source
512 (origin
513 (method url-fetch)
514 (uri (string-append "mirror://sourceforge/" name "/" name "/"
515 name "-" version ".tar.xz"))
516 (sha256 (base32
517 "1sn95flxrh85qjsg1kk700c1ggxaaccr9j1nnw7x4daw8lky25ac"))))
518 (build-system gnu-build-system)
519 (native-inputs
520 `(("doxygen" ,doxygen)
521 ("pkg-config" ,pkg-config)))
522 (inputs
523 `(("boost" ,boost)
524 ("librevenge" ,librevenge)
525 ("zlib" ,zlib)))
526 (arguments
527 ;; avoid triggering configure errors by simple inclusion of boost headers
528 `(#:configure-flags '("--disable-werror")))
529 (home-page "http://sourceforge.net/p/libmwaw/wiki/Home/")
530 (synopsis "Import library for some old Macintosh text documents")
531 (description "Libmwaw contains some import filters for old Macintosh
532 text documents (MacWrite, ClarisWorks, ... ) and for some graphics and
533 spreadsheet documents.")
534 (license (list mpl2.0 lgpl2.1+)))) ; dual license
535
536 (define-public libwps
537 (package
538 (name "libwps")
539 (version "0.3.1")
540 (source
541 (origin
542 (method url-fetch)
543 (uri (string-append "mirror://sourceforge/" name "/" name "/"
544 name "-" version ".tar.xz"))
545 (sha256 (base32
546 "14wfhw1ahavhx4hrdzc4hdwxjlffrm939kswf2x1250jnmyjlb5v"))))
547 (build-system gnu-build-system)
548 (native-inputs
549 `(("doxygen" ,doxygen)
550 ("pkg-config" ,pkg-config)))
551 (inputs
552 `(("boost" ,boost)
553 ("librevenge" ,librevenge)
554 ("zlib" ,zlib)))
555 (arguments
556 ;; avoid triggering configure errors by simple inclusion of boost headers
557 `(#:configure-flags '("--disable-werror")))
558 (home-page "http://libwps.sourceforge.net/")
559 (synopsis "Import library for Microsoft Works text documents")
560 (description "Libwps is a library for importing files in the Microsoft
561 Works word processor file format.")
562 (license (list mpl2.0 lgpl2.1+)))) ; dual license
563
564 (define-public hunspell
565 (package
566 (name "hunspell")
567 (version "1.3.3")
568 (source
569 (origin
570 (method url-fetch)
571 (uri (string-append "mirror://sourceforge/" name "/"
572 name "-" version ".tar.gz"))
573 (sha256 (base32
574 "0v14ff9s37vkh45diaddndcrj0hmn67arh8xh8k79q9c1vgc1cm7"))))
575 (build-system gnu-build-system)
576 (home-page "http://hunspell.sourceforge.net/")
577 (synopsis "Spell checker")
578 (description "Hunspell is a spell checker and morphological analyzer
579 library and program designed for languages with rich morphology and complex
580 word compounding or character encoding.")
581 ;; triple license, including "mpl1.1 or later"
582 (license (list mpl1.1 gpl2+ lgpl2.1+))))
583
584 (define-public hyphen
585 (package
586 (name "hyphen")
587 (version "2.8.8")
588 (source
589 (origin
590 (method url-fetch)
591 (uri (string-append "mirror://sourceforge/hunspell/"
592 name "-" version ".tar.gz"))
593 (sha256 (base32
594 "01ap9pr6zzzbp4ky0vy7i1983fwyqy27pl0ld55s30fdxka3ciih"))))
595 (build-system gnu-build-system)
596 (inputs
597 `(("perl" ,perl)))
598 (home-page "http://hunspell.sourceforge.net/")
599 (synopsis "Hyphenation library")
600 (description "Hyphen is a hyphenation library using TeX hyphenation
601 patterns, which are pre-processed by a perl script.")
602 ;; triple license, including "mpl1.1 or later"
603 (license (list mpl1.1 mpl2.0 gpl2+ lgpl2.1+))))
604
605 (define-public mythes
606 (package
607 (name "mythes")
608 (version "1.2.4")
609 (source
610 (origin
611 (method url-fetch)
612 (uri (string-append "mirror://sourceforge/hunspell/"
613 name "-" version ".tar.gz"))
614 (sha256 (base32
615 "0prh19wy1c74kmzkkavm9qslk99gz8h8wmjvwzjc6lf8v2az708y"))))
616 (build-system gnu-build-system)
617 (native-inputs
618 `(("pkg-config" ,pkg-config)))
619 (inputs
620 `(("hunspell" ,hunspell)
621 ("perl" ,perl)))
622 (home-page "http://hunspell.sourceforge.net/")
623 (synopsis "Thesaurus")
624 (description "MyThes is a simple thesaurus that uses a structured text
625 data file and an index file with binary search to look up words and phrases
626 and to return information on pronunciations, meaningss and synonyms.")
627 (license (non-copyleft "file://COPYING"
628 "See COPYING in the distribution."))))