Correct name and email address for ng0.
[jackhill/guix/guix.git] / gnu / packages / fvwm.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017 ng0 <ng0@n0.is>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages fvwm)
22 #:use-module ((guix licenses) #:select (gpl2+))
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages fribidi)
27 #:use-module (gnu packages gnome)
28 #:use-module (gnu packages image)
29 #:use-module (gnu packages perl)
30 #:use-module (gnu packages pkg-config)
31 #:use-module (gnu packages readline)
32 #:use-module (gnu packages xml)
33 #:use-module (gnu packages xorg))
34
35 (define-public fvwm
36 (package
37 (name "fvwm")
38 (version "2.6.8")
39 (source (origin
40 (method url-fetch)
41 (uri (string-append
42 "https://github.com/fvwmorg/fvwm/releases/download/"
43 version "/" name "-" version ".tar.gz"))
44 (sha256
45 (base32
46 "0hgkkdzcqjnaabvv9cnh0bz90nnjskbhjg9qnzpi2x0mbliwjdpv"))))
47 (build-system gnu-build-system)
48 (arguments
49 `(#:phases
50 (modify-phases %standard-phases
51 (add-after 'install 'install-xsession
52 (lambda* (#:key outputs #:allow-other-keys)
53 (let* ((out (assoc-ref outputs "out"))
54 (xsessions (string-append out "/share/xsessions")))
55 (mkdir-p xsessions)
56 (with-output-to-file
57 (string-append xsessions "/fvwm2.desktop")
58 (lambda _
59 (format #t
60 "[Desktop Entry]~@
61 Name=FVWM~@
62 Comment=FVWM~@
63 Exec=~a/bin/fvwm~@
64 TryExec=~@*~a/bin/fvwm~@
65 Icon=~@
66 Type=Application~%"
67 out))))
68 #t)))))
69 (native-inputs
70 `(("perl" ,perl)
71 ("pkg-config" ,pkg-config)
72 ("xsltproc" ,libxslt)))
73 (inputs
74 `(("fribidi" ,fribidi)
75 ("libpng" ,libpng)
76 ("librsvg" ,librsvg)
77 ("libxcursor" ,libxcursor)
78 ("libxext" ,libxext)
79 ("libxft" ,libxft)
80 ("libxinerama" ,libxinerama)
81 ("libxpm" ,libxpm)
82 ("libxt" ,libxt)
83 ("readline" ,readline)))
84 (synopsis "Virtual window manager for X11")
85 (description
86 "FVWM is an extremely powerful ICCCM-compliant multiple virtual desktop
87 window manager for the X Window system.")
88 (home-page "http://www.fvwm.org/")
89 (license gpl2+)))