gnu: Add xfconf.
[jackhill/guix/guix.git] / gnu / packages / tor.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages tor)
21 #:use-module ((guix licenses) #:select (bsd-3 gpl2+))
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages libevent)
26 #:use-module (gnu packages compression)
27 #:use-module (gnu packages openssl)
28 #:use-module (gnu packages pcre)
29 #:use-module (gnu packages autotools)
30 #:use-module (gnu packages w3m))
31
32 (define-public tor
33 (package
34 (name "tor")
35 (version "0.2.5.10")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append "https://www.torproject.org/dist/tor-"
39 version ".tar.gz"))
40 (sha256
41 (base32
42 "0fx8qnwh2f8ykfx0np4hyznjfi4xfy96z59pk96y3zyjvjjh5pdk"))))
43 (build-system gnu-build-system)
44 (inputs
45 `(("zlib" ,zlib)
46 ("openssl" ,openssl)
47 ("libevent" ,libevent)))
48
49 ;; TODO: Recommend `torsocks' since `torify' needs it.
50
51 (home-page "http://www.torproject.org/")
52 (synopsis "Anonymous network router to improve privacy on the Internet")
53 (description
54 "Tor protects you by bouncing your communications around a distributed
55 network of relays run by volunteers all around the world: it prevents
56 somebody watching your Internet connection from learning what sites you
57 visit, and it prevents the sites you visit from learning your physical
58 location. Tor works with many of your existing applications, including
59 web browsers, instant messaging clients, remote login, and other
60 applications based on the TCP protocol.")
61 (license bsd-3)))
62
63 (define-public torsocks
64 (package
65 (name "torsocks")
66 (version "1.2")
67 (source (origin
68 (method url-fetch)
69 (uri (string-append "http://torsocks.googlecode.com/files/torsocks-"
70 version ".tar.gz"))
71 (sha256
72 (base32
73 "1m0is5q24sf7jjlkl0icfkdc0m53nbkg0q72s57p48yp4hv7v9dy"))))
74 (build-system gnu-build-system)
75 (home-page "http://code.google.com/p/torsocks/")
76 (synopsis "Use socks-friendly applications with Tor")
77 (description
78 "Torsocks allows you to use most socks-friendly applications in a safe
79 way with Tor. It ensures that DNS requests are handled safely and explicitly
80 rejects UDP traffic from the application you're using.")
81 (license gpl2+)))
82
83 (define-public privoxy
84 (package
85 (name "privoxy")
86 (version "3.0.21")
87 (source (origin
88 (method url-fetch)
89 (uri (string-append "mirror://sourceforge/ijbswa/Sources/"
90 version "%20%28stable%29/privoxy-"
91 version "-stable-src.tar.gz"))
92 (sha256
93 (base32
94 "1f6xb7aa47p90c26vqaw74y6drs9gpnhxsgby3mx0awdjh0ydisy"))))
95 (build-system gnu-build-system)
96 (arguments
97 '(;; The default 'sysconfdir' is $out/etc; change that to
98 ;; $out/etc/privoxy.
99 #:configure-flags (list (string-append "--sysconfdir="
100 (assoc-ref %outputs "out")
101 "/etc/privoxy"))
102 #:phases (alist-cons-before
103 'configure 'autoconf
104 (lambda _
105 ;; Unfortunately, this is not a tarball produced by
106 ;; "make dist".
107 (zero? (system* "autoreconf" "-vfi")))
108 %standard-phases)
109 #:tests? #f))
110 (inputs
111 `(("w3m" ,w3m)
112 ("pcre" ,pcre)
113 ("zlib" ,zlib)
114 ("autoconf" ,autoconf)
115 ("automake" ,automake)))
116 (home-page "http://www.privoxy.org")
117 (synopsis "Web proxy with advanced filtering capabilities for enhancing privacy")
118 (description
119 "Privoxy is a non-caching web proxy with advanced filtering capabilities
120 for enhancing privacy, modifying web page data and HTTP headers, controlling
121 access, and removing ads and other obnoxious Internet junk. Privoxy has a
122 flexible configuration and can be customized to suit individual needs and
123 tastes. It has application for both stand-alone systems and multi-user
124 networks.")
125 (license gpl2+)))