gnu: bitcoin: Fix test failure with Python 3.8.
[jackhill/guix/guix.git] / gnu / packages / patches / perl-text-markdown-discount-unbundle.patch
1 Description: Use the markdown library provided by the libmarkdown2 package.
2 Author: Alessandro Ghedini <al3xbio@gmail.com>
3 Origin: vendor
4 Forwarded: not-needed
5 Last-Update: 2012-01-01
6
7 --- a/Makefile.PL
8 +++ b/Makefile.PL
9 @@ -57,12 +57,6 @@
10
11
12
13 -sub MY::postamble {
14 - return sprintf('
15 -$(MYEXTLIB):
16 - %s
17 -', qq{( cd $extdir; CC='cc -fPIC' sh configure.sh; make )\n});
18 -}
19
20 WriteMakefile(
21 NAME => 'Text::Markdown::Discount',
22 @@ -71,8 +65,6 @@
23 ($] >= 5.005 ?
24 (ABSTRACT_FROM => 'lib/Text/Markdown/Discount.pm',
25 AUTHOR => 'Masayoshi Sekimura <sekimura@cpan.org>') : ()),
26 - LIBS => '-L' . $extdir,
27 - INC => '-I. -I' . $extdir,
28 - MYEXTLIB => $myextlib,
29 - clean => { FILES => $clean_files },
30 + LIBS => '-lmarkdown',
31 + INC => '-I.',
32 );