Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / kde.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
4 ;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
5 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
7 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages kde)
25 #:use-module (guix build-system cmake)
26 #:use-module (guix download)
27 #:use-module (guix git-download)
28 #:use-module ((guix licenses) #:prefix license:)
29 #:use-module (guix packages)
30 #:use-module (guix utils)
31 #:use-module (gnu packages algebra)
32 #:use-module (gnu packages apr)
33 #:use-module (gnu packages boost)
34 #:use-module (gnu packages compression)
35 #:use-module (gnu packages curl)
36 #:use-module (gnu packages documentation)
37 #:use-module (gnu packages gettext)
38 #:use-module (gnu packages ghostscript)
39 #:use-module (gnu packages gl)
40 #:use-module (gnu packages gnome)
41 #:use-module (gnu packages graphics)
42 #:use-module (gnu packages image)
43 #:use-module (gnu packages kde-frameworks)
44 #:use-module (gnu packages kde-plasma)
45 #:use-module (gnu packages llvm)
46 #:use-module (gnu packages maths)
47 #:use-module (gnu packages pdf)
48 #:use-module (gnu packages perl)
49 #:use-module (gnu packages photo)
50 #:use-module (gnu packages pkg-config)
51 #:use-module (gnu packages python)
52 #:use-module (gnu packages tls)
53 #:use-module (gnu packages qt)
54 #:use-module (gnu packages version-control)
55 #:use-module (gnu packages video)
56 #:use-module (gnu packages xdisorg)
57 #:use-module (gnu packages xorg))
58
59 (define-public kdenlive
60 (let ((version "18.08.1"))
61 (package
62 (name "kdenlive")
63 (version version)
64 (source
65 (origin
66 (method git-fetch)
67 (uri (git-reference
68 (url "git://anongit.kde.org/kdenlive.git")
69 (commit (string-append "v" version))))
70 (file-name (string-append name "-" version "-checkout"))
71 (sha256
72 (base32
73 "0ifnaclsz7w08mc485i3j1kkcpd1m8q5qamckrfwc375ac13xf4g"))))
74 (build-system cmake-build-system)
75 (native-inputs
76 `(("extra-cmake-modules" ,extra-cmake-modules)
77 ("qttools" ,qttools)))
78 (propagated-inputs
79 `(("mlt" ,mlt)))
80 (inputs
81 `(("shared-mime-info" ,shared-mime-info)
82 ("frei0r-plugins" ,frei0r-plugins)
83 ("qtbase" ,qtbase)
84 ("qtscript" ,qtscript)
85 ("qtsvg" ,qtsvg)
86 ("kparts" ,kparts)
87 ("knotifications" ,knotifications)
88 ("karchive" ,karchive)
89 ("kdbusaddons" ,kdbusaddons)
90 ("kcrash" ,kcrash)
91 ("kguiaddons" ,kguiaddons)
92 ("knewstuff" ,knewstuff)
93 ("knotifyconfig" ,knotifyconfig)
94 ("kfilemetadata" ,kfilemetadata)
95 ("kdoctools" ,kdoctools)
96 ("kdeclarative" ,kdeclarative)
97 ("qtdeclarative" ,qtdeclarative)
98 ("qtquickcontrols" ,qtquickcontrols)
99 ("kiconthemes" ,kiconthemes)
100 ("qtgraphicaleffects" ,qtgraphicaleffects)
101 ("kplotting" ,kplotting)))
102 (arguments
103 `(#:phases
104 (modify-phases %standard-phases
105 (add-after 'install 'wrap-executable
106 (lambda* (#:key inputs outputs #:allow-other-keys)
107 (let* ((out (assoc-ref outputs "out"))
108 (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
109 (qtbase (assoc-ref inputs "qtbase"))
110 (qtdeclarative (assoc-ref inputs "qtdeclarative"))
111 (frei0r (assoc-ref inputs "frei0r-plugins"))
112 (qml "/lib/qt5/qml"))
113 (wrap-program (string-append out "/bin/kdenlive")
114 `("QT_PLUGIN_PATH" ":" prefix
115 ,(map (lambda (label)
116 (string-append (assoc-ref inputs label)
117 "/lib/qt5/plugins/"))
118 '("qtbase" "qtsvg")))
119 `("FREI0R_PATH" ":" =
120 (,(string-append frei0r "/lib/frei0r-1/")))
121 `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
122 (,(string-append qtbase "/lib/qt5/plugins/platforms")))
123 `("QML2_IMPORT_PATH" ":" prefix
124 (,(string-append qtquickcontrols qml)
125 ,(string-append qtdeclarative qml)))))
126 #t)))))
127 (home-page "https://kdenlive.org")
128 (synopsis "Non-linear video editor")
129 (description "Kdenlive is an acronym for KDE Non-Linear Video Editor.
130
131 Non-linear video editing is much more powerful than beginner's (linear)
132 editors, hence it requires a bit more organization before starting. However,
133 it is not reserved to specialists and can be used for small personal
134 projects.")
135 (license license:gpl2+))))
136
137 (define-public kdevelop
138 (package
139 (name "kdevelop")
140 (version "5.1.2")
141 (source
142 (origin
143 (method url-fetch)
144 (uri (string-append "mirror://kde/stable/kdevelop"
145 "/" version "/src/kdevelop-"
146 version ".tar.xz"))
147 (sha256
148 (base32
149 "1iqaq0ilijjigqb34v5wq9in6bnjs0p9cmgbygjmy53xhh3yhm5g"))))
150 (build-system cmake-build-system)
151 (native-inputs
152 `(("extra-cmake-modules" ,extra-cmake-modules)
153 ("pkg-config" ,pkg-config)
154 ("qttools" ,qttools)))
155 (inputs
156 `(("kdevplatform" ,kdevplatform)
157 ("kdevelop-pg-qt" ,kdevelop-pg-qt)
158 ("qtbase" ,qtbase)
159 ("qtdeclarative" ,qtdeclarative)
160 ("qtquickcontrols" ,qtquickcontrols)
161 ("qtwebkit" ,qtwebkit)
162 ("karchive" ,karchive)
163 ("kcmutils" ,kcmutils)
164 ("kconfig" ,kconfig)
165 ("kdeclarative" ,kdeclarative)
166 ("kdoctools" ,kdoctools)
167 ("kguiaddons" ,kguiaddons)
168 ("ki18n" ,ki18n)
169 ("kio" ,kio)
170 ("kiconthemes" ,kiconthemes)
171 ("kitemmodels" ,kitemmodels)
172 ("kitemviews" ,kitemviews)
173 ("kjobwidgets" ,kjobwidgets)
174 ("knotifyconfig" ,knotifyconfig)
175 ("knotifications" ,knotifications)
176 ("kparts" ,kparts)
177 ("kcrash" ,kcrash)
178 ("knewstuff" ,knewstuff)
179 ("krunner" ,krunner)
180 ("kxmlgui" ,kxmlgui)
181 ("libksysguard" ,libksysguard)
182 ("threadweaver" ,threadweaver)
183 ("ktexteditor" ,ktexteditor)
184 ("kwindowsystem" ,kwindowsystem)
185 ("plasma" ,plasma-framework)
186 ("grantlee" ,grantlee)
187 ("libepoxy" ,libepoxy)
188 ("clang" ,clang)
189 ("shared-mime-info" ,shared-mime-info)))
190 (arguments
191 `(#:phases
192 (modify-phases %standard-phases
193 (delete 'check) ;; there are some issues with the test suite
194 (add-after 'install 'wrap-executable
195 (lambda* (#:key inputs outputs #:allow-other-keys)
196 (let* ((out (assoc-ref outputs "out"))
197 (kdevplatform (assoc-ref inputs "kdevplatform"))
198 (kio (assoc-ref inputs "kio"))
199 (kcmutils (assoc-ref inputs "kcmutils"))
200 (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
201 (qtbase (assoc-ref inputs "qtbase"))
202 (qtdeclarative (assoc-ref inputs "qtdeclarative"))
203 (qml "/qml"))
204 (wrap-program (string-append out "/bin/kdevelop")
205 `("XDG_DATA_DIRS" ":" prefix
206 ,(map (lambda (s) (string-append s "/share"))
207 (list out kdevplatform kcmutils)))
208 `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
209 (,(string-append qtbase "/plugins/platforms")))
210 `("QT_PLUGIN_PATH" ":" prefix
211 ,(map (lambda (s) (string-append s "/lib/plugins"))
212 (list out kdevplatform kio)))
213 `("QML2_IMPORT_PATH" ":" prefix
214 (,(string-append qtquickcontrols qml)
215 ,(string-append qtdeclarative qml))))))))))
216 (home-page "https://kdevelop.org")
217 (synopsis "IDE for C, C++, Python, Javascript and PHP")
218 (description "The KDevelop IDE provides semantic syntax highlighting, as
219 well as code navigation and completion for C, C++ (using Clang/LLVM), QML,
220 JavaScript, Python and PHP. It also integrates with a debugger, different
221 build systems (CMake, QMake, custom Makefiles) and version control
222 software (Git, Subversion, Mercurial, CVS and Bazaar).")
223 (license license:lgpl2.1+)))
224
225 (define-public kdevelop-pg-qt
226 (package
227 (name "kdevelop-pg-qt")
228 (version "2.0.0")
229 (source
230 (origin
231 (method url-fetch)
232 (uri (string-append "https://github.com/KDE/kdevelop-pg-qt/archive/v"
233 version ".tar.gz"))
234 (file-name (string-append name "-" version ".tar.gz"))
235 (sha256
236 (base32 "1av8plqz7hyhrd07avnmn6ryslqlarmxn0pw7swzvb6ddiqp59j4"))))
237 (native-inputs
238 `(("extra-cmake-modules" ,extra-cmake-modules)))
239 (inputs
240 `(("qtbase" ,qtbase)))
241 (build-system cmake-build-system)
242 (home-page "https://kde.org")
243 (synopsis "Parser generator library for KDevplatform")
244 (description "KDevelop-PG-Qt is the parser generator used in KDevplatform
245 for some KDevelop language plugins (Ruby, PHP, CSS...).")
246 (license license:lgpl2.0+)))
247
248 (define-public kdevplatform
249 (package
250 (name "kdevplatform")
251 (version "5.1.2")
252 (source (origin
253 (method url-fetch)
254 (uri (string-append "mirror://kde/stable/kdevelop"
255 "/" version "/src/kdevplatform-"
256 version ".tar.xz"))
257 (sha256
258 (base32
259 "0jk6g1kiqpyjy8pca0236b9944gxqnymqv8ny6m8nrraannxs8p6"))))
260 (build-system cmake-build-system)
261 (native-inputs
262 `(("extra-cmake-modules" ,extra-cmake-modules)
263 ("pkg-config" ,pkg-config)))
264 (inputs
265 `(("apr" ,apr)
266 ("apr-util" ,apr-util)
267 ("boost" ,boost)
268 ("karchive" ,karchive)
269 ("kconfigwidgets" ,kconfigwidgets)
270 ("kcmutils" ,kcmutils)
271 ("kiconthemes" ,kiconthemes)
272 ("kdeclarative" ,kdeclarative)
273 ("kdoctools" ,kdoctools)
274 ("kguiaddons" ,kguiaddons)
275 ("kinit" ,kinit)
276 ("kitemmodels" ,kitemmodels)
277 ("knewstuff" ,knewstuff)
278 ("knotifications" ,knotifications)
279 ("knotifyconfig" ,knotifyconfig)
280 ("kwindowsystem" ,kwindowsystem)
281 ("kio" ,kio)
282 ("ki18n" ,ki18n)
283 ("kparts" ,kparts)
284 ("kservice" ,kservice)
285 ("grantlee" ,grantlee)
286 ("libkomparediff2" ,libkomparediff2)
287 ("sonnet" ,sonnet)
288 ("threadweaver" ,threadweaver)
289 ("ktexteditor" ,ktexteditor)
290 ("qtbase" ,qtbase)
291 ("qtdeclarative" ,qtdeclarative)
292 ("qtscript" ,qtscript)
293 ("qtwebkit" ,qtwebkit)
294 ("qtx11extras" ,qtx11extras)
295 ("plasma" ,plasma-framework)
296 ("subversion" ,subversion)
297 ("zlib" ,zlib)))
298 (arguments
299 `(#:phases
300 (modify-phases %standard-phases
301 (delete 'check)
302 (add-after 'install 'check
303 (lambda* (#:key outputs #:allow-other-keys)
304 (let ((out (assoc-ref outputs "out")))
305 (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
306 (setenv "QT_PLUGIN_PATH"
307 (string-append out "/lib/plugins:"
308 (getenv "QT_PLUGIN_PATH")))
309 (setenv "XDG_DATA_DIRS"
310 (string-append out "/share:"
311 (getenv "XDG_DATA_DIRS")))
312 (invoke "ctest" "-R" ; almost all tests require a display
313 "filteringstrategy|kdevvarlengtharray|kdevhash")))))))
314 (home-page "https://github.com/KDE/kdevplatform")
315 (synopsis "Framework to build integrated development environments (IDEs)")
316 (description "KDevPlatform is the basis of KDevelop and contains some
317 plugins, as well as code to create plugins, or complete applications.")
318 (license license:gpl3+)))
319
320 (define-public krita
321 (package
322 (name "krita")
323 (version "4.2.5")
324 (source (origin
325 (method url-fetch)
326 (uri (string-append
327 "mirror://kde/stable/krita/"
328 (version-prefix version 3)
329 "/krita-" version ".tar.gz"))
330 (sha256
331 (base32
332 "1f14r2mrqasl6nr3sss0xy2h8xlxd5wdcjcd64m9nz2gwlm39r7w"))))
333 (build-system cmake-build-system)
334 (arguments
335 `(#:tests? #f
336 #:configure-flags
337 (list "-DBUILD_TESTING=OFF"
338 (string-append "-DCMAKE_CXX_FLAGS=-I"
339 (assoc-ref %build-inputs "ilmbase")
340 "/include/OpenEXR"))
341 #:phases
342 (modify-phases %standard-phases
343 ;; Ensure that icons are found at runtime.
344 ;; This works around <https://bugs.gnu.org/22138>.
345 (add-after 'install 'wrap-executable
346 (lambda* (#:key inputs outputs #:allow-other-keys)
347 (let ((out (assoc-ref outputs "out"))
348 (qt '("qtbase" "qtsvg")))
349 (wrap-program (string-append out "/bin/krita")
350 `("QT_PLUGIN_PATH" ":" prefix
351 ,(map (lambda (label)
352 (string-append (assoc-ref inputs label)
353 "/lib/qt5/plugins/"))
354 qt)))
355 #t))))))
356 (native-inputs
357 `(("curl" ,curl)
358 ("eigen" ,eigen)
359 ("extra-cmake-modules" ,extra-cmake-modules)
360 ("gettext-minimal" ,gettext-minimal)
361 ("kitemmodels" ,kitemmodels)
362 ("pkg-config" ,pkg-config)
363 ("qwt" ,qwt)
364 ("vc" ,vc)))
365 (inputs
366 `(("boost" ,boost)
367 ("exiv2" ,exiv2)
368 ("fftw" ,fftw)
369 ("gsl" ,gsl)
370 ("ilmbase" ,ilmbase)
371 ("karchive" ,karchive)
372 ("kcompletion" ,kcompletion)
373 ("kconfig" ,kconfig)
374 ("kcoreaddons" ,kcoreaddons)
375 ("kcrash" ,kcrash)
376 ("kguiaddons" ,kguiaddons)
377 ("ki18n" ,ki18n)
378 ("kiconthemes" ,kiconthemes)
379 ("kio" ,kio)
380 ("kitemviews" ,kitemviews)
381 ("kwidgetsaddons" ,kwidgetsaddons)
382 ("kwindowsystem" ,kwindowsystem)
383 ("kxmlgui" ,kxmlgui)
384 ("lcms" ,lcms)
385 ("libjpeg-turbo" ,libjpeg-turbo)
386 ("libpng" ,libpng)
387 ("libraw" ,libraw-0.18)
388 ("libtiff" ,libtiff)
389 ("libx11" ,libx11)
390 ("libxcb" ,libxcb)
391 ("libxi" ,libxi)
392 ("openexr" ,openexr)
393 ("perl" ,perl)
394 ("poppler-qt5" ,poppler-qt5)
395 ("qtbase" ,qtbase)
396 ("qtdeclarative" ,qtdeclarative)
397 ("qtmultimedia" ,qtmultimedia)
398 ("qtsvg" ,qtsvg)
399 ("qtx11extras" ,qtx11extras)
400 ("quazip" ,quazip)
401 ("zlib" ,zlib)))
402 (home-page "https://krita.org")
403 (synopsis "Digital painting application")
404 (description
405 "Krita is a professional painting tool designed for concept artists,
406 illustrators, matte and texture artists, and the VFX industry. Notable
407 features include brush stabilizers, brush engines and wrap-around mode.")
408 (license license:gpl2+)))
409
410 (define-public kholidays
411 (package
412 (name "kholidays")
413 (version "17.12.1")
414 (source
415 (origin
416 (method url-fetch)
417 (uri (string-append
418 "mirror://kde/stable/applications/" version "/src/"
419 name "-" version ".tar.xz"))
420 (sha256
421 (base32 "0595d7wbnz8kyq1bnivdrp20lwdp8ykvdll1fmb0fgm4q24z0cl8"))))
422 (build-system cmake-build-system)
423 (arguments
424 `(#:phases
425 (modify-phases %standard-phases
426 (add-before 'check 'check-setup
427 (lambda _
428 ;; blacklist a failing test function TODO: make it pass
429 (with-output-to-file "autotests/BLACKLIST"
430 (lambda _
431 (display "[testDefaultRegions]\n*\n")))
432 #t)))))
433 (native-inputs
434 `(("extra-cmake-modules" ,extra-cmake-modules)
435 ("qttools" ,qttools)))
436 (inputs
437 `(("qtbase" ,qtbase)
438 ("qtdeclarative" ,qtdeclarative)))
439 (home-page "https://cgit.kde.org/kholidays.git")
440 (synopsis "Library for regional holiday information")
441 (description "This library provides a C++ API that determines holiday and
442 other special events for a geographical region.")
443 (license license:lgpl2.0+)))
444
445 (define-public libkomparediff2
446 (package
447 (name "libkomparediff2")
448 (version "19.04.1")
449 (source
450 (origin
451 (method url-fetch)
452 (uri (string-append "mirror://kde/stable/applications/" version
453 "/src/libkomparediff2-" version ".tar.xz"))
454 (sha256
455 (base32 "1cyi7a5ss7jv87llk0k8c9g3h1qsp6j6nmdzh3xxcswr4p5skc9a"))))
456 (native-inputs
457 `(("extra-cmake-modules" ,extra-cmake-modules)
458 ("pkg-config" ,pkg-config)))
459 (inputs
460 `(("kcodecs" ,kcodecs)
461 ("kconfig" ,kconfig)
462 ("kcoreaddons" ,kcoreaddons)
463 ("ki18n" ,ki18n)
464 ("kio" ,kio)
465 ("kxmlgui" ,kxmlgui)
466 ("qtbase" ,qtbase)))
467 (build-system cmake-build-system)
468 (home-page "https://kde.org")
469 (synopsis "Library to compare files and strings, used in Kompare and KDevelop")
470 (description "Libkomparediff2 is a library to work with diffs and patches,
471 used in KDE development tools Kompare and KDevelop.")
472
473 ;; GPL, some files are also licensed under LGPL or BSD, see COPYING in the
474 ;; source archive
475 (license (list license:gpl2+ license:lgpl2.0+ license:bsd-3))))
476
477 (define-public qca
478 (package
479 (name "qca")
480 (version "2.2.1")
481 (source
482 (origin
483 (method url-fetch)
484 (uri (string-append "mirror://kde/stable/qca/" version
485 "/qca-" version ".tar.xz"))
486 (sha256
487 (base32
488 "00kv1vsrc8fp556hm8s6yw3240vx3l4067q6vfxrb3gdwgcd45np"))))
489 (build-system cmake-build-system)
490 (native-inputs
491 `(("pkg-config" ,pkg-config)))
492 (inputs
493 `(("openssl" ,openssl)
494 ("qtbase" ,qtbase)))
495 (home-page "https://userbase.kde.org/QCA")
496 (synopsis "Libraries for the Qt Cryptographic Architecture")
497 (description "The Qt Cryptographic Architecture (QCA) provides a
498 straightforward and cross-platform API for a range of cryptographic features,
499 including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
500 cards.")
501 (license license:lgpl2.1)))
502
503 (define-public snorenotify
504 (package
505 (name "snorenotify")
506 (version "0.7.0")
507 (source
508 (origin
509 (method url-fetch)
510 (uri (string-append "mirror://kde/stable/snorenotify/"
511 version "/src/snorenotify-" version ".tar.xz"))
512 (sha256
513 (base32
514 "0jz6ivk90h7iwgyxar7xzzj8yvzn6s1my6cqs9bdnwqswfk1nhbd"))))
515 (build-system cmake-build-system)
516 (arguments
517 `(#:tests? #f)) ; both tests fail, require display
518 (inputs
519 `(("extra-cmake-modules" ,extra-cmake-modules)
520 ("qtbase" ,qtbase)
521 ("qttools" ,qttools)))
522 (home-page "https://techbase.kde.org/Projects/Snorenotify")
523 (synopsis "Qt notification framework")
524 (description "Snorenotify is a multi platform Qt notification framework.
525 Using a plugin system it is possible to create notifications with many
526 different notification systems.")
527 (license license:lgpl3)))
528
529 (define-public kdeconnect
530 (package
531 (name "kdeconnect")
532 (version "1.3.3")
533 (source
534 (origin
535 (method url-fetch)
536 (uri (string-append "mirror://kde/stable/kdeconnect/"
537 version "/src/kdeconnect-kde-"
538 version ".tar.xz"))
539 (sha256
540 (base32
541 "1vac0mw1myrswr61adv7lgif0c4wzw5wnsj0sqxj6msp4l4pfgsg"))))
542 (build-system cmake-build-system)
543 (arguments
544 `(#:configure-flags '("-DBUILD_TESTING=ON")
545 #:tests? #f ; tests fail hard in our build environment
546 #:modules ((guix build cmake-build-system)
547 (guix build qt-utils)
548 (guix build utils))
549 #:imported-modules (,@%cmake-build-system-modules
550 (guix build qt-utils))
551 #:phases
552 (modify-phases %standard-phases
553 (add-before 'check 'check-setup
554 (lambda _
555 (setenv "QT_QPA_PLATFORM" "offscreen")
556 #t))
557 (add-after 'install 'wrap-executable
558 (lambda* (#:key outputs #:allow-other-keys)
559 (let ((out (assoc-ref outputs "out")))
560 (setenv "QT_PLUGIN_PATH"
561 (string-append out "/lib/qt5/plugins"
562 ":" (getenv "QT_PLUGIN_PATH")))
563 (wrap-qt-program out "../lib/libexec/kdeconnectd")
564 (wrap-qt-program out "kdeconnect-cli")
565 (wrap-qt-program out "kdeconnect-handler")
566 (wrap-qt-program out "kdeconnect-indicator"))
567 #t)))))
568 (native-inputs
569 `(("extra-cmake-modules" ,extra-cmake-modules)
570 ("kdoctools" ,kdoctools)
571 ("libxtst" ,libxtst)
572 ("pkg-config" ,pkg-config)
573 ("python" ,python-wrapper)))
574 (inputs
575 `(("kcmutils" ,kcmutils)
576 ("kconfigwidgets" ,kconfigwidgets)
577 ("kdbusaddons" ,kdbusaddons)
578 ("ki18n" ,ki18n)
579 ("kiconthemes" ,kiconthemes)
580 ("kio" ,kio)
581 ("knotifications" ,knotifications)
582 ("kwayland" ,kwayland)
583 ("libfakekey" ,libfakekey)
584 ("qca" ,qca)
585 ("qtbase" ,qtbase)
586 ("qtdeclarative" ,qtdeclarative)
587 ("qtx11extras" ,qtx11extras)))
588 (home-page "https://community.kde.org/KDEConnect")
589 (synopsis "Enable your devices to communicate with each other")
590 (description "KDE Connect is a project that enables all your devices to
591 communicate with each other. Here's a few things KDE Connect can do:
592 @enumerate
593 @item Receive your phone notifications on your desktop computer and reply to messages
594 @item Control music playing on your desktop from your phone
595 @item Use your phone as a remote control for your desktop
596 @item Run predefined commands on your PC from connected devices
597 @item Check your phones battery level from the desktop
598 @item Ring your phone to help finding it
599 @item Share files and links between devices
600 @item Browse your phone from the desktop
601 @item Control the desktop's volume from the phone
602 @end enumerate")
603 (license (list license:gpl2 license:gpl3)))) ; dual licensed