Revert "gnu: inetutils: Update to 2.0."
[jackhill/guix/guix.git] / gnu / packages / patches / symmetrica-int32.patch
1 diff -ru src/def.h c/def.h
2 --- src/def.h 2007-12-06 17:30:56.000000000 +0100
3 +++ c/def.h 2013-10-19 18:42:55.118745730 +0200
4 @@ -2,14 +2,9 @@
5 /* INT should always be 4 byte */
6 #ifndef DEF_H
7
8 -
9 -#ifdef __alpha
10 -typedef int INT;
11 -typedef unsigned int UINT;
12 -#else /* __alpha */
13 -typedef long INT;
14 -typedef unsigned long UINT;
15 -#endif /* __alpha */
16 +#include <stdint.h>
17 +typedef int32_t INT;
18 +typedef uint32_t UINT;
19
20 #include <stdio.h>
21 #include <memory.h>
22 @@ -65,10 +60,13 @@
23
24
25 /* definitionen fuer object.c */
26 -typedef INT OBJECTKIND; /* 4 byte */
27 +/* NOTE: partition code assumes that there is no unused space in the
28 + * object struct when an INT is stored. This requires both OBJECTKIND
29 + * and OBJECTSELF to have a size equal to a machine word. */
30 +typedef intptr_t OBJECTKIND;
31
32 typedef union {
33 - INT ob_INT;
34 + intptr_t ob_INT;
35 INT * ob_INTpointer;
36 char *ob_charpointer;
37 struct bruch *ob_bruch;