gnu: mc: Update to 4.8.16.
[jackhill/guix/guix.git] / gnu / packages / mc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages mc)
21 #:use-module (guix packages)
22 #:use-module (guix licenses)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages aspell)
27 #:use-module (gnu packages ncurses)
28 #:use-module (gnu packages glib)
29 #:use-module (gnu packages ssh)
30 #:use-module (gnu packages pkg-config)
31 #:use-module (gnu packages check)
32 #:use-module (gnu packages perl))
33
34 (define-public mc
35 (package
36 (name "mc")
37 (version "4.8.16")
38 (source
39 (origin
40 (method url-fetch)
41 (uri (string-append "http://ftp.midnight-commander.org/mc-"
42 version ".tar.xz"))
43 (sha256
44 (base32
45 "083h5gwc0nny9b557way5dsmj71g2bzkiai4bn30y5nkjwqbxg5v"))))
46 (build-system gnu-build-system)
47 (native-inputs `(("pkg-config" ,pkg-config)
48 ("perl" ,perl)))
49 (inputs `(("aspell" ,aspell)
50 ("ncurses" ,ncurses)
51 ("libssh2" ,libssh2)
52 ("glib" ,glib)
53 ("check" ,check)))
54 (arguments
55 `(#:configure-flags
56 '("--with-screen=ncurses" "--enable-aspell")))
57 (home-page "http://www.midnight-commander.org")
58 (synopsis "Graphical file manager")
59 (description
60 "GNU Midnight Commander is a command-line file manager laid out in a
61 common two-pane format. In addition to standard file management tasks such as
62 copying and moving, Midnight Commander also supports viewing the contents of
63 RPM package files and other archives and managing files on other computers via
64 FTP or FISH. It also includes a powerful text editor for opening text
65 files.")
66 (license gpl3+)))