gnu: facter: Update to 4.0.33.
[jackhill/guix/guix.git] / gnu / packages / lighting.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
3 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages lighting)
21 #:use-module (guix build-system gnu)
22 #:use-module (guix download)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix packages)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages bison)
27 #:use-module (gnu packages check)
28 #:use-module (gnu packages compression)
29 #:use-module (gnu packages gnunet)
30 #:use-module (gnu packages flex)
31 #:use-module (gnu packages libftdi)
32 #:use-module (gnu packages libusb)
33 #:use-module (gnu packages linux)
34 #:use-module (gnu packages pkg-config)
35 #:use-module (gnu packages protobuf))
36
37 (define-public ola
38 (package
39 (name "ola")
40 (version "0.10.7")
41 (source (origin
42 (method url-fetch)
43 (uri (string-append
44 "https://github.com/OpenLightingProject/ola/releases/download/"
45 version "/ola-" version ".tar.gz"))
46 (patches (search-patches "ola-readdir-r.patch"))
47 (sha256
48 (base32
49 "181imc9qkjm2m1iwrb5ixsckx893nc6qwjfzacsjlqp0jlnj8rca"))))
50 (build-system gnu-build-system)
51 (native-inputs
52 `(("bison" ,bison)
53 ("cppunit" ,cppunit)
54 ("flex" ,flex)
55 ("pkg-config" ,pkg-config)))
56 (inputs
57 `(("libftdi" ,libftdi)
58 ("libmicrohttpd" ,libmicrohttpd)
59 ("libusb" ,libusb)
60 ("libuuid" ,util-linux "lib")
61 ("zlib" ,zlib)))
62 (propagated-inputs
63 ;; Ola 0.10.5 only supports protobuf 2.x, and building it with 3.x breaks.
64 ;; XXX Remove protobuf-2 when it is no longer needed.
65 `(("protobuf" ,protobuf-2))) ;; for pkg-config --libs libola
66 (arguments
67 `(;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
68 ;; build to fail on low memory systems. We disable that with the
69 ;; following configure flags.
70 #:configure-flags (list "CXXFLAGS=-ftrack-macro-expansion=0")))
71 (synopsis "Framework for controlling entertainment lighting equipment")
72 (description "The Open Lighting Architecture is a framework for lighting
73 control information. It supports a range of protocols and over a dozen USB
74 devices. It can run as a standalone service, which is useful for converting
75 signals between protocols, or alternatively using the OLA API, it can be used
76 as the backend for lighting control software. OLA runs on many different
77 platforms including ARM, which makes it a perfect fit for low cost Ethernet to
78 DMX gateways.")
79 (home-page "https://www.openlighting.org/ola")
80 (license license:lgpl2.1+)))