gnu: facter: Update to 4.0.33.
[jackhill/guix/guix.git] / gnu / packages / kde-multimedia.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
3 ;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages kde-multimedia)
21 #:use-module (guix build-system qt)
22 #:use-module (guix download)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix packages)
25 #:use-module (guix utils)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages audio)
28 #:use-module (gnu packages base)
29 #:use-module (gnu packages compression)
30 #:use-module (gnu packages cdrom)
31 #:use-module (gnu packages glib)
32 #:use-module (gnu packages gtk)
33 #:use-module (gnu packages gnome)
34 #:use-module (gnu packages gstreamer)
35 #:use-module (gnu packages kde-frameworks)
36 #:use-module (gnu packages libcanberra)
37 #:use-module (gnu packages linux)
38 #:use-module (gnu packages mp3)
39 #:use-module (gnu packages music)
40 #:use-module (gnu packages pkg-config)
41 #:use-module (gnu packages pulseaudio)
42 #:use-module (gnu packages qt)
43 #:use-module (gnu packages video)
44 #:use-module (gnu packages xiph)
45 #:use-module (gnu packages xorg))
46
47 (define-public audiocd-kio
48 (package
49 (name "audiocd-kio")
50 (version "20.04.1")
51 (source
52 (origin
53 (method url-fetch)
54 (uri (string-append "mirror://kde/stable/release-service/" version
55 "/src/audiocd-kio-" version ".tar.xz"))
56 (sha256
57 (base32 "0qlnxxbayqhz25jbvzis27jw2zbw1pmacp8rv7v5wa7zfqn3kmyk"))))
58 (build-system qt-build-system)
59 (native-inputs
60 `(("extra-cmake-modules" ,extra-cmake-modules)
61 ("kdoctools" ,kdoctools)))
62 (inputs
63 `(("cdparanoia" ,cdparanoia)
64 ("flac" ,flac)
65 ("kcmutils" ,kcmutils)
66 ("kconfig" ,kconfig)
67 ("ki18n" ,ki18n)
68 ("kio" ,kio)
69 ("libkcddb" ,libkcddb)
70 ("libkcompactdisc", libkcompactdisc)
71 ("libvorbis" ,libvorbis)
72 ("phonon" ,phonon)
73 ("qtbase" ,qtbase)))
74 (home-page "https://kde.org/applications/multimedia/org.kde.kio_audiocd")
75 (synopsis "Transparent audio CD integration for applications using the KDE
76 Platform")
77 (description "KIO AudioCD is a KIO slave that enables KIO-aware
78 applications (such as Dolphin or k3b) to access audio and CD text data on the
79 audio compact disks. It allows transparent drag and drop conversion of audio
80 data into the popular formats and has a configuration System Settings module
81 available in the \"Multimedia\" section.
82
83 This package is part of the KDE multimedia module.")
84 (license ;; GPL for programs, FDL for documentation
85 (list license:gpl2+ license:fdl1.2+))))
86
87 (define-public dragon
88 (package
89 (name "dragon")
90 (version "20.04.1")
91 (source
92 (origin
93 (method url-fetch)
94 (uri (string-append "mirror://kde/stable/release-service/" version
95 "/src/dragon-" version ".tar.xz"))
96 (sha256
97 (base32 "1sssg20a1vpwk816lp5jgwahilaswb9f3hgfqvc73il4g11ky1xj"))))
98 (build-system qt-build-system)
99 (native-inputs
100 `(("extra-cmake-modules" ,extra-cmake-modules)
101 ("kdoctools" ,kdoctools)))
102 (inputs
103 `(("kconfig" ,kconfig)
104 ("kconfigwidgets" ,kconfigwidgets)
105 ("kcoreaddons" ,kcoreaddons)
106 ("kcrash" ,kcrash)
107 ("kdbusaddons" ,kdbusaddons)
108 ("ki18n" ,ki18n)
109 ("kio" ,kio)
110 ("kjobwidgets" ,kjobwidgets)
111 ("knotifications" ,knotifications)
112 ("kparts" ,kparts)
113 ("kwidgetsaddons" ,kwidgetsaddons)
114 ("kwindowsystem" ,kwindowsystem)
115 ("kxmlgui" ,kxmlgui)
116 ("oxygen-icons" ,oxygen-icons) ; default icon set
117 ("phonon" ,phonon)
118 ("phonon-backend-gstreamer" ,phonon-backend-gstreamer)
119 ("qtbase" ,qtbase)
120 ("solid" ,solid)))
121 (home-page "https://kde.org/applications/multimedia/org.kde.dragonplayer")
122 (synopsis "Simple video player")
123 (description "Dragon Player is a multimedia player where the focus is on
124 simplicity, instead of features. Dragon Player does one thing, and only one
125 thing, which is playing multimedia files. It's simple interface is designed
126 not to get in your way and instead empower you to simply play multimedia
127 files.
128
129 This package is part of the KDE multimedia module.")
130 (license ;; GPL for programs, FDL for documentation
131 (list license:gpl2+ license:fdl1.2+))))
132
133 (define-public elisa
134 (package
135 (name "elisa")
136 (version "0.4.2")
137 (source
138 (origin
139 (method url-fetch)
140 (uri (string-append "mirror://kde//stable/elisa/0.4.2"
141 "/elisa-" version ".tar.xz"))
142 (sha256
143 (base32 "0v9af6l89pgz1g7naf7gwcnq8znlicyh7z985kxalbdmv359c97w"))))
144 (build-system qt-build-system)
145 (native-inputs
146 `(("extra-cmake-modules" ,extra-cmake-modules)
147 ("pkg-config" ,pkg-config)
148 ("dbus" ,dbus)
149 ("kdoctools" ,kdoctools)
150 ("xorg-server" , xorg-server-for-tests)))
151 (inputs
152 `(("kconfig" ,kconfig)
153 ("baloo" ,baloo)
154 ("kconfigwidgets" ,kconfigwidgets)
155 ("kcoreaddons" ,kcoreaddons)
156 ("kcrash" ,kcrash)
157 ("kcmutils" ,kcmutils)
158 ("kdbusaddons" ,kdbusaddons)
159 ("kdeclarative" ,kdeclarative)
160 ("kfilemetadata" ,kfilemetadata)
161 ("ki18n" ,ki18n)
162 ("kio" ,kio)
163 ("kirigami" ,kirigami)
164 ("kmediaplayer" ,kmediaplayer)
165 ("kparts" ,kparts)
166 ("kpackage" ,kpackage)
167 ("kwidgetsaddons" ,kwidgetsaddons)
168 ("kxmlgui" ,kxmlgui)
169 ("oxygen-icons" ,oxygen-icons) ; default icon set
170 ("phonon" ,phonon)
171 ("qtbase" ,qtbase)
172 ("qtdeclarative" ,qtdeclarative)
173 ("qtgraphicaleffects" ,qtgraphicaleffects) ; not listed as dependency
174 ("qtmultimedia" ,qtmultimedia)
175 ("qtquickcontrols" ,qtquickcontrols)
176 ("qtquickcontrols2" ,qtquickcontrols2)
177 ("qtsvg" ,qtsvg)
178 ("qtx11extras" ,qtx11extras)
179 ;; TODO: upnpqt https://gitlab.com/homeautomationqt/upnp-player-qt
180 ("vlc" ,vlc)))
181 (arguments
182 `(#:phases
183 (modify-phases %standard-phases
184 (add-before 'check 'start-xorg-server
185 (lambda* (#:key inputs #:allow-other-keys)
186 ;; The test suite requires a running X server, setting
187 ;; QT_QPA_PLATFORM=offscreen does not suffice.
188 (system (string-append (assoc-ref inputs "xorg-server")
189 "/bin/Xvfb :1 -screen 0 640x480x24 &"))
190 (setenv "DISPLAY" ":1")
191 #t)))))
192 (home-page "https://kde.org/applications/multimedia/org.kde.elisa")
193 (synopsis "Powerful music player for Plasma 5")
194 (description "Elisa is a simple music player aiming to provide a nice
195 experience for its users. Elisa browses music by album, artist or
196 all tracks. The music is indexed using either a private indexer or an indexer
197 using Baloo. The private one can be configured to scan music on chosen paths.
198 The Baloo one is much faster because Baloo is providing all needed data from
199 its own database. You can build and play your own playlist.")
200 (license license:lgpl3+)))
201
202 (define-public ffmpegthumbs
203 (package
204 (name "ffmpegthumbs")
205 (version "20.04.1")
206 (source
207 (origin
208 (method url-fetch)
209 (uri (string-append "mirror://kde/stable/release-service/" version
210 "/src/ffmpegthumbs-" version ".tar.xz"))
211 (sha256
212 (base32 "17l50z33a1h5zkrrfkb261yi2hms66qj36l1mndq7mvs97y2ggmc"))))
213 (build-system qt-build-system)
214 (native-inputs
215 `(("extra-cmake-modules" ,extra-cmake-modules)
216 ("pkg-config" ,pkg-config)))
217 (inputs
218 `(("ffmpeg" ,ffmpeg)
219 ("kconfig" ,kconfig)
220 ("ki18n" ,ki18n)
221 ("kio" ,kio)
222 ("qtbase" ,qtbase)))
223 (home-page "https://kde.org/applications/multimedia/org.kde.ffmpegthumbs")
224 (synopsis "Video thumbnail generator for KDE using ffmpeg")
225 (description "
226 FFMpegThumbs is a video thumbnail generator for KDE file managers
227 like Dolphin and Konqueror. It enables them to show preview images
228 of video files using FFMpeg.
229
230 This package is part of the KDE multimedia module.")
231 (license license:gpl2+)))
232
233 (define-public juk
234 (package
235 (name "juk")
236 (version "20.04.1")
237 (source
238 (origin
239 (method url-fetch)
240 (uri (string-append "mirror://kde/stable/release-service/" version
241 "/src/juk-" version ".tar.xz"))
242 (sha256
243 (base32 "06vsh7knyhcbcbf632jhldbqpzfkdyils2l8dbcdw5nj5hhgzzmr"))))
244 (build-system qt-build-system)
245 (native-inputs
246 `(("extra-cmake-modules" ,extra-cmake-modules)))
247 (inputs
248 `(("kcoreaddons" ,kcoreaddons)
249 ("kcompletion" ,kcompletion)
250 ("kconfig" ,kconfig)
251 ("kcrash" ,kcrash)
252 ("kdbusaddons" ,kdbusaddons)
253 ("kdoctools" ,kdoctools)
254 ("kglobalaccel" ,kglobalaccel)
255 ("ki18n" ,ki18n)
256 ("kiconthemes" ,kiconthemes)
257 ("kjobwidgets" ,kjobwidgets)
258 ("kio" ,kio)
259 ("knotifications" ,knotifications)
260 ("ktextwidgets" ,ktextwidgets)
261 ("kwallet" ,kwallet)
262 ("kwidgetsaddons" ,kwidgetsaddons)
263 ("kwindowsystem" ,kwindowsystem)
264 ("kxmlgui" ,kxmlgui)
265 ("oxygen-icons" ,oxygen-icons) ; default icon set
266 ("phonon" ,phonon)
267 ("phonon-backend-gstreamer" ,phonon-backend-gstreamer)
268 ("qtbase" ,qtbase)
269 ("qtsvg" ,qtsvg)
270 ("taglib" ,taglib)))
271 (home-page "https://kde.org/applications/multimedia/org.kde.juk")
272 (synopsis "Music jukebox / music player")
273 (description "JuK is a powerful music player capable of managing a large
274 music collection.
275
276 Some of JuK's features include:
277 @itemize
278 @item Music collection, playlists, and smart playlists
279 @item Tag editing support, including the ability to edit multiple files at once
280 @item Tag-based music file organization and renaming
281 @item CD burning support using k3b
282 @item Album art using Google Image Search
283 @end itemize
284
285 This package is part of the KDE multimedia module.")
286 (license license:gpl2+)))
287
288 (define-public k3b
289 (package
290 (name "k3b")
291 (version "20.04.2")
292 (source
293 (origin
294 (method url-fetch)
295 (uri (string-append "mirror://kde/stable/release-service/" version
296 "/src/k3b-" version ".tar.xz"))
297 (sha256
298 (base32 "15wm987hz6rfs9ds9l1gbs6gdsardj1ywvk6zmpvj2i2190y4b3q"))))
299 (build-system qt-build-system)
300 (arguments
301 `(#:phases
302 (modify-phases %standard-phases
303 (add-after 'unpack 'set-absolute-library-paths
304 (lambda _
305 ;; Set absolute paths for dlopened libraries. We can’t use k3b’s
306 ;; runpath as they are loaded by the Qt library.
307 (let ((libcdio-paranoia (assoc-ref %build-inputs "libcdio-paranoia"))
308 (libdvdcss (assoc-ref %build-inputs "libdvdcss")))
309 (substitute* "libk3b/tools/k3bcdparanoialib.cpp"
310 (("\"(cdio_cdda|cdio_paranoia)\"" _ library)
311 (string-append "\"" libcdio-paranoia "/lib/" library "\"")))
312 (substitute* "libk3b/tools/k3blibdvdcss.cpp"
313 (("\"(dvdcss)\"" _ library)
314 (string-append "\"" libdvdcss "/lib/" library "\""))))
315 #t))
316 (add-after 'qt-wrap 'wrap-path
317 (lambda _
318 ;; Set paths to backend programs.
319 (wrap-program (string-append (assoc-ref %outputs "out") "/bin/k3b")
320 `("PATH" ":" prefix
321 ,(map (lambda (input)
322 (string-append (assoc-ref %build-inputs input) "/bin"))
323 '("cdrdao" "dvd+rw-tools" "libburn" "sox"))))
324 #t)))))
325 (native-inputs
326 `(("extra-cmake-modules" ,extra-cmake-modules)
327 ("pkg-config" ,pkg-config)
328 ("kdoctools" ,kdoctools)))
329 (inputs
330 `(("cdrdao" ,cdrdao)
331 ("dvd+rw-tools" ,dvd+rw-tools)
332 ("ffmpeg" ,ffmpeg)
333 ("flac" ,flac)
334 ("karchive" ,karchive)
335 ("kcmutils" ,kcmutils)
336 ("kconfig" ,kconfig)
337 ("kcoreaddons" ,kcoreaddons)
338 ("kfilemetadata" ,kfilemetadata)
339 ("ki18n" ,ki18n)
340 ("kiconthemes" ,kiconthemes)
341 ("kio" ,kio)
342 ("kjobwidgets" ,kjobwidgets)
343 ("knewstuff" ,knewstuff)
344 ("knotifications" ,knotifications)
345 ("knotifyconfig" ,knotifyconfig)
346 ("kservice" ,kservice)
347 ("kwidgetsaddons" ,kwidgetsaddons)
348 ("kxmlgui" ,kxmlgui)
349 ("lame" ,lame)
350 ("libburn" ,libburn)
351 ("libcdio-paranoia" ,libcdio-paranoia)
352 ("libdvdcss" ,libdvdcss)
353 ("libdvdread" ,libdvdread)
354 ;; TODO: LibFuzzer
355 ("libiconv" ,libiconv)
356 ("libkcddb" ,libkcddb)
357 ("libmad" ,libmad)
358 ("libmpcdec" ,libmpcdec) ;; FIXME: why does cmake not find this?
359 ;;("libmusicbrainz" ,libmusicbrainz) ; wants old version 2
360 ("libsamplerate" ,libsamplerate)
361 ("libsndfile" ,libsndfile)
362 ("libvorbis" ,libvorbis)
363 ("oxygen-icons" ,oxygen-icons) ; default icon set
364 ("qtbase" ,qtbase)
365 ("qtwebkit" ,qtwebkit)
366 ("shared-mime-info" ,shared-mime-info)
367 ("solid" ,solid)
368 ("sox" ,sox)
369 ("taglib" ,taglib)))
370 (home-page "https://kde.org/applications/multimedia/org.kde.k3b")
371 (synopsis "Sophisticated CD/DVD burning application")
372 (description "K3b is CD-writing software which intends to be feature-rich
373 and provide an easily usable interface. Features include burning audio CDs
374 from .WAV and .MP3 audio files, configuring external programs and configuring
375 devices.
376
377 The @code{udisks-service} should be enabled for @command{k3b} to discover the
378 available CD drives.")
379 (license ;; GPL for programs, FDL for documentation
380 (list license:gpl2+ license:fdl1.2+))))
381
382 (define-public kaffeine
383 (package
384 (name "kaffeine")
385 (version "2.0.18")
386 (source
387 (origin
388 (method url-fetch)
389 (uri (string-append "mirror://kde/stable/kaffeine"
390 "/kaffeine-" version ".tar.xz"))
391 (sha256
392 (base32 "10dnhr9v2jlki44i3gmjagky66ybixmv6f29z5imk9clgddrlyfr"))))
393 (build-system qt-build-system)
394 (native-inputs
395 `(("extra-cmake-modules" ,extra-cmake-modules)
396 ("pkg-config" ,pkg-config)
397 ("kdoctools" ,kdoctools)))
398 (inputs
399 `(("eudev" ,eudev)
400 ("kcoreaddons" ,kcoreaddons)
401 ("kdbusaddons" ,kdbusaddons)
402 ("ki18n" ,ki18n)
403 ("kio" ,kio)
404 ("kwidgetsaddons" ,kwidgetsaddons)
405 ("kwindowsystem" ,kwindowsystem)
406 ("kxmlgui" ,kxmlgui)
407 ("libxscrnsaver" ,libxscrnsaver)
408 ("oxygen-icons" ,oxygen-icons) ; default icon set
409 ("qtbase" ,qtbase)
410 ("qtx11extras" ,qtx11extras)
411 ("solid" ,solid)
412 ("v4l-utils" ,v4l-utils) ; libdvbv5
413 ("vlc" ,vlc)))
414 (arguments
415 `(#:phases
416 (modify-phases %standard-phases
417 (add-after 'unpack 'fix-code
418 (lambda _
419 (substitute* "src/dvb/dvbdevice_linux.cpp"
420 (("\\s*qPrintable\\(transponder\\.getTransmissionType\\(\\)\\)\\);")
421 "transponder.getTransmissionType());"))
422 #t)))))
423 (home-page "https://kde.org/applications/multimedia/org.kde.kaffeine")
424 (synopsis "Versatile media player for KDE")
425 (description "Kaffeine is a media player for KDE. While it supports
426 multiple Phonon backends, its default backend is Xine, giving Kaffeine a wide
427 variety of supported media types and letting Kaffeine access CDs, DVDs, and
428 network streams easily.
429
430 Kaffeine can keep track of multiple playlists simultaneously, and supports
431 autoloading of subtitle files for use while playing video.")
432 (license ;; GPL for programs, FDL for documentation
433 (list license:gpl2+ license:fdl1.2+))))
434
435 (define-public kamoso
436 (package
437 (name "kamoso")
438 (version "20.04.1")
439 (source
440 (origin
441 (method url-fetch)
442 (uri (string-append "mirror://kde/stable/release-service/" version
443 "/src/kamoso-" version ".tar.xz"))
444 (sha256
445 (base32 "0c47j315kjfikd3b6x18786k3gqymicjjslpm0a58zdxl3wpqfay"))))
446 (build-system qt-build-system)
447 (native-inputs
448 `(("extra-cmake-modules" ,extra-cmake-modules)
449 ("glib:bin" ,glib "bin")
450 ("kdoctools" ,kdoctools)
451 ("pkg-config" ,pkg-config)))
452 (inputs
453 `(("gstreamer" ,gstreamer)
454 ("gst-plugins-base" ,gst-plugins-base)
455 ("kconfig" ,kconfig)
456 ("ki18n" ,ki18n)
457 ("kio" ,kio)
458 ("kirigami" ,kirigami)
459 ("knotifications" ,knotifications)
460 ("kparts" ,kparts)
461 ("oxygen-icons" ,oxygen-icons) ; default icon set
462 ("purpose" ,purpose)
463 ("qtbase" ,qtbase)
464 ("qtdeclarative" ,qtdeclarative)
465 ("qtgraphicaleffects" ,qtgraphicaleffects)
466 ("qtquickcontrols" ,qtquickcontrols)
467 ("qtquickcontrols2" ,qtquickcontrols2) ; not listed as dependency
468 ("qtx11extras" ,qtx11extras)))
469 (arguments
470 `(#:tests? #f ; test program gets built, but is not found
471 #:configure-flags
472 (list (string-append "-DCMAKE_CXX_FLAGS=-I"
473 (assoc-ref %build-inputs "gst-plugins-base")
474 "/include/gstreamer-1.0"))))
475 (home-page "https://kde.org/applications/multimedia/org.kde.kamoso")
476 (synopsis "Take pictures and videos out of your webcam")
477 (description "Kamoso is a simple and friendly program to use your
478 camera. Use it to take pictures and make videos to share.")
479 (license ;; GPL for programs, LGPL for libraries
480 (list license:gpl2+ license:lgpl2.0+))))
481
482 (define-public kmix
483 (package
484 (name "kmix")
485 (version "20.04.1")
486 (source
487 (origin
488 (method url-fetch)
489 (uri (string-append "mirror://kde/stable/release-service/" version
490 "/src/kmix-" version ".tar.xz"))
491 (sha256
492 (base32 "1na52ypp57wqrc6pl1khinx9i6fidv1k97nnxcy8zb4l7d5sh1nd"))))
493 (build-system qt-build-system)
494 (native-inputs
495 `(("extra-cmake-modules" ,extra-cmake-modules)
496 ("pkg-config" ,pkg-config)))
497 (inputs
498 `(("alsa-lib" ,alsa-lib)
499 ("glib" ,glib)
500 ("kconfigwidgets" ,kconfigwidgets)
501 ("kcompletion" ,kcompletion)
502 ("kconfig" ,kconfig)
503 ("kconfigwidgets" ,kconfigwidgets)
504 ("kcrash" ,kcrash)
505 ("kdbusaddons" ,kdbusaddons)
506 ("kdoctools" ,kdoctools)
507 ("kglobalaccel" ,kglobalaccel)
508 ("ki18n" ,ki18n)
509 ("kiconthemes" ,kiconthemes)
510 ("knotifications" ,knotifications)
511 ("kwidgetsaddons" ,kwidgetsaddons)
512 ("kwindowsystem" ,kwindowsystem)
513 ("kxmlgui" ,kxmlgui)
514 ("libcanberra" ,libcanberra)
515 ("oxygen-icons" ,oxygen-icons) ; default icon set
516 ("plasma-framework" ,plasma-framework)
517 ("pulseaudio" ,pulseaudio)
518 ("qtbase" ,qtbase)
519 ("solid" ,solid)))
520 (home-page "https://kde.org/applications/multimedia/org.kde.kmix")
521 (synopsis "Volume control and mixer")
522 (description "KMix is an audio device mixer, used to adjust volume, select
523 recording inputs, and set other hardware options.
524
525 This package is part of the KDE multimedia module.")
526 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
527 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
528
529 (define-public kmplayer
530 (package
531 (name "kmplayer")
532 (version "0.12.0b")
533 (source
534 (origin
535 (method url-fetch)
536 (uri (string-append "mirror://kde/stable/kmplayer/0.12"
537 "/kmplayer-" version ".tar.bz2"))
538 (sha256
539 (base32 "0wzdxym4fc83wvqyhcwid65yv59a2wvp1lq303cn124mpnlwx62y"))
540 (patches (search-patches
541 "kmplayer-aarch64.patch"
542 "kmplayer-upstream_Fix-build-with-Qt-5.9.patch"))))
543 (build-system qt-build-system)
544 (native-inputs
545 `(("extra-cmake-modules" ,extra-cmake-modules)
546 ("pkg-config" ,pkg-config)
547 ("kdoctools" ,kdoctools)))
548 (inputs
549 `(("kconfig" ,kconfig)
550 ("kcoreaddons" ,kcoreaddons)
551 ("kdelibs4support" ,kdelibs4support)
552 ("ki18n" ,ki18n)
553 ("kinit" ,kinit)
554 ("kio" ,kio)
555 ("kparts" ,kparts)
556 ("kmediaplayer" ,kmediaplayer)
557 ("kwidgetsaddons" ,kwidgetsaddons)
558 ("libxcb" ,libxcb) ;; FIXME: why does cmake not find XEVIE and XPRINT?
559 ("oxygen-icons" ,oxygen-icons) ; default icon set
560 ("phonon" ,phonon)
561 ("qtbase" ,qtbase)
562 ("cairo" ,cairo)
563 ("qtsvg" ,qtsvg)
564 ("qtx11extras" ,qtx11extras)
565 ("xcb-util" ,xcb-util)
566 ("xcb-util-cursor" ,xcb-util-cursor)
567 ("xcb-util-errors" ,xcb-util-errors)
568 ("xcb-util-image" ,xcb-util-image)
569 ("xcb-util-keysyms" ,xcb-util-keysyms)
570 ("xcb-util-wm" ,xcb-util-wm)))
571 (arguments
572 `(#:configure-flags
573 (list (string-append
574 "-DCMAKE_CXX_FLAGS=-I"
575 (assoc-ref %build-inputs "qtx11extras") "/include/qt5"))))
576 (home-page "https://kde.org/applications/multimedia/org.kde.kmplayer")
577 (synopsis "Media player using mplayer/phonon as backend")
578 (description "Kmplayer can play all the audio/video supported by
579 mplayer/phonon from a local file or URL and be embedded in Konqueror and
580 KHTML. It also plays DVDs.
581
582 Some features:
583 @itemize
584 @item play DVD/VCD movies (from file or url and from a video device)
585 @item embed inside konqueror (movie is played inside konqueror)
586 @item embed inside khtml (movie playback inside a html page)
587 @item Movie recording using mencoder (part of the mplayer package)
588 @item No video during recording, but you can always open a new window and play it
589 @item Broadcasting, http streaming, using ffserver/ffmpeg
590 @item For TV sources, you need v4lctl (part of the xawtv package)
591 @end itemize")
592 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
593 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
594
595 (define-public kwave
596 (package
597 (name "kwave")
598 (version "20.04.1")
599 (source
600 (origin
601 (method url-fetch)
602 (uri (string-append "mirror://kde/stable/release-service/" version
603 "/src/kwave-" version ".tar.xz"))
604 (sha256
605 (base32 "0ysa873pc2gip95cxr8yv7ifd9qql5zg6h67i9n9q3iqa6v58iyw"))))
606 (build-system qt-build-system)
607 (native-inputs
608 `(("extra-cmake-modules" ,extra-cmake-modules)
609 ("librsvg" ,librsvg)
610 ("pkg-config" ,pkg-config)
611 ("kdoctools" ,kdoctools)))
612 (inputs
613 `(("also-lib" ,alsa-lib)
614 ("audiofile" ,audiofile)
615 ("flac" ,flac)
616 ("id3lib" ,id3lib)
617 ("karchive" ,karchive)
618 ("kcompletion" ,kcompletion)
619 ("kconfig" ,kconfig)
620 ("kconfigwidgets" ,kconfigwidgets)
621 ("kcoreaddons" ,kcoreaddons)
622 ("kcrash" ,kcrash)
623 ("kdbusaddons" ,kdbusaddons)
624 ("ki18n" ,ki18n)
625 ("kiconthemes" ,kiconthemes)
626 ("kio" ,kio)
627 ("kservice" ,kservice)
628 ("ktextwidgets" ,ktextwidgets)
629 ("kwidgetsaddons" ,kwidgetsaddons)
630 ("kxmlgui" ,kxmlgui)
631 ("libmad" ,libmad)
632 ("libsamplerate" ,libsamplerate)
633 ("libvorbis" ,libvorbis)
634 ("opus" ,opus)
635 ("oxygen-icons" ,oxygen-icons) ; default icon set
636 ("pulseaudio" ,pulseaudio)
637 ("qtbase" ,qtbase)
638 ("qtmultimedia" ,qtmultimedia)
639 ("zlib" ,zlib)))
640 (home-page "https://kde.org/applications/multimedia/org.kde.kwave")
641 (synopsis "Sound editor for KDE")
642 (description "Kwave is a sound editor designed for the KDE Desktop
643 Environment.
644
645 With Kwave you can record, play back, import and edit many sorts of audio
646 files including multi-channel files. It includes some plugins to transform
647 audio files in several ways and presents a graphical view with a complete
648 zoom- and scroll capability.
649
650 Its features include:
651 @itemize
652 @item 24 Bit Support
653 @item Undo/Redo
654 @item Use of multicore CPUs (SMP, hyperthreading)
655 @item Simple Drag & Drop
656 @item Realtime Pre-Listen for some effects
657 @item Support for multi-track files
658 @item Playback and recording via native ALSA (or OSS, deprecated)
659 @item Playback via PulseAudio and Phonon
660 @item Load and edit-capability for large files (can use virtual memory)
661 @item Reading and auto-repair of damaged wav-files
662 @item Supports multiple windows
663 @item Extendable Plugin interface
664 @item a nice splashscreen
665 @item some label handling
666 @end itemize")
667 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
668 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+
669 license:cc-by-sa3.0 license:cc-by-sa4.0 ;; icons, samples
670 license:cc0 license:bsd-3)))) ;; utilities files
671
672 (define-public libkcddb
673 (package
674 (name "libkcddb")
675 (version "20.04.1")
676 (source
677 (origin
678 (method url-fetch)
679 (uri (string-append "mirror://kde/stable/release-service/" version
680 "/src/libkcddb-" version ".tar.xz"))
681 (sha256
682 (base32 "1fwryaj8ldmsqhl5qxjda8by9i7xlb97r8p9rqzckw697hkfhs0h"))))
683 (build-system qt-build-system)
684 (native-inputs
685 `(("extra-cmake-modules" ,extra-cmake-modules)
686 ("kdoctools" ,kdoctools)))
687 (inputs
688 `(("kcodecs" ,kcodecs)
689 ("kconfig" ,kconfig)
690 ("ki18n" ,ki18n)
691 ("kio" ,kio)
692 ("kwidgetsaddons" ,kwidgetsaddons)
693 ("libmusicbrainz" ,libmusicbrainz)
694 ("qtbase" ,qtbase)))
695 (arguments
696 `(#:tests? #f)) ; Most tests require network
697 (home-page "https://cgit.kde.org/libkcddb.git")
698 (synopsis "CDDB library for KDE Platform (runtime)")
699 (description "A library for retrieving and sending cddb information.")
700 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
701 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
702
703 (define-public libkcompactdisc
704 (package
705 (name "libkcompactdisc")
706 (version "20.04.1")
707 (source
708 (origin
709 (method url-fetch)
710 (uri (string-append "mirror://kde/stable/release-service/" version
711 "/src/libkcompactdisc-" version ".tar.xz"))
712 (sha256
713 (base32 "0iy4i0hxqsrnndd4iqkww7v1rqry7kvi5paxdw5qjfffwn8kcsbx"))))
714 (build-system qt-build-system)
715 (native-inputs
716 `(("extra-cmake-modules" ,extra-cmake-modules)))
717 (inputs
718 `(("alsa-lib" ,alsa-lib)
719 ("kcoreaddons" ,kcoreaddons)
720 ("ki18n" ,ki18n)
721 ("phonon" ,phonon)
722 ("qtbase" ,qtbase)
723 ("solid" ,solid)))
724 (home-page "https://cgit.kde.org/libkcompactdisc.git/")
725 (synopsis "KDE library for playing & ripping CDs")
726 (description "The KDE Compact Disc library provides an API for
727 applications using the KDE Platform to interface with the CD drives for audio
728 CDs.")
729 (license ;; GPL for programs, LGPL for libraries
730 (list license:gpl2+ license:lgpl2.0+))))