gnu: facter: Update to 4.0.33.
[jackhill/guix/guix.git] / gnu / packages / enlightenment.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
3 ;;; Copyright © 2015 Daniel Pimentel <d4n1@member.fsf.org>
4 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2017 Nikita <nikita@n0.is>
6 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018 Timo Eisenmann <eisenmann@fn.de>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages enlightenment)
25 #:use-module ((guix licenses) #:prefix license:)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix utils)
29 #:use-module (guix build-system gnu)
30 #:use-module (guix build-system meson)
31 #:use-module (guix build-system python)
32 #:use-module (gnu packages)
33 #:use-module (gnu packages algebra)
34 #:use-module (gnu packages avahi)
35 #:use-module (gnu packages bash)
36 #:use-module (gnu packages bittorrent)
37 #:use-module (gnu packages check)
38 #:use-module (gnu packages code)
39 #:use-module (gnu packages compression)
40 #:use-module (gnu packages curl)
41 #:use-module (gnu packages fontutils)
42 #:use-module (gnu packages freedesktop)
43 #:use-module (gnu packages fribidi)
44 #:use-module (gnu packages game-development)
45 #:use-module (gnu packages gettext)
46 #:use-module (gnu packages ghostscript)
47 #:use-module (gnu packages gl)
48 #:use-module (gnu packages glib)
49 #:use-module (gnu packages gnome)
50 #:use-module (gnu packages gstreamer)
51 #:use-module (gnu packages gtk)
52 #:use-module (gnu packages ibus)
53 #:use-module (gnu packages image)
54 #:use-module (gnu packages linux)
55 #:use-module (gnu packages llvm)
56 #:use-module (gnu packages lua)
57 #:use-module (gnu packages pdf)
58 #:use-module (gnu packages perl)
59 #:use-module (gnu packages photo)
60 #:use-module (gnu packages pkg-config)
61 #:use-module (gnu packages pulseaudio)
62 #:use-module (gnu packages python)
63 #:use-module (gnu packages python-xyz)
64 #:use-module (gnu packages tls)
65 #:use-module (gnu packages video)
66 #:use-module (gnu packages xdisorg)
67 #:use-module (gnu packages xorg)
68 #:use-module (ice-9 match))
69
70 (define-public efl
71 (package
72 (name "efl")
73 (version "1.24.3")
74 (source (origin
75 (method url-fetch)
76 (uri (string-append
77 "https://download.enlightenment.org/rel/libs/efl/efl-"
78 version ".tar.xz"))
79 (sha256
80 (base32
81 "0ajwc8lmay5ai7nsrp778g393h0p4h98p4c22gic2w61fgkcd5fy"))))
82 (build-system meson-build-system)
83 (native-inputs
84 `(("check" ,check)
85 ("gettext" ,gettext-minimal)
86 ("pkg-config" ,pkg-config)))
87 (inputs
88 `(("curl" ,curl)
89 ("giflib" ,giflib)
90 ("gstreamer" ,gstreamer)
91 ("gst-plugins-base" ,gst-plugins-base)
92 ("ibus" ,ibus)
93 ("mesa" ,mesa)
94 ("libraw" ,libraw)
95 ("librsvg" ,librsvg)
96 ("libspectre" ,libspectre)
97 ("libtiff" ,libtiff)
98 ("libxau" ,libxau)
99 ("libxcomposite" ,libxcomposite)
100 ("libxcursor" ,libxcursor)
101 ("libxdamage" ,libxdamage)
102 ("libxdmcp" ,libxdmcp)
103 ("libxext" ,libxext)
104 ("libxi" ,libxi)
105 ("libxfixes" ,libxfixes)
106 ("libxinerama" ,libxinerama)
107 ("libxrandr" ,libxrandr)
108 ("libxrender" ,libxrender)
109 ("libxss" ,libxscrnsaver)
110 ("libxtst" ,libxtst)
111 ("libwebp" ,libwebp)
112 ("openjpeg" ,openjpeg)
113 ("poppler" ,poppler)
114 ("util-linux" ,util-linux "lib")
115 ("wayland-protocols" ,wayland-protocols)))
116 (propagated-inputs
117 ;; All these inputs are in package config files in section
118 ;; Requires.private.
119 `(("avahi" ,avahi)
120 ("dbus" ,dbus)
121 ("elogind" ,elogind)
122 ("eudev" ,eudev)
123 ("fontconfig" ,fontconfig)
124 ("freetype" ,freetype)
125 ("fribidi" ,fribidi)
126 ("glib" ,glib)
127 ("harfbuzz" ,harfbuzz)
128 ("libinput" ,libinput-minimal)
129 ("libjpeg" ,libjpeg-turbo)
130 ("libsndfile" ,libsndfile)
131 ("libpng" ,libpng)
132 ("libx11" ,libx11)
133 ("libxkbcommon" ,libxkbcommon)
134 ("luajit" ,luajit)
135 ("lz4" ,lz4)
136 ("openssl" ,openssl)
137 ("pulseaudio" ,pulseaudio)
138 ("wayland" ,wayland)
139 ("zlib" ,zlib)))
140 (arguments
141 `(#:configure-flags '("-Dsystemd=false"
142 "-Delogind=true"
143 "-Dembedded-lz4=false"
144 "-Devas-loaders-disabler=json"
145 "-Dbuild-examples=false"
146 "-Decore-imf-loaders-disabler=scim"
147 "-Davahi=true"
148 "-Dglib=true"
149 "-Dmount-path=/run/setuid-programs/mount"
150 "-Dunmount-path=/run/setuid-programs/umount"
151 ;(string-append "-Ddictionaries-hyphen-dir="
152 ; (assoc-ref %build-inputs "hyphen")
153 ; "/share/hyphen")
154 "-Dnetwork-backend=connman"
155 ;; for wayland
156 "-Dwl=true"
157 "-Ddrm=true")
158 #:tests? #f ; Many tests fail due to timeouts and network requests.
159 #:phases
160 (modify-phases %standard-phases
161 ;; If we don't hardcode the location of libcurl.so and others then we
162 ;; have to wrap the outputs of efl's dependencies in those libraries.
163 (add-after 'unpack 'hardcode-dynamic-libraries
164 (lambda* (#:key inputs #:allow-other-keys)
165 (let ((curl (assoc-ref inputs "curl"))
166 (pulse (assoc-ref inputs "pulseaudio"))
167 (sndfile (assoc-ref inputs "libsndfile"))
168 (lib "/lib/"))
169 (substitute* "src/lib/ecore_con/ecore_con_url_curl.c"
170 (("libcurl.so.?" libcurl) ; libcurl.so.[45]
171 (string-append curl lib libcurl)))
172 (substitute* "src/lib/ecore_audio/ecore_audio.c"
173 (("libpulse.so.0" libpulse)
174 (string-append pulse lib libpulse))
175 (("libsndfile.so.1" libsnd)
176 (string-append sndfile lib libsnd)))
177 #t)))
178 (add-after 'unpack 'fix-install-paths
179 (lambda _
180 (substitute* "dbus-services/meson.build"
181 (("install_dir.*")
182 "install_dir: join_paths(dir_data, 'dbus-1', 'services'))\n"))
183 (substitute* "src/tests/elementary/meson.build"
184 (("dir_data") "meson.source_root(), 'test-output'"))
185 #t))
186 (add-after 'unpack 'set-home-directory
187 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
188 (lambda _ (setenv "HOME" "/tmp") #t)))))
189 (home-page "https://www.enlightenment.org/about-efl")
190 (synopsis "Enlightenment Foundation Libraries")
191 (description
192 "Enlightenment Foundation Libraries is a set of libraries developed
193 for Enlightenment. Libraries covers data serialization, wide support for
194 graphics rendering, UI layout and themes, interaction with OS, access to
195 removable devices or support for multimedia.")
196 ;; Different parts are under different licenses.
197 (license (list license:bsd-2 license:lgpl2.1 license:zlib))))
198
199 (define-public terminology
200 (package
201 (name "terminology")
202 (version "1.8.0")
203 (source (origin
204 (method url-fetch)
205 (uri
206 (string-append "https://download.enlightenment.org/rel/apps/"
207 "terminology/terminology-" version ".tar.xz"))
208 (sha256
209 (base32
210 "0pvn8mdzxlx7181xdha32fbr0w8xl7hsnb3hfxr5099g841v1xf6"))
211 (modules '((guix build utils)))
212 ;; Remove the bundled fonts.
213 (snippet
214 '(begin
215 (delete-file-recursively "data/fonts")
216 (substitute* "data/meson.build"
217 (("subdir\\('fonts'\\)") ""))
218 #t))))
219 (build-system meson-build-system)
220 (arguments
221 `(#:configure-flags (list "-Dtests=true"
222 (string-append "-Dedje-cc="
223 (assoc-ref %build-inputs "efl")
224 "/bin/edje_cc"))
225 #:phases
226 (modify-phases %standard-phases
227 (add-after 'unpack 'set-home-directory
228 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
229 (lambda _ (setenv "HOME" "/tmp") #t))
230 (replace 'check
231 (lambda _
232 (with-directory-excursion
233 (string-append "../" ,name "-" ,version "/tests")
234 (invoke "sh" "run_tests.sh" "--verbose"
235 "-t" "../../build/src/bin/tytest"))))
236 (add-after 'install 'remove-test-binary
237 (lambda* (#:key outputs #:allow-other-keys)
238 ;; This file is not meant to be installed.
239 (delete-file (string-append (assoc-ref outputs "out")
240 "/bin/tytest"))
241 #t)))))
242 (native-inputs
243 `(("gettext" ,gettext-minimal)
244 ("perl" ,perl)
245 ("pkg-config" ,pkg-config)))
246 (inputs
247 `(("efl" ,efl)))
248 (home-page "https://www.enlightenment.org/about-terminology")
249 (synopsis "Powerful terminal emulator based on EFL")
250 (description
251 "Terminology is fast and feature rich terminal emulator. It is solely
252 based on Enlightenment Foundation Libraries. It supports multiple tabs, UTF-8,
253 URL and local path detection, themes, popup based content viewer for non-text
254 contents and more.")
255 (license license:bsd-2)))
256
257 (define-public rage
258 (package
259 (name "rage")
260 (version "0.3.1")
261 (source (origin
262 (method url-fetch)
263 (uri
264 (string-append
265 "https://download.enlightenment.org/rel/apps/rage/rage-"
266 version ".tar.xz"))
267 (sha256
268 (base32
269 "04fdk23bbgvni212zrfy4ndg7vmshbsjgicrhckdvhay87pk9i75"))))
270 (build-system meson-build-system)
271 (arguments
272 '(#:phases
273 (modify-phases %standard-phases
274 (add-after 'unpack 'set-home-directory
275 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
276 (lambda _ (setenv "HOME" "/tmp") #t)))))
277 (native-inputs
278 `(("pkg-config" ,pkg-config)))
279 (inputs
280 `(("efl" ,efl)))
281 (home-page "https://www.enlightenment.org/about-rage")
282 (synopsis "Video and audio player based on EFL")
283 (description
284 "Rage is a video and audio player written with Enlightenment Foundation
285 Libraries with some extra bells and whistles.")
286 (license license:bsd-2)))
287
288 (define-public enlightenment
289 (package
290 (name "enlightenment")
291 (version "0.24.2")
292 (source (origin
293 (method url-fetch)
294 (uri
295 (string-append "https://download.enlightenment.org/rel/apps/"
296 "enlightenment/enlightenment-" version ".tar.xz"))
297 (sha256
298 (base32
299 "1wfz0rwwsx7c1mkswn4hc9xw1i6bsdirhxiycf7ha2vcipqy465y"))
300 (patches (search-patches "enlightenment-fix-setuid-path.patch"))))
301 (build-system meson-build-system)
302 (arguments
303 `(#:configure-flags
304 (let ((efl (assoc-ref %build-inputs "efl")))
305 (list "-Dsystemd=false"
306 "-Dpackagekit=false"
307 (string-append "-Dedje-cc=" efl "/bin/edje_cc")
308 (string-append "-Deldbus-codegen=" efl "/bin/eldbus-codegen")
309 (string-append "-Deet=" efl "/bin/eet")))
310 #:phases
311 (modify-phases %standard-phases
312 (delete 'bootstrap) ; We don't want to run the autogen script.
313 (add-before 'configure 'set-system-actions
314 (lambda* (#:key inputs #:allow-other-keys)
315 (setenv "HOME" "/tmp")
316 (let ((xkeyboard (assoc-ref inputs "xkeyboard-config"))
317 (setxkbmap (assoc-ref inputs "setxkbmap"))
318 (utils (assoc-ref inputs "util-linux"))
319 (libc (assoc-ref inputs "libc"))
320 (bc (assoc-ref inputs "bc"))
321 (efl (assoc-ref inputs "efl")))
322 ;; We need to patch the path to 'base.lst' to be able
323 ;; to switch the keyboard layout in E.
324 (substitute* (list "src/modules/xkbswitch/e_mod_parse.c"
325 "src/modules/wizard/page_011.c")
326 (("/usr/share/X11/xkb/rules/xorg.lst")
327 (string-append xkeyboard
328 "/share/X11/xkb/rules/base.lst")))
329 (substitute* "src/bin/e_xkb.c"
330 (("\"setxkbmap \"")
331 (string-append "\"" setxkbmap "/bin/setxkbmap \"")))
332 (substitute* (list "src/bin/e_intl.c"
333 "src/modules/conf_intl/e_int_config_intl.c"
334 "src/modules/wizard/page_010.c")
335 (("locale -a") (string-append libc "/bin/locale -a")))
336 (substitute* "src/modules/everything/evry_plug_apps.c"
337 (("/usr/bin/") ""))
338 (substitute* '("src/bin/e_sys_main.c"
339 "src/bin/e_util_suid.h")
340 (("PATH=/bin:/usr/bin:/sbin:/usr/sbin")
341 (string-append "PATH=/run/setuid-programs:"
342 "/run/current-system/profile/bin:"
343 "/run/current-system/profile/sbin")))
344 (substitute* "src/modules/everything/evry_plug_calc.c"
345 (("bc -l") (string-append bc "/bin/bc -l")))
346 (substitute* "data/etc/meson.build"
347 (("/bin/mount") "/run/setuid-programs/mount")
348 (("/bin/umount") "/run/setuid-programs/umount")
349 (("/usr/bin/eject") (string-append utils "/bin/eject")))
350 (substitute* "src/bin/system/e_system_power.c"
351 (("systemctl") "loginctl"))
352 #t))))))
353 (native-inputs
354 `(("gettext" ,gettext-minimal)
355 ("pkg-config" ,pkg-config)
356 ("util-linux" ,util-linux)))
357 (inputs
358 `(("alsa-lib" ,alsa-lib)
359 ("bc" ,bc)
360 ("bluez" ,bluez)
361 ("dbus" ,dbus)
362 ("efl" ,efl)
363 ("freetype" ,freetype)
364 ("libxcb" ,libxcb)
365 ("libxext" ,libxext)
366 ("linux-pam" ,linux-pam)
367 ("puleseaudio" ,pulseaudio)
368 ("setxkbmap" ,setxkbmap)
369 ("xcb-util-keysyms" ,xcb-util-keysyms)
370 ("xkeyboard-config" ,xkeyboard-config)))
371 (home-page "https://www.enlightenment.org/about-enlightenment")
372 (synopsis "Lightweight desktop environment")
373 (description
374 "Enlightenment is resource friendly desktop environment with integrated
375 file manager, wide range of configuration options, plugin system allowing to
376 unload unused functionality, with support for touchscreen and suitable for
377 embedded systems.")
378 (license license:bsd-2)))
379
380 (define-public enlightenment-wayland
381 (package
382 (inherit enlightenment)
383 (name "enlightenment-wayland")
384 (arguments
385 (substitute-keyword-arguments (package-arguments enlightenment)
386 ((#:configure-flags flags)
387 `(cons* "-Dwl=true" ,flags))))
388 (inputs
389 `(("wayland-protocols" ,wayland-protocols)
390 ("xorg-server-xwayland" ,xorg-server-xwayland)
391 ,@(package-inputs enlightenment)))))
392
393 (define-public python-efl
394 (package
395 (name "python-efl")
396 (version "1.24.0")
397 (source
398 (origin
399 (method url-fetch)
400 (uri (string-append "https://download.enlightenment.org/rel/bindings/"
401 "python/python-efl-" version ".tar.xz"))
402 (sha256
403 (base32
404 "1vk1cdd959gia4a9qzyq56a9zw3lqf9ck66k8c9g3c631mp5cfpy"))
405 (modules '((guix build utils)))
406 ;; Remove files generated by Cython
407 (snippet
408 '(begin
409 (copy-file "efl/dbus_mainloop/e_dbus.c" "efl/dbus_mainloop/e_dbus.q")
410 (for-each delete-file (find-files "efl" ".*\\.c$"))
411 (delete-file "efl/eo/efl.eo_api.h")
412 (copy-file "efl/dbus_mainloop/e_dbus.q" "efl/dbus_mainloop/e_dbus.c")
413 (delete-file "efl/dbus_mainloop/e_dbus.q")
414 #t))))
415 (build-system python-build-system)
416 (arguments
417 '(#:phases
418 (modify-phases %standard-phases
419 (replace 'build
420 (lambda _
421 (setenv "ENABLE_CYTHON" "1")
422 (invoke "python" "setup.py" "build")))
423 (add-before 'build 'set-flags
424 (lambda _
425 (setenv "CFLAGS"
426 (string-append "-I" (assoc-ref %build-inputs "python-dbus")
427 "/include/dbus-1.0"))
428 #t))
429 (add-before 'check 'set-environment
430 (lambda _
431 ;; Some tests require write access to HOME.
432 (setenv "HOME" "/tmp")
433 ;; These tests try to connect to the internet.
434 (delete-file "tests/ecore/test_09_file_download.py")
435 (delete-file "tests/ecore/test_11_con.py")
436 #t)))))
437 (native-inputs
438 `(("pkg-config" ,pkg-config)
439 ("python-cython" ,python-cython)))
440 (inputs
441 `(("efl" ,efl)
442 ("python-dbus" ,python-dbus)))
443 (home-page "https://www.enlightenment.org/")
444 (synopsis "Python bindings for EFL")
445 (description
446 "PYTHON-EFL are the python bindings for the whole Enlightenment Foundation
447 Libraries stack (eo, evas, ecore, edje, emotion, ethumb and elementary).")
448 (license license:lgpl3)))
449
450 (define-public python2-efl
451 (package-with-python2 python-efl))
452
453 (define-public edi
454 (package
455 (name "edi")
456 (version "0.8.0")
457 (source
458 (origin
459 (method url-fetch)
460 (uri (string-append "https://github.com/Enlightenment/edi/releases/"
461 "download/v" version "/edi-" version ".tar.xz"))
462 (sha256
463 (base32
464 "01k8gp8r2wa6pyg3dkbm35m6hdsbss06hybghg0qjmd4mzswcd3a"))))
465 (build-system meson-build-system)
466 (arguments
467 '(#:phases
468 (modify-phases %standard-phases
469 (add-after 'unpack 'fix-clang-header
470 (lambda _
471 (substitute* "scripts/clang_include_dir.sh"
472 (("grep clang") "grep clang | head -n1"))
473 #t))
474 (add-after 'unpack 'set-home-directory
475 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
476 (lambda _ (setenv "HOME" "/tmp") #t)))
477 #:tests? #f)) ; tests require running dbus service
478 (native-inputs
479 `(("check" ,check)
480 ("gettext" ,gettext-minimal)
481 ("pkg-config" ,pkg-config)))
482 (inputs
483 `(("clang" ,clang)
484 ("efl" ,efl)))
485 (home-page "https://www.enlightenment.org/about-edi")
486 (synopsis "Development environment for Enlightenment")
487 (description "EDI is a development environment designed for and built using
488 the EFL. It's aim is to create a new, native development environment for Linux
489 that tries to lower the barrier to getting involved in Enlightenment development
490 and in creating applications based on the Enlightenment Foundation Library suite.")
491 (license (list license:public-domain ; data/extra/skeleton
492 license:gpl2 ; edi
493 license:gpl3)))) ; data/extra/examples/images/mono-runtime.png
494
495 (define-public lekha
496 (package
497 (name "lekha")
498 (version "0.2.1")
499 (source (origin
500 (method url-fetch)
501 (uri (pypi-uri "Lekha" version))
502 (sha256
503 (base32
504 "0zr6i74ik58pbzrd7r9l7sawqbdv0r2c1a9927qkqzwga27x8j15"))))
505 (build-system python-build-system)
506 (arguments
507 `(#:tests? #f ; no test target
508 #:python ,python-2
509 #:phases
510 (modify-phases %standard-phases
511 (add-after 'unpack 'fix-data-location
512 (lambda _ (substitute* "setup.py"
513 (("'/usr/")"'"))
514 #t)))))
515 (propagated-inputs
516 `(("python2-efl" ,python2-efl)
517 ("python2-pypdf2" ,python2-pypdf2)
518 ("python2-pyxdg" ,python2-pyxdg)))
519 (synopsis "Simple PDF viewer")
520 (description
521 "Simple PDF viewer based on the Enlightenment Foundation Libraries.")
522 (home-page "https://github.com/kaihu/lekha")
523 (license license:gpl3+)))
524
525 (define-public ephoto
526 (package
527 (name "ephoto")
528 (version "1.5")
529 (source
530 (origin
531 (method url-fetch)
532 (uri (string-append "https://download.enlightenment.org/rel/"
533 "apps/ephoto/ephoto-" version ".tar.xz"))
534 (sha256
535 (base32 "1q7v9abjp9jrs08xc7pqaac64yzax24dk1snjb9rciarzzh3mlzy"))))
536 (build-system gnu-build-system)
537 (arguments
538 '(#:phases
539 (modify-phases %standard-phases
540 (add-after 'unpack 'set-home-directory
541 ;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
542 (lambda _ (setenv "HOME" "/tmp") #t)))))
543 (native-inputs
544 `(("check" ,check)
545 ("pkg-config" ,pkg-config)))
546 (inputs
547 `(("efl" ,efl)))
548 (home-page "https://smhouston.us/projects/ephoto/")
549 (synopsis "EFL image viewer/editor/manipulator/slideshow creator")
550 (description "Ephoto is an image viewer and editor written using the
551 @dfn{Enlightenment Foundation Libraries} (EFL). It focuses on simplicity and
552 ease of use, while taking advantage of the speed and small footprint the EFL
553 provide.
554
555 Ephoto’s features include:
556 @enumerate
557 @item Browsing the file system and displaying images in an easy-to-use grid view.
558 @item Browsing images in a single image view format.
559 @item Viewing images in a slideshow.
560 @item Editing your image with features such as cropping, auto enhance,
561 blurring, sharpening, brightness/contrast/gamma adjustments, hue/saturation/value
562 adjustments, and color level adjustment.
563 @item Applying artistic filters to your image such as black and white and old
564 photo.
565 @item Drag And Drop along with file operations to easily maintain your photo
566 directories.
567 @end enumerate\n")
568 (license (list
569 license:bsd-2 ; Ephoto's thumbnailing code
570 license:bsd-3))))
571
572 (define-public evisum
573 (package
574 (name "evisum")
575 (version "0.5.1")
576 (source
577 (origin
578 (method url-fetch)
579 (uri (string-append "https://download.enlightenment.org/rel/apps/"
580 "evisum/evisum-" version ".tar.xz"))
581 (sha256
582 (base32
583 "1gl0nfcsfnzl9vc2qcm5chj2nsavdgyy8szpamq2ggnn5p9llh16"))))
584 (build-system meson-build-system)
585 (arguments
586 '(#:tests? #f)) ; no tests
587 (native-inputs
588 `(("pkg-config" ,pkg-config)))
589 (inputs
590 `(("efl" ,efl)))
591 (home-page "https://www.enlightenment.org")
592 (synopsis "EFL process viewer")
593 (description
594 "This is a process monitor and system monitor using the
595 @dfn{Enlightenment Foundation Libraries} (EFL).")
596 (license license:bsd-2)))
597
598 (define-public epour
599 (package
600 (name "epour")
601 (version "0.7.0")
602 (source
603 (origin
604 (method url-fetch)
605 (uri (string-append "https://download.enlightenment.org/rel/apps/epour"
606 "/epour-" version ".tar.xz"))
607 (sha256
608 (base32
609 "0g9f9p01hsq6dcf4cs1pwq95g6fpkyjgwqlvdjk1km1i5gj5ygqw"))))
610 (build-system python-build-system)
611 (arguments
612 `(#:tests? #f ; no test target
613 #:use-setuptools? #f
614 #:phases
615 (modify-phases %standard-phases
616 (add-after 'unpack 'find-theme-dir
617 (lambda* (#:key outputs #:allow-other-keys)
618 (let ((out (assoc-ref outputs "out")))
619 (substitute* "epour/gui/__init__.py"
620 (("join\\(data_path")
621 (string-append "join(\"" out "/share/epour\"")))
622 #t))))))
623 (native-inputs
624 `(("intltool" ,intltool)
625 ("python-distutils-extra" ,python-distutils-extra)))
626 (inputs
627 `(("libtorrent-rasterbar" ,libtorrent-rasterbar)
628 ("python-dbus" ,python-dbus)
629 ("python-efl" ,python-efl)
630 ("python-pyxdg" ,python-pyxdg)))
631 (home-page "https://www.enlightenment.org")
632 (synopsis "EFL Bittorrent client")
633 (description "Epour is a BitTorrent client based on the @dfn{Enlightenment
634 Foundation Libraries} (EFL) and rb-libtorrent.")
635 (license license:gpl3+)))