Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / xiph.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
4 ;;; Copyright © 2013 David Thompson <dthompson2@worcester.edu>
5 ;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
6 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
7 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
8 ;;; Copyright © 2015, 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
9 ;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
10 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
11 ;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
12 ;;;
13 ;;; This file is part of GNU Guix.
14 ;;;
15 ;;; GNU Guix is free software; you can redistribute it and/or modify it
16 ;;; under the terms of the GNU General Public License as published by
17 ;;; the Free Software Foundation; either version 3 of the License, or (at
18 ;;; your option) any later version.
19 ;;;
20 ;;; GNU Guix is distributed in the hope that it will be useful, but
21 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
22 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
23 ;;; GNU General Public License for more details.
24 ;;;
25 ;;; You should have received a copy of the GNU General Public License
26 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
27
28 (define-module (gnu packages xiph)
29 #:use-module (gnu packages)
30 #:use-module (gnu packages bison)
31 #:use-module (gnu packages compression)
32 #:use-module (gnu packages curl)
33 #:use-module (gnu packages documentation)
34 #:use-module (gnu packages image)
35 #:use-module (gnu packages pkg-config)
36 #:use-module (gnu packages python)
37 #:use-module (gnu packages linux)
38 #:use-module (gnu packages pulseaudio)
39 #:use-module (gnu packages tls)
40 #:use-module (gnu packages xml)
41 #:use-module ((guix licenses) #:prefix license:)
42 #:use-module (guix packages)
43 #:use-module (guix download)
44 #:use-module (guix build-system gnu)
45 #:export (libogg
46 libvorbis
47 libtheora
48 speex
49 speexdsp
50 ao
51 flac
52 libkate
53 vorbis-tools
54 opus
55 opusfile
56 opus-tools))
57
58 (define libogg
59 (package
60 (name "libogg")
61 (version "1.3.3")
62 (source (origin
63 (method url-fetch)
64 (uri (string-append "https://downloads.xiph.org/releases/ogg/libogg-"
65 version ".tar.xz"))
66 (sha256
67 (base32
68 "022wjlzn8fx7mfby4pcgyjwx8zir7jr7cizichh3jgaki8bwcgsg"))))
69 (build-system gnu-build-system)
70 (synopsis "Library for manipulating the ogg multimedia format")
71 (description
72 "The libogg library allows to manipulate the ogg multimedia container
73 format, which encapsulates raw compressed data and allows the interleaving of
74 audio and video data. In addition to encapsulation and interleaving of
75 multiple data streams, ogg provides packet framing, error detection, and
76 periodic timestamps for seeking.")
77 (license (license:non-copyleft "file://COPYING"
78 "See COPYING in the distribution."))
79 (home-page "https://xiph.org/ogg/")))
80
81 (define libvorbis
82 (package
83 (name "libvorbis")
84 (version "1.3.6")
85 (source (origin
86 (method url-fetch)
87 (uri (string-append "https://downloads.xiph.org/releases/vorbis/"
88 "libvorbis-" version ".tar.xz"))
89 (sha256
90 (base32
91 "05dlzjkdpv46zb837wysxqyn8l636x3dw8v8ymlrwz2fg1dbn05g"))))
92 (build-system gnu-build-system)
93 (propagated-inputs `(("libogg" ,libogg)))
94 (arguments `(#:configure-flags '("LDFLAGS=-lm")
95 #:parallel-tests? #f))
96 (synopsis "Library implementing the vorbis audio format")
97 (description
98 "The libvorbis library implements the ogg vorbis audio format,
99 a fully open, non-proprietary, patent-and-royalty-free, general-purpose
100 compressed audio format for mid to high quality (8kHz-48.0kHz, 16+ bit,
101 polyphonic) audio and music at fixed and variable bitrates from 16 to
102 128 kbps/channel.")
103 (license (license:non-copyleft "file://COPYING"
104 "See COPYING in the distribution."))
105 (home-page "https://xiph.org/vorbis/")))
106
107 (define libtheora
108 (package
109 (name "libtheora")
110 (version "1.1.1")
111 (source (origin
112 (method url-fetch)
113 (uri (string-append "https://downloads.xiph.org/releases/theora/"
114 "libtheora-" version ".tar.xz"))
115 (sha256
116 (base32
117 "0q8wark9ribij57dciym5vdikg2464p8q2mgqvfb78ksjh4s8vgk"))
118 (patches (search-patches "libtheora-config-guess.patch"))))
119 (build-system gnu-build-system)
120 (inputs `(("libvorbis" ,libvorbis)))
121 ;; The .pc files refer to libogg.
122 (propagated-inputs `(("libogg" ,libogg)))
123 (synopsis "Library implementing the Theora video format")
124 (description
125 "The libtheora library implements the ogg theora video format,
126 a fully open, non-proprietary, patent-and-royalty-free, general-purpose
127 compressed video format.")
128 (license license:bsd-3)
129 (home-page "https://xiph.org/theora/")))
130
131 (define speex
132 (package
133 (name "speex")
134 (version "1.2.0")
135 (source
136 (origin
137 (method url-fetch)
138 (uri (string-append "https://downloads.xiph.org/releases/speex/speex-"
139 version ".tar.gz"))
140 (sha256
141 (base32
142 "150047wnllz4r94whb9r73l5qf0z5z3rlhy98bawfbblmkq8mbpa"))))
143 (build-system gnu-build-system)
144 (native-inputs
145 `(("pkg-config" ,pkg-config)))
146 (inputs
147 `(("libogg" ,libogg)
148 ("speexdsp" ,speexdsp)))
149 (home-page "https://gnu.org/software/speex")
150 (synopsis "Library for patent-free audio compression format")
151 (description
152 "GNU Speex is a patent-free audio compression codec specially designed
153 for speech. It is well-adapted to internet applications, such as VoIP. It
154 features compression of different bands in the same bitstream, intensity
155 stereo encoding, and voice activity detection.")
156 ;; 'src/getopt.c' is under LGPLv2+
157 (license (license:non-copyleft "file://COPYING"
158 "See COPYING in the distribution."))))
159
160 (define speexdsp
161 (package
162 (name "speexdsp")
163 (version "1.2.0")
164 (source (origin
165 (method url-fetch)
166 (uri (string-append "https://downloads.xiph.org/releases/speex/"
167 "speexdsp-" version ".tar.gz"))
168 (sha256
169 (base32
170 "0wa7sqpk3x61zz99m7lwkgr6yv62ml6lfgs5xja65vlvdzy44838"))))
171 (build-system gnu-build-system)
172 (arguments
173 `(#:configure-flags '(,@(if (string=? "aarch64-linux"
174 (%current-system))
175 '("--enable-neon=no") ; neon defaults to armv7-a
176 '()))))
177 (home-page "https://speex.org/")
178 (synopsis "Speex processing library")
179 (description
180 "SpeexDSP is a @dfn{DSP} (Digital Signal Processing) library based on
181 work from the @code{speex} codec.")
182 (license (license:non-copyleft "file://COPYING"
183 "See COPYING in the distribution."))))
184
185 (define ao
186 (package
187 (name "ao")
188 (version "1.2.0")
189 (source
190 (origin
191 (method url-fetch)
192 (uri (string-append "https://downloads.xiph.org/releases/ao/libao-"
193 version ".tar.gz"))
194 (sha256
195 (base32
196 "1bwwv1g9lchaq6qmhvj1pp3hnyqr64ydd4j38x94pmprs4d27b83"))))
197 (build-system gnu-build-system)
198 ;; FIXME: Add further backends, see the summary printed after configure.
199 ;; XXX: Should back-ends be pushed to different outputs? For instance,
200 ;; "out" would include only the ALSA back-end, while "pulse" would
201 ;; contain 'lib/ao/plugins-4/libpulse.*'.
202 (inputs
203 `(("alsa-lib" ,alsa-lib)
204 ("pulseaudio" ,pulseaudio)))
205 (native-inputs
206 `(("pkg-config" ,pkg-config)))
207 (synopsis "Cross platform audio library")
208 (description
209 "Libao is a cross-platform audio library that allows programs to
210 output audio using a simple API on a wide variety of platforms.
211 It currently supports:
212 @enumerate
213 @item Null output (handy for testing without a sound device),
214 @item WAV files,
215 @item AU files,
216 @item RAW files,
217 @item OSS (Open Sound System, used on Linux and FreeBSD),
218 @item ALSA (Advanced Linux Sound Architecture),
219 @item aRts (Analog RealTime Synth, used by KDE),
220 @item PulseAudio (next generation GNOME sound server),
221 @item esd (EsounD or Enlightened Sound Daemon),
222 @item Mac OS X,
223 @item Windows (98 and later),
224 @item AIX,
225 @item Sun/NetBSD/OpenBSD,
226 @item IRIX,
227 @item NAS (Network Audio Server),
228 @item RoarAudio (Modern, multi-OS, networked Sound System),
229 @item OpenBSD's sndio.
230 @end enumerate
231 ")
232 (license license:gpl2+)
233 (home-page "https://www.xiph.org/ao/")))
234
235 (define flac
236 (package
237 (name "flac")
238 (version "1.3.2")
239 (source (origin
240 (method url-fetch)
241 (uri (string-append "https://downloads.xiph.org/releases/flac/flac-"
242 version ".tar.xz"))
243 (sha256
244 (base32
245 "0gymm2j3276kr9nz6vmgfwsdfrq6c449n40a0mzz8h6wc7nw7kwi"))
246 (patches (search-patches "flac-CVE-2017-6888.patch"))))
247 (build-system gnu-build-system)
248 (arguments
249 `(#:parallel-tests? #f))
250 ;; FIXME: configure also looks for xmms, input could be added once it exists
251 (propagated-inputs `(("libogg" ,libogg))) ; required by flac.pc
252 (synopsis "Free lossless audio codec")
253 (description
254 "FLAC stands for Free Lossless Audio Codec, an audio format that is lossless,
255 meaning that audio is compressed in FLAC without any loss in quality.")
256 (license (license:non-copyleft "file://COPYING"
257 "See COPYING in the distribution.")) ; and LGPL and GPL
258 (home-page "https://xiph.org/flac/")))
259
260 (define libkate
261 (package
262 (name "libkate")
263 (version "0.4.1")
264 (source (origin
265 (method url-fetch)
266 (uri (string-append "https://downloads.xiph.org/releases/kate/"
267 "libkate-" version ".tar.gz"))
268 (sha256
269 (base32
270 "0s3vr2nxfxlf1k75iqpp4l78yf4gil3f0v778kvlngbchvaq23n4"))))
271 (build-system gnu-build-system)
272 (native-inputs `(("doxygen" ,doxygen)
273 ("pkg-config" ,pkg-config)))
274 ;; FIXME: Add optional input liboggz
275 (inputs `(("bison" ,bison)
276 ("libogg" ,libogg)
277 ("libpng" ,libpng)
278 ("python" ,python-wrapper)
279 ("zlib" ,zlib)))
280 (synopsis "Karaoke and text codec for embedding in ogg")
281 (description
282 "Kate is an overlay codec, originally designed for karaoke and text,
283 that can be multiplixed in Ogg. Text and images can be carried by a Kate
284 stream, and animated. Most of the time, this would be multiplexed with
285 audio/video to carry subtitles, song lyrics (with or without karaoke data),
286 etc., but doesn't have to be.
287
288 Series of curves (splines, segments, etc.) may be attached to various
289 properties (text position, font size, etc.) to create animated overlays.
290 This allows scrolling or fading text to be defined. This can even be used
291 to draw arbitrary shapes, so hand drawing can also be represented by a
292 Kate stream.")
293 (license license:bsd-3)
294 (home-page "https://wiki.xiph.org/OggKate")))
295
296 (define vorbis-tools
297 (package
298 (name "vorbis-tools")
299 (version "1.4.0")
300 (source (origin
301 (method url-fetch)
302 (uri (string-append "https://downloads.xiph.org/releases/vorbis/"
303 "vorbis-tools-" version ".tar.gz"))
304 (sha256
305 (base32
306 "1g12bnh5ah08v529y72kfdz5lhvy75iaz7f9jskyby23m9dkk2d3"))
307 (patches (search-patches
308 "vorbis-tools-CVE-2014-9638+CVE-2014-9639.patch"
309 "vorbis-tools-CVE-2014-9640.patch"
310 "vorbis-tools-CVE-2015-6749.patch"))))
311 (build-system gnu-build-system)
312 (inputs `(("ao" ,ao)
313 ("curl" ,curl)
314 ("flac" ,flac)
315 ("libkate" ,libkate)
316 ("libogg" ,libogg)
317 ("libvorbis" ,libvorbis)
318 ("speex" ,speex)))
319 (native-inputs `(("pkg-config" ,pkg-config)))
320 (synopsis "Ogg vorbis tools")
321 (description
322 "Ogg vorbis is a non-proprietary, patent-and-royalty-free,
323 general-purpose compressed audio format.
324
325 The package vorbis-tools contains
326 ogg123, an ogg vorbis command line audio player;
327 oggenc, the ogg vorbis encoder;
328 oggdec, a simple, portable command line decoder (to wav and raw);
329 ogginfo, to obtain information (tags, bitrate, length, etc.) about
330 an ogg vorbis file.")
331 (license license:gpl2)
332 (home-page "https://xiph.org/vorbis/")))
333
334 (define opus
335 (package
336 (name "opus")
337 (version "1.3.1")
338 (source (origin
339 (method url-fetch)
340 (uri (string-append "https://archive.mozilla.org/pub/opus/opus-"
341 version ".tar.gz"))
342 (sha256
343 (base32
344 "17gz8kxs4i7icsc1gj713gadiapyklynlwqlf0ai98dj4lg8xdb5"))))
345 (build-system gnu-build-system)
346 (synopsis "Versatile audio codec")
347 (description
348 "Opus is a totally open, royalty-free, highly versatile audio codec. Opus
349 is unmatched for interactive speech and music transmission over the Internet,
350 but is also intended for storage and streaming applications. It is
351 standardized by the Internet Engineering Task Force (IETF) as RFC 6716 which
352 incorporated technology from Skype's SILK codec and Xiph.Org's CELT codec.")
353 (license license:bsd-3)
354 (home-page "https://www.opus-codec.org")))
355
356 (define opus-tools
357 (package
358 (name "opus-tools")
359 (version "0.2")
360 (source (origin
361 (method url-fetch)
362 (uri (string-append
363 "https://downloads.xiph.org/releases/opus/opus-tools-"
364 version ".tar.gz"))
365 (sha256
366 (base32
367 "11pzl27s4vcz4m18ch72nivbhww2zmzn56wspb7rll1y1nq6rrdl"))))
368 (build-system gnu-build-system)
369 (arguments
370 ;; The package developers misuse pkg-config such that it doesn't work
371 ;; when cross compiling. Therefore we avoid it completly and set the
372 ;; necessary flags ourselves.
373 `(#:configure-flags (list (string-append "CFLAGS=-I"
374 (assoc-ref %build-inputs "libogg")
375 "/include -I"
376 (assoc-ref %build-inputs "opus")
377 "/include/opus"))))
378 (native-inputs
379 `(("pkg-config" ,pkg-config)))
380 (inputs
381 `(("libopusenc" ,libopusenc)
382 ("opusfile" ,opusfile)
383 ("flac" ,flac)))
384 (synopsis
385 "Command line utilities to encode, inspect, and decode .opus files")
386 (description "Opus is a royalty-free, highly versatile audio codec.
387 Opus-tools provide command line utilities for creating, inspecting and
388 decoding .opus files.")
389 (license license:bsd-3)
390 (home-page "https://www.opus-codec.org")))
391
392 (define opusfile
393 (package
394 (name "opusfile")
395 (version "0.11")
396 (source (origin
397 (method url-fetch)
398 (uri (string-append
399 "https://downloads.xiph.org/releases/opus/opusfile-" version
400 ".tar.gz"))
401 (sha256
402 (base32
403 "1gq3aszzl5glgbajw5p1f5a1kdyf23w5vjdmwwrk246syin9pkkl"))))
404 (build-system gnu-build-system)
405 ;; Required by opusfile.pc and opusurl.pc.
406 (propagated-inputs
407 `(("libogg" ,libogg)
408 ("openssl" ,openssl)
409 ("opus" ,opus)))
410 (native-inputs
411 `(("pkg-config" ,pkg-config)))
412 (synopsis "Versatile audio codec")
413 (description
414 "The opusfile library provides seeking, decode, and playback of Opus
415 streams in the Ogg container (.opus files) including over http(s) on posix and
416 windows systems.")
417 (license license:bsd-3)
418 (home-page "https://www.opus-codec.org")))
419
420 (define-public libopusenc
421 (package
422 (name "libopusenc")
423 (version "0.2.1")
424 (source (origin
425 (method url-fetch)
426 (uri (string-append "https://archive.mozilla.org/pub/opus/"
427 "libopusenc-" version ".tar.gz"))
428 (sha256
429 (base32
430 "1ffb0vhlymlsq70pxsjj0ksz77yfm2x0a1x8q50kxmnkm1hxp642"))))
431 (build-system gnu-build-system)
432 (native-inputs
433 `(("pkg-config" ,pkg-config)))
434 (propagated-inputs
435 `(("opus" ,opus)))
436 (synopsis "Library for encoding Opus audio files and streams ")
437 (description "The libopusenc libraries provide a high-level API for
438 encoding Opus files and streams.")
439 (home-page "https://www.opus-codec.org/")
440 (license license:bsd-3)))
441
442 (define-public icecast
443 (package
444 (name "icecast")
445 (version "2.4.4")
446 (source (origin
447 (method url-fetch)
448 (uri (string-append
449 "https://downloads.xiph.org/releases/icecast/icecast-"
450 version ".tar.gz"))
451 (sha256
452 (base32
453 "0i2d9rhav0x6js2qhjf5iy6j2a7f0d11ail0lfv40hb1kygrgda9"))))
454 (build-system gnu-build-system)
455 (native-inputs
456 `(("pkg-config" ,pkg-config)))
457 (inputs
458 `(("libxslt" ,libxslt)
459 ("libxml2" ,libxml2)
460 ("openssl" ,openssl)
461 ("curl" ,curl)
462 ("libogg" ,libogg)
463 ("libvorbis" ,libvorbis)
464 ("libtheora" ,libtheora)
465 ("speex" ,speex)))
466 (synopsis "Streaming media server")
467 (description "Icecast is a streaming media server which currently supports
468 Ogg (Vorbis and Theora), Opus, WebM and MP3 audio streams. It can be used to
469 create an Internet radio station or a privately running jukebox and many
470 things in between.")
471 (home-page "https://icecast.org/")
472 (license license:gpl2)))
473
474 (define-public libshout
475 (package
476 (name "libshout")
477 (version "2.4.2")
478 (source (origin
479 (method url-fetch)
480 (uri (string-append
481 "https://downloads.xiph.org/releases/libshout/"
482 "libshout-" version ".tar.gz"))
483 (sha256
484 (base32
485 "0qgwarqp2p6jy3zadds6dzj8z1jfb2mbwc3lsdlidf527h0a86ym"))))
486 (build-system gnu-build-system)
487 (native-inputs
488 `(("pkg-config" ,pkg-config)))
489 (propagated-inputs
490 ;; shout.pc refers to all these.
491 `(("libtheora" ,libtheora)
492 ("libvorbis" ,libvorbis)
493 ("speex" ,speex)))
494 (home-page "https://icecast.org/")
495 (synopsis "Audio streaming library for icecast encoders")
496 (description
497 "Libshout is a library for communicating with and sending data to an
498 icecast server. It handles the socket connection, the timing of the data,
499 and prevents bad data from getting to the icecast server.")
500 (license license:gpl2+)))