gnu: rust-streaming-stats-0.2: Update to 0.2.3.
[jackhill/guix/guix.git] / gnu / packages / sdr.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Christopher Howard <christopher@librehacker.com>
3 ;;; Copyright © 2019, 2020 Evan Straw <evan.straw99@gmail.com>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages sdr)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix git-download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages algebra)
27 #:use-module (gnu packages autotools))
28
29 (define-public liquid-dsp
30 (package
31 (name "liquid-dsp")
32 (version "1.3.2")
33 (source
34 (origin (method git-fetch)
35 (uri (git-reference
36 (url "https://github.com/jgaeddert/liquid-dsp.git")
37 (commit (string-append "v" version))))
38 (file-name (git-file-name name version))
39 (sha256
40 (base32 "1n6dbg13q8ga5qhg1yiszwly4jj0rxqr6f1xwm9waaly5z493xsd"))))
41 (build-system gnu-build-system)
42 (native-inputs
43 `(("autoconf" ,autoconf)))
44 (inputs
45 `(("fftw" ,fftw)
46 ("fftwf" ,fftwf)))
47 (home-page "https://liquidsdr.org")
48 (synopsis "Signal processing library for software-defined radios")
49 (description
50 "Liquid DSP is a @dfn{digital signal processing} (DSP) library designed
51 specifically for software-defined radios on embedded platforms. The aim is to
52 provide a lightweight DSP library that does not rely on a myriad of external
53 dependencies or proprietary and otherwise cumbersome frameworks. All signal
54 processing elements are designed to be flexible, scalable, and dynamic,
55 including filters, filter design, oscillators, modems, synchronizers, complex
56 mathematical operations, and much more.")
57 (license license:expat)))