gnu: arb: Build with flint 2.6.
[jackhill/guix/guix.git] / gnu / packages / patches / arb-flint-2.6.patch
1 From d3d9983231e0f034e86a1e75761627eb8213b704 Mon Sep 17 00:00:00 2001
2 From: fredrik <fredrik.johansson@gmail.com>
3 Date: Wed, 29 Apr 2020 13:41:36 +0200
4 Subject: [PATCH] handle flint incompatibilities
5
6 ---
7 fmpr.h | 4 ++++
8 fmpz_extras.h | 4 ++++
9 2 files changed, 8 insertions(+)
10
11 diff --git a/fmpr.h b/fmpr.h
12 index 2204d72e..c6a8c342 100644
13 --- a/fmpr.h
14 +++ b/fmpr.h
15 @@ -22,7 +22,11 @@
16 #include "flint/flint.h"
17 #include "flint/fmpz.h"
18 #include "flint/fmpq.h"
19 +#if __FLINT_RELEASE < 20600
20 #include "flint/config.h"
21 +#else
22 +#include "flint/flint-config.h"
23 +#endif
24 #include "fmpz_extras.h"
25
26 #ifndef flint_abort
27 diff --git a/fmpz_extras.h b/fmpz_extras.h
28 index 4fd0538f..486e28c8 100644
29 --- a/fmpz_extras.h
30 +++ b/fmpz_extras.h
31 @@ -43,6 +43,8 @@ fmpz_add_inline(fmpz_t z, const fmpz_t x, const fmpz_t y)
32 fmpz_add(z, x, y);
33 }
34
35 +#if __FLINT_RELEASE < 20600
36 +
37 static __inline__ void
38 fmpz_add_si(fmpz_t z, const fmpz_t x, slong y)
39 {
40 @@ -61,6 +63,8 @@ fmpz_sub_si(fmpz_t z, const fmpz_t x, slong y)
41 fmpz_add_ui(z, x, -y);
42 }
43
44 +#endif
45 +
46 static __inline__ void
47 fmpz_add_si_inline(fmpz_t z, const fmpz_t x, slong y)
48 {