gnu: irssi: Update to 1.2.3.
[jackhill/guix/guix.git] / gnu / packages / irc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2014 Kevin Lemonnier <lemonnierk@ulrar.net>
4 ;;; Copyright © 2015, 2017 Ludovic Courtès <ludo@gnu.org>
5 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2016 Nikita <nikita@n0.is>
7 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
8 ;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
10 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
11 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
12 ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
13 ;;;
14 ;;; This file is part of GNU Guix.
15 ;;;
16 ;;; GNU Guix is free software; you can redistribute it and/or modify it
17 ;;; under the terms of the GNU General Public License as published by
18 ;;; the Free Software Foundation; either version 3 of the License, or (at
19 ;;; your option) any later version.
20 ;;;
21 ;;; GNU Guix is distributed in the hope that it will be useful, but
22 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
23 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
24 ;;; GNU General Public License for more details.
25 ;;;
26 ;;; You should have received a copy of the GNU General Public License
27 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
28
29 (define-module (gnu packages irc)
30 #:use-module ((guix licenses) #:prefix license:)
31 #:use-module (guix download)
32 #:use-module (guix git-download)
33 #:use-module (guix packages)
34 #:use-module (guix build-system cmake)
35 #:use-module (guix build-system glib-or-gtk)
36 #:use-module (guix build-system gnu)
37 #:use-module (guix build-system python)
38 #:use-module (guix build-system qt)
39 #:use-module (gnu packages)
40 #:use-module (gnu packages admin)
41 #:use-module (gnu packages aspell)
42 #:use-module (gnu packages autogen)
43 #:use-module (gnu packages autotools)
44 #:use-module (gnu packages base)
45 #:use-module (gnu packages backup)
46 #:use-module (gnu packages check)
47 #:use-module (gnu packages compression)
48 #:use-module (gnu packages curl)
49 #:use-module (gnu packages cyrus-sasl)
50 #:use-module (gnu packages databases)
51 #:use-module (gnu packages file)
52 #:use-module (gnu packages gettext)
53 #:use-module (gnu packages geo)
54 #:use-module (gnu packages glib)
55 #:use-module (gnu packages gnome)
56 #:use-module (gnu packages gnupg)
57 #:use-module (gnu packages gtk)
58 #:use-module (gnu packages guile)
59 #:use-module (gnu packages lua)
60 #:use-module (gnu packages lxqt)
61 #:use-module (gnu packages ncurses)
62 #:use-module (gnu packages openldap)
63 #:use-module (gnu packages kde)
64 #:use-module (gnu packages kde-frameworks)
65 #:use-module (gnu packages password-utils)
66 #:use-module (gnu packages pcre)
67 #:use-module (gnu packages perl)
68 #:use-module (gnu packages pkg-config)
69 #:use-module (gnu packages python)
70 #:use-module (gnu packages python-crypto)
71 #:use-module (gnu packages python-xyz)
72 #:use-module (gnu packages regex)
73 #:use-module (gnu packages ruby)
74 #:use-module (gnu packages sqlite)
75 #:use-module (gnu packages qt)
76 #:use-module (gnu packages tcl)
77 #:use-module (gnu packages textutils)
78 #:use-module (gnu packages time)
79 #:use-module (gnu packages tls)
80 #:use-module (gnu packages web)
81 #:use-module (srfi srfi-1)
82 #:use-module (srfi srfi-26))
83
84 (define-public quassel
85 (package
86 (name "quassel")
87 (version "0.13.1")
88 (source
89 (origin
90 (method url-fetch)
91 (uri (string-append "https://quassel-irc.org/pub/quassel-"
92 version ".tar.bz2"))
93 (sha256
94 (base32
95 "0mg8jydc70vlylppzich26q4s40kr78r3ysfyjwisfvlg2byxvs8"))
96 (patches (search-patches "quassel-qt-514-compat.patch"))
97 (modules '((guix build utils)))
98 ;; We don't want to install the bundled inxi script.
99 (snippet
100 '(begin
101 (delete-file "data/scripts/inxi")
102 #t))))
103 (build-system qt-build-system)
104 (arguments
105 ;; The three binaries are not mutually exlusive, and are all built
106 ;; by default.
107 '(#:configure-flags '(;;"-DWANT_QTCLIENT=OFF" ; 6.1 MiB
108 ;;"-DWANT_CORE=OFF" ; 3.0 MiB
109 ;;"-DWANT_MONO=OFF" ; 7.6 MiB
110 "-DWITH_KDE=OFF" ; no to kde integration ...
111 "-DWITH_BUNDLED_ICONS=ON" ; so we install bundled icons
112 "-DWITH_OXYGEN_ICONS=ON" ; also the oxygen ones
113 "-DWITH_WEBENGINE=OFF") ; we don't depend on qtwebengine
114 #:phases
115 (modify-phases %standard-phases
116 (add-after 'unpack 'patch-inxi-reference
117 (lambda* (#:key inputs #:allow-other-keys)
118 (let ((inxi (string-append (assoc-ref inputs "inxi") "/bin/inxi")))
119 (symlink inxi "data/scripts/inxi")
120 #t))))
121 #:tests? #f)) ; no test target
122 (native-inputs
123 `(("extra-cmake-modules" ,extra-cmake-modules)
124 ("pkg-config" ,pkg-config)
125 ("qttools" ,qttools)))
126 (inputs
127 `(("inxi" ,inxi-minimal)
128 ("libdbusmenu-qt" ,libdbusmenu-qt)
129 ("qca" ,qca)
130 ("qtbase" ,qtbase)
131 ("qtmultimedia" ,qtmultimedia)
132 ("qtscript" ,qtscript)
133 ("qtsvg" ,qtsvg)
134 ("snorenotify" ,snorenotify)
135 ("zlib" ,zlib)))
136 (home-page "https://quassel-irc.org/")
137 (synopsis "Distributed IRC client")
138 (description "Quassel is a distributed IRC client, meaning that one or more
139 clients can attach to and detach from the central core. It resembles the
140 popular combination of screen and a text-based IRC client such as WeeChat or
141 irssi, but graphical.")
142 (license (list license:gpl2 license:gpl3)))) ;; dual licensed
143
144 (define-public irssi
145 (package
146 (name "irssi")
147 (version "1.2.3")
148 (source (origin
149 (method url-fetch)
150 (uri (string-append "https://github.com/irssi/irssi/"
151 "releases/download/" version "/irssi-"
152 version ".tar.xz"))
153 (sha256
154 (base32
155 "17vninwcdfxw39xl2q55qircckckjk2xlvkvlwgj5lhlxppvyix6"))))
156 (build-system gnu-build-system)
157 (arguments
158 `(#:phases
159 (modify-phases %standard-phases
160 (replace 'configure
161 (lambda* (#:key inputs outputs #:allow-other-keys)
162 (let ((out (assoc-ref outputs "out")))
163 (setenv "CONFIG_SHELL" (which "bash"))
164 (invoke "./configure"
165 (string-append "--prefix=" out)
166 (string-append "--with-proxy")
167 (string-append "--with-socks")
168 (string-append "--with-bot")))))
169 (add-before 'check 'set-home
170 (lambda _
171 (setenv "HOME" (getcwd)))))))
172 (inputs
173 `(("glib" ,glib)
174 ("ncurses" ,ncurses)
175 ("openssl" ,openssl)
176 ("perl" ,perl)))
177 (native-inputs
178 `(("pkg-config" ,pkg-config)))
179 (home-page "https://irssi.org/")
180 (synopsis "Terminal-based IRC client")
181 (description
182 "Irssi is a terminal based IRC client for UNIX systems. It also supports
183 SILC and ICB protocols via plugins.")
184 (license license:gpl2+)))
185
186 (define-public weechat
187 (package
188 (name "weechat")
189 (version "3.1")
190 (source (origin
191 (method url-fetch)
192 (uri (string-append "https://weechat.org/files/src/weechat-"
193 version ".tar.xz"))
194 (sha256
195 (base32
196 "1xx4fx7785yw3ml3k1z08h3qvrizvcypwl0j6jc7d7qim9sjjnm5"))))
197 (build-system cmake-build-system)
198 (native-inputs
199 `(("gettext" ,gettext-minimal)
200 ("pkg-config" ,pkg-config)
201 ;; For tests.
202 ("cpputest" ,cpputest)))
203 (inputs
204 `(("aspell" ,aspell)
205 ("curl" ,curl)
206 ("gnutls" ,gnutls)
207 ("libgcrypt" ,libgcrypt "out")
208 ("ncurses" ,ncurses)
209 ("zlib" ,zlib)
210
211 ;; Scripting language plug-ins.
212 ("guile" ,guile-3.0)
213 ("lua" ,lua-5.1)
214 ("perl" ,perl)
215 ("python" ,python)
216 ("tcl" ,tcl)))
217 (arguments
218 `(#:configure-flags
219 (list "-DENABLE_PHP=OFF"
220 "-DENABLE_RUBY=OFF"
221 "-DENABLE_TESTS=ON") ; ‘make test’ fails otherwise
222 ;; Tests hang indefinitely on non-Intel platforms.
223 #:tests? ,(if (any (cute string-prefix? <> (or (%current-target-system)
224 (%current-system)))
225 '("i686" "x86_64"))
226 '#t '#f)))
227 (synopsis "Extensible chat client")
228 (description "WeeChat (Wee Enhanced Environment for Chat) is an
229 @dfn{Internet Relay Chat} (IRC) client, which is designed to be light and fast.
230 The client uses a curses frontend, and there are remote interfaces for Web,
231 Qt, Android, and Emacs.
232
233 Everything in WeeChat can be done with the keyboard, though it also supports
234 using a mouse. It is customizable and extensible with plugins and scripts.")
235 (home-page "https://www.weechat.org/")
236 (license license:gpl3)))
237
238 (define-public srain
239 (package
240 (name "srain")
241 (version "1.1.3")
242 (source
243 (origin
244 (method git-fetch)
245 (uri (git-reference
246 (url "https://github.com/SrainApp/srain")
247 (commit version)))
248 (file-name (git-file-name name version))
249 (sha256
250 (base32 "1vqjjsxzc4601dpc8lf9k25rp2c7sjab7l5a6cbfygpr8dqvm6vq"))))
251 (arguments
252 `(#:tests? #f ;there are no tests
253 #:phases
254 (modify-phases %standard-phases
255 (add-before 'install 'fix-permissions
256 ;; Make po folder writable for gettext to install translations.
257 (lambda _
258 (for-each make-file-writable
259 (find-files "po" "." #:directories? #t)))))))
260 (build-system glib-or-gtk-build-system)
261 (native-inputs
262 `(("gettext" ,gettext-minimal)
263 ("glib:bin" ,glib "bin")
264 ("pkg-config" ,pkg-config)
265 ("python" ,python-wrapper)))
266 (inputs
267 `(("glib-networking" ,glib-networking)
268 ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
269 ("gtk+" ,gtk+)
270 ("libconfig" ,libconfig)
271 ("libsecret" ,libsecret)
272 ("libsoup" ,libsoup)
273 ("openssl" ,openssl)))
274 (home-page "https://srain.im")
275 (synopsis "Modern IRC client written in GTK")
276 (description
277 "Srain is an IRC client written in GTK. It aims to be modern and easy to
278 use while still remaining useful to power users. It also has partial support
279 for the IRCv3 protocol.")
280 (license license:gpl3+)))
281
282 (define-public ircii
283 (package
284 (name "ircii")
285 (version "20210314")
286 (source (origin
287 (method url-fetch)
288 (uri (string-append "https://ircii.warped.com/"
289 name "-" version ".tar.gz"))
290 (sha256
291 (base32
292 "04jczayv1vdn21fcf5zkfaa98sy7d6ydrv2sns2i67gvya2z28j3"))))
293 (build-system gnu-build-system)
294 ;; TODO: We should package a small socks4/5 library/server to configure
295 ;; ircii with socks client. `ghc-socks' pulls in lots of haskell, which
296 ;; is too big.
297 (arguments
298 `(#:tests? #f
299 #:configure-flags (list
300 "--enable-ipv6"
301 "--with-emacs-meta-keys"
302 (string-append "--with-openssl="
303 (assoc-ref %build-inputs "openssl")))
304 #:phases
305 (modify-phases %standard-phases
306 (add-after 'unpack 'patch-bsdinstall-absolute-path-bins
307 (lambda* (#:key inputs #:allow-other-keys)
308 (substitute* "bsdinstall"
309 (("/bin/strip") "strip")
310 (("/bin/cp") "cp")
311 (("/bin/chmod") "chmod")
312 (("/etc/chown") "chown")
313 (("/bin/chgrp") "chgrp")
314 (("/bin/mkdir") "mkdir")
315 (("/bin/rm") "rm")
316 (("/bin/mv") "mv")))))))
317 (inputs
318 `(("ncurses" ,ncurses)
319 ("openssl" ,openssl)))
320 (native-inputs
321 `(("pkg-config" ,pkg-config)
322 ("perl" ,perl)))
323 (home-page "http://www.eterna.com.au/ircii/")
324 (synopsis "Terminal-based IRC and ICB client")
325 (description
326 "ircII is a terminal based IRC and ICB client for UNIX systems.")
327 (license license:bsd-3)))
328
329 (define-public ii
330 (package
331 (name "ii")
332 (version "1.8")
333 (source (origin
334 (method url-fetch)
335 (uri (string-append "http://dl.suckless.org/tools/"
336 name "-" version ".tar.gz"))
337 (sha256
338 (base32
339 "1lk8vjl7i8dcjh4jkg8h8bkapcbs465sy8g9c0chfqsywbmf3ndr"))))
340 (build-system gnu-build-system)
341 (arguments
342 `(#:tests? #f ; no tests
343 #:make-flags (list (string-append "PREFIX=" %output)
344 "CC=gcc")
345 #:phases
346 (modify-phases %standard-phases
347 (delete 'configure)))) ; no configure
348 (home-page "https://tools.suckless.org/ii/")
349 (synopsis "FIFO and file system based IRC client")
350 (description
351 "ii (Irc it) is a minimalist FIFO and file system based IRC client.")
352 (license license:expat)))
353
354 (define-public sic
355 (package
356 (name "sic")
357 (version "1.2")
358 (source (origin
359 (method url-fetch)
360 (uri (string-append "http://dl.suckless.org/tools/"
361 name "-" version ".tar.gz"))
362 (sha256
363 (base32
364 "11aiavxp44yayibc58bvimi8mrxvbw1plbci8cnbl4syk42zj1xc"))))
365 (build-system gnu-build-system)
366 (arguments
367 `(#:tests? #f ; no tests
368 #:make-flags (list "CC=gcc"
369 (string-append "PREFIX=" %output))
370 #:phases
371 (modify-phases %standard-phases
372 (delete 'configure)))) ; no configure
373 (home-page "https://tools.suckless.org/sic/")
374 (synopsis "Simple IRC client")
375 (description
376 "sic is a simple IRC client, even more minimalistic than ii.")
377 (license license:expat)))
378
379 (define-public limnoria
380 (package
381 (name "limnoria")
382 (version "2019.11.22")
383 (source
384 (origin
385 (method url-fetch)
386 (uri (pypi-uri "limnoria" version))
387 (sha256
388 (base32 "0853xk1ps3v6lkmfx50wv56vynnzpl84v66hxnhl8i34zl36kk3c"))))
389 (build-system python-build-system)
390 (inputs
391 `(("python-pytz" ,python-pytz)
392 ("python-chardet" ,python-chardet)
393 ("python-dateutil" ,python-dateutil)
394 ("python-gnupg" ,python-gnupg)
395 ("python-feedparser" ,python-feedparser)
396 ("python-sqlalchemy" ,python-sqlalchemy)
397 ("python-socksipy-branch" ,python-socksipy-branch)
398 ("python-ecdsa" ,python-ecdsa)))
399 (native-inputs
400 `(("python-mock" ,python-mock)))
401 ;; Despite the existence of a test folder there is no test phase.
402 ;; We need to package https://github.com/ProgVal/irctest and write
403 ;; our own testphase.
404 (arguments
405 `(#:tests? #f))
406 (home-page "https://github.com/ProgVal/Limnoria")
407 (synopsis "Modified version of Supybot (an IRC bot and framework)")
408 (description
409 "Modified version of Supybot with Python 3 and IRCv3 support,
410 embedded web server, translations (fr, fi, it, hu, de), and many
411 other enhancements and bug fixes.")
412 (license license:bsd-3)))
413
414 (define-public epic5
415 (package
416 (name "epic5")
417 (version "2.0.1")
418 (source (origin
419 (method url-fetch)
420 (uri (string-append "http://ftp.epicsol.org/pub/"
421 "epic/EPIC5-PRODUCTION/"
422 name "-" version ".tar.xz"))
423 (sha256
424 (base32
425 "1ap73d5f4vccxjaaq249zh981z85106vvqmxfm4plvy76b40y9jm"))))
426 (build-system gnu-build-system)
427 (arguments
428 `(#:test-target "test"
429 #:phases
430 (modify-phases %standard-phases
431 (add-after 'unpack 'patch-perl
432 (lambda _
433 (substitute* "regress/crash-irc"
434 (("perl5") (which "perl")))
435 #t))
436 (add-after 'unpack 'patch-bsdinstall
437 ;; If we just remove /bin/ some part of the bsdinstall breaks.
438 ;; Furthermore bsdinstalls has a reference to /etc/chmod here, which
439 ;; means if we leave /etc/ in, install fails.
440 (lambda _
441 (substitute* "bsdinstall"
442 (("/bin/strip") "strip")
443 (("/bin/cp") "cp")
444 (("/bin/chmod") "chmod")
445 (("/bin/chgrp") "chgrp")
446 (("/bin/mkdir") "mkdir")
447 (("/bin/rm") "rm")
448 (("/bin/mv") "mv")
449 (("/etc/") ""))
450 #t))
451 (replace 'configure
452 (lambda* (#:key outputs #:allow-other-keys)
453 ;; The tarball uses a very old version of autconf. It does not
454 ;; understand extra flags like `--enable-fast-install', so
455 ;; we need to invoke it with just what it understands.
456 (let ((out (assoc-ref outputs "out")))
457 ;; 'configure' doesn't understand '--host'.
458 ,@(if (%current-target-system)
459 `((setenv "CHOST" ,(%current-target-system)))
460 '())
461 (setenv "CONFIG_SHELL" (which "bash"))
462 (setenv "SHELL" (which "bash"))
463 (invoke "./configure"
464 (string-append "--prefix=" out)
465 "--with-ipv6" "--with-libarchive"
466 ;; We use libressl because openssl does not come
467 ;; with the lib/libssl.a which is needed for epic5.
468 ;; XXX: No matter which implementation is chosen,
469 ;; epic5 fails to connect to tls ports of roundrobin
470 ;; irc networks. This however is believed to be an
471 ;; protocol issue at epic5 related to ircd.
472 (string-append "--with-ssl="
473 (assoc-ref %build-inputs "libressl"))
474 (string-append "--with-tcl="
475 (assoc-ref %build-inputs "tcl")
476 "/lib/tclConfig.sh"))))))))
477 (inputs
478 `(("libressl" ,libressl)
479 ("ncurses" ,ncurses)
480 ("libarchive" ,libarchive) ; CHANGELOG: "Support for loading zip files"
481 ("perl" ,perl)
482 ("tcl" ,tcl)
483 ("ruby" ,ruby)))
484 (native-inputs
485 `(("pkg-config" ,pkg-config)))
486 (home-page "http://epicsol.org")
487 (synopsis "Epic5 IRC Client")
488 (description
489 "EPIC is a IRC client that has been under active development for
490 over 20 years. It is stable and mature, and offers an excellent ircII
491 interface for those who are accustomed to the ircII way of doing things.")
492 (license (list license:bsd-3
493 license:isc
494 license:bsd-4
495 ;; The epic license is equal to the standard three-clause
496 ;; BSD license except that you are not permitted to remove the
497 ;; "Redistribution is permitted" clause of the license if you
498 ;; distribute binaries.
499 (license:non-copyleft "http://epicsol.org/copyright")))))
500
501 (define-public inspircd
502 (package
503 (name "inspircd")
504 (version "3.8.1")
505 (source
506 (origin
507 (method git-fetch)
508 (uri (git-reference
509 (url "https://github.com/inspircd/inspircd")
510 (commit (string-append "v" version))))
511 (file-name (git-file-name name version))
512 (sha256
513 (base32 "1i30649dw84iscxa5as81g96f393mn1i883aq4za5ypdinr5x65g"))))
514 (build-system gnu-build-system)
515 (arguments
516 `(#:configure-flags (map (lambda (module)
517 (string-append "--enable-extras=" module))
518 '("m_argon2.cpp"
519 "m_geo_maxmind.cpp"
520 "m_ldap.cpp"
521 "m_mysql.cpp"
522 "m_pgsql.cpp"
523 "m_regex_pcre.cpp"
524 "m_regex_posix.cpp"
525 "m_regex_stdlib.cpp"
526 "m_regex_re2.cpp"
527 "m_regex_tre.cpp"
528 "m_sqlite3.cpp"
529 "m_ssl_gnutls.cpp"
530 "m_ssl_openssl.cpp"
531 "m_ssl_mbedtls.cpp"
532 "m_sslrehashsignal.cpp"))
533 #:tests? #f ; Figure out later.
534 #:phases
535 (modify-phases %standard-phases
536 (add-before 'configure 'module-configure
537 (lambda* (#:key configure-flags #:allow-other-keys)
538 (apply invoke "./configure"
539 configure-flags)
540 #t))
541 (replace 'configure
542 (lambda* (#:key outputs #:allow-other-keys)
543 (let* ((out (assoc-ref outputs "out"))
544 (out-lib (string-append out "/lib/"))
545 (out-bin (string-append out "/bin/"))
546 (out-etc (string-append out "/etc/"))
547 (name "inspircd"))
548 (invoke "./configure"
549 (string-append "--prefix=" out-lib name)
550 (string-append "--binary-dir=" out-bin)
551 (string-append "--module-dir=" out-lib name "/modules/")
552 (string-append "--config-dir=" out-etc name)))
553 #t)))))
554 (native-inputs
555 `(("pkg-config" ,pkg-config)))
556 (inputs
557 `(("argon2" ,argon2)
558 ("gnutls" ,gnutls)
559 ("libmaxminddb" ,libmaxminddb)
560 ("mbedtls-apache" ,mbedtls-apache)
561 ("mysql" ,mysql)
562 ("openldap" ,openldap)
563 ("openssl" ,openssl)
564 ("pcre" ,pcre "bin")
565 ("perl" ,perl)
566 ("postgresql" ,postgresql)
567 ("re2" ,re2)
568 ("sqlite" ,sqlite)
569 ("tre" ,tre)))
570 (synopsis "Modular IRC server written in C++")
571 (description "InspIRCd is a modular Internet Relay Chat
572 server written in C++ for Unix-like operating systems.")
573 (home-page "https://www.inspircd.org/")
574 (license license:gpl2)))