gnu: efl: Update to 1.18.2.
[jackhill/guix/guix.git] / gnu / packages / enlightenment.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
3 ;;; Copyright © 2015 Daniel Pimentel <d4n1@member.fsf.org>
4 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages enlightenment)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (guix build-system python)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages bash)
29 #:use-module (gnu packages check)
30 #:use-module (gnu packages code)
31 #:use-module (gnu packages compression)
32 #:use-module (gnu packages curl)
33 #:use-module (gnu packages fontutils)
34 #:use-module (gnu packages fribidi)
35 #:use-module (gnu packages game-development)
36 #:use-module (gnu packages gettext)
37 #:use-module (gnu packages ghostscript)
38 #:use-module (gnu packages gl)
39 #:use-module (gnu packages glib)
40 #:use-module (gnu packages gnome)
41 #:use-module (gnu packages gstreamer)
42 #:use-module (gnu packages gtk)
43 #:use-module (gnu packages image)
44 #:use-module (gnu packages linux)
45 #:use-module (gnu packages llvm)
46 #:use-module (gnu packages lua)
47 #:use-module (gnu packages pdf)
48 #:use-module (gnu packages photo)
49 #:use-module (gnu packages pkg-config)
50 #:use-module (gnu packages pulseaudio)
51 #:use-module (gnu packages python)
52 #:use-module (gnu packages tls)
53 #:use-module (gnu packages video)
54 #:use-module (gnu packages xorg))
55
56 (define-public efl
57 (package
58 (name "efl")
59 (version "1.18.2")
60 (source (origin
61 (method url-fetch)
62 (uri (string-append
63 "https://download.enlightenment.org/rel/libs/efl/efl-"
64 version ".tar.xz"))
65 (sha256
66 (base32
67 "1vbvsrrpkvvrmvjavwnp5q77kw5i7vmbaj2vq5mnmrbzamvaybr9"))))
68 (build-system gnu-build-system)
69 (native-inputs
70 `(("pkg-config" ,pkg-config)))
71 (inputs
72 `(("alsa-lib" ,alsa-lib)
73 ("compositeproto" ,compositeproto)
74 ("curl" ,curl)
75 ("ghostscript" ,ghostscript)
76 ("giflib" ,giflib)
77 ("gstreamer" ,gstreamer)
78 ("gst-plugins-base" ,gst-plugins-base)
79 ("libexif" ,libexif)
80 ("libjpeg" ,libjpeg)
81 ("libraw" ,libraw)
82 ("librsvg" ,librsvg)
83 ("libspectre" ,libspectre)
84 ("libtiff" ,libtiff)
85 ("libwebp" ,libwebp)
86 ("libx11" ,libx11)
87 ("libxcomposite" ,libxcomposite)
88 ("libxcursor" ,libxcursor)
89 ("libxdmcp" ,libxdmcp)
90 ("libxext" ,libxext)
91 ("libxi" ,libxi)
92 ("libxkbfile" ,libxkbfile)
93 ("libxinerama" ,libxinerama)
94 ("libxp" ,libxp)
95 ("libxrandr" ,libxrandr)
96 ("libxscrnsaver" ,libxscrnsaver)
97 ("libxtst" ,libxtst)
98 ("lz4" ,lz4)
99 ("mesa" ,mesa)
100 ("openjpeg" ,openjpeg-1)
101 ("poppler" ,poppler)
102 ("printproto" ,printproto)
103 ("scrnsaverproto" ,scrnsaverproto)
104 ("xextproto" ,xextproto)
105 ("xinput" ,xinput)
106 ("xpr" ,xpr)
107 ("xproto" ,xproto)))
108 (propagated-inputs
109 ;; All these inputs are in package config files in section
110 ;; Require.private.
111 `(("bullet" ,bullet) ; ephysics.pc
112 ("dbus" ,dbus) ; eldbus.pc, elementary.pc, elocation.pc, ethumb_client.pc
113 ("eudev" ,eudev) ; eeze.pc
114 ("fontconfig" ,fontconfig) ; evas.pc, evas-cxx.pc
115 ("freetype" ,freetype) ; evas.pc, evas-cxx.pc
116 ("fribidi" ,fribidi) ; evas.pc, evas-cxx.pc
117 ("glib" ,glib) ; ecore.pc, ecore-cxx.pc
118 ("harfbuzz" ,harfbuzz) ; evas.pc, evas-cxx.pc
119 ("luajit" ,luajit) ; elua.pc, evas.pc, evas-cxx.pc
120 ("libpng" ,libpng) ; evas.pc, evas-cxx.pc
121 ("libsndfile" ,libsndfile) ; ecore-audio.pc, ecore-audio-cxx.pc
122 ("openssl" ,openssl) ; ecore-con.pc, eet.pc, eet-cxx.pc, emile.pc
123 ("pulseaudio" ,pulseaudio) ; ecore-audio.pc, ecore-audio-cxx.pc
124 ("util-linux" ,util-linux) ; eeze.pc
125 ("zlib" ,zlib))) ; eet.pc, eet-cxx.pc, emile.pc
126 (arguments
127 `(#:configure-flags '("--disable-silent-rules"
128 "--enable-liblz4"
129 "--enable-xinput22"
130 "--enable-image-loader-webp"
131 "--enable-multisense"
132 "--with-opengl=es"
133 "--enable-egl"
134 "--enable-harfbuzz")))
135 (home-page "https://www.enlightenment.org")
136 (synopsis "Enlightenment Foundation Libraries")
137 (description
138 "Enlightenment Foundation Libraries is a set of libraries developed
139 for Enlightenment. Libraries covers data serialization, wide support for
140 graphics rendering, UI layout and themes, interaction with OS, access to
141 removable devices or support for multimedia.")
142 ;; Different parts are under different licenses.
143 (license (list license:bsd-2 license:lgpl2.1 license:zlib))))
144
145 (define-public terminology
146 (package
147 (name "terminology")
148 (version "0.9.1")
149 (source (origin
150 (method url-fetch)
151 (uri
152 (string-append "https://download.enlightenment.org/rel/apps/"
153 "terminology/terminology-" version ".tar.xz"))
154 (sha256
155 (base32
156 "1kwv9vkhngdm5v38q93xpcykghnyawhjjcb5bgy0p89gpbk7mvpc"))))
157 (build-system gnu-build-system)
158 (native-inputs
159 `(("pkg-config" ,pkg-config)))
160 (inputs
161 `(("efl" ,efl)))
162 (home-page "https://www.enlightenment.org")
163 (synopsis "Powerful terminal emulator based on EFL")
164 (description
165 "Terminology is fast and feature rich terminal emulator. It is solely
166 based on Enlightenment Foundation Libraries. It supports multiple tabs, UTF-8,
167 URL and local path detection, themes, popup based content viewer for non-text
168 contents and more.")
169 (license license:bsd-2)))
170
171 (define-public rage
172 (package
173 (name "rage")
174 (version "0.2.1")
175 (source (origin
176 (method url-fetch)
177 (uri
178 (string-append
179 "https://download.enlightenment.org/rel/apps/rage/rage-"
180 version ".tar.xz"))
181 (sha256
182 (base32
183 "06kbgcnbhl9clhdl7k983m4d0n6ggsl4qvizzi1nrp8c7np87fix"))))
184 (build-system gnu-build-system)
185 (native-inputs
186 `(("pkg-config" ,pkg-config)))
187 (inputs
188 `(("efl" ,efl)))
189 (home-page "https://www.enlightenment.org/about-rage")
190 (synopsis "Video and audio player based on EFL")
191 (description
192 "Rage is a video and audio player written with Enlightenment Foundation
193 Libraries with some extra bells and whistles.")
194 (license license:bsd-2)))
195
196 (define-public enlightenment
197 (package
198 (name "enlightenment")
199 (version "0.21.3")
200 (source (origin
201 (method url-fetch)
202 (uri
203 (string-append "https://download.enlightenment.org/rel/apps/"
204 name "/" name "-" version ".tar.xz"))
205 (sha256
206 (base32
207 "1ljzcq775njhbcaj8vdnypf2rgc6yqqdwfkf7c22603qvv9if1dr"))))
208 (build-system gnu-build-system)
209 (arguments
210 `(#:configure-flags '("--enable-mount-eeze")))
211 (native-inputs
212 `(("gettext" ,gnu-gettext)
213 ("pkg-config" ,pkg-config)))
214 (inputs
215 `(("alsa-lib" ,alsa-lib)
216 ("dbus" ,dbus)
217 ("efl" ,efl)
218 ("freetype" ,freetype)
219 ("libxcb" ,libxcb)
220 ("libxext" ,libxext)
221 ("linux-pam" ,linux-pam)
222 ("xcb-util-keysyms" ,xcb-util-keysyms)))
223 (home-page "https://www.enlightenment.org")
224 (synopsis "Lightweight desktop environment")
225 (description
226 "Enlightenment is resource friendly desktop environment with integrated
227 file manager, wide range of configuration options, plugin system allowing to
228 unload unused functionality, with support for touchscreen and suitable for
229 embedded systems.")
230 (license license:bsd-2)))
231
232 (define-public python-efl
233 (package
234 (name "python-efl")
235 (version "1.18.0")
236 (source
237 (origin
238 (method url-fetch)
239 (uri (pypi-uri "python-efl" version))
240 (sha256
241 (base32
242 "0x49rb7mx7ysjp23m919r2rx8qnl4xackhl9s9x2697m7cs77n1r"))))
243 (build-system python-build-system)
244 (arguments
245 '(#:phases
246 (modify-phases %standard-phases
247 (replace 'build
248 (lambda _
249 (zero?
250 (system* "env" "ENABLE_CYTHON=1" "python" "setup.py" "build"))))
251 (add-before 'build 'set-flags
252 (lambda _
253 (setenv "CFLAGS"
254 (string-append "-I" (assoc-ref %build-inputs "python-dbus")
255 "/include/dbus-1.0")))))))
256 (native-inputs
257 `(("pkg-config" ,pkg-config)
258 ("python-cython" ,python-cython)))
259 (inputs
260 `(("efl" ,efl)
261 ("python-dbus" ,python-dbus)))
262 (home-page "https://www.enlightenment.org/")
263 (synopsis "Python bindings for EFL")
264 (description
265 "PYTHON-EFL are the python bindings for the whole Enlightenment Foundation
266 Libraries stack (eo, evas, ecore, edje, emotion, ethumb and elementary).")
267 (license license:lgpl3)))
268
269 (define-public python2-efl
270 (package-with-python2 python-efl))
271
272 (define-public edi
273 (package
274 (name "edi")
275 (version "0.4.0")
276 (source
277 (origin
278 (method url-fetch)
279 (uri (string-append "https://github.com/ajwillia-ms/edi/releases/"
280 "download/v" version "/edi-" version ".tar.bz2"))
281 (sha256
282 (base32
283 "0qczz5psryxasphg5km95845h510237rf0k1dy8f0dad52ii90j1"))))
284 (build-system gnu-build-system)
285 (arguments '(#:configure-flags '("--with-tests=coverage")))
286 (native-inputs
287 `(("check" ,check)
288 ("lcov" ,lcov)
289 ("pkg-config" ,pkg-config)))
290 (inputs
291 `(("clang" ,clang)
292 ("efl" ,efl)))
293 (home-page "https://www.enlightenment.org/about-edi")
294 (synopsis "Development environment for Enlightenment")
295 (description "EDI is a development environment designed for and built using
296 the EFL. It's aim is to create a new, native development environment for Linux
297 that tries to lower the barrier to getting involved in Enlightenment development
298 and in creating applications based on the Enlightenment Foundation Library suite.")
299 (license (list license:public-domain ; data/extra/skeleton
300 license:gpl2)))) ; edi