Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / display-managers.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Joshua Grant <tadni@riseup.net>
3 ;;; Copyright © 2014, 2018 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
5 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
6 ;;; Copyright © 2017 Sou Bunnbu <iyzsong@gmail.com>
7 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
8 ;;; Copyright © 2017, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages display-managers)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix build-system cmake)
30 #:use-module (guix build-system qt)
31 #:use-module (guix build-system gnu)
32 #:use-module (guix packages)
33 #:use-module (guix utils)
34 #:use-module (gnu packages)
35 #:use-module (gnu packages admin)
36 #:use-module (gnu packages fontutils)
37 #:use-module (gnu packages freedesktop)
38 #:use-module (gnu packages gl)
39 #:use-module (gnu packages glib)
40 #:use-module (gnu packages gnome)
41 #:use-module (gnu packages gnupg)
42 #:use-module (gnu packages gtk)
43 #:use-module (gnu packages image)
44 #:use-module (gnu packages kde-frameworks)
45 #:use-module (gnu packages linux)
46 #:use-module (gnu packages pkg-config)
47 #:use-module (gnu packages python)
48 #:use-module (gnu packages qt)
49 #:use-module (gnu packages xdisorg)
50 #:use-module (gnu packages xfce)
51 #:use-module (gnu packages xorg))
52
53 (define-public sddm
54 (package
55 (name "sddm")
56 (version "0.18.1")
57 (source (origin
58 (method url-fetch)
59 (uri (string-append
60 "https://github.com/sddm/sddm"
61 "/releases/download/v" version "/"
62 "sddm-" version ".tar.xz"))
63 (sha256
64 (base32
65 "0nilrhwlyvkngjgxfc08n73c16azgmw80pvx0a78xqww9y3hv4xh"))))
66 (build-system qt-build-system)
67 (native-inputs
68 `(("extra-cmake-modules" ,extra-cmake-modules)
69 ("pkg-config" ,pkg-config)
70 ("qttools" ,qttools)))
71 (inputs
72 `(("elogind" ,elogind)
73 ("glib" ,glib)
74 ("libxcb" ,libxcb)
75 ("libxkbcommon" ,libxkbcommon)
76 ("linux-pam" ,linux-pam)
77 ("qtbase" ,qtbase)
78 ("qtdeclarative" ,qtdeclarative)
79
80 ;; Some user-defined themes use QtQuick components internally. Adding
81 ;; QtQuick & co. here; they end up in QML2_IMPORT_PATH thanks to
82 ;; 'wrap-qt-program'.
83 ("qtgraphicaleffects" ,qtgraphicaleffects)
84 ("qtquickcontrols" ,qtquickcontrols)
85 ("qtquickcontrols2" ,qtquickcontrols2)
86 ("qtsvg" ,qtsvg)
87
88 ("shadow" ,shadow)
89 ("wayland" ,wayland)))
90 (arguments
91 `(#:configure-flags
92 (list
93 ;; This option currently does nothing, but will presumably be enabled
94 ;; if/when <https://github.com/sddm/sddm/pull/616> is merged.
95 "-DENABLE_WAYLAND=ON"
96 "-DENABLE_PAM=ON"
97 ;; Both flags are required for elogind support.
98 "-DNO_SYSTEMD=ON" "-DUSE_ELOGIND=ON"
99 "-DCONFIG_FILE=/etc/sddm.conf"
100 ;; Set path to /etc/login.defs.
101 ;; An alternative would be to use -DUID_MIN and -DUID_MAX.
102 (string-append "-DLOGIN_DEFS_PATH="
103 (assoc-ref %build-inputs "shadow")
104 "/etc/login.defs")
105 (string-append "-DQT_IMPORTS_DIR="
106 (assoc-ref %outputs "out") "/lib/qt5/qml")
107 (string-append "-DCMAKE_INSTALL_SYSCONFDIR="
108 (assoc-ref %outputs "out") "/etc"))
109 #:phases
110 (modify-phases %standard-phases
111 (add-after 'unpack 'embed-loginctl-reference
112 (lambda _
113 (substitute* "CMakeLists.txt"
114 (("/usr/bin/loginctl") (which "loginctl")))
115 #t)))))
116 (synopsis "QML based X11 and Wayland display manager")
117 (description "SDDM is a display manager for X11 and Wayland aiming to be
118 fast, simple and beautiful. SDDM is themeable and puts no restrictions on the
119 user interface design. It uses QtQuick which gives the designer the ability to
120 create smooth, animated user interfaces.")
121 (home-page "https://github.com/sddm/sddm")
122 ;; QML files are MIT licensed and images are CC BY 3.0.
123 (license (list license:gpl2+ license:expat license:cc-by3.0))))
124
125 (define-public lightdm
126 (package
127 (name "lightdm")
128 (version "1.24.0")
129 (source (origin
130 (method url-fetch)
131 (uri (string-append "https://launchpad.net/lightdm/"
132 (version-major+minor version) "/"
133 version "/+download/lightdm-"
134 version ".tar.xz"))
135 (sha256
136 (base32
137 "18j33bm54i8k7ncxcs69zqi4105s62n58jrydqn3ikrb71s9nl6d"))))
138 (build-system gnu-build-system)
139 (arguments
140 '(#:parallel-tests? #f ; fails when run in parallel
141 #:configure-flags
142 (list "--localstatedir=/var")
143 #:phases
144 (modify-phases %standard-phases
145 (add-after 'unpack 'fix-paths
146 (lambda _
147 (substitute* "src/shared-data-manager.c"
148 (("/bin/rm") (which "rm")))
149 (substitute* '("data/users.conf"
150 "common/user-list.c")
151 (("/bin/false") (which "false"))
152 (("/usr/sbin/nologin") (which "nologin")))
153 (substitute* "src/seat.c"
154 (("/bin/sh") (which "sh")))
155 #t))
156 (add-after 'unpack 'disable-broken-tests
157 (lambda _
158 (substitute* "tests/Makefile.in"
159 (("test-sessions-gobject ") "")
160 ((" test-sessions-python ") " "))
161 #t))
162 (add-before 'check 'pre-check
163 ;; Run test-suite under a dbus session.
164 (lambda* (#:key inputs #:allow-other-keys)
165 (wrap-program "tests/src/test-python-greeter"
166 `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH")))
167 `("GI_TYPELIB_PATH" ":" prefix (,(getenv "GI_TYPELIB_PATH"))))
168
169 ;; Avoid printing locale warnings, which trip up the text
170 ;; matching tests.
171 (unsetenv "LC_ALL")
172 #t)))))
173 (inputs
174 `(("audit" ,audit)
175 ("linux-pam" ,linux-pam)
176 ("shadow" ,shadow) ;for sbin/nologin
177 ("libgcrypt" ,libgcrypt)
178 ("libxcb" ,libxcb)))
179 (native-inputs
180 `(("gobject-introspection" ,gobject-introspection)
181 ("pkg-config" ,pkg-config)
182 ("itstool" ,itstool)
183 ("intltool" ,intltool)
184 ;; For tests
185 ("dbus" ,dbus)
186 ("python" ,python-2)
187 ("python-pygobject" ,python2-pygobject)))
188 ;; Required by liblightdm-gobject-1.pc.
189 (propagated-inputs
190 `(("glib" ,glib)
191 ("libx11" ,libx11)
192 ("libxklavier" ,libxklavier)))
193 (home-page "https://www.freedesktop.org/wiki/Software/LightDM/")
194 (synopsis "Lightweight display manager")
195 (description "The Light Display Manager (LightDM) is a cross-desktop
196 display manager which supports different greeters.")
197 (license license:gpl3+)))
198
199 (define-public lightdm-gtk-greeter
200 (package
201 (name "lightdm-gtk-greeter")
202 (version "2.0.7")
203 (source (origin
204 (method url-fetch)
205 (uri (string-append
206 "https://launchpad.net/lightdm-gtk-greeter/"
207 (version-major+minor version) "/" version
208 "/+download/lightdm-gtk-greeter-" version ".tar.gz"))
209 (sha256
210 (base32
211 "1g7wc3d3vqfa7mrdhx1w9ywydgjbffla6rbrxq9k3sc62br97qms"))))
212 (build-system gnu-build-system)
213 (native-inputs
214 `(("exo" ,exo)
215 ("intltool" ,intltool)
216 ("pkg-config" ,pkg-config)))
217 (inputs
218 `(("lightdm" ,lightdm)
219 ("gtk+" ,gtk+)))
220 (synopsis "GTK+ greeter for LightDM")
221 (home-page "https://launchpad.net/lightdm-gtk-greeter")
222 (description "This package provides a LightDM greeter implementation using
223 GTK+, lets you select a desktop session and log in to it.")
224 (license license:gpl3+)))
225
226 (define-public slim
227 (package
228 (name "slim")
229 (version "1.3.6")
230 (source (origin
231 (method url-fetch)
232 ;; Used to be available from download.berlios.de.
233 (uri (string-append
234 "mirror://sourceforge/slim.berlios/slim-"
235 version ".tar.gz"))
236 (sha256
237 (base32 "1pqhk22jb4aja4hkrm7rjgbgzjyh7i4zswdgf5nw862l2znzxpi1"))
238 (patches (search-patches "slim-config.patch"
239 "slim-reset.patch"
240 "slim-login.patch"
241 "slim-session.patch"
242 "slim-sigusr1.patch"
243 "slim-display.patch"))))
244 (build-system cmake-build-system)
245 (inputs `(("linux-pam" ,linux-pam)
246 ("libpng" ,libpng)
247 ("libjpeg" ,libjpeg)
248 ("freeglut" ,freeglut)
249 ("libxrandr" ,libxrandr)
250 ("libxrender" ,libxrender)
251 ("freetype" ,freetype)
252 ("fontconfig" ,fontconfig)
253 ("libx11" ,libx11)
254 ("libxft" ,libxft)
255 ("libxmu" ,libxmu)
256 ("xauth" ,xauth)))
257 (native-inputs
258 `(("pkg-config" ,pkg-config)))
259 (arguments
260 '(#:phases
261 (modify-phases %standard-phases
262 (add-before 'configure 'set-new-etc-location
263 (lambda _
264 (substitute* "CMakeLists.txt"
265 (("/etc")
266 (string-append (assoc-ref %outputs "out") "/etc"))
267 (("install.*systemd.*")
268 ;; The build system's logic here is: if "Linux", then
269 ;; "systemd". Strip that.
270 ""))
271 #t)))
272 #:configure-flags '("-DUSE_PAM=yes"
273 "-DUSE_CONSOLEKIT=no")
274 #:tests? #f))
275
276 ;; This used to be at <http://slim.berlios.de/>.
277 (home-page "https://sourceforge.net/projects/slim.berlios/")
278 (synopsis "Desktop-independent graphical login manager for X11")
279 (description
280 "SLiM is a Desktop-independent graphical login manager for X11, derived
281 from Login.app. It aims to be light and simple, although completely
282 configurable through themes and an option file; is suitable for machines on
283 which remote login functionalities are not needed.
284
285 Features included: PNG and XFT support for alpha transparency and antialiased
286 fonts, External themes support, Configurable runtime options: X server --
287 login / shutdown / reboot commands, Single (GDM-like) or double (XDM-like)
288 input control, Can load predefined user at startup, Configurable welcome /
289 shutdown messages, Random theme selection.")
290 (license license:gpl2)))