Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / motti.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages motti)
20 #:use-module (gnu packages)
21 #:use-module (guix build-system gnu)
22 #:use-module (guix licenses)
23 #:use-module (guix packages)
24 #:use-module (guix download))
25
26 (define-public motti
27 (package
28 (name "motti")
29 (version "3.1.1")
30 (source
31 (origin
32 (method url-fetch)
33 (uri (string-append
34 "mirror://gnu/motti/motti-" version ".tar.gz"))
35 (sha256
36 (base32
37 "0ag4gpxy42l30660b4f2lrp52xi5sik9s6frr7jfxqxjsf29lbb3"))))
38 (build-system gnu-build-system)
39 (synopsis "Multiplayer strategy game")
40 (description
41 "GNU Motti is a simple multiplayer strategy game played in a terminal.
42 The objective of the game is to conquer enemy capitals by occupying and
43 encircling territory.")
44 (home-page "https://www.gnu.org/software/motti")
45 (license gpl3+)))