gnu: extempore: Update to 0.8.6.
[jackhill/guix/guix.git] / gnu / packages / patches / extempore-unbundle-external-dependencies.patch
1 Remove build machinery for bundled dependencies.
2
3 diff --git a/CMakeLists.txt b/CMakeLists.txt
4 index 89e6125e..c5e90750 100644
5 --- a/CMakeLists.txt
6 +++ b/CMakeLists.txt
7 @@ -36,7 +36,7 @@ endif()
8 if(PACKAGE)
9 # this needs to be set before project() is called
10 set(CMAKE_OSX_DEPLOYMENT_TARGET 10.12)
11 - set(ASSETS ON) # necessary for packaging
12 + set(ASSETS OFF) # necessary for packaging
13 message(STATUS "Building Extempore for binary distribution (assets directory will be downloaded)")
14 endif()
15
16 @@ -134,71 +134,6 @@ else()
17 message(FATAL_ERROR "Sorry, Extempore isn't supported on this platform - macOS, Linux & Windows only.")
18 endif()
19
20 -########
21 -# PCRE #
22 -########
23 -
24 -# current in-tree PCRE version: 8.38
25 -
26 -add_library(pcre STATIC
27 - # headers
28 - src/pcre/config.h
29 - src/pcre/pcre.h
30 - src/pcre/ucp.h
31 - # source files
32 - src/pcre/pcre_chartables.c
33 - src/pcre/pcre_compile.c
34 - src/pcre/pcre_exec.c
35 - src/pcre/pcre_globals.c
36 - src/pcre/pcre_internal.h
37 - src/pcre/pcre_newline.c
38 - src/pcre/pcre_tables.c
39 - )
40 -
41 -target_compile_definitions(pcre
42 - PRIVATE -DHAVE_CONFIG_H
43 - )
44 -
45 -if(PACKAGE)
46 - target_compile_options(pcre
47 - PRIVATE -mtune=generic)
48 -endif()
49 -
50 -#############
51 -# portaudio #
52 -#############
53 -
54 -add_library(portaudio STATIC
55 - src/portaudio/src/common/pa_allocation.c
56 - src/portaudio/src/common/pa_allocation.h
57 - src/portaudio/src/common/pa_converters.c
58 - src/portaudio/src/common/pa_converters.h
59 - src/portaudio/src/common/pa_cpuload.c
60 - src/portaudio/src/common/pa_cpuload.h
61 - src/portaudio/src/common/pa_debugprint.c
62 - src/portaudio/src/common/pa_debugprint.h
63 - src/portaudio/src/common/pa_dither.c
64 - src/portaudio/src/common/pa_dither.h
65 - src/portaudio/src/common/pa_endianness.h
66 - src/portaudio/src/common/pa_front.c
67 - src/portaudio/src/common/pa_hostapi.h
68 - src/portaudio/src/common/pa_memorybarrier.h
69 - src/portaudio/src/common/pa_process.c
70 - src/portaudio/src/common/pa_process.h
71 - src/portaudio/src/common/pa_ringbuffer.c
72 - src/portaudio/src/common/pa_ringbuffer.h
73 - src/portaudio/src/common/pa_stream.c
74 - src/portaudio/src/common/pa_stream.h
75 - src/portaudio/src/common/pa_trace.c
76 - src/portaudio/src/common/pa_trace.h
77 - src/portaudio/src/common/pa_types.h
78 - src/portaudio/src/common/pa_util.h
79 - )
80 -
81 -target_include_directories(portaudio
82 - PRIVATE src/portaudio/include
83 - PRIVATE src/portaudio/src/common)
84 -
85 # platform-specific
86
87 if(APPLE)
88 @@ -224,25 +159,8 @@ if(APPLE)
89
90 elseif(UNIX AND NOT APPLE)
91 # use ALSA on Linux
92 - target_sources(portaudio
93 - PRIVATE src/portaudio/src/hostapi/alsa/pa_linux_alsa.c
94 - PRIVATE src/portaudio/src/os/unix/pa_unix_hostapis.c
95 - PRIVATE src/portaudio/src/os/unix/pa_unix_util.c
96 - )
97 - target_include_directories(portaudio
98 - PRIVATE src/portaudio/src/os/unix)
99 - target_compile_definitions(portaudio
100 - PRIVATE -DPA_USE_ALSA)
101 - target_link_libraries(portaudio
102 - PRIVATE asound)
103
104 if(JACK)
105 - target_sources(portaudio
106 - PRIVATE src/portaudio/src/hostapi/jack/pa_jack.c)
107 - target_compile_definitions(portaudio
108 - PRIVATE -DPA_USE_JACK)
109 - target_link_libraries(portaudio
110 - PRIVATE jack)
111 endif()
112
113 elseif(WIN32)
114 @@ -292,8 +210,6 @@ if(ASIO)
115 endif()
116
117 if(PACKAGE)
118 - target_compile_options(portaudio
119 - PRIVATE -mtune=generic)
120 endif()
121
122 ##############
123 @@ -411,8 +327,6 @@ endif()
124
125 # dependencies
126
127 -add_dependencies(extempore pcre portaudio)
128 -
129 if(BUILD_LLVM)
130 if(WIN32)
131 add_dependencies(extempore LLVM-install)
132 @@ -553,7 +467,7 @@ else()
133 install(TARGETS extempore
134 RUNTIME
135 DESTINATION ".")
136 - install(DIRECTORY assets runtime libs examples tests
137 + install(DIRECTORY runtime libs examples
138 DESTINATION "."
139 PATTERN ".DS_Store" EXCLUDE)
140 endif()