Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / openstack.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2016, 2017, 2019 Clément Lassieur <clement@lassieur.org>
5 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages openstack)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages check)
26 #:use-module (gnu packages gnupg)
27 #:use-module (gnu packages python)
28 #:use-module (gnu packages python-crypto)
29 #:use-module (gnu packages python-web)
30 #:use-module (gnu packages python-xyz)
31 #:use-module (gnu packages ssh)
32 #:use-module (gnu packages time)
33 #:use-module (gnu packages tls)
34 #:use-module (gnu packages version-control)
35 #:use-module (guix build-system python)
36 #:use-module (guix download)
37 #:use-module ((guix licenses)
38 #:select (asl2.0))
39 #:use-module (guix packages)
40 #:use-module (srfi srfi-1))
41
42 (define-public python-bandit
43 (package
44 (name "python-bandit")
45 (version "1.4.0")
46 (source
47 (origin
48 (method url-fetch)
49 (uri (pypi-uri "bandit" version))
50 (sha256
51 (base32
52 "1m5bm42120zyazky4k0lp3d9r0jwhjmp6sb108xfr0vz952p15yb"))))
53 (build-system python-build-system)
54 (arguments
55 `(#:phases (modify-phases %standard-phases
56 (delete 'check)
57 (add-after 'install 'check
58 (lambda* (#:key inputs outputs #:allow-other-keys)
59 ;; Tests require the 'bandit' executable in PATH.
60 ;; It's only built during install time.
61 (add-installed-pythonpath inputs outputs)
62 (setenv "PATH" (string-append (assoc-ref outputs "out")
63 "/bin:" (getenv "PATH")))
64 (invoke "python" "setup.py" "testr"))))))
65 (propagated-inputs
66 `(("python-gitpython" ,python-gitpython)
67 ("python-pyyaml" ,python-pyyaml)
68 ("python-six" ,python-six)
69 ("python-stevedore" ,python-stevedore)))
70 (native-inputs
71 `(;; Tests.
72 ("python-beautifulsoup4" ,python-beautifulsoup4)
73 ("python-fixtures" ,python-fixtures)
74 ("python-mock" ,python-mock)
75 ("python-subunit" ,python-subunit)
76 ("python-testrepository" ,python-testrepository)
77 ("python-testscenarios" ,python-testscenarios)
78 ("python-testtools" ,python-testtools)))
79 (home-page "https://wiki.openstack.org/wiki/Security/Projects/Bandit")
80 (synopsis "Security oriented static analyser for python code")
81 (description
82 "Bandit is a tool designed to find common security issues in Python code.
83 To do this Bandit processes each file, builds an AST from it, and runs
84 appropriate plugins against the AST nodes. Once Bandit has finished scanning
85 all the files it generates a report.")
86 (license asl2.0)))
87
88 (define-public python2-bandit
89 (package-with-python2 python-bandit))
90
91 (define-public python-debtcollector
92 (package
93 (name "python-debtcollector")
94 (version "1.19.0")
95 (source
96 (origin
97 (method url-fetch)
98 (uri (pypi-uri "debtcollector" version))
99 (sha256
100 (base32
101 "06c7vyn184y9f0lsrwaz13aq63hdz5fjrd191b8nifx6acsni42f"))))
102 (build-system python-build-system)
103 (propagated-inputs
104 `(("python-pbr" ,python-pbr)
105 ("python-six" ,python-six)
106 ("python-wrapt" ,python-wrapt)))
107 (native-inputs
108 `(;; Tests.
109 ("python-subunit" ,python-subunit)
110 ("python-testrepository" ,python-testrepository)
111 ("python-testtools" ,python-testtools)))
112 (home-page "https://www.openstack.org/")
113 (synopsis
114 "Find deprecated patterns and strategies in Python code")
115 (description
116 "This package provides a collection of Python deprecation patterns and
117 strategies that help you collect your technical debt in a non-destructive
118 manner.")
119 (properties `((python2-variant . ,(delay python2-debtcollector))))
120 (license asl2.0)))
121
122 (define-public python2-debtcollector
123 (let ((base (package-with-python2 (strip-python2-variant
124 python-debtcollector))))
125 (package
126 (inherit base)
127 (propagated-inputs
128 `(("python2-funcsigs" ,python2-funcsigs)
129 ,@(package-propagated-inputs base))))))
130
131 (define-public python-hacking
132 (package
133 (name "python-hacking")
134 (version "1.0.0")
135 (source
136 (origin
137 (method url-fetch)
138 (uri (pypi-uri "hacking" version))
139 (sha256
140 (base32
141 "0s9l99s64jsyvm28fa4hzllbdi21sb7jn4gzdf1pd5ckvy7p4b0k"))))
142 (build-system python-build-system)
143 (propagated-inputs
144 `(("python-flake8" ,python-flake8-2.5)
145 ("python-mccabe-0.2.1" ,python-mccabe-0.2.1)
146 ("python-pbr" ,python-pbr)
147 ("python-pep8-1.5.7" ,python-pep8-1.5.7)
148 ("python-pyflakes-0.8.1" ,python-pyflakes-0.8.1)
149 ("python-six" ,python-six)))
150 (native-inputs
151 `( ;; Tests
152 ("python-eventlet" ,python-eventlet)
153 ("python-mock" ,python-mock)
154 ("python-reno" ,python-reno)
155 ("python-testrepository" ,python-testrepository)
156 ("python-testscenarios" ,python-testscenarios)))
157 (home-page "https://github.com/openstack-dev/hacking")
158 (synopsis "OpenStack hacking guideline enforcement")
159 (description
160 "Python-hacking is a set of flake8 plugins that test and enforce the
161 @uref{http://docs.openstack.org/developer/hacking/, OpenStack style
162 guidelines}.")
163 (license asl2.0)))
164
165 (define-public python2-hacking
166 (package-with-python2 python-hacking))
167
168 (define-public python-mox3
169 (package
170 (name "python-mox3")
171 (version "0.24.0")
172 (source
173 (origin
174 (method url-fetch)
175 (uri (pypi-uri "mox3" version))
176 (patches (search-patches "python-mox3-python3.6-compat.patch"))
177 (sha256
178 (base32
179 "0w58adwv7q9wzvmq9mlrk2asfk73myq9fpwy7mjkzsz3baa95zf5"))))
180 (build-system python-build-system)
181 (propagated-inputs
182 `(("python-fixtures" ,python-fixtures)
183 ("python-pbr" ,python-pbr)))
184 (native-inputs
185 `(("python-openstackdocstheme" ,python-openstackdocstheme)
186 ("python-sphinx" ,python-sphinx)
187 ("python-subunit" ,python-subunit)
188 ("python-testrepository" ,python-testrepository)
189 ("python-testtools" ,python-testtools)))
190 (home-page "https://www.openstack.org/")
191 (synopsis "Mock object framework for Python")
192 (description
193 "Mox3 is an unofficial port of the @uref{https://code.google.com/p/pymox/,
194 Google mox framework} to Python 3. It was meant to be as compatible
195 with mox as possible, but small enhancements have been made.")
196 (license asl2.0)))
197
198 (define-public python2-mox3
199 (package-with-python2 python-mox3))
200
201 (define-public python-openstackdocstheme
202 (package
203 (name "python-openstackdocstheme")
204 (version "1.18.1")
205 (source (origin
206 (method url-fetch)
207 (uri (pypi-uri "openstackdocstheme" version))
208 (sha256
209 (base32
210 "1ki5204rjdqjvr8xr9w2qc1z6b6d2i5jas0i70xzkf9njlzjzv2r"))))
211 (build-system python-build-system)
212 (arguments
213 ;; FIXME: Tests require an old version of python-hacking, which in
214 ;; turn depends on mox3 which depends on this package.
215 `(#:tests? #f))
216 (propagated-inputs
217 `(("python-dulwich" ,python-dulwich)
218 ("python-pbr" ,python-pbr)))
219 (native-inputs
220 `(("python-sphinx" ,python-sphinx)))
221 (home-page "https://docs.openstack.org/openstackdocstheme/latest/")
222 (synopsis "OpenStack Docs Theme")
223 (description
224 "This package provides themes and extensions for Sphinx for publishing
225 to docs.openstack.org and developer.openstack.org.")
226 (license asl2.0)))
227
228 (define-public python2-openstackdocstheme
229 (package-with-python2 python-openstackdocstheme))
230
231 (define-public python-os-client-config
232 (package
233 (name "python-os-client-config")
234 (version "1.12.0")
235 (source
236 (origin
237 (method url-fetch)
238 (uri (pypi-uri "os-client-config" version))
239 (sha256
240 (base32
241 "1vjn7667pswnmpqv6ngwyqm2xn46w90hi5b4pv2grwfz751cn1lf"))))
242 (build-system python-build-system)
243 (arguments
244 `(#:tests? #f)) ;; Circular dependency with python-oslotest
245 (propagated-inputs
246 `(("python-appdirs" ,python-appdirs)
247 ("python-pyyaml" ,python-pyyaml)))
248 (native-inputs
249 `(("python-pbr" ,python-pbr)
250 ("python-fixtures" ,python-fixtures)
251 ("python-mimeparse" ,python-mimeparse)
252 ("python-testrepository" ,python-testrepository)
253 ("python-testscenarios" ,python-testscenarios)
254 ("python-testtools" ,python-testtools)))
255 (home-page "https://www.openstack.org/")
256 (synopsis
257 "OpenStack Client Configuration Library")
258 (description
259 "The OpenStack Client Configuration Library is a library for collecting
260 client configuration for using an OpenStack cloud in a consistent and
261 comprehensive manner.")
262 (license asl2.0)))
263
264 (define-public python2-os-client-config
265 (package-with-python2 python-os-client-config))
266
267 (define-public python-os-testr
268 (package
269 (name "python-os-testr")
270 (version "0.8.0")
271 (source
272 (origin
273 (method url-fetch)
274 (uri (pypi-uri "os-testr" version))
275 (sha256
276 (base32
277 "0mknd9hlmxmihr755gjkxyjp180380jajq5i3zm34q7y7bi62lss"))))
278 (build-system python-build-system)
279 (arguments
280 ;; os-testr uses itself to run the tests. It seems like pbr writes the
281 ;; exectuable in the virtualenv when using tox. Not sure how to do this
282 ;; when building the package. Skip the tests for now.
283 `(#:tests? #f))
284 (propagated-inputs
285 `(("python-subunit" ,python-subunit)))
286 (native-inputs
287 `(("python-pbr" ,python-pbr)
288 ("python-testtools" ,python-testtools)
289 ("python-babel" ,python-babel)))
290 (home-page "https://www.openstack.org/")
291 (synopsis "Testr wrapper to provide functionality for OpenStack projects")
292 (description
293 "Os-testr provides developers with a testr wrapper and an output filter
294 for subunit.")
295 (license asl2.0)))
296
297 (define-public python2-os-testr
298 (package-with-python2 python-os-testr))
299
300 (define-public python-stevedore
301 (package
302 (name "python-stevedore")
303 (version "1.28.0")
304 (source
305 (origin
306 (method url-fetch)
307 (uri (pypi-uri "stevedore" version))
308 (sha256
309 (base32
310 "02ynfgwma84g59834dmvzr39mcppy5s229zf1w23c0qngf753izi"))))
311 (build-system python-build-system)
312 (propagated-inputs
313 `(("python-pbr" ,python-pbr)
314 ("python-six" ,python-six)))
315 (native-inputs
316 `(("python-mock" ,python-mock)
317 ("python-sphinx" ,python-sphinx)
318 ("python-testrepository" ,python-testrepository)))
319 (home-page "https://github.com/dreamhost/stevedore")
320 (synopsis "Manage dynamic plugins for Python applications")
321 (description
322 "Python makes loading code dynamically easy, allowing you to configure
323 and extend your application by discovering and loading extensions (\"plugins\")
324 at runtime. Many applications implement their own library for doing this,
325 using __import__ or importlib. Stevedore avoids creating yet another extension
326 mechanism by building on top of setuptools entry points. The code for managing
327 entry points tends to be repetitive, though, so stevedore provides manager
328 classes for implementing common patterns for using dynamically loaded
329 extensions.")
330 (license asl2.0)))
331
332 (define-public python2-stevedore
333 (package-with-python2 python-stevedore))
334
335 (define-public python-tempest-lib
336 (package
337 (name "python-tempest-lib")
338 (version "1.0.0")
339 (source
340 (origin
341 (method url-fetch)
342 (uri (pypi-uri "tempest-lib" version))
343 (sha256
344 (base32
345 "1cpp2vwmawpd29hjsklsps181lq2ah91cl412qvpnz228nf9sqn5"))))
346 (build-system python-build-system)
347 (arguments
348 `(#:tests? #f ; FIXME: Requires oslo.log >= 1.14.0.
349 #:phases
350 (modify-phases %standard-phases
351 (add-before
352 'check 'pre-check
353 (lambda _
354 (substitute* "tempest_lib/tests/cli/test_execute.py"
355 (("/bin/ls") (which "ls"))))))))
356 (propagated-inputs
357 `(("python-fixtures" ,python-fixtures)
358 ("python-httplib2" ,python-httplib2)
359 ("python-iso8601" ,python-iso8601)
360 ("python-jsonschema" ,python-jsonschema)
361 ("python-oslo.log" ,python-oslo.log)
362 ("python-paramiko" ,python-paramiko)
363 ("python-pbr" ,python-pbr)
364 ("python-six" ,python-six)))
365 (native-inputs
366 `(("python-babel" ,python-babel)
367 ("python-mock" ,python-mock)
368 ("python-os-testr" ,python-os-testr)
369 ("python-oslotest" ,python-oslotest)))
370 (home-page "https://www.openstack.org/")
371 (synopsis "OpenStack functional testing library")
372 (description
373 "Tempest-lib is a functional testing library for OpenStack. It provides
374 common features used in Tempest.")
375 (license asl2.0)))
376
377 (define-public python2-tempest-lib
378 (package-with-python2 python-tempest-lib))
379
380 ;; Packages from the Oslo library
381 (define-public python-oslo.config
382 (package
383 (name "python-oslo.config")
384 (version "5.2.0")
385 (source
386 (origin
387 (method url-fetch)
388 (uri (pypi-uri "oslo.config" version))
389 (sha256
390 (base32
391 "0ymf7jxbq29fifyvkwhfiys1qvljqfxdw8ajwzwaf3yiqidgpxqd"))))
392 (build-system python-build-system)
393 (propagated-inputs
394 `(("python-debtcollector" ,python-debtcollector)
395 ("python-netaddr" ,python-netaddr)
396 ("python-oslo.i18n" ,python-oslo.i18n)
397 ("python-pbr" ,python-pbr)
398 ("python-rfc3986" ,python-rfc3986)
399 ("python-six" ,python-six)
400 ("python-stevedore" ,python-stevedore)
401 ("python-pyyaml" ,python-pyyaml)))
402 (native-inputs
403 `(("python-bandit" ,python-bandit)
404 ("python-coverage" ,python-coverage)
405 ("python-mock" ,python-mock)
406 ("python-openstackdocstheme" ,python-openstackdocstheme)
407 ("python-oslotest" ,python-oslotest)
408 ("python-reno" ,python-reno)
409 ("python-sphinx" ,python-sphinx)
410 ("python-testrepository" ,python-testrepository)
411 ("python-testscenarios" ,python-testscenarios)
412 ("python-testtools" ,python-testtools)))
413 (home-page "https://launchpad.net/oslo")
414 (synopsis "Oslo Configuration API")
415 (description
416 "The Oslo configuration API supports parsing command line arguments and
417 .ini style configuration files.")
418 (license asl2.0)))
419
420 (define-public python2-oslo.config
421 (package-with-python2 python-oslo.config))
422
423 (define-public python-oslo.context
424 (package
425 (name "python-oslo.context")
426 (version "2.20.0")
427 (source
428 (origin
429 (method url-fetch)
430 (uri (pypi-uri "oslo.context" version))
431 (sha256
432 (base32
433 "0iiq9rpwg6wrdqnhf3d8z8g0g7fjhs5zn6qw6igvxplz2c3rbvvx"))))
434 (build-system python-build-system)
435 (propagated-inputs
436 `(("python-debtcollector" ,python-debtcollector)
437 ("python-pbr" ,python-pbr)))
438 (native-inputs
439 `(("python-fixtures" ,python-fixtures)
440 ("python-hacking" ,python-hacking)
441 ("python-oslotest" ,python-oslotest)))
442 (home-page "https://launchpad.net/oslo")
443 (synopsis "Oslo context library")
444 (description
445 "The Oslo context library has helpers to maintain useful information
446 about a request context. The request context is usually populated in the WSGI
447 pipeline and used by various modules such as logging.")
448 (license asl2.0)))
449
450 (define-public python2-oslo.context
451 (package-with-python2 python-oslo.context))
452
453 (define-public python-oslo.i18n
454 (package
455 (name "python-oslo.i18n")
456 (version "3.20.0")
457 (source
458 (origin
459 (method url-fetch)
460 (uri (pypi-uri "oslo.i18n" version))
461 (sha256
462 (base32
463 "0kjcdw4bk3mi4vqmqwhhq053kxbbbj05si6nwxd1pzx33z067ky3"))))
464 (build-system python-build-system)
465 (propagated-inputs
466 `(("python-babel" ,python-babel)
467 ("python-six" ,python-six)))
468 (native-inputs
469 `(("python-pbr" ,python-pbr)
470 ;; Tests
471 ("python-mock" ,python-mock)
472 ("python-mox3" ,python-mox3)
473 ("python-oslotest" ,python-oslotest)
474 ("python-testscenarios" ,python-testscenarios)))
475 (home-page "https://launchpad.net/oslo")
476 (synopsis "Oslo internationalization (i18n) library")
477 (description
478 "The oslo.i18n library contain utilities for working with
479 internationalization (i18n) features, especially translation for text strings
480 in an application or library.")
481 (license asl2.0)))
482
483 (define-public python2-oslo.i18n
484 (package-with-python2 python-oslo.i18n))
485
486 (define-public python-oslo.log
487 (package
488 (name "python-oslo.log")
489 (version "3.36.0")
490 (source
491 (origin
492 (method url-fetch)
493 (uri (pypi-uri "oslo.log" version))
494 (sha256
495 (base32
496 "0h7hplf1h8k24v75m3mq1jlrl74x5ynyr4hwgffsg5campxnza4x"))))
497 (build-system python-build-system)
498 (propagated-inputs
499 `(("python-dateutil" ,python-dateutil)
500 ("python-debtcollector" ,python-debtcollector)
501 ("python-monotonic" ,python-monotonic)
502 ("python-oslo.config" ,python-oslo.config)
503 ("python-oslo.context" ,python-oslo.context)
504 ("python-oslo.i18n" ,python-oslo.i18n)
505 ("python-oslo.utils" ,python-oslo.utils)
506 ("python-oslo.serialization" ,python-oslo.serialization)
507 ("python-pbr" ,python-pbr)
508 ("python-pyinotify" ,python-pyinotify)
509 ("python-six" ,python-six)))
510 (native-inputs
511 `(("python-mock" ,python-mock)
512 ("python-oslotest" ,python-oslotest)
513 ("python-subunit" ,python-subunit)
514 ("python-testrepository" ,python-testrepository)
515 ("python-testtools" ,python-testtools)))
516 (home-page "https://launchpad.net/oslo")
517 (synopsis "Python logging library of the Oslo project")
518 (description
519 "The oslo.log (logging) configuration library provides standardized
520 configuration for all OpenStack projects. It also provides custom formatters,
521 handlers and support for context specific logging (like resource id’s etc).")
522 (license asl2.0)))
523
524 (define-public python2-oslo.log
525 (package-with-python2 python-oslo.log))
526
527 (define-public python-oslo.serialization
528 (package
529 (name "python-oslo.serialization")
530 (version "2.24.0")
531 (source
532 (origin
533 (method url-fetch)
534 (uri (pypi-uri "oslo.serialization" version))
535 (sha256
536 (base32
537 "08bxkp98c617y58x630xq44iiffm7f0f3cwh6zbnlkgq0zgh7jk1"))))
538 (build-system python-build-system)
539 (propagated-inputs
540 `(("python-msgpack" ,python-msgpack)
541 ("python-netaddr" ,python-netaddr)
542 ("python-oslo.utils" ,python-oslo.utils)
543 ("python-six" ,python-six)
544 ("python-pytz" ,python-pytz)))
545 (native-inputs
546 `(("python-pbr" ,python-pbr)
547 ;; Tests.
548 ("python-mock" ,python-mock)
549 ("python-oslo.i18n" ,python-oslo.i18n)
550 ("python-oslotest" ,python-oslotest)))
551 (home-page "https://launchpad.net/oslo")
552 (synopsis "Oslo serialization library")
553 (description
554 "The oslo.serialization library provides support for representing objects
555 in transmittable and storable formats, such as JSON and MessagePack.")
556 (properties `((python2-variant . ,(delay python2-oslo.serialization))))
557 (license asl2.0)))
558
559 (define-public python2-oslo.serialization
560 (let ((base (package-with-python2 (strip-python2-variant
561 python-oslo.serialization))))
562 (package
563 (inherit base)
564 (native-inputs
565 `(("python2-ipaddress" ,python2-ipaddress)
566 ,@(package-native-inputs base))))))
567
568 (define-public python-reno
569 (package
570 (name "python-reno")
571 (version "2.7.0")
572 (source
573 (origin
574 (method url-fetch)
575 (uri (pypi-uri "reno" version))
576 (sha256
577 (base32 "0gwzi5dvacqx43smxl3rd1z33npn7gfhm50bvgmq90fib2q431wc"))))
578 (build-system python-build-system)
579 (arguments
580 `(#:phases
581 (modify-phases %standard-phases
582 (add-before 'check 'init-git
583 (lambda _
584 ;; reno expects a git repo
585 (zero? (system* "git" "init")))))))
586 (propagated-inputs
587 `(("python-dulwich" ,python-dulwich)
588 ("python-pbr" ,python-pbr)
589 ("python-pyyaml" ,python-pyyaml)
590 ("python-six" ,python-six)))
591 (native-inputs
592 `(("python-testtools" ,python-testtools)
593 ("python-testscenarios" ,python-testscenarios)
594 ("python-testrepository" ,python-testrepository)
595 ("python-mock" ,python-mock)
596 ("python-docutils" ,python-docutils)
597 ("python-sphinx" ,python-sphinx)
598 ("gnupg" ,gnupg)
599 ("git" ,git)))
600 (home-page "http://docs.openstack.org/developer/reno/")
601 (synopsis "Release notes manager")
602 (description "Reno is a tool for storing release notes in a git repository
603 and building documentation from them.")
604 (license asl2.0)))
605
606 (define-public python2-reno
607 (package-with-python2 python-reno))
608
609 (define-public python-oslosphinx
610 (package
611 (name "python-oslosphinx")
612 (version "4.10.0")
613 (source
614 (origin
615 (method url-fetch)
616 (uri (pypi-uri "oslosphinx" version))
617 (sha256
618 (base32
619 "09mxqyabi68f3s3arvdhlhq0mn38vf74jbsfcg84151hcj6czhnl"))))
620 (build-system python-build-system)
621 (arguments
622 `(#:phases
623 (modify-phases %standard-phases
624 (replace 'check
625 (lambda _
626 ;; Note: Upstream tests would have also built the release notes.
627 ;; That only would work if we were in a git checkout.
628 ;; Therefore, we don't do it here.
629 (zero? (system* "python" "setup.py" "build_sphinx")))))))
630 (propagated-inputs
631 `(("python-requests" ,python-requests)))
632 (native-inputs
633 `(("python-pbr" ,python-pbr)
634 ("python-docutils" ,python-docutils)
635 ("python-hacking" ,python-hacking)
636 ("python-sphinx" ,python-sphinx)))
637 (home-page "https://www.openstack.org/")
638 (synopsis "OpenStack sphinx extensions and theme")
639 (description
640 "This package provides themes and extensions for Sphinx documentation
641 from the OpenStack project.")
642 (license asl2.0)))
643
644 (define-public python2-oslosphinx
645 (package-with-python2 python-oslosphinx))
646
647 (define-public python-oslotest
648 (package
649 (name "python-oslotest")
650 (version "3.4.0")
651 (source
652 (origin
653 (method url-fetch)
654 (uri (pypi-uri "oslotest" version))
655 (sha256
656 (base32
657 "1pp8lq61d548cxcqi451czvrz5i5b3hyi2ry00wmngdgiswcqj1h"))))
658 (build-system python-build-system)
659 (propagated-inputs
660 `(("python-fixtures" ,python-fixtures)
661 ("python-mock" ,python-mock)
662 ("python-mox3" ,python-mox3)
663 ("python-os-client-config" ,python-os-client-config)
664 ("python-six" ,python-six)
665 ("python-subunit" ,python-subunit)
666 ("python-testrepository" ,python-testrepository)
667 ("python-testtools" ,python-testtools)))
668 (native-inputs
669 `(("python-pbr" ,python-pbr)
670 ("python-testscenarios" ,python-testscenarios)))
671 (home-page "https://launchpad.net/oslo")
672 (synopsis "Oslo test framework")
673 (description
674 "The Oslo Test framework provides common fixtures, support for debugging,
675 and better support for mocking results.")
676 (license asl2.0)))
677
678 (define-public python2-oslotest
679 (package-with-python2 python-oslotest))
680
681 (define-public python-oslo.utils
682 (package
683 (name "python-oslo.utils")
684 (version "3.36.2")
685 (source
686 (origin
687 (method url-fetch)
688 (uri (pypi-uri "oslo.utils" version))
689 (sha256
690 (base32
691 "1ipjcgg9z697wmibhcbg5lqpk5gafakdx4qkff3w255zr0mvw04r"))))
692 (build-system python-build-system)
693 (propagated-inputs
694 `(("python-debtcollector" ,python-debtcollector)
695 ("python-oslo.i18n" ,python-oslo.i18n)
696 ("python-iso8601" ,python-iso8601)
697 ("python-monotonic" ,python-monotonic)
698 ("python-netaddr" ,python-netaddr)
699 ("python-netifaces" ,python-netifaces)
700 ("python-pyparsing" ,python-pyparsing)
701 ("python-pytz" ,python-pytz)
702 ("python-six" ,python-six)))
703 (native-inputs
704 `(("python-pbr" ,python-pbr)
705 ;; Tests.
706 ("python-bandit" ,python-bandit)
707 ("python-ddt" ,python-ddt)
708 ("python-fixtures" ,python-fixtures)
709 ("python-oslo.config" ,python-oslo.config)
710 ("python-oslotest" ,python-oslotest)
711 ("python-mock" ,python-mock)
712 ("python-testrepository" ,python-testrepository)
713 ("python-testscenarios" ,python-testscenarios)
714 ("python-testtools" ,python-testtools)))
715 (home-page "https://launchpad.net/oslo")
716 (synopsis "Oslo utility library")
717 (description
718 "The @code{oslo.utils} library provides support for common utility type
719 functions, such as encoding, exception handling, string manipulation, and time
720 handling.")
721 (license asl2.0)))
722
723 (define-public python2-oslo.utils
724 (package-with-python2 python-oslo.utils))
725
726 (define-public python-keystoneclient
727 (package
728 (name "python-keystoneclient")
729 (version "1.8.1")
730 (source
731 (origin
732 (method url-fetch)
733 (uri (pypi-uri "python-keystoneclient" version))
734 (sha256
735 (base32
736 "1w4csvkah67rfpxylxnvs2s3594i0f9isy8pf4gnsqs5zirvjaa4"))))
737 (build-system python-build-system)
738 (arguments
739 '(#:tests? #f)) ; FIXME: Many tests are failing.
740 (native-inputs
741 `(("python-sphinx" ,python-sphinx)
742 ;; and some packages for the tests
743 ("openssl" ,openssl)
744 ("python-coverage" ,python-coverage)
745 ("python-discover" ,python-discover)
746 ("python-fixtures" ,python-fixtures)
747 ("python-hacking" ,python-hacking)
748 ("python-keyring" ,python-keyring)
749 ("python-lxml" ,python-lxml)
750 ("python-mock" ,python-mock)
751 ("python-mox3" ,python-mox3)
752 ("python-oauthlib" ,python-oauthlib)
753 ("python-oslosphinx" ,python-oslosphinx)
754 ("python-oslotest" ,python-oslotest)
755 ("python-pycrypto" ,python-pycrypto)
756 ("python-requests-mock" ,python-requests-mock)
757 ("python-temptest-lib" ,python-tempest-lib)
758 ("python-testrepository" ,python-testrepository)
759 ("python-testresources" ,python-testresources)
760 ("python-testtools" ,python-testtools)
761 ("python-webob" ,python-webob)))
762 (propagated-inputs
763 `(("python-babel" ,python-babel)
764 ("python-debtcollector" ,python-debtcollector)
765 ("python-iso8601" ,python-iso8601)
766 ("python-netaddr" ,python-netaddr)
767 ("python-oslo.config" ,python-oslo.config)
768 ("python-oslo.i18n" ,python-oslo.i18n)
769 ("python-oslo.serialization" ,python-oslo.serialization)
770 ("python-oslo.utils" ,python-oslo.utils)
771 ("python-pbr" ,python-pbr)
772 ("python-prettytable" ,python-prettytable)
773 ("python-requests" ,python-requests)
774 ("python-six" ,python-six)
775 ("python-stevedore" ,python-stevedore)))
776 (home-page "https://www.openstack.org/")
777 (synopsis "Client Library for OpenStack Identity")
778 (description
779 "Python-keystoneclient is the identity service used by OpenStack for
780 authentication (authN) and high-level authorization (authZ). It currently
781 supports token-based authN with user/service authZ, and is scalable to support
782 OAuth, SAML, and OpenID in future versions. Out of the box, Keystone uses
783 SQLite for its identity store database, with the option to connect to external
784 LDAP.")
785 (license asl2.0)))
786
787 (define-public python2-keystoneclient
788 (let ((keystoneclient (package-with-python2 python-keystoneclient)))
789 (package (inherit keystoneclient)
790 (propagated-inputs
791 `(("python2-requests" ,python2-requests)
792 ,@(alist-delete "python-requests"
793 (package-propagated-inputs keystoneclient))))
794 (native-inputs
795 `(("python2-oauthlib" ,python2-oauthlib)
796 ("python2-oslosphinx" ,python2-oslosphinx)
797 ("python2-requests-mock" ,python2-requests-mock)
798 ("python2-tempest-lib" ,python2-tempest-lib)
799 ,@(fold alist-delete (package-native-inputs keystoneclient)
800 '("python-oauthlib" "python-oslosphinx" "python-requests-mock" "python-tempest-lib")))))))
801
802 (define-public python-swiftclient
803 (package
804 (name "python-swiftclient")
805 (version "2.6.0")
806 (source
807 (origin
808 (method url-fetch)
809 (uri (pypi-uri "python-swiftclient" version))
810 (sha256
811 (base32
812 "1j33l4z9vqh0scfncl4fxg01zr1hgqxhhai6gvcih1gccqm4nd7p"))))
813 (build-system python-build-system)
814 (native-inputs
815 `(("python-pbr" ,python-pbr)
816 ("python-sphinx" ,python-sphinx)
817 ;; The folloing packages are needed for the tests.
818 ("python-coverage" ,python-coverage)
819 ("python-discover" ,python-discover)
820 ("python-hacking" ,python-hacking)
821 ("python-mock" ,python-mock)
822 ("python-oslosphinx" ,python-oslosphinx)
823 ("python-keystoneclient" ,python-keystoneclient)
824 ("python-testrepository" ,python-testrepository)
825 ("python-testtools" ,python-testtools)))
826 (propagated-inputs
827 `(("python-requests" ,python-requests)
828 ("python-six" ,python-six)))
829 (home-page "https://www.openstack.org/")
830 (synopsis "OpenStack Object Storage API Client Library")
831 (description
832 "OpenStack Object Storage (code-named Swift) creates redundant, scalable
833 object storage using clusters of standardized servers to store petabytes of
834 accessible data. It is not a file system or real-time data storage system, but
835 rather a long-term storage system for a more permanent type of static data that
836 can be retrieved, leveraged, and then updated if necessary. Primary examples of
837 data that best fit this type of storage model are virtual machine images, photo
838 storage, email storage and backup archiving. Having no central \"brain\" or
839 master point of control provides greater scalability, redundancy and
840 permanence.")
841 (properties `((python2-variant . ,(delay python2-swiftclient))))
842 (license asl2.0)))
843
844 (define-public python2-swiftclient
845 (let ((swiftclient (package-with-python2
846 (strip-python2-variant python-swiftclient))))
847 (package (inherit swiftclient)
848 (propagated-inputs
849 `(("python2-futures" ,python2-futures)
850 ,@(package-propagated-inputs swiftclient))))))
851
852 (define-public python-git-review
853 (package
854 (name "python-git-review")
855 (version "1.27.0")
856 (source
857 (origin
858 (method url-fetch)
859 (uri (pypi-uri "git-review" version))
860 (sha256
861 (base32
862 "0xkllc8ql401sfqbjqf7i451mkgwgv0j4gysxdlyzqb27kfsyc3s"))))
863 (build-system python-build-system)
864 (arguments
865 '(#:tests? #f ; tests require a running Gerrit server
866 #:phases
867 (modify-phases %standard-phases
868 (add-after 'install 'wrap-program
869 (lambda* (#:key inputs outputs #:allow-other-keys)
870 (let* ((out (assoc-ref outputs "out"))
871 (git (assoc-ref inputs "git"))
872 (openssh (assoc-ref inputs "openssh")))
873 (wrap-program (string-append out "/bin/git-review")
874 `("PATH" ":" prefix
875 ,(map (lambda (dir)
876 (string-append dir "/bin"))
877 (list git openssh)))))
878 #t)))))
879 (native-inputs
880 `(("python-pbr" ,python-pbr)))
881 (propagated-inputs
882 `(("python-requests" ,python-requests)))
883 (inputs
884 `(("git" ,git)
885 ("openssh" ,openssh)))
886 (home-page "https://docs.openstack.org/infra/git-review/")
887 (synopsis "Command-line tool for Gerrit")
888 (description
889 "Git-review is a command-line tool that helps submitting Git branches to
890 Gerrit for review, or fetching existing ones.")
891 (license asl2.0)))
892
893 (define-public python2-git-review
894 (package-with-python2 python-git-review))