gnu: ripit: Use archived source and home page.
[jackhill/guix/guix.git] / gnu / packages / cdrom.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015, 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
5 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
6 ;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
8 ;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
9 ;;; Copyright © 2017 John Darrington <jmd@gnu.org>
10 ;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
11 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
12 ;;; Copyright © 2017 ng0 <ng0@n0.is>
13 ;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
14 ;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
15 ;;; Copyright © 2019 Eric Bavier <bavier@member.fsf.org>
16 ;;;
17 ;;; This file is part of GNU Guix.
18 ;;;
19 ;;; GNU Guix is free software; you can redistribute it and/or modify it
20 ;;; under the terms of the GNU General Public License as published by
21 ;;; the Free Software Foundation; either version 3 of the License, or (at
22 ;;; your option) any later version.
23 ;;;
24 ;;; GNU Guix is distributed in the hope that it will be useful, but
25 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
26 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
27 ;;; GNU General Public License for more details.
28 ;;;
29 ;;; You should have received a copy of the GNU General Public License
30 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
31
32 (define-module (gnu packages cdrom)
33 #:use-module (guix download)
34 #:use-module (guix git-download)
35 #:use-module (guix packages)
36 #:use-module ((guix licenses) #:select (lgpl2.1+ gpl2 gpl2+ gpl3+ cddl1.0))
37 #:use-module (guix build-system cmake)
38 #:use-module (guix build-system gnu)
39 #:use-module (guix build-system glib-or-gtk)
40 #:use-module (guix gexp)
41 #:use-module (gnu packages)
42 #:use-module (gnu packages acl)
43 #:use-module (gnu packages audio)
44 #:use-module (gnu packages bison)
45 #:use-module (gnu packages compression)
46 #:use-module (gnu packages flex)
47 #:use-module (gnu packages fontutils)
48 #:use-module (gnu packages gettext)
49 #:use-module (gnu packages docbook)
50 #:use-module (gnu packages xml)
51 #:use-module (gnu packages gtk)
52 #:use-module (gnu packages glib)
53 #:use-module (gnu packages m4)
54 #:use-module (gnu packages man)
55 #:use-module (gnu packages mp3)
56 #:use-module (gnu packages music)
57 #:use-module (gnu packages ncurses)
58 #:use-module (gnu packages elf)
59 #:use-module (gnu packages wxwidgets)
60 #:use-module (gnu packages linux)
61 #:use-module (gnu packages pkg-config)
62 #:use-module (gnu packages readline)
63 #:use-module (gnu packages base)
64 #:use-module (gnu packages perl)
65 #:use-module (gnu packages perl-web)
66 #:use-module (gnu packages python)
67 #:use-module (gnu packages image)
68 #:use-module (gnu packages photo)
69 #:use-module (gnu packages video)
70 #:use-module (gnu packages wget)
71 #:use-module (gnu packages xiph))
72
73 (define-public libcddb
74 (package
75 (name "libcddb")
76 (version "1.3.2")
77 (source (origin
78 (method url-fetch)
79 (uri (string-append "mirror://sourceforge/libcddb/libcddb/" version
80 "/libcddb-" version ".tar.bz2"))
81 (sha256
82 (base32
83 "0fr21a7vprdyy1bq6s99m0x420c9jm5fipsd63pqv8qyfkhhxkim"))))
84 (build-system gnu-build-system)
85 (arguments '(#:tests? #f)) ; tests rely on access to external servers
86 (home-page "http://libcddb.sourceforge.net/")
87 (synopsis "C library to access data on a CDDB server")
88 (description
89 "Libcddb is a C library to access data on a CDDB server (freedb.org). It
90 allows you to:
91
92 1. search the database for possible CD matches;
93
94 2. retrieve detailed information about a specific CD;
95
96 3. submit new CD entries to the database.
97
98 Libcddb supports both the custom CDDB protocol and tunnelling the query and
99 read operations over plain HTTP. It is also possible to use an HTTP proxy
100 server. If you want to speed things up, you can make use of the built-in
101 caching facility provided by the library.")
102 (license lgpl2.1+)))
103
104 (define-public libcdio
105 (package
106 (name "libcdio")
107 (version "2.0.0")
108 (source (origin
109 (method url-fetch)
110 (uri (string-append "mirror://gnu/libcdio/libcdio-"
111 version ".tar.bz2"))
112 (sha256
113 (base32
114 "0jr8ppdm80c533nzmrpz3iffnpc6nhvsria1di9f4jg1l19a03fd"))))
115 (build-system gnu-build-system)
116 (inputs
117 `(("ncurses" ,ncurses)
118 ("libcddb" ,libcddb)))
119 (native-inputs
120 `(("help2man" ,help2man)
121 ("pkg-config" ,pkg-config)))
122 (home-page "https://www.gnu.org/software/libcdio/")
123 (synopsis "CD Input and Control library")
124 (description
125 "The GNU Compact Disc Input and Control Library (libcdio) is a library
126 for CD-ROM and CD image file access. It allows the developer to add CD
127 access to an application without having to worry about the OS- and
128 device-dependent properties of CD-ROM or the specific details of CD image
129 formats. It includes pycdio, a Python interface to libcdio, and
130 libcdio-paranoia, a library providing jitter-free and error-free audio
131 extraction from CDs.")
132 (license gpl3+)))
133
134 (define-public libcdio-paranoia
135 (package
136 (name "libcdio-paranoia")
137 (version "10.2+0.94+2")
138 (source (origin
139 (method url-fetch)
140 (uri (string-append "mirror://gnu/libcdio/libcdio-paranoia-"
141 version ".tar.gz"))
142 (sha256
143 (base32
144 "0h8rr1ir05r29rgawa1ccw335668k4s3zq4yg9095svyx7n843yn"))))
145 (build-system gnu-build-system)
146 (native-inputs `(("pkg-config" ,pkg-config)))
147 (propagated-inputs `(("libcdio" ,libcdio)))
148 (home-page "https://www.gnu.org/software/libcdio/")
149 (synopsis "Jitter- and error-tolerant CD audio extraction")
150 (description
151 "libcdio-paranoia is an implementation of CD paranoia libraries based on
152 libcdio.")
153 (license gpl3+)))
154
155 (define-public xorriso
156 (package
157 (name "xorriso")
158 (version "1.5.0")
159 (source (origin
160 (method url-fetch)
161 (uri (string-append "mirror://gnu/xorriso/xorriso-"
162 version ".tar.gz"))
163 (sha256
164 (base32
165 "0aq6lvlwlkxz56l5sbvgycr6j5c82ch2bv6zrnc2345ibfpafgx9"))))
166 (build-system gnu-build-system)
167 (inputs
168 `(("acl" ,acl)
169 ("readline" ,readline)
170 ("zlib" ,zlib)))
171 (home-page "https://www.gnu.org/software/xorriso/")
172 (synopsis "Create, manipulate, burn ISO-9660 file systems")
173 (description
174 "GNU Xorriso is a tool for copying files to and from ISO 9660 Rock
175 Ridge, a.k.a. Compact Disc File System, file systems and it allows
176 session-wise manipulation of them. It features a formatter and burner for
177 CD, DVD and BD. It can operate on existing ISO images or it can create new
178 ones. xorriso can then be used to copy files directly into or out of ISO
179 files.")
180 (license gpl3+)))
181
182 (define-public cdparanoia
183 (package
184 (name "cdparanoia")
185 (version "10.2")
186 (source (origin
187 (method url-fetch)
188 (uri (string-append "http://downloads.xiph.org/releases/"
189 "cdparanoia/cdparanoia-III-"
190 version ".src.tgz"))
191 (sha256
192 (base32
193 "1pv4zrajm46za0f6lv162iqffih57a8ly4pc69f7y0gfyigb8p80"))
194 (patches (search-patches "cdparanoia-fpic.patch"))
195 (modules '((guix build utils)))
196 (snippet
197 '(begin
198 ;; Make libraries respect LDFLAGS.
199 (substitute* '("paranoia/Makefile.in" "interface/Makefile.in")
200 (("-Wl,-soname") "$(LDFLAGS) -Wl,-soname"))
201 #t))))
202 (build-system gnu-build-system)
203 (arguments
204 `(#:tests? #f ; there is no check target
205 #:configure-flags ; Add $libdir to the RUNPATH of all the executables.
206 (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))))
207 (home-page "http://www.xiph.org/paranoia/")
208 (synopsis "Audio CD reading utility")
209 (description "Cdparanoia retrieves audio tracks from CDDA capable CDROM
210 drives. The data can be saved to a file or directed to standard output
211 in WAV, AIFF, AIFF-C or raw format. Most ATAPI, SCSI and several
212 proprietary CDROM drive makes are supported; cdparanoia can determine if the
213 target drive is CDDA capable. In addition to simple reading, cdparanoia adds
214 extra-robust data verification, synchronization, error handling and scratch
215 reconstruction capability.")
216 (license gpl2))) ; libraries under lgpl2.1
217
218 (define-public cdrtools
219 (package
220 (name "cdrtools")
221 (version "3.01")
222 (source (origin
223 (method url-fetch)
224 (uri (string-append
225 "mirror://sourceforge/cdrtools/cdrtools-" version ".tar.bz2"))
226 (sha256
227 (base32
228 "03w6ypsmwwy4d7vh6zgwpc60v541vc5ywp8bdb758hbc4yv2wa7d"))
229 (modules '((guix build utils)))
230 (snippet
231 '(begin
232 ;; By default 'cdda2wav --help' would print a string like
233 ;; "Version 3.01_linux_4.19.10-gnu_x86_64_x86_64". Change
234 ;; it to not capture the kernel version of the build
235 ;; machine, to allow for reproducible builds.
236 (substitute* "cdda2wav/local.cnf.in"
237 (("^VERSION_OS=.*")
238 (string-append
239 "actual_os := $(shell uname -o)\n"
240 "actual_arch := $(shell uname -m)\n"
241 "VERSION_OS = _$(actual_os)_$(actual_arch)\n")))
242 #t))
243 (patches (search-patches "cdrtools-3.01-mkisofs-isoinfo.patch"))))
244 (build-system gnu-build-system)
245 ;; XXX cdrtools bundles a modified, relicensed early version of cdparanoia.
246 (inputs
247 `(("linux-headers" ,linux-libre-headers)))
248 (arguments
249 `(#:make-flags
250 (list "RM=rm" "LN=ln" "SYMLINK=ln -s"
251 "CONFIG_SHELL=sh" "CCOM=gcc"
252 (string-append "INS_BASE=" (assoc-ref %outputs "out"))
253 (string-append "INS_RBASE=" (assoc-ref %outputs "out")))
254 ;; Parallel builds appear to be unsafe, see
255 ;; https://hydra.gnu.org/build/3346840/log/raw
256 #:parallel-build? #f
257 #:phases
258 (modify-phases %standard-phases
259 (delete 'configure)
260 (add-before 'build 'set-linux-headers
261 (lambda _
262 (substitute* "autoconf/configure"
263 (("/usr/src/linux")
264 (assoc-ref %build-inputs "linux-headers")))
265 #t))
266 (add-before 'build 'substitute-dirs
267 (lambda _
268 (substitute* (append (find-files "DEFAULTS" "^Defaults\\.")
269 (find-files "DEFAULTS_ENG" "^Defaults\\.")
270 (find-files "TEMPLATES" "^Defaults\\."))
271 (("/opt/schily") (assoc-ref %outputs "out")))
272 #t)))
273 #:tests? #f)) ; no tests
274 (synopsis "Command line utilities to manipulate and burn CD/DVD/BD images")
275 (description "cdrtools is a collection of command line utilities to create
276 CD's, DVD's or Blue Ray discs. The most important components are
277 @command{cdrecord}, a burning program, @command{cdda2wav}, a CD audio ripper
278 which uses libparanoia, and @command{mkisofs}, which can create various disc
279 images.")
280 (home-page "http://cdrtools.sourceforge.net/private/cdrecord.html")
281
282 ;; mkisofs is GPL, the other programs are CDDL.
283 (license (list cddl1.0 gpl2))))
284
285 (define-public dvd+rw-tools
286 (package
287 (name "dvd+rw-tools")
288 (version "7.1")
289 (source (origin
290 (method url-fetch)
291 (uri (string-append
292 "http://fy.chalmers.se/~appro/linux/DVD+RW/tools/dvd+rw-tools-"
293 version ".tar.gz"))
294 (sha256
295 (base32
296 "1jkjvvnjcyxpql97xjjx0kwvy70kxpiznr2zpjy2hhci5s10zmpq"))
297 (patches (search-patches "dvd+rw-tools-add-include.patch"))))
298 (build-system gnu-build-system)
299 (inputs
300 `(("cdrtools" ,cdrtools)))
301 (native-inputs
302 `(("m4" ,m4)))
303 (arguments
304 `(#:tests? #f ; No tests.
305 #:phases
306 (modify-phases %standard-phases
307 (add-after 'unpack 'fix-glibc-compatability
308 (lambda* (#:key inputs #:allow-other-keys)
309 ;; We use sed --in-place because substitute* cannot handle the
310 ;; character encoding used by growisofs.c.
311 (invoke "sed" "-i" "-e"
312 (string-append
313 "s,<sys/stat.h>,"
314 "<sys/stat.h>\\\n#include <sys/sysmacros.h>,")
315 "growisofs.c")))
316 (replace 'configure
317 (lambda _ (setenv "prefix" (assoc-ref %outputs "out")) #t))
318 (add-before 'build 'embed-mkisofs
319 (lambda* (#:key inputs #:allow-other-keys)
320 ;; We use sed --in-place because substitute* cannot handle the
321 ;; character encoding used by growisofs.c.
322 (invoke "sed" "-i" "-e"
323 (string-append
324 "s,\"mkisofs\","
325 "\"" (which "mkisofs") "\",")
326 "growisofs.c"))))))
327 (home-page "http://fy.chalmers.se/~appro/linux/DVD+RW/")
328 (synopsis "DVD and Blu-ray Disc burning tools")
329 (description "dvd+rw-tools, mostly known for its command
330 @command{growisofs}, is a collection of DVD and Blu-ray Disc burning tools.
331 It requires another program, such as @command{mkisofs}, @command{genisoimage},
332 or @command{xorrisofs} to create ISO 9660 images.")
333 (license gpl2)))
334
335 (define-public dvdisaster
336 (package
337 (name "dvdisaster")
338 (version "0.79.5")
339 (source
340 (origin
341 (method url-fetch)
342 ;; Update this (and update HOME-PAGE) when/if one reappears.
343 (uri (string-append "https://web.archive.org/web/20180428070843/"
344 "http://dvdisaster.net/downloads/dvdisaster-"
345 version ".tar.bz2"))
346 (sha256
347 (base32 "0f8gjnia2fxcbmhl8b3qkr5b7idl8m855dw7xw2fnmbqwvcm6k4w"))))
348 (build-system gnu-build-system)
349 (inputs
350 `(("gtk+" ,gtk+-2)))
351 (native-inputs
352 `(("gettext" ,gettext-minimal)
353 ("pkg-config" ,pkg-config)
354 ("which" ,which)))
355 (arguments
356 `(;; Parallel builds appear to be unsafe, see
357 ;; <http://hydra.gnu.org/build/49331/nixlog/1/raw>.
358 #:parallel-build? #f
359 #:phases
360 (modify-phases %standard-phases
361 (replace 'check
362 (lambda _
363 (with-directory-excursion "regtest"
364 (substitute* "common.bash"
365 (("ISODIR=/var/tmp/regtest") "ISODIR=/tmp"))
366 (for-each invoke (find-files "." "rs.*\\.bash")))
367 #t))
368 (add-after 'install 'install-desktop
369 (lambda* (#:key outputs #:allow-other-keys)
370 (let* ((datadir (string-append (assoc-ref outputs "out") "/share")))
371 (substitute* "contrib/dvdisaster.desktop"
372 (("dvdisaster48.png") "dvdisaster.png"))
373 (install-file "contrib/dvdisaster.desktop"
374 (string-append datadir "/applications"))
375 (for-each
376 (lambda (png)
377 (let* ((size (substring png
378 (string-index png char-set:digit)
379 (string-rindex png #\.)))
380 (icondir (string-append datadir "/icons/"
381 size "x" size "/apps")))
382 (mkdir-p icondir)
383 (copy-file png (string-append icondir "/dvdisaster.png"))))
384 (find-files "contrib" "dvdisaster[0-9]*\\.png"))
385 (mkdir-p (string-append datadir "/pixmaps"))
386 (copy-file "contrib/dvdisaster48.xpm"
387 (string-append datadir "/pixmaps/dvdisaster.xpm"))
388 #t))))))
389 (home-page (string-append "https://web.archive.org/web/20180428070843/"
390 "http://dvdisaster.net/en/index.html"))
391 (synopsis "Error correcting codes for optical media images")
392 (description "Optical media (CD,DVD,BD) keep their data only for a
393 finite time (typically for many years). After that time, data loss develops
394 slowly with read errors growing from the outer media region towards the
395 inside.
396
397 Dvdisaster stores data on CD/DVD/BD (supported media) in a way that it is
398 fully recoverable even after some read errors have developed. This enables
399 you to rescue the complete data to a new medium.
400
401 Data loss is prevented by using error correcting codes. Error correction
402 data is either added to the medium or kept in separate error correction
403 files. Dvdisaster works at the image level so that the recovery does not
404 depend on the file system of the medium. The maximum error correction
405 capacity is user-selectable.")
406 (license gpl2+)))
407
408 (define-public dvdstyler
409 (package
410 (name "dvdstyler")
411 (version "3.0.4")
412 (source
413 (origin
414 (method url-fetch)
415 (uri (string-append "mirror://sourceforge/dvdstyler/dvdstyler/"
416 version "/DVDStyler-" version ".tar.bz2"))
417 (sha256
418 (base32
419 "0lwc0hn94m9r8fi07sjqz3fr618l6lnw3zsakxw7nlgnxbjsk7pi"))))
420 (build-system gnu-build-system)
421 (arguments
422 `(#:configure-flags
423 (list (string-append "XMLTO="
424 (assoc-ref %build-inputs "xmlto")
425 "/bin/xmlto --searchpath "
426 (assoc-ref %build-inputs "docbook-xsl")
427 "/xml/xsl/docbook-xsl-" ,(package-version docbook-xsl)
428 "/htmlhelp:"
429 (assoc-ref %build-inputs "docbook-xml")
430 "/xml/dtd/docbook"))
431 #:phases
432 (modify-phases %standard-phases
433 (add-after 'install 'wrap-program
434 (lambda* (#:key inputs outputs #:allow-other-keys)
435 (wrap-program (string-append (assoc-ref outputs "out") "/bin/dvdstyler")
436 `("PATH" ":" prefix
437 (,(string-join
438 (map (lambda (in) (string-append (assoc-ref inputs in) "/bin"))
439 '("cdrtools" "dvdauthor" "dvd+rw-tools" "ffmpeg"))
440 ":"))))
441 #t)))
442 #:tests? #f)) ; No tests.
443 (inputs ; TODO package bundled wxvillalib
444 `(("wxwidgets" ,wxwidgets-3.1)
445 ("wssvg" ,wxsvg)
446 ("dbus" ,dbus)
447 ("cdrtools" ,cdrtools)
448 ("dvd+rw-tools" ,dvd+rw-tools)
449 ("dvdauthor" ,dvdauthor)
450 ("eudev" ,eudev)
451 ("fontconfig" ,fontconfig)
452 ("libexif" ,libexif)
453 ("libjpeg" ,libjpeg)
454 ("ffmpeg" ,ffmpeg-3.4)))
455 (native-inputs
456 `(("pkg-config" ,pkg-config)
457 ("flex" ,flex)
458 ("python" ,python-2)
459 ("xmlto" ,xmlto)
460 ("gettext" ,gnu-gettext)
461 ("docbook-xml" ,docbook-xml)
462 ("docbook-xsl" ,docbook-xsl)
463 ("zip" ,zip)))
464 (synopsis "DVD authoring application")
465 (description "DVDStyler is a DVD authoring application which allows users
466 to burn video files in many formats to DVD discs, complete with individually
467 designed menus. It can be used to create professional-looking DVD's with
468 custom buttons, backgrounds and animations, from within a user-friendly
469 graphical interface.")
470 (home-page "https://www.dvdstyler.org")
471 (license gpl2)))
472
473 (define-public libcue
474 (package
475 (name "libcue")
476 (version "2.2.1")
477 (source (origin
478 (method git-fetch)
479 (uri (git-reference
480 (url "https://github.com/lipnitsk/libcue.git")
481 (commit (string-append "v" version))))
482 (file-name (git-file-name name version))
483 (sha256
484 (base32
485 "1iqw4n01rv2jyk9lksagyxj8ml0kcfwk67n79zy1r6zv1xfp5ywm"))))
486 (build-system cmake-build-system)
487 (arguments
488 `(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
489 (native-inputs
490 `(("bison" ,bison)
491 ("flex" ,flex)))
492 (home-page "https://github.com/lipnitsk/libcue")
493 (synopsis "C library to parse cue sheets")
494 (description "Libcue is a C library to parse so-called @dfn{cue sheets}
495 which contain meta-data for CD/DVD tracks. It provides an API to manipulate
496 the data.")
497 (license gpl2+)))
498
499 (define-public cd-discid
500 (package
501 (name "cd-discid")
502 (version "1.4")
503 (home-page "http://linukz.org/cd-discid.shtml")
504 (source (origin
505 (method url-fetch)
506 (uri (string-append "http://linukz.org/download/cd-discid-"
507 version ".tar.gz"))
508 (sha256
509 (base32
510 "0qrcvn7227qaayjcd5rm7z0k5q89qfy5qkdgwr5pd7ih0va8rmpz"))
511 (modules '((guix build utils)))
512 (snippet
513 '(begin
514 (substitute* "Makefile"
515 (("/usr/bin/install")
516 "install"))
517 #t))))
518 (build-system gnu-build-system)
519 (arguments
520 '(#:tests? #f
521 #:phases (modify-phases %standard-phases (delete 'configure))
522 #:make-flags (list "CC=gcc"
523 (string-append "PREFIX="
524 (assoc-ref %outputs "out")))))
525 (synopsis "Get CDDB discid information from an audio CD")
526 (description
527 "cd-discid is a command-line tool to retrieve CDDB discid information
528 from an audio CD.")
529 (license gpl2+)))
530
531 (define-public abcde
532 (package
533 (name "abcde")
534 (version "2.9.3")
535 (home-page "https://abcde.einval.com/")
536 (source (origin
537 (method url-fetch)
538 (uri (string-append home-page "/download/abcde-"
539 version ".tar.gz"))
540 (sha256
541 (base32
542 "091ip2iwb6b67bhjsj05l0sxyq2whqjycbzqpkfbpm4dlyxx0v04"))
543 (modules '((guix build utils)))
544 (snippet
545 '(begin
546 (substitute* "Makefile"
547 (("/usr/bin/install")
548 "install"))
549 #t))))
550 (build-system gnu-build-system)
551 (arguments
552 '(#:phases
553 (modify-phases %standard-phases
554 (replace 'configure
555 (lambda* (#:key outputs inputs #:allow-other-keys)
556 (substitute* "Makefile"
557 (("^prefix = .*$")
558 (string-append "prefix = "
559 (assoc-ref outputs "out")
560 "\n"))
561 (("^sysconfdir = .*$")
562 (string-append "sysconfdir = "
563 (assoc-ref outputs "out")
564 "/etc/\n")))
565 #t))
566 (add-after 'install 'wrap
567 (lambda* (#:key inputs outputs #:allow-other-keys)
568 (let ((wget (assoc-ref inputs "wget"))
569 (vorbis (assoc-ref inputs "vorbis-tools"))
570 (parano (assoc-ref inputs "cdparanoia"))
571 (which (assoc-ref inputs "which"))
572 (discid (assoc-ref inputs "cd-discid"))
573 (perl-discid (assoc-ref inputs "perl-musicbrainz-discid"))
574 (perl-ws (assoc-ref inputs "perl-webservice-musicbrainz"))
575 (perl-mojo (assoc-ref inputs "perl-mojolicious"))
576 (flac (assoc-ref inputs "flac"))
577 (out (assoc-ref outputs "out")))
578 (define (wrap file)
579 (wrap-program file
580 `("PATH" ":" prefix
581 (,(string-append out "/bin:"
582 wget "/bin:"
583 flac "/bin:"
584 which "/bin:"
585 vorbis "/bin:"
586 discid "/bin:"
587 parano "/bin")))
588 `("PERL5LIB" ":" prefix
589 (,(string-append perl-discid
590 "/lib/perl5/site_perl:"
591 perl-ws
592 "/lib/perl5/site_perl:"
593 perl-mojo
594 "/lib/perl5/site_perl")))))
595
596 (for-each wrap
597 (find-files (string-append out "/bin")
598 ".*")))
599 #t)))
600 #:tests? #f)) ; no test target
601
602 (inputs `(("wget" ,wget)
603 ("which" ,which)
604 ("cdparanoia" ,cdparanoia)
605 ("cd-discid" ,cd-discid)
606 ("vorbis-tools" ,vorbis-tools)
607 ("flac" ,flac)
608
609 ("perl-musicbrainz-discid" ,perl-musicbrainz-discid)
610 ("perl-webservice-musicbrainz" ,perl-webservice-musicbrainz)
611 ("perl-mojolicious" ,perl-mojolicious) ;indirect dependency
612
613 ;; A couple of Python and Perl scripts are included.
614 ("python" ,python)
615 ("perl" ,perl)))
616
617 (synopsis "Command-line audio CD ripper")
618 (description
619 "abcde is a front-end command-line utility (actually, a shell script)
620 that grabs tracks off a CD, encodes them to Ogg/Vorbis, MP3, FLAC, Ogg/Speex
621 and/or MPP/MP+ (Musepack) format, and tags them, all in one go.")
622 (license gpl2+)))
623
624 (define-public geteltorito
625 (package
626 (name "geteltorito")
627 (version "0.6")
628 (home-page
629 "https://userpages.uni-koblenz.de/~krienke/ftp/noarch/geteltorito/")
630 (source (origin
631 (method url-fetch)
632 (uri (string-append home-page name "-" version ".tar.gz"))
633 (sha256
634 (base32
635 "1gkbm9ahj2mgqrkrfpibzclsriqgsbsvjh19fr815vpd9f6snkxv"))))
636 (build-system gnu-build-system)
637 (arguments
638 `(#:tests? #f ; No tests.
639 #:phases
640 (modify-phases %standard-phases
641 (delete 'configure)
642 (delete 'build)
643 (replace 'install
644 (lambda* (#:key outputs #:allow-other-keys)
645 (let ((out (assoc-ref outputs "out")))
646 (install-file "geteltorito"
647 (string-append out "/bin"))))))))
648 (inputs `(("perl" ,perl)))
649 (synopsis "Extract the boot image from a CD-ROM")
650 (description
651 "@command{geteltorito} can extract the initial/default boot
652 image from CDs (and ISOs) that follow the El Torito specification
653 for bootable CD-ROMs.
654
655 Image data is written to standard output by default and all other
656 information is written to standard error.")
657 (license gpl2+)))
658
659 (define-public asunder
660 (package
661 (name "asunder")
662 (version "2.9.3")
663 (source (origin
664 (method url-fetch)
665 (uri
666 (string-append "http://www.littlesvr.ca/asunder/releases/asunder-"
667 version
668 ".tar.bz2"))
669 (sha256
670 (base32
671 "1630i1df06y840v3fgdf75jxw1s8kwbfn5bhi0686viah0scccw5"))))
672 (build-system glib-or-gtk-build-system)
673 (arguments
674 '(#:out-of-source? #f
675 #:phases (modify-phases %standard-phases
676 (add-after 'install 'wrap
677 (lambda* (#:key inputs outputs #:allow-other-keys)
678 (let ((program (string-append (assoc-ref outputs "out")
679 "/bin/asunder")))
680 (define (bin-directory input-name)
681 (string-append (assoc-ref inputs input-name) "/bin"))
682 (wrap-program program
683 `("PATH" ":" prefix
684 ,(map bin-directory (list "cdparanoia"
685 "lame"
686 "vorbis-tools"
687 "flac"
688 "opus-tools"
689 "wavpack"))))))))))
690 (native-inputs `(("intltool" ,intltool)
691 ("pkg-config" ,pkg-config)))
692 ;; TODO: Add the necessary packages for Musepack encoding.
693 (inputs `(("gtk+-2" ,gtk+-2)
694 ("glib" ,glib)
695 ("libcddb" ,libcddb)
696 ("cdparanoia" ,cdparanoia)
697 ("lame" ,lame)
698 ("vorbis-tools" ,vorbis-tools)
699 ("flac" ,flac)
700 ("opus-tools" ,opus-tools)
701 ("wavpack" ,wavpack)))
702 (home-page "http://www.littlesvr.ca/asunder/")
703 (synopsis "Graphical audio CD ripper and encoder")
704 (description
705 "Asunder is a graphical audio CD ripper and encoder. It can save audio
706 tracks as WAV, MP3, Ogg Vorbis, FLAC, Opus, Wavpack, and Musepack. It can use
707 CDDB to name and tag each track automatically, and it allows for each track to
708 be by a different artist. Asunder can encode to multiple formats in one
709 session, and it can create M3U playlists.")
710 (license gpl2)))
711
712 (define-public ripit
713 (package
714 (name "ripit")
715 (version "3.9.0")
716 (source
717 (origin
718 (method url-fetch)
719 ;; The original suwald.com domain has expired.
720 (uri (list
721 (string-append "https://web.archive.org/web/20160327050927/"
722 "http://suwald.com/ripit/ripit-" version ".tar.gz")
723 (string-append "https://ponce.cc/slackware/sources/repo/ripit-"
724 version ".tar.gz")))
725 (sha256
726 (base32 "0ap71x477jy9c4jiqazb3y45hxdxm3jbq24x05g3vjyqzigi4x1b"))))
727 (build-system gnu-build-system)
728 (arguments
729 `(#:tests? #f ; no test suite
730 #:phases
731 (modify-phases %standard-phases
732 (delete 'configure)
733 (add-after 'unpack 'patch-usr-bin-install
734 (lambda* (#:key inputs outputs #:allow-other-keys)
735 (substitute* "Makefile"
736 (("/usr/bin/install") (string-append
737 (assoc-ref inputs "coreutils")
738 "/bin/install"))
739 (("\\$\\(DESTDIR\\)/usr/local") (assoc-ref outputs "out"))
740 (("../../etc") "etc")))))))
741 (native-inputs
742 `(("coreutils" ,coreutils)))
743 (inputs
744 `(("perl" ,perl)))
745 (propagated-inputs
746 `(("cdparanoia" ,cdparanoia)
747 ("flac" ,flac)
748 ("vorbis-tools" ,vorbis-tools)
749 ("wavpack" ,wavpack)
750 ("perl-cddb-get" ,perl-cddb-get)))
751 (home-page (string-append "https://web.archive.org/web/20170119092156/"
752 "http://www.suwald.com/ripit/about.php"))
753 (synopsis "Command-line program to extract audio CDs")
754 (description "RipIT is used to extract audio from CDs.")
755 (license gpl2)))
756
757 (define-public ccd2cue
758 (package
759 (name "ccd2cue")
760 (version "0.5")
761 (source
762 (origin
763 (method url-fetch)
764 (uri (string-append
765 "mirror://gnu/ccd2cue/ccd2cue-" version
766 ".tar.gz"))
767 (sha256
768 (base32
769 "1icrkg25hwx4gsn3dski2172ia4ywjh8m1sa17zmjclnrgdwy9c7"))))
770 (build-system gnu-build-system)
771 (synopsis "CCD to CUE sheet conversion")
772 (description
773 "GNU ccd2cue is a preprocessor for CD burning software that allows
774 the conversion of the proprietary CCD format to the CUE format, which
775 is well-supported by free software. These files are commonly
776 distributed with CD images and are used to describe how tracks are
777 laid out on the image.")
778 (home-page "https://www.gnu.org/software/ccd2cue/")
779 (license gpl3+)))
780
781 (define-public libburn
782 (package
783 (name "libburn")
784 (version "1.5.0")
785 (source (origin
786 (method url-fetch)
787 (uri (string-append "http://files.libburnia-project.org/releases/"
788 "libburn-" version ".tar.gz"))
789 (sha256
790 (base32
791 "1gg2kgnqvaa2fwghai62prxz6slpak1f6bvgjh8m4dn16v114asq"))))
792 (build-system gnu-build-system)
793 (native-inputs
794 `(("pkg-config" ,pkg-config)))
795 (home-page "https://dev.lovelyhq.com/libburnia/libburn")
796 (synopsis "Library for reading and writing optical discs")
797 (description
798 "Libburn is a library for reading and writing optical discs.
799 Supported media are: CD-R, CD-RW, DVD-RAM, DVD+RW, DVD+R, DVD+R/DL,
800 DVD-RW, DVD-R, DVD-R/DL, BD-R, and BD-RE.")
801 (license gpl2)))
802
803 (define-public libisofs
804 (package
805 (name "libisofs")
806 (version "1.5.0")
807 (source (origin
808 (method url-fetch)
809 (uri (string-append "http://files.libburnia-project.org/releases/"
810 "libisofs-" version ".tar.gz"))
811 (sha256
812 (base32
813 "001l3akf3wb6msl9man776w560iqyvsbwwzs7d7y7msx13irspys"))))
814 (build-system gnu-build-system)
815 (inputs
816 `(("zlib" ,zlib)
817 ("acl" ,acl)))
818 (native-inputs
819 `(("pkg-config" ,pkg-config)))
820 (home-page "https://dev.lovelyhq.com/libburnia/libisofs")
821 (synopsis "Library to create ISO 9660 images")
822 (description
823 "Libisofs creates ISO 9660 (also known as ECMA-119) file system images
824 which can either be written to POSIX file objects or handed over to
825 libburn for being written directly to optical media.
826 It can read metadata of ISO 9660 filesystems, manipulate them, and use them
827 to produce new complete file system images or add-on images to be appended
828 to the read file system image.
829 Supported extensions to ISO 9660 are Rock Ridge, Joliet, AAIP, zisofs.")
830 (license gpl2+)))
831
832 (define-public cdrkit-libre
833 (package
834 (name "cdrkit-libre")
835 (version "1.1.11")
836 (source (origin
837 (method url-fetch)
838 ;; cdrkit.org is dead.
839 ;;
840 ;; ‘cdrkit-libre’ removes a couple of problematic files,
841 ;; see <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32165#14>.
842 (uri (string-append
843 "https://repo.parabola.nu/other/cdrkit-libre/cdrkit-libre-"
844 version ".tar.gz"))
845 (sha256
846 (base32
847 "0g2zyzb56czh429qy87lvaddzjnlcq8c616ddxsmsshz3clhyzrh"))))
848 (build-system cmake-build-system)
849 (inputs
850 `(("bzip2" ,bzip2)
851 ("libcap" ,libcap)
852 ("perl" ,perl)
853 ("zlib" ,zlib)))
854 (arguments
855 `(#:tests? #f ;no tests
856 #:phases
857 (modify-phases %standard-phases
858 (add-after 'install 'old-cdrecord
859 (lambda* (#:key outputs #:allow-other-keys)
860 (with-directory-excursion (string-append (assoc-ref outputs "out")
861 "/bin")
862 (symlink "genisoimage" "mkisofs")
863 (symlink "wodim" "cdrecord"))
864 #t)))))
865 (home-page "https://repo.parabola.nu/other/cdrkit-libre/")
866 (synopsis "Command-line CD/DVD recorder")
867 (description "Cdrkit is a suite of programs for recording CDs and DVDs,
868 blanking CD-RW media, creating ISO-9660 file system images, extracting audio
869 CD data, and more. It's mostly compatible with @code{cdrtools}.")
870 (license gpl2+)))
871
872 (define-public libmirage
873 (package
874 (name "libmirage")
875 (version "3.2.2")
876 (source (origin
877 (method url-fetch)
878 (uri (string-append
879 "https://downloads.sourceforge.net/cdemu/libmirage-"
880 version ".tar.bz2"))
881 (sha256
882 (base32
883 "0gwrfia0fyhi0b3p2pfyyvrcfcb0qysfzgpdqsqjqbx4xaqx5wpi"))))
884 (build-system cmake-build-system)
885 (native-inputs
886 `(("pkg-config" ,pkg-config)
887 ("intltool" ,intltool)))
888 (inputs
889 `(("glib" ,glib)))
890 (arguments
891 ;; No tests.
892 '(#:tests? #f))
893 (home-page "https://cdemu.sourceforge.io/")
894 (synopsis "CD-ROM image access library")
895 (description "libMirage is a CD-ROM image access library. It supports the
896 following formats: B6T, C2D, CCD, CDI, CIF, CUE, ISO, MDS, MDX, NRG, TOC. It
897 is written in C and based on GLib. Its aim is to provide uniform access to
898 the data stored in various image formats.")
899 (license gpl2+)))
900
901 (define-public cdemu-daemon
902 (package
903 (name "cdemu-daemon")
904 (version "3.2.2")
905 (source (origin
906 (method url-fetch)
907 (uri (string-append
908 "https://downloads.sourceforge.net/cdemu/cdemu-daemon/cdemu-daemon-"
909 version ".tar.bz2"))
910 (sha256
911 (base32
912 "0himyrhhfjsr4ff5aci7240bpm9x34h20pid412ci8fm16nk929b"))))
913 (build-system cmake-build-system)
914 (native-inputs
915 `(("pkg-config" ,pkg-config)
916 ("intltool" ,intltool)))
917 (inputs
918 `(("libmirage" ,libmirage)
919 ("glib" ,glib)
920 ("ao" ,ao)))
921 (arguments
922 ;; No tests.
923 '(#:tests? #f))
924 (home-page "https://cdemu.sourceforge.io/")
925 (synopsis "CD/DVD-ROM device emulator")
926 (description "CDemu is a software suite designed to emulate an optical
927 drive and disc (including CD-ROMs and DVD-ROMs).")
928 (license gpl2+)))
929
930 (define-public cdemu-client
931 (package
932 (name "cdemu-client")
933 (version "3.2.1")
934 (source (origin
935 (method url-fetch)
936 (uri (string-append
937 "https://downloads.sourceforge.net/cdemu/cdemu-client-"
938 version ".tar.bz2"))
939 (sha256
940 (base32
941 "1d8m24qvv62xcwafw5zs4yf39vs64kxl4idqcngd8yyjhrb2ykg5"))))
942 (build-system cmake-build-system)
943 (native-inputs
944 `(("pkg-config" ,pkg-config)
945 ("intltool" ,intltool)))
946 (inputs
947 `(("python" ,python)
948 ("python-pygobject" ,python-pygobject)
949 ("cdemu-daemon" ,cdemu-daemon)))
950 (arguments
951 ;; No tests.
952 `(#:tests? #f
953 #:phases
954 (modify-phases %standard-phases
955 (add-after 'install 'patch-shebang
956 (lambda* (#:key outputs #:allow-other-keys)
957 (patch-shebang (string-append (assoc-ref outputs "out")
958 "/bin/cdemu"))
959 #t))
960 (add-after 'patch-shebang 'wrap-program
961 (lambda* (#:key outputs #:allow-other-keys)
962 (let ((prog (string-append (assoc-ref outputs "out")
963 "/bin/cdemu")))
964 (wrap-program prog
965 `("PYTHONPATH" = (,(getenv "PYTHONPATH"))))
966 #t))))))
967 (home-page "https://cdemu.sourceforge.io/")
968 (synopsis "Command-line client for controlling cdemu-daemon")
969 (description "CDEmu client is a simple command-line client for controlling
970 CDEmu daemon.
971
972 It provides a way to perform the key tasks related to controlling the CDEmu
973 daemon, such as loading and unloading devices, displaying devices' status and
974 retrieving/setting devices' debug masks.")
975 (license gpl2+)))