Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / libidn.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages libidn)
21 #:use-module (gnu packages)
22 #:use-module (guix licenses)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu))
26
27 (define-public libidn
28 (package
29 (name "libidn")
30 (version "1.32")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/libidn/libidn-" version
34 ".tar.gz"))
35 (sha256 (base32
36 "1xf4hphhahcjm2xwx147lfpsavjwv9l4c2gf6hx71zxywbz5lpds"))))
37 (build-system gnu-build-system)
38 ;; FIXME: No Java and C# libraries are currently built.
39 (synopsis "Internationalized string processing library")
40 (description
41 "libidn is a library implementing of the Stringprep, Punycode and IDNA
42 specifications. These are used to encode and decode internationalized domain
43 names. It includes native C, C# and Java libraries.")
44 ;; The C code is dual-licensed gpl2+ lgpl3+, the manual is fdl1.3+,
45 ;; the command line tool is gpl3+.
46 (license (list gpl2+ gpl3+ lgpl3+ fdl1.3+))
47 (home-page "http://www.gnu.org/software/libidn/")))