Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / gps.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages gps)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix git-download)
24 #:use-module (guix build-system gnu)
25 #:use-module ((guix licenses) #:prefix license:)
26 #:use-module (gnu packages base)
27 #:use-module (gnu packages pkg-config)
28 #:use-module (gnu packages compression)
29 #:use-module (gnu packages docbook)
30 #:use-module (gnu packages geeqie) ;exiv2
31 #:use-module (gnu packages xml)
32 #:use-module (gnu packages gtk)
33 #:use-module (gnu packages qt))
34
35 (define-public gpsbabel
36 (package
37 (name "gpsbabel")
38 (version "1.5.2")
39 (source (origin
40 (method url-fetch)
41 ;; XXX: Downloads from gpsbabel.org are hidden behind a POST, so
42 ;; get it from elsewhere.
43 (uri (string-append
44 "mirror://debian/pool/main/g/gpsbabel/gpsbabel_"
45 version ".orig.tar.gz"))
46 (sha256
47 (base32
48 "0xf7wmy2m29g2lm8lqc74yf8rf7sxfl3cfwbk7dpf0yf42pb0b6w"))))
49 (build-system gnu-build-system)
50 (arguments
51 `(#:configure-flags '("--with-zlib=system")
52 #:phases
53 (modify-phases %standard-phases
54 (add-before 'configure 'pre-configure
55 (lambda _
56 (chdir "gpsbabel"))))
57 ;; TODO: "make doc" requires Docbook & co.
58
59 ;; On i686, 'raymarine.test' fails because of a rounding error:
60 ;; <http://hydra.gnu.org/build/133040>. As a workaround, disable tests
61 ;; on these platforms.
62 #:tests? ,(not (string-prefix? "i686" (%current-system)))))
63 (inputs
64 `(("expat" ,expat)
65 ("zlib" ,zlib)
66 ("qtbase" ,qtbase)
67 ("qttools" ,qttools)))
68 (native-inputs
69 `(("which" ,which)
70 ("libxml2" ,libxml2))) ;'xmllint' needed for the KML tests
71 (home-page "http://www.gpsbabel.org/")
72 (synopsis "Convert and exchange data with GPS and map programs")
73 (description
74 "GPSBabel converts waypoints, tracks, and routes between hundreds of
75 popular GPS receivers and mapping programs. It contains extensive data
76 manipulation abilities making it a convenient for server-side processing or as
77 the back-end for other tools. It does not convert, transfer, send, or
78 manipulate maps.")
79 (license license:gpl2+)))
80
81 (define-public gpscorrelate
82 ;; This program is "lightly maintained", so to speak, so we end up taking it
83 ;; directly from its Git repo.
84 (let ((commit "365f6e1b3f"))
85 (package
86 (name "gpscorrelate")
87 (version (string-append "1.6.1." commit))
88 (source (origin
89 (method git-fetch)
90 (uri (git-reference
91 (url "https://github.com/freefoote/gpscorrelate")
92 (commit commit)))
93 (sha256
94 (base32
95 "006a6l8p38a4h7y2959sqrmjjn29d8pd50zj9nypcp5ph18nybjb"))))
96 (build-system gnu-build-system)
97 (arguments
98 `(#:phases (alist-replace
99 'configure
100 (lambda* (#:key inputs outputs #:allow-other-keys)
101 ;; This is a rudimentary build system.
102 (substitute* "Makefile"
103 (("prefix[[:blank:]]*=.*$")
104 (string-append "prefix = " (assoc-ref outputs "out")
105 "\n"))))
106 %standard-phases)
107 #:tests? #f))
108 (inputs
109 `(("gtk+" ,gtk+-2)
110 ("libxml2" ,libxml2)
111 ("exiv2" ,exiv2)))
112 (native-inputs
113 `(("pkg-config" ,pkg-config)
114 ("docbook-xml" ,docbook-xml)
115 ("docbook-xsl" ,docbook-xsl)
116 ("libxslt" ,libxslt)))
117 (home-page "http://freefoote.dview.net/linux/gpscorrelate")
118 (synopsis "GPS photo correlation tool to geo-localize images")
119 (description
120 "GPS Correlate is a program to match a recorded GPS track with the EXIF
121 tags in digital camera photos, and update the EXIF tags with the location that
122 the photo was taken. It does this by using the timestamp in the photo and
123 finding a data point in the GPS track that matches, or interpolating a point
124 between two other data points.")
125 (license license:gpl2+))))