Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / geeqie.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages geeqie)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module ((guix licenses) #:prefix l:)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages autotools)
26 #:use-module (gnu packages compression)
27 #:use-module (gnu packages ghostscript)
28 #:use-module (gnu packages glib)
29 #:use-module (gnu packages gtk)
30 #:use-module (gnu packages image)
31 #:use-module (gnu packages pkg-config)
32 #:use-module (gnu packages xml))
33
34 (define-public exiv2 ; XXX: move elsewhere?
35 (package
36 (name "exiv2")
37 (version "0.25")
38 (source (origin
39 (method url-fetch)
40 (uri (list (string-append "http://www.exiv2.org/exiv2-"
41 version ".tar.gz")
42 (string-append "https://fossies.org/linux/misc/exiv2-"
43 version ".tar.gz")))
44 (sha256
45 (base32
46 "197g6vgcpyf9p2cwn5p5hb1r714xsk1v4p96f5pv1z8mi9vzq2y8"))))
47 (build-system gnu-build-system)
48 (arguments '(#:tests? #f)) ; no `check' target
49 (propagated-inputs
50 `(("expat" ,expat)
51 ("zlib" ,zlib)))
52 (native-inputs
53 `(("intltool" ,intltool)))
54 (home-page "http://www.exiv2.org/")
55 (synopsis "Library and command-line utility to manage image metadata")
56 (description
57 "Exiv2 is a C++ library and a command line utility to manage image
58 metadata. It provides fast and easy read and write access to the Exif, IPTC
59 and XMP metadata of images in various formats.")
60
61 ;; Files under `xmpsdk' are a copy of Adobe's XMP SDK, licensed under the
62 ;; 3-clause BSD license: <http://www.adobe.com/devnet/xmp/sdk/eula.html>.
63 ;; The core is GPLv2+:
64 ;; <https://launchpad.net/ubuntu/precise/+source/exiv2/+copyright>.
65 (license l:gpl2+)))
66
67 (define-public geeqie
68 (package
69 (name "geeqie")
70 (version "1.3")
71 (source (origin
72 (method url-fetch)
73 (uri (string-append "https://github.com/BestImageViewer/geeqie/"
74 "releases/download/v" version "/geeqie-"
75 version ".tar.xz"))
76 (sha256
77 (base32
78 "0gzc82sy66pbsmq7lnmq4y37zqad1zfwfls3ik3dmfm8s5nmcvsb"))))
79 (build-system gnu-build-system)
80 (arguments
81 `(#:phases
82 (modify-phases %standard-phases
83 (add-after 'unpack 'autogen
84 (lambda _
85 (setenv "NOCONFIGURE" "true")
86 (zero? (system* "sh" "autogen.sh")))))))
87 (inputs
88 `(;; ("libchamplain" ,libchamplain)
89 ("lcms" ,lcms)
90 ("exiv2" ,exiv2)
91 ("libpng" ,libpng)
92 ("gtk+" ,gtk+-2)))
93 (native-inputs
94 `(("autoconf" ,autoconf)
95 ("automake" ,automake)
96 ("glib" ,glib "bin") ; glib-gettextize
97 ("intltool" ,intltool)
98 ("pkg-config" ,pkg-config)))
99 (home-page "http://www.geeqie.org/")
100 (synopsis "Lightweight GTK+ based image viewer")
101 (description
102 "Geeqie is a lightweight GTK+ based image viewer for Unix like operating
103 systems. It features: EXIF, IPTC and XMP metadata browsing and editing
104 interoperability; easy integration with other software; geeqie works on files
105 and directories, there is no need to import images; fast preview for many raw
106 image formats; tools for image comparison, sorting and managing photo
107 collection. Geeqie was initially based on GQview.")
108 (license l:gpl2+)))