Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / connman.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages connman)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses)
24 #:use-module (guix utils)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages admin)
27 #:use-module (gnu packages glib)
28 #:use-module (gnu packages linux)
29 #:use-module (gnu packages pkg-config)
30 #:use-module (gnu packages python)
31 #:use-module (gnu packages readline)
32 #:use-module (gnu packages samba)
33 #:use-module (gnu packages tls)
34 #:use-module (gnu packages vpn))
35
36 (define-public connman
37 (package
38 (name "connman")
39 (version "1.32")
40 (source
41 (origin
42 (method url-fetch)
43 (uri (string-append "mirror://kernel.org/linux/network/connman/"
44 name "-" version ".tar.xz"))
45 (sha256
46 (base32
47 "0k4kw2j78gwxf0rq79a099qkzl6wi4v5i7rfs4rn0si0fd68d19i"))))
48 (build-system gnu-build-system)
49 (arguments
50 `(#:configure-flags
51 (list "--enable-nmcompat"
52 ;; "--enable-polkit"
53 "--enable-openconnect"
54 "--enable-openvpn"
55 "--enable-vpnc"
56 "--enable-pptp"
57 "--enable-l2tp"
58 (string-append
59 "--with-dbusconfdir=" (assoc-ref %outputs "out") "/etc")
60 (string-append
61 "--with-dbusdatadir=" (assoc-ref %outputs "out") "/share"))))
62 (native-inputs
63 `(("pkg-config", pkg-config)
64 ("python" ,python-2)))
65 (inputs
66 `(("dbus" ,dbus)
67 ("glib" ,glib)
68 ("gnutls" ,gnutls)
69 ("iptables" ,iptables)
70 ;; ("polkit" ,polkit) ; pkg-config cannot find polkit.pc
71 ("readline" ,readline)
72 ;; These inputs are needed for connman to include the interface to
73 ;; these technologies so IF they are installed they can be used.
74 ;; TODO: add neard, ofono
75 ("openconnect" ,openconnect)
76 ("openvpn" ,openvpn)
77 ("ppp", ppp)
78 ("vpnc" ,vpnc)
79 ("wpa-supplicant" ,wpa-supplicant)))
80 (home-page "https://01.org/connman")
81 (synopsis "Connection management daemon")
82 (description "Connman provides a daemon for managing Internet connections.
83 The Connection Manager is designed to be slim and to use as few resources as
84 possible. It is fully modular system that can be extended through plug-ins.
85 The plug-in approach allows for easy adaption and modification for various use
86 cases. Connman implements DNS resolving and caching, DHCP clients for both
87 IPv4 and IPv6, link-local IPv4 address handling and tethering (IP connection
88 sharing) to clients via USB, ethernet, WiFi, cellular and Bluetooth.")
89 (license gpl2)))