Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / augeas.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages augeas)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix utils)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages readline)
27 #:use-module (gnu packages pkg-config)
28 #:use-module (gnu packages xml))
29
30 (define-public augeas
31 (package
32 (name "augeas")
33 (version "1.4.0")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append "http://download.augeas.net/augeas-"
37 version ".tar.gz"))
38 (sha256
39 (base32
40 "0c2vncn0afmgwggnqa5s5z7m3zbcc66bi8v9m1h9w0i9q9xax7v5"))))
41 (build-system gnu-build-system)
42 ;; Marked as "required" in augeas.pc
43 (propagated-inputs
44 `(("libxml2" ,libxml2)))
45 (inputs
46 `(("readline" ,readline)))
47 (native-inputs
48 `(("pkg-config" ,pkg-config)))
49 (home-page "http://augeas.net/")
50 (synopsis "Edit configuration files programmatically")
51 (description
52 "Augeas is a library and command line tool for programmatically editing
53 configuration files in a controlled manner. Augeas exposes a tree of all
54 configuration settings and a simple local API for manipulating the tree.
55 Augeas then modifies underlying configuration files according to the changes
56 that have been made to the tree; it does as little modeling of configurations
57 as possible, and focuses exclusivley on transforming the tree-oriented syntax
58 of its public API to the myriad syntaxes of individual configuration files.")
59 (license license:lgpl2.1+)))