Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / abiword.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages abiword)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages autotools)
27 #:use-module (gnu packages boost)
28 #:use-module (gnu packages compression)
29 #:use-module (gnu packages enchant)
30 #:use-module (gnu packages fribidi)
31 #:use-module (gnu packages fontutils)
32 #:use-module (gnu packages glib)
33 #:use-module (gnu packages gnome)
34 #:use-module (gnu packages gtk)
35 #:use-module (gnu packages image)
36 #:use-module (gnu packages ots)
37 #:use-module (gnu packages popt)
38 #:use-module (gnu packages pkg-config)
39 #:use-module (gnu packages readline)
40 #:use-module (gnu packages wv)
41 #:use-module (gnu packages xml))
42
43 (define-public abiword
44 (package
45 (name "abiword")
46 (version "3.0.1")
47 (source
48 (origin
49 (method url-fetch)
50 (uri
51 (string-append "http://abisource.org/downloads/" name "/" version
52 "/source/" name "-" version ".tar.gz"))
53 (sha256
54 (base32 "1ik591rx15nn3n1297cwykl8wvrlgj78i528id9wbidgy3xzd570"))
55 (patches
56 (search-patches "abiword-wmf-version-lookup-fix.patch"
57 "abiword-explictly-cast-bools.patch"))))
58
59 (build-system gnu-build-system)
60 (arguments ;; NOTE: rsvg is disabled, since Abiword
61 `(#:configure-flags ;; supports it directly, and its BS is broken.
62 (list
63 "--enable-clipart" ;; TODO: The following plugins have unresolved
64 "--enable-templates" ;; dependencies: aiksaurus, grammar, wpg, gda,
65 (string-append ;; wordperfect, psion, mathview.
66 "--enable-plugins="
67 "applix " "babelfish " "bmp " "clarisworks " "collab " "command "
68 "docbook " "eml " "epub " "freetranslation " "garble " "gdict "
69 "gimp " "goffice " "google " "hancom " "hrtext " "iscii " "kword "
70 "latex " "loadbindings " "mht " "mif " "mswrite " "opendocument "
71 "openwriter " "openxml " "opml " "ots " "paint " "passepartout "
72 "pdb " "pdf " "presentation " "s5 " "sdw " "t602 " "urldict "
73 "wikipedia " "wmf " "wml " "xslfo"))
74 ;; tests fail with: Gtk-CRITICAL **: gtk_settings_get_for_screen:
75 ;; assertion 'GDK_IS_SCREEN (screen)' failed
76 ;; GLib-GObject-CRITICAL **: g_object_get_qdata:
77 ;; assertion 'G_IS_OBJECT (object)' failed
78 ;; Manually starting the X server before the test phase did not help
79 ;; the tests to pass.
80 #:tests? #f))
81 (inputs
82 `(("boost" ,boost)
83 ("enchant" ,enchant)
84 ("fontconfig" ,fontconfig)
85 ("fribidi" ,fribidi)
86 ("glib" ,glib)
87 ("goffice" ,goffice)
88 ("gtk+" ,gtk+)
89 ("libchamplain" ,libchamplain)
90 ("libglade" ,libglade)
91 ("libgsf" ,libgsf)
92 ("libjpeg" ,libjpeg)
93 ("libpng" ,libpng)
94 ("librsvg" ,librsvg)
95 ("libwmf" ,libwmf)
96 ("libxml2" ,libxml2)
97 ("libxslt" ,libxslt)
98 ("ots" ,ots)
99 ("popt" ,popt)
100 ("readline" ,readline)
101 ("telepathy" ,telepathy-glib)
102 ("wv" ,wv)
103 ("zlib" ,zlib)))
104 (native-inputs
105 `(("intltool" ,intltool)
106 ("glib:bin" ,glib "bin")
107 ("libtool" ,libtool)
108 ("pkg-config" ,pkg-config)))
109 (home-page "http://abisource.org/")
110 (synopsis "Word processing program")
111
112 ;; HACKERS: The comment below is here so that it shows up early in the
113 ;; .pot file.
114
115 ;; TRANSLATORS: Dear translator, We would like to inform you that package
116 ;; descriptions may occasionally include Texinfo markup. Texinfo markup
117 ;; looks like "@code{rm -rf}", "@emph{important}", etc. When translating,
118 ;; please leave markup as is.
119 (description "AbiWord is a word processing program. It is rapidly
120 becoming a state of the art word processor, with lots of features useful for
121 your daily work, personal needs, or for just some good old typing fun.")
122 (license license:gpl2+)))