Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / popt.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2016, 2019 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages popt)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix git-download)
25 #:use-module (guix build-system gnu)
26 #:use-module (guix build-system cmake)
27 #:use-module (guix licenses)
28 #:use-module (gnu packages texinfo))
29
30 (define-public argtable
31 (package
32 (name "argtable")
33 (version "2.13")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append
37 "mirror://sourceforge/argtable/argtable/"
38 "argtable-" version "/argtable"
39 (string-join (string-split version #\.) "-")
40 ".tar.gz"))
41 (sha256
42 (base32
43 "1gyxf4bh9jp5gb3l6g5qy90zzcf3vcpk0irgwbv1lc6mrskyhxwg"))))
44 (build-system gnu-build-system)
45 (home-page "http://argtable.sourceforge.net/")
46 (synopsis "Command line option parsing library")
47 (description
48 "Argtable is an ANSI C library for parsing GNU style command line
49 options. It enables a program's command line syntax to be defined in the
50 source code as an array of argtable structs. The command line is then parsed
51 according to that specification and the resulting values are returned in those
52 same structs where they are accessible to the main program. Both tagged (-v,
53 --verbose, --foo=bar) and untagged arguments are supported, as are multiple
54 instances of each argument. Syntax error handling is automatic and the library
55 also provides the means for generating a textual description of the command
56 line syntax.")
57 (license lgpl2.0+)))
58
59 (define-public popt
60 (package
61 (name "popt")
62 (version "1.16")
63 (source (origin
64 (method url-fetch)
65 ;; The rpm5.org domain does not resolve since 2019-06-13, so we
66 ;; borrow Debians infrastructure for the source download.
67 (uri (list (string-append "https://deb.debian.org/debian/pool/main"
68 "/p/popt/popt_" version ".orig.tar.gz")
69 ;; Keep the old URL around in case it reappears.
70 (string-append "http://rpm5.org/files/popt/popt-"
71 version ".tar.gz")))
72 (sha256
73 (base32
74 "1j2c61nn2n351nhj4d25mnf3vpiddcykq005w2h6kw79dwlysa77"))))
75 (build-system gnu-build-system)
76 (arguments
77 '(#:phases
78 (modify-phases %standard-phases
79 (add-before 'configure 'patch-test
80 (lambda _
81 (substitute* "test-poptrc.in"
82 (("/bin/echo") (which "echo")))
83 (substitute* "testit.sh" ; don't expect old libtool names
84 (("lt-test1") "test1"))
85 #t)))))
86 (home-page "http://rpm5.org/files/popt/")
87 (synopsis "Command line option parsing library")
88 (description
89 "This is the popt(3) command line option parsing library. While it is
90 similar to getopt(3), it contains a number of enhancements, including:
91
92 - popt is fully reentrant;
93
94 - popt can parse arbitrary argv[] style arrays while getopt(3) makes this
95 quite difficult;
96
97 - popt allows users to alias command line arguments;
98
99 - popt provides convience functions for parsing strings into argv[] style
100 arrays.")
101 (license x11)))
102
103 (define-public gflags
104 (package
105 (name "gflags")
106 (version "2.2.2")
107 (source
108 (origin
109 (method git-fetch)
110 (uri (git-reference
111 (url "https://github.com/gflags/gflags.git")
112 (commit (string-append "v" version))))
113 (sha256
114 (base32 "147i3md3nxkjlrccqg4mq1kyzc7yrhvqv5902iibc7znkvzdvlp0"))
115 (file-name (git-file-name name version))))
116 (build-system cmake-build-system)
117 (arguments
118 '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON"
119 "-DBUILD_TESTING=ON")))
120 (home-page "https://gflags.github.io/gflags/")
121 (synopsis "C++ library for command-line argument parsing")
122 (description
123 "Gflags is a C++ library to parse command-line flags. It differs from
124 other such libraries in that command-line flag definitions can be scattered
125 around the source code, and not just listed in one place such as @code{main}.
126 This means that a single source-code file will define and use flags that are
127 meaningful to that file. Any application that links in that file will get the
128 flags, and the gflags library will automatically handle that flag
129 appropriately.")
130 (license bsd-3)))
131
132 (define-public gengetopt
133 (package
134 (name "gengetopt")
135 (version "2.23")
136 (source
137 (origin
138 (method url-fetch)
139 (uri (string-append "mirror://gnu/gengetopt/gengetopt-"
140 version ".tar.xz"))
141 (sha256
142 (base32
143 "1b44fn0apsgawyqa4alx2qj5hls334mhbszxsy6rfr0q074swhdr"))))
144 (build-system gnu-build-system)
145 (arguments
146 `(#:parallel-build? #f ; not supported
147 #:parallel-tests? #f)) ; likewise
148 (native-inputs
149 `(("texinfo" ,texinfo)))
150 (synopsis "Create parsers for command line options")
151 (description
152 "GNU Gengetopt is a program to generate a C/C++ function for parsing
153 command-line options using the getopt_long function found in GNU
154 libc, removing some of the tedium of this task for large programs
155 that accept many options. The options parsed by the generated
156 function may be in both short (e.g., \"-h\") and long (\"--help\")
157 formats, as specified by the GNU coding standards. Additionally, the
158 output of the standard options \"--help\" and \"--version\" is generated
159 automatically.")
160 (home-page "https://www.gnu.org/software/gengetopt/gengetopt.html")
161 (license gpl3+)))