mailmap: Update entries for Nikita.
[jackhill/guix/guix.git] / gnu / packages / tor.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016, 2017, 2018, 2020 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
6 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2017, 2018, 2019 Eric Bavier <bavier@member.fsf.org>
8 ;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
9 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
10 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
11 ;;;
12 ;;; This file is part of GNU Guix.
13 ;;;
14 ;;; GNU Guix is free software; you can redistribute it and/or modify it
15 ;;; under the terms of the GNU General Public License as published by
16 ;;; the Free Software Foundation; either version 3 of the License, or (at
17 ;;; your option) any later version.
18 ;;;
19 ;;; GNU Guix is distributed in the hope that it will be useful, but
20 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
21 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
22 ;;; GNU General Public License for more details.
23 ;;;
24 ;;; You should have received a copy of the GNU General Public License
25 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
26
27 (define-module (gnu packages tor)
28 #:use-module ((guix licenses) #:prefix license:)
29 #:use-module (guix packages)
30 #:use-module (guix download)
31 #:use-module (guix git-download)
32 #:use-module (guix build-system gnu)
33 #:use-module (guix build-system python)
34 #:use-module (gnu packages)
35 #:use-module (gnu packages base)
36 #:use-module (gnu packages libevent)
37 #:use-module (gnu packages linux)
38 #:use-module (gnu packages check)
39 #:use-module (gnu packages compression)
40 #:use-module (gnu packages pcre)
41 #:use-module (gnu packages pkg-config)
42 #:use-module (gnu packages python)
43 #:use-module (gnu packages python-crypto)
44 #:use-module (gnu packages python-web)
45 #:use-module (gnu packages python-xyz)
46 #:use-module (gnu packages qt)
47 #:use-module (gnu packages autotools)
48 #:use-module (gnu packages tls)
49 #:use-module (gnu packages w3m))
50
51 (define-public tor
52 (package
53 (name "tor")
54 (version "0.4.2.7")
55 (source (origin
56 (method url-fetch)
57 (uri (string-append "https://dist.torproject.org/tor-"
58 version ".tar.gz"))
59 (sha256
60 (base32
61 "0v82ngwwmmcb7i9563bgsmrjy6xp83xyhqhaljygd0pkvlsxi886"))))
62 (build-system gnu-build-system)
63 (native-inputs
64 `(("pkg-config" ,pkg-config)
65 ("python" ,python-2))) ; for tests
66 (inputs
67 `(("zlib" ,zlib)
68 ("openssl" ,openssl)
69 ("libevent" ,libevent)
70 ("libseccomp" ,libseccomp)
71 ("xz" ,xz)
72 ("zstd" ,zstd "lib")))
73 (home-page "https://www.torproject.org/")
74 (synopsis "Anonymous network router to improve privacy on the Internet")
75 (description
76 "Tor protects you by bouncing your communications around a distributed
77 network of relays run by volunteers all around the world: it prevents
78 somebody watching your Internet connection from learning what sites you
79 visit, and it prevents the sites you visit from learning your physical
80 location. Tor works with many of your existing applications, including
81 web browsers, instant messaging clients, remote login, and other
82 applications based on the TCP protocol.
83
84 To @code{torify} applications (to take measures to ensure that an application,
85 which has not been designed for use with Tor such as ssh, will use only Tor for
86 internet connectivity, and also ensures that there are no leaks from DNS, UDP or
87 the application layer) you need to install @code{torsocks}.")
88 (license license:bsd-3)))
89
90 (define-public torsocks
91 (package
92 (name "torsocks")
93 (version "2.3.0")
94 (source (origin
95 (method url-fetch)
96 (uri (string-append "https://people.torproject.org/~dgoulet/"
97 "torsocks/torsocks-" version ".tar.xz"))
98 (sha256
99 (base32
100 "08inrkap29gikb6sdmb58z43hw4abwrfw7ny40c4xzdkss0vkwdr"))))
101 (build-system gnu-build-system)
102 (inputs
103 `(("libcap" ,libcap)))
104 (arguments
105 `(#:phases (modify-phases %standard-phases
106 (add-after 'build 'absolutize
107 (lambda* (#:key inputs #:allow-other-keys)
108 (substitute* "src/bin/torsocks"
109 (("getcap=.*")
110 (string-append "getcap=" (which "getcap") "\n")))
111 #t)))))
112 (home-page "https://www.torproject.org/")
113 (synopsis "Use socks-friendly applications with Tor")
114 (description
115 "Torsocks allows you to use most socks-friendly applications in a safe
116 way with Tor. It ensures that DNS requests are handled safely and explicitly
117 rejects UDP traffic from the application you're using.")
118
119 ;; All the files explicitly say "version 2 only".
120 (license license:gpl2)))
121
122 (define-public privoxy
123 (package
124 (name "privoxy")
125 (version "3.0.28")
126 (source (origin
127 (method url-fetch)
128 (uri (string-append "mirror://sourceforge/ijbswa/Sources/"
129 version "%20%28stable%29/privoxy-"
130 version "-stable-src.tar.gz"))
131 (sha256
132 (base32
133 "0jl2yav1qzqnaqnnx8i6i53ayckkimcrs3l6ryvv7bda6v08rmxm"))))
134 (build-system gnu-build-system)
135 (arguments
136 '(;; The default 'sysconfdir' is $out/etc; change that to
137 ;; $out/etc/privoxy.
138 #:configure-flags (list (string-append "--sysconfdir="
139 (assoc-ref %outputs "out")
140 "/etc/privoxy"))
141 #:tests? #f))
142 (inputs
143 `(("w3m" ,w3m)
144 ("pcre" ,pcre)
145 ("zlib" ,zlib)))
146 (native-inputs
147 `(("autoconf" ,autoconf)
148 ("automake" ,automake)))
149 (home-page "https://www.privoxy.org")
150 (synopsis "Web proxy with advanced filtering capabilities for enhancing privacy")
151 (description
152 "Privoxy is a non-caching web proxy with advanced filtering capabilities
153 for enhancing privacy, modifying web page data and HTTP headers, controlling
154 access, and removing ads and other obnoxious Internet junk. Privoxy has a
155 flexible configuration and can be customized to suit individual needs and
156 tastes. It has application for both stand-alone systems and multi-user
157 networks.")
158 (license license:gpl2+)))
159
160 (define-public onionshare
161 (package
162 (name "onionshare")
163 (version "2.2")
164 (source
165 (origin
166 (method git-fetch)
167 (uri (git-reference
168 (url "https://github.com/micahflee/onionshare.git")
169 (commit (string-append "v" version))))
170 (file-name (git-file-name name version))
171 (sha256
172 (base32 "0m8ygxcyp3nfzzhxs2dfnpqwh1vx0aws44lszpnnczz4fks3a5j4"))))
173 (build-system python-build-system)
174 (arguments
175 `(#:phases
176 (modify-phases %standard-phases
177 (add-after 'unpack 'fix-install-path
178 (lambda* (#:key outputs #:allow-other-keys)
179 (let* ((out (assoc-ref outputs "out"))
180 (onionshare (string-append out "/share/onionshare")))
181 (substitute* '("setup.py" "onionshare/common.py")
182 (("sys.prefix,") (string-append "'" out "',")))
183 (substitute* "setup.py"
184 ;; For the nautilus plugin.
185 (("/usr/share/nautilus") "share/nautilus"))
186 (substitute* "install/org.onionshare.OnionShare.desktop"
187 (("/usr") out))
188 #t)))
189 (delete 'check)
190 (add-before 'strip 'check
191 ;; After all the patching we run the tests after installing.
192 (lambda _
193 (setenv "HOME" "/tmp") ; Some tests need a writable homedir
194 (invoke "pytest" "tests/")
195 #t)))))
196 (native-inputs
197 `(("python-pytest" ,python-pytest)))
198 (inputs
199 `(("python-pycrypto" ,python-pycrypto)
200 ("python-flask" ,python-flask)
201 ("python-flask-httpauth" ,python-flask-httpauth)
202 ("python-nautilus" ,python-nautilus)
203 ("python-sip" ,python-sip)
204 ("python-stem" ,python-stem)
205 ("python-pysocks" ,python-pysocks)
206 ("python-pyqt" ,python-pyqt)))
207 (home-page "https://onionshare.org/")
208 (synopsis "Securely and anonymously share files")
209 (description "OnionShare is a tool for securely and anonymously sending
210 and receiving files using Tor onion services. It works by starting a web
211 server directly on your computer and making it accessible as an unguessable
212 Tor web address that others can load in a Tor-enabled web browser to download
213 files from you, or upload files to you. It doesn't require setting up a
214 separate server, using a third party file-sharing service, or even logging
215 into an account.")
216 ;; Bundled, minified jquery is expat licensed.
217 (license (list license:gpl3+ license:expat))))
218
219 (define-public nyx
220 (package
221 (name "nyx")
222 (version "2.1.0")
223 (source
224 (origin
225 (method url-fetch)
226 (uri (pypi-uri name version))
227 (sha256
228 (base32
229 "02rrlllz2ci6i6cs3iddyfns7ang9a54jrlygd2jw1f9s6418ll8"))))
230 (build-system python-build-system)
231 (inputs
232 `(("python-stem" ,python-stem)))
233 (arguments
234 `(#:phases
235 (modify-phases %standard-phases
236 (add-after 'install 'install-man-page
237 (lambda* (#:key outputs #:allow-other-keys)
238 (let* ((out (assoc-ref outputs "out"))
239 (man (string-append out "/share/man")))
240 (install-file "nyx.1" (string-append man "/man1"))
241 #t)))
242 (add-after 'install 'install-sample-configuration
243 (lambda* (#:key outputs #:allow-other-keys)
244 (let* ((out (assoc-ref outputs "out"))
245 (doc (string-append out "/share/doc/" ,name "-" ,version)))
246 (install-file "web/nyxrc.sample" doc)
247 #t))))
248 ;; XXX The tests seem to require more of a real terminal than the build
249 ;; environment provides:
250 ;; _curses.error: setupterm: could not find terminal
251 ;; With TERM=linux, the tests try to move the cursor and still fail:
252 ;; _curses.error: cbreak() returned ERR
253 #:tests? #f))
254 (home-page "https://nyx.torproject.org/")
255 (synopsis "Tor relay status monitor")
256 (description
257 "Nyx monitors the performance of relays participating in the
258 @uref{https://www.torproject.org/, Tor anonymity network}. It displays this
259 information visually and in real time, using a curses-based terminal interface.
260 This makes Nyx well-suited for remote shell connections and servers without a
261 graphical display. It's like @command{top} for Tor, providing detailed
262 statistics and status reports on:
263
264 @enumerate
265 @item connections (with IP address, hostname, fingerprint, and consensus data),
266 @item bandwidth, processor, and memory usage,
267 @item the relay's current configuration,
268 @item logged events,
269 @item and much more.
270 @end enumerate
271
272 Potential client and exit connections are scrubbed of sensitive information.")
273 (license license:gpl3+)))