gnu: snorenotify: Update inputs.
[jackhill/guix/guix.git] / gnu / packages / kde.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
4 ;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
5 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
7 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
8 ;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages kde)
26 #:use-module (guix build-system cmake)
27 #:use-module (guix download)
28 #:use-module (guix git-download)
29 #:use-module ((guix licenses) #:prefix license:)
30 #:use-module (guix packages)
31 #:use-module (guix utils)
32 #:use-module (gnu packages algebra)
33 #:use-module (gnu packages apr)
34 #:use-module (gnu packages boost)
35 #:use-module (gnu packages compression)
36 #:use-module (gnu packages curl)
37 #:use-module (gnu packages documentation)
38 #:use-module (gnu packages gettext)
39 #:use-module (gnu packages ghostscript)
40 #:use-module (gnu packages gl)
41 #:use-module (gnu packages gnome)
42 #:use-module (gnu packages graphics)
43 #:use-module (gnu packages image)
44 #:use-module (gnu packages kde-frameworks)
45 #:use-module (gnu packages kde-plasma)
46 #:use-module (gnu packages llvm)
47 #:use-module (gnu packages maths)
48 #:use-module (gnu packages pdf)
49 #:use-module (gnu packages perl)
50 #:use-module (gnu packages photo)
51 #:use-module (gnu packages pkg-config)
52 #:use-module (gnu packages python)
53 #:use-module (gnu packages tls)
54 #:use-module (gnu packages qt)
55 #:use-module (gnu packages version-control)
56 #:use-module (gnu packages video)
57 #:use-module (gnu packages xdisorg)
58 #:use-module (gnu packages xorg))
59
60 (define-public kdenlive
61 (let ((version "18.08.1"))
62 (package
63 (name "kdenlive")
64 (version version)
65 (source
66 (origin
67 (method git-fetch)
68 (uri (git-reference
69 (url "git://anongit.kde.org/kdenlive.git")
70 (commit (string-append "v" version))))
71 (file-name (string-append name "-" version "-checkout"))
72 (sha256
73 (base32
74 "0ifnaclsz7w08mc485i3j1kkcpd1m8q5qamckrfwc375ac13xf4g"))))
75 (build-system cmake-build-system)
76 (native-inputs
77 `(("extra-cmake-modules" ,extra-cmake-modules)
78 ("qttools" ,qttools)))
79 (propagated-inputs
80 `(("mlt" ,mlt)))
81 (inputs
82 `(("shared-mime-info" ,shared-mime-info)
83 ("frei0r-plugins" ,frei0r-plugins)
84 ("qtbase" ,qtbase)
85 ("qtscript" ,qtscript)
86 ("qtsvg" ,qtsvg)
87 ("kparts" ,kparts)
88 ("knotifications" ,knotifications)
89 ("karchive" ,karchive)
90 ("kdbusaddons" ,kdbusaddons)
91 ("kcrash" ,kcrash)
92 ("kguiaddons" ,kguiaddons)
93 ("knewstuff" ,knewstuff)
94 ("knotifyconfig" ,knotifyconfig)
95 ("kfilemetadata" ,kfilemetadata)
96 ("kdoctools" ,kdoctools)
97 ("kdeclarative" ,kdeclarative)
98 ("qtdeclarative" ,qtdeclarative)
99 ("qtquickcontrols" ,qtquickcontrols)
100 ("kiconthemes" ,kiconthemes)
101 ("qtgraphicaleffects" ,qtgraphicaleffects)
102 ("kplotting" ,kplotting)))
103 (arguments
104 `(#:phases
105 (modify-phases %standard-phases
106 (add-after 'install 'wrap-executable
107 (lambda* (#:key inputs outputs #:allow-other-keys)
108 (let* ((out (assoc-ref outputs "out"))
109 (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
110 (qtbase (assoc-ref inputs "qtbase"))
111 (qtdeclarative (assoc-ref inputs "qtdeclarative"))
112 (frei0r (assoc-ref inputs "frei0r-plugins"))
113 (qml "/lib/qt5/qml"))
114 (wrap-program (string-append out "/bin/kdenlive")
115 `("QT_PLUGIN_PATH" ":" prefix
116 ,(map (lambda (label)
117 (string-append (assoc-ref inputs label)
118 "/lib/qt5/plugins/"))
119 '("qtbase" "qtsvg")))
120 `("FREI0R_PATH" ":" =
121 (,(string-append frei0r "/lib/frei0r-1/")))
122 `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
123 (,(string-append qtbase "/lib/qt5/plugins/platforms")))
124 `("QML2_IMPORT_PATH" ":" prefix
125 (,(string-append qtquickcontrols qml)
126 ,(string-append qtdeclarative qml)))))
127 #t)))))
128 (home-page "https://kdenlive.org")
129 (synopsis "Non-linear video editor")
130 (description "Kdenlive is an acronym for KDE Non-Linear Video Editor.
131
132 Non-linear video editing is much more powerful than beginner's (linear)
133 editors, hence it requires a bit more organization before starting. However,
134 it is not reserved to specialists and can be used for small personal
135 projects.")
136 (license license:gpl2+))))
137
138 (define-public kdevelop
139 (package
140 (name "kdevelop")
141 (version "5.1.2")
142 (source
143 (origin
144 (method url-fetch)
145 (uri (string-append "mirror://kde/stable/kdevelop"
146 "/" version "/src/kdevelop-"
147 version ".tar.xz"))
148 (sha256
149 (base32
150 "1iqaq0ilijjigqb34v5wq9in6bnjs0p9cmgbygjmy53xhh3yhm5g"))))
151 (build-system cmake-build-system)
152 (native-inputs
153 `(("extra-cmake-modules" ,extra-cmake-modules)
154 ("pkg-config" ,pkg-config)
155 ("qttools" ,qttools)))
156 (inputs
157 `(("kdevplatform" ,kdevplatform)
158 ("kdevelop-pg-qt" ,kdevelop-pg-qt)
159 ("qtbase" ,qtbase)
160 ("qtdeclarative" ,qtdeclarative)
161 ("qtquickcontrols" ,qtquickcontrols)
162 ("qtwebkit" ,qtwebkit)
163 ("karchive" ,karchive)
164 ("kcmutils" ,kcmutils)
165 ("kconfig" ,kconfig)
166 ("kdeclarative" ,kdeclarative)
167 ("kdoctools" ,kdoctools)
168 ("kguiaddons" ,kguiaddons)
169 ("ki18n" ,ki18n)
170 ("kio" ,kio)
171 ("kiconthemes" ,kiconthemes)
172 ("kitemmodels" ,kitemmodels)
173 ("kitemviews" ,kitemviews)
174 ("kjobwidgets" ,kjobwidgets)
175 ("knotifyconfig" ,knotifyconfig)
176 ("knotifications" ,knotifications)
177 ("kparts" ,kparts)
178 ("kcrash" ,kcrash)
179 ("knewstuff" ,knewstuff)
180 ("krunner" ,krunner)
181 ("kxmlgui" ,kxmlgui)
182 ("libksysguard" ,libksysguard)
183 ("threadweaver" ,threadweaver)
184 ("ktexteditor" ,ktexteditor)
185 ("kwindowsystem" ,kwindowsystem)
186 ("plasma" ,plasma-framework)
187 ("grantlee" ,grantlee)
188 ("libepoxy" ,libepoxy)
189 ("clang" ,clang)
190 ("shared-mime-info" ,shared-mime-info)))
191 (arguments
192 `(#:phases
193 (modify-phases %standard-phases
194 (delete 'check) ;; there are some issues with the test suite
195 (add-after 'install 'wrap-executable
196 (lambda* (#:key inputs outputs #:allow-other-keys)
197 (let* ((out (assoc-ref outputs "out"))
198 (kdevplatform (assoc-ref inputs "kdevplatform"))
199 (kio (assoc-ref inputs "kio"))
200 (kcmutils (assoc-ref inputs "kcmutils"))
201 (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
202 (qtbase (assoc-ref inputs "qtbase"))
203 (qtdeclarative (assoc-ref inputs "qtdeclarative"))
204 (qml "/qml"))
205 (wrap-program (string-append out "/bin/kdevelop")
206 `("XDG_DATA_DIRS" ":" prefix
207 ,(map (lambda (s) (string-append s "/share"))
208 (list out kdevplatform kcmutils)))
209 `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
210 (,(string-append qtbase "/plugins/platforms")))
211 `("QT_PLUGIN_PATH" ":" prefix
212 ,(map (lambda (s) (string-append s "/lib/plugins"))
213 (list out kdevplatform kio)))
214 `("QML2_IMPORT_PATH" ":" prefix
215 (,(string-append qtquickcontrols qml)
216 ,(string-append qtdeclarative qml))))))))))
217 (home-page "https://kdevelop.org")
218 (synopsis "IDE for C, C++, Python, Javascript and PHP")
219 (description "The KDevelop IDE provides semantic syntax highlighting, as
220 well as code navigation and completion for C, C++ (using Clang/LLVM), QML,
221 JavaScript, Python and PHP. It also integrates with a debugger, different
222 build systems (CMake, QMake, custom Makefiles) and version control
223 software (Git, Subversion, Mercurial, CVS and Bazaar).")
224 (license license:lgpl2.1+)))
225
226 (define-public kdevelop-pg-qt
227 (package
228 (name "kdevelop-pg-qt")
229 (version "2.0.0")
230 (source
231 (origin
232 (method url-fetch)
233 (uri (string-append "https://github.com/KDE/kdevelop-pg-qt/archive/v"
234 version ".tar.gz"))
235 (file-name (string-append name "-" version ".tar.gz"))
236 (sha256
237 (base32 "1av8plqz7hyhrd07avnmn6ryslqlarmxn0pw7swzvb6ddiqp59j4"))))
238 (native-inputs
239 `(("extra-cmake-modules" ,extra-cmake-modules)))
240 (inputs
241 `(("qtbase" ,qtbase)))
242 (build-system cmake-build-system)
243 (home-page "https://kde.org")
244 (synopsis "Parser generator library for KDevplatform")
245 (description "KDevelop-PG-Qt is the parser generator used in KDevplatform
246 for some KDevelop language plugins (Ruby, PHP, CSS...).")
247 (license license:lgpl2.0+)))
248
249 (define-public kdevplatform
250 (package
251 (name "kdevplatform")
252 (version "5.1.2")
253 (source (origin
254 (method url-fetch)
255 (uri (string-append "mirror://kde/stable/kdevelop"
256 "/" version "/src/kdevplatform-"
257 version ".tar.xz"))
258 (sha256
259 (base32
260 "0jk6g1kiqpyjy8pca0236b9944gxqnymqv8ny6m8nrraannxs8p6"))))
261 (build-system cmake-build-system)
262 (native-inputs
263 `(("extra-cmake-modules" ,extra-cmake-modules)
264 ("pkg-config" ,pkg-config)))
265 (inputs
266 `(("apr" ,apr)
267 ("apr-util" ,apr-util)
268 ("boost" ,boost)
269 ("karchive" ,karchive)
270 ("kconfigwidgets" ,kconfigwidgets)
271 ("kcmutils" ,kcmutils)
272 ("kiconthemes" ,kiconthemes)
273 ("kdeclarative" ,kdeclarative)
274 ("kdoctools" ,kdoctools)
275 ("kguiaddons" ,kguiaddons)
276 ("kinit" ,kinit)
277 ("kitemmodels" ,kitemmodels)
278 ("knewstuff" ,knewstuff)
279 ("knotifications" ,knotifications)
280 ("knotifyconfig" ,knotifyconfig)
281 ("kwindowsystem" ,kwindowsystem)
282 ("kio" ,kio)
283 ("ki18n" ,ki18n)
284 ("kparts" ,kparts)
285 ("kservice" ,kservice)
286 ("grantlee" ,grantlee)
287 ("libkomparediff2" ,libkomparediff2)
288 ("sonnet" ,sonnet)
289 ("threadweaver" ,threadweaver)
290 ("ktexteditor" ,ktexteditor)
291 ("qtbase" ,qtbase)
292 ("qtdeclarative" ,qtdeclarative)
293 ("qtscript" ,qtscript)
294 ("qtwebkit" ,qtwebkit)
295 ("qtx11extras" ,qtx11extras)
296 ("plasma" ,plasma-framework)
297 ("subversion" ,subversion)
298 ("zlib" ,zlib)))
299 (arguments
300 `(#:phases
301 (modify-phases %standard-phases
302 (delete 'check)
303 (add-after 'install 'check
304 (lambda* (#:key outputs #:allow-other-keys)
305 (let ((out (assoc-ref outputs "out")))
306 (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
307 (setenv "QT_PLUGIN_PATH"
308 (string-append out "/lib/plugins:"
309 (getenv "QT_PLUGIN_PATH")))
310 (setenv "XDG_DATA_DIRS"
311 (string-append out "/share:"
312 (getenv "XDG_DATA_DIRS")))
313 (invoke "ctest" "-R" ; almost all tests require a display
314 "filteringstrategy|kdevvarlengtharray|kdevhash")))))))
315 (home-page "https://github.com/KDE/kdevplatform")
316 (synopsis "Framework to build integrated development environments (IDEs)")
317 (description "KDevPlatform is the basis of KDevelop and contains some
318 plugins, as well as code to create plugins, or complete applications.")
319 (license license:gpl3+)))
320
321 (define-public krita
322 (package
323 (name "krita")
324 (version "4.2.5")
325 (source (origin
326 (method url-fetch)
327 (uri (string-append
328 "mirror://kde/stable/krita/"
329 (version-prefix version 3)
330 "/krita-" version ".tar.gz"))
331 (sha256
332 (base32
333 "1f14r2mrqasl6nr3sss0xy2h8xlxd5wdcjcd64m9nz2gwlm39r7w"))))
334 (build-system cmake-build-system)
335 (arguments
336 `(#:tests? #f
337 #:configure-flags
338 (list "-DBUILD_TESTING=OFF"
339 (string-append "-DCMAKE_CXX_FLAGS=-I"
340 (assoc-ref %build-inputs "ilmbase")
341 "/include/OpenEXR"))
342 #:phases
343 (modify-phases %standard-phases
344 ;; Ensure that icons are found at runtime.
345 ;; This works around <https://bugs.gnu.org/22138>.
346 (add-after 'install 'wrap-executable
347 (lambda* (#:key inputs outputs #:allow-other-keys)
348 (let ((out (assoc-ref outputs "out"))
349 (qt '("qtbase" "qtsvg")))
350 (wrap-program (string-append out "/bin/krita")
351 `("QT_PLUGIN_PATH" ":" prefix
352 ,(map (lambda (label)
353 (string-append (assoc-ref inputs label)
354 "/lib/qt5/plugins/"))
355 qt)))
356 #t))))))
357 (native-inputs
358 `(("curl" ,curl)
359 ("eigen" ,eigen)
360 ("extra-cmake-modules" ,extra-cmake-modules)
361 ("gettext-minimal" ,gettext-minimal)
362 ("kitemmodels" ,kitemmodels)
363 ("pkg-config" ,pkg-config)
364 ("qwt" ,qwt)
365 ("vc" ,vc)))
366 (inputs
367 `(("boost" ,boost)
368 ("exiv2" ,exiv2)
369 ("fftw" ,fftw)
370 ("gsl" ,gsl)
371 ("ilmbase" ,ilmbase)
372 ("karchive" ,karchive)
373 ("kcompletion" ,kcompletion)
374 ("kconfig" ,kconfig)
375 ("kcoreaddons" ,kcoreaddons)
376 ("kcrash" ,kcrash)
377 ("kguiaddons" ,kguiaddons)
378 ("ki18n" ,ki18n)
379 ("kiconthemes" ,kiconthemes)
380 ("kio" ,kio)
381 ("kitemviews" ,kitemviews)
382 ("kwidgetsaddons" ,kwidgetsaddons)
383 ("kwindowsystem" ,kwindowsystem)
384 ("kxmlgui" ,kxmlgui)
385 ("lcms" ,lcms)
386 ("libjpeg-turbo" ,libjpeg-turbo)
387 ("libpng" ,libpng)
388 ("libraw" ,libraw-0.18)
389 ("libtiff" ,libtiff)
390 ("libx11" ,libx11)
391 ("libxcb" ,libxcb)
392 ("libxi" ,libxi)
393 ("openexr" ,openexr)
394 ("perl" ,perl)
395 ("poppler-qt5" ,poppler-qt5)
396 ("qtbase" ,qtbase)
397 ("qtdeclarative" ,qtdeclarative)
398 ("qtmultimedia" ,qtmultimedia)
399 ("qtsvg" ,qtsvg)
400 ("qtx11extras" ,qtx11extras)
401 ("quazip" ,quazip)
402 ("zlib" ,zlib)))
403 (home-page "https://krita.org")
404 (synopsis "Digital painting application")
405 (description
406 "Krita is a professional painting tool designed for concept artists,
407 illustrators, matte and texture artists, and the VFX industry. Notable
408 features include brush stabilizers, brush engines and wrap-around mode.")
409 (license license:gpl2+)))
410
411 (define-public kholidays
412 (package
413 (name "kholidays")
414 (version "17.12.1")
415 (source
416 (origin
417 (method url-fetch)
418 (uri (string-append
419 "mirror://kde/stable/applications/" version "/src/"
420 name "-" version ".tar.xz"))
421 (sha256
422 (base32 "0595d7wbnz8kyq1bnivdrp20lwdp8ykvdll1fmb0fgm4q24z0cl8"))))
423 (build-system cmake-build-system)
424 (arguments
425 `(#:phases
426 (modify-phases %standard-phases
427 (add-before 'check 'check-setup
428 (lambda _
429 ;; blacklist a failing test function TODO: make it pass
430 (with-output-to-file "autotests/BLACKLIST"
431 (lambda _
432 (display "[testDefaultRegions]\n*\n")))
433 #t)))))
434 (native-inputs
435 `(("extra-cmake-modules" ,extra-cmake-modules)
436 ("qttools" ,qttools)))
437 (inputs
438 `(("qtbase" ,qtbase)
439 ("qtdeclarative" ,qtdeclarative)))
440 (home-page "https://cgit.kde.org/kholidays.git")
441 (synopsis "Library for regional holiday information")
442 (description "This library provides a C++ API that determines holiday and
443 other special events for a geographical region.")
444 (license license:lgpl2.0+)))
445
446 (define-public libkomparediff2
447 (package
448 (name "libkomparediff2")
449 (version "19.04.1")
450 (source
451 (origin
452 (method url-fetch)
453 (uri (string-append "mirror://kde/stable/applications/" version
454 "/src/libkomparediff2-" version ".tar.xz"))
455 (sha256
456 (base32 "1cyi7a5ss7jv87llk0k8c9g3h1qsp6j6nmdzh3xxcswr4p5skc9a"))))
457 (native-inputs
458 `(("extra-cmake-modules" ,extra-cmake-modules)
459 ("pkg-config" ,pkg-config)))
460 (inputs
461 `(("kcodecs" ,kcodecs)
462 ("kconfig" ,kconfig)
463 ("kcoreaddons" ,kcoreaddons)
464 ("ki18n" ,ki18n)
465 ("kio" ,kio)
466 ("kxmlgui" ,kxmlgui)
467 ("qtbase" ,qtbase)))
468 (build-system cmake-build-system)
469 (home-page "https://kde.org")
470 (synopsis "Library to compare files and strings, used in Kompare and KDevelop")
471 (description "Libkomparediff2 is a library to work with diffs and patches,
472 used in KDE development tools Kompare and KDevelop.")
473
474 ;; GPL, some files are also licensed under LGPL or BSD, see COPYING in the
475 ;; source archive
476 (license (list license:gpl2+ license:lgpl2.0+ license:bsd-3))))
477
478 (define-public qca
479 (package
480 (name "qca")
481 (version "2.2.1")
482 (source
483 (origin
484 (method url-fetch)
485 (uri (string-append "mirror://kde/stable/qca/" version
486 "/qca-" version ".tar.xz"))
487 (sha256
488 (base32
489 "00kv1vsrc8fp556hm8s6yw3240vx3l4067q6vfxrb3gdwgcd45np"))))
490 (build-system cmake-build-system)
491 (native-inputs
492 `(("pkg-config" ,pkg-config)))
493 (inputs
494 `(("openssl" ,openssl)
495 ("qtbase" ,qtbase)))
496 (home-page "https://userbase.kde.org/QCA")
497 (synopsis "Libraries for the Qt Cryptographic Architecture")
498 (description "The Qt Cryptographic Architecture (QCA) provides a
499 straightforward and cross-platform API for a range of cryptographic features,
500 including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
501 cards.")
502 (license license:lgpl2.1)))
503
504 (define-public snorenotify
505 (package
506 (name "snorenotify")
507 (version "0.7.0")
508 (source
509 (origin
510 (method url-fetch)
511 (uri (string-append "mirror://kde/stable/snorenotify/"
512 version "/src/snorenotify-" version ".tar.xz"))
513 (sha256
514 (base32
515 "0jz6ivk90h7iwgyxar7xzzj8yvzn6s1my6cqs9bdnwqswfk1nhbd"))))
516 (build-system cmake-build-system)
517 (arguments
518 `(#:tests? #f)) ; both tests fail, require display
519 (inputs
520 `(("qtbase" ,qtbase)))
521 (native-inputs
522 `(("extra-cmake-modules" ,extra-cmake-modules)
523 ("qttools" ,qttools)))
524 (home-page "https://techbase.kde.org/Projects/Snorenotify")
525 (synopsis "Qt notification framework")
526 (description "Snorenotify is a multi platform Qt notification framework.
527 Using a plugin system it is possible to create notifications with many
528 different notification systems.")
529 (license license:lgpl3)))
530
531 (define-public kdeconnect
532 (package
533 (name "kdeconnect")
534 (version "1.3.5")
535 (source
536 (origin
537 (method url-fetch)
538 (uri (string-append "mirror://kde/stable/kdeconnect/"
539 version "/kdeconnect-kde-"
540 version ".tar.xz"))
541 (sha256
542 (base32
543 "02lr3xx5s2mgddac4n3lkgr7ppf1z5m6ajs90rjix0vs8a271kp5"))))
544 (build-system cmake-build-system)
545 (arguments
546 `(#:configure-flags '("-DBUILD_TESTING=ON")
547 #:tests? #f ; tests fail hard in our build environment
548 #:modules ((guix build cmake-build-system)
549 (guix build qt-utils)
550 (guix build utils))
551 #:imported-modules (,@%cmake-build-system-modules
552 (guix build qt-utils))
553 #:phases
554 (modify-phases %standard-phases
555 (add-before 'check 'check-setup
556 (lambda _
557 (setenv "QT_QPA_PLATFORM" "offscreen")
558 #t))
559 (add-after 'install 'wrap-executable
560 (lambda* (#:key outputs #:allow-other-keys)
561 (let ((out (assoc-ref outputs "out")))
562 (wrap-qt-program out "../lib/libexec/kdeconnectd")
563 (wrap-qt-program out "kdeconnect-cli")
564 (wrap-qt-program out "kdeconnect-handler")
565 (wrap-qt-program out "kdeconnect-indicator"))
566 #t)))))
567 (native-inputs
568 `(("extra-cmake-modules" ,extra-cmake-modules)
569 ("kdoctools" ,kdoctools)
570 ("libxtst" ,libxtst)
571 ("pkg-config" ,pkg-config)
572 ("python" ,python-wrapper)))
573 (inputs
574 `(("kcmutils" ,kcmutils)
575 ("kconfigwidgets" ,kconfigwidgets)
576 ("kdbusaddons" ,kdbusaddons)
577 ("ki18n" ,ki18n)
578 ("kiconthemes" ,kiconthemes)
579 ("kio" ,kio)
580 ("knotifications" ,knotifications)
581 ("kwayland" ,kwayland)
582 ("libfakekey" ,libfakekey)
583 ("qca" ,qca)
584 ("qtbase" ,qtbase)
585 ("qtdeclarative" ,qtdeclarative)
586 ("qtx11extras" ,qtx11extras)))
587 (home-page "https://community.kde.org/KDEConnect")
588 (synopsis "Enable your devices to communicate with each other")
589 (description "KDE Connect is a project that enables all your devices to
590 communicate with each other. Here's a few things KDE Connect can do:
591 @enumerate
592 @item Receive your phone notifications on your desktop computer and reply to messages
593 @item Control music playing on your desktop from your phone
594 @item Use your phone as a remote control for your desktop
595 @item Run predefined commands on your PC from connected devices
596 @item Check your phones battery level from the desktop
597 @item Ring your phone to help finding it
598 @item Share files and links between devices
599 @item Browse your phone from the desktop
600 @item Control the desktop's volume from the phone
601 @end enumerate")
602 (properties `((upstream-name . "kdeconnect-kde")))
603 (license (list license:gpl2 license:gpl3)))) ; dual licensed
604
605 (define-public kqtquickcharts
606 (package
607 (name "kqtquickcharts")
608 (version "19.08.1")
609 (source
610 (origin
611 (method url-fetch)
612 (uri (string-append "mirror://kde/stable/applications/"
613 version "/src/kqtquickcharts-" version ".tar.xz"))
614 (sha256
615 (base32
616 "1j3rivvh4sa94lsd0hi4xfvcikl05zrqd7634wxyaxs718ais6dg"))))
617 (build-system cmake-build-system)
618 (native-inputs
619 `(("extra-cmake-modules" ,extra-cmake-modules)))
620 (inputs
621 `(("qtbase" ,qtbase)
622 ("qtdeclarative" ,qtdeclarative)))
623 (home-page "https://phabricator.kde.org/source/kqtquickcharts/")
624 (synopsis "Interactive charts for Qt Quick")
625 (description
626 "Kqtquickcharts is a QtQuick plugin to render beautiful and interactive
627 charts.")
628 (license license:lgpl2.1+)))
629
630 (define-public kcachegrind
631 (package
632 (name "kcachegrind")
633 (version "19.04.1")
634 (source (origin
635 (method url-fetch)
636 (uri (string-append "mirror://kde/stable/applications/" version
637 "/src/kcachegrind-" version ".tar.xz"))
638 (sha256
639 (base32
640 "1hhsk64yp6q2xh8j269j4wp9y24ggmii861r6gf02mj1mbn2p1jb"))))
641 (build-system cmake-build-system)
642 (native-inputs
643 `(("extra-cmake-modules" ,extra-cmake-modules)
644 ("perl" ,perl)
645 ("python" ,python)
646 ("qttools" ,qttools)
647 ("kdoctools" ,kdoctools)))
648 (inputs
649 `(("qtbase" ,qtbase)
650 ("karchive" ,karchive)
651 ("ki18n" ,ki18n)
652 ("kio" ,kio)
653 ("kdbusaddons" ,kdbusaddons)))
654 ;; Note: The 'hotshot2calltree' and 'pprof2calltree' scripts depend on
655 ;; Python and PHP, respectively. These are optional and we ignore them
656 ;; for now.
657 (home-page "https://kcachegrind.github.io/html/Home.html")
658 (synopsis "Visualize profiles produces by Valgrind's Cachegrind tool")
659 (description
660 "The data files generated by the Callgrind of Valgrind, an application
661 profiler, can be loaded into KCachegrind for browsing the performance results.
662 There is also a command-line tool to get ASCII reports from data files without
663 the need to use KCachegrind.
664
665 The format of Callgrind output is documented. With conversion scripts,
666 KCachegrind is able to visualize output of other profilers like OProfile, a
667 system-wide profiler for Linux using statistical sampling with hardware
668 performance counters. There also exist converters for profiling output of
669 Python, PHP, and Perl.")
670 (license license:gpl2)))