gnu: openbox: Update to 3.6.1.
[jackhill/guix/guix.git] / gnu / packages / openbox.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Julien Lepiller <julien@lepiller.eu>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages openbox)
21 #:use-module ((guix licenses) #:select (gpl2+))
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages gnome)
26 #:use-module (gnu packages gtk)
27 #:use-module (gnu packages image)
28 #:use-module (gnu packages pkg-config)
29 #:use-module (gnu packages xml)
30 #:use-module (gnu packages xorg))
31
32 (define-public openbox
33 (package
34 (name "openbox")
35 (version "3.6.1")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append
39 "http://www.icculus.org/openbox/releases/" name "-"
40 version ".tar.xz"))
41 (sha256
42 (base32
43 "0vg2y1qddsdxkjv806mzpvmkgzliab8ll4s7zm7ma5jnriamirxb"))))
44 (build-system gnu-build-system)
45 (native-inputs `(("pkg-config" ,pkg-config)))
46 (inputs `(("imlib2" ,imlib2)
47 ("libxml2" ,libxml2)
48 ("librsvg" ,librsvg)
49 ("libsm" ,libsm)
50 ("libxcursor" ,libxcursor)
51 ("libxinerama" ,libxinerama)
52 ("libxml2" ,libxml2)
53 ("libxrandr" ,libxrandr)
54 ("libxft" ,libxft)
55 ("pango" ,pango)))
56 (synopsis "Box style window manager")
57 (description
58 "Openbox is a highly configurable, next generation window manager with
59 extensive standards support. The *box visual style is well known for its
60 minimalistic appearance. Openbox uses the *box visual style, while providing
61 a greater number of options for theme developers than previous *box
62 implementations.")
63 (home-page "http://openbox.org/wiki/Main_Page")
64 (license gpl2+)))
65
66 ;;; openbox.scm ends here