Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / avr.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages avr)
20 #:use-module (guix licenses)
21 #:use-module (guix download)
22 #:use-module (guix packages)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages cross-base))
26
27 (define-public avr-libc
28 (package
29 (name "avr-libc")
30 (version "1.8.1")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append
34 "mirror://savannah//avr-libc/avr-libc-"
35 version ".tar.bz2"))
36 (sha256
37 (base32
38 "0sd9qkvhmk9av4g1f8dsjwc309hf1g0731bhvicnjb3b3d42l1n3"))))
39 (build-system gnu-build-system)
40 (arguments
41 `(#:out-of-source? #t
42 #:configure-flags '("--host=avr")))
43
44 (native-inputs `(("cross-binutils" ,(cross-binutils "avr"))
45 ("cross-gcc" ,xgcc-avr)))
46 (home-page "http://www.nongnu.org/avr-libc/")
47 (synopsis "The AVR C Library")
48 (description
49 "AVR Libc is a project whose goal is to provide a high quality C library
50 for use with GCC on Atmel AVR microcontrollers.")
51 (license (non-copyleft "http://www.nongnu.org/avr-libc/LICENSE.txt"))))