Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / libedit.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
3 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages libedit)
23 #:use-module (guix licenses)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu)
27 #:use-module (gnu packages ncurses))
28
29 (define-public libedit
30 (package
31 (name "libedit")
32 (version "20190324-3.1")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (string-append "http://thrysoee.dk/editline"
37 "/libedit-" version ".tar.gz"))
38 (sha256
39 (base32 "1bhvp8xkkgrg89k4ci1k8vjl3nhb6szd4ghy9lp4jrfgq58hz3xc"))))
40 (build-system gnu-build-system)
41 (inputs
42 `(("ncurses" ,ncurses)))
43 (home-page "https://thrysoee.dk/editline/")
44 (synopsis "NetBSD Editline library")
45 (description
46 "This is an autotool- and libtoolized port of the NetBSD Editline
47 library (libedit). This Berkeley-style licensed command line editor library
48 provides generic line editing, history, and tokenization functions, similar to
49 those found in GNU Readline.")
50 (license bsd-3)))