Merge remote-tracking branch 'origin/master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / m4.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages m4)
20 #:use-module (guix licenses)
21 #:use-module (gnu packages)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu))
25
26 (define-public m4
27 (package
28 (name "m4")
29 (version "1.4.18")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append "mirror://gnu/m4/m4-"
33 version ".tar.xz"))
34 (sha256
35 (base32
36 "01sfjd5a4waqw83bibvmn522g69qfqvwig9i2qlgy154l1nfihgj"))))
37 (build-system gnu-build-system)
38 (arguments
39 `(;; Explicitly disable tests when cross-compiling, otherwise 'make check'
40 ;; proceeds and fails, unsurprisingly.
41 #:tests? ,(not (%current-target-system))
42
43 #:phases (alist-cons-before
44 'check 'pre-check
45 (lambda* (#:key inputs #:allow-other-keys)
46 ;; Fix references to /bin/sh.
47 (let ((bash (assoc-ref inputs "bash")))
48 (for-each patch-shebang
49 (find-files "tests" "\\.sh$"))
50 (substitute* (find-files "tests"
51 "posix_spawn")
52 (("/bin/sh")
53 (format #f "~a/bin/sh" bash)))))
54 %standard-phases)))
55 (synopsis "Macro processor")
56 (description
57 "GNU M4 is an implementation of the M4 macro language, which features
58 some extensions over other implementations, some of which are required by GNU
59 Autoconf. It is used as a macro processor, which means it processes text,
60 expanding macros as it encounters them. It also has some built-in functions,
61 for example to run shell commands or to do arithmetic.")
62 (license gpl3+)
63 (home-page "http://www.gnu.org/software/m4/")))