gnu: git-annex: Update to 8.20200810.
[jackhill/guix/guix.git] / gnu / packages / haskell-apps.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
3 ;;; Copyright © 2015, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2016, 2017, 2018 Nikita <nikita@n0.is>
5 ;;; Copyright © 2017 Danny Milosavljevic <dannym@scratchpost.org>
6 ;;; Copyright © 2017, 2018 Alex Vong <alexvong1995@gmail.com>
7 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;; Copyright © 2018 Timothy Sample <samplet@ngyro.com>
9 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
10 ;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
11 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
12 ;;; Copyright © 2019, 2020 Kyle Meyer <kyle@kyleam.com>
13 ;;; Copyright © 2015 John Soo <jsoo1@asu.edu>
14 ;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
15 ;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
16 ;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
17 ;;; Copyright © 2020 Brian Leung <bkleung89@gmail.com>
18 ;;;
19 ;;; This file is part of GNU Guix.
20 ;;;
21 ;;; GNU Guix is free software; you can redistribute it and/or modify it
22 ;;; under the terms of the GNU General Public License as published by
23 ;;; the Free Software Foundation; either version 3 of the License, or (at
24 ;;; your option) any later version.
25 ;;;
26 ;;; GNU Guix is distributed in the hope that it will be useful, but
27 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
28 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
29 ;;; GNU General Public License for more details.
30 ;;;
31 ;;; You should have received a copy of the GNU General Public License
32 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
33
34 (define-module (gnu packages haskell-apps)
35 #:use-module (guix download)
36 #:use-module (guix git-download)
37 #:use-module (guix packages)
38 #:use-module ((guix licenses) #:prefix license:)
39 #:use-module (guix build-system haskell)
40 #:use-module (gnu packages base)
41 #:use-module (gnu packages curl)
42 #:use-module (gnu packages gl)
43 #:use-module (gnu packages haskell)
44 #:use-module (gnu packages haskell-check)
45 #:use-module (gnu packages haskell-crypto)
46 #:use-module (gnu packages haskell-web)
47 #:use-module (gnu packages haskell-xyz)
48 #:use-module (gnu packages ncurses)
49 #:use-module (gnu packages perl)
50 #:use-module (gnu packages pkg-config)
51 #:use-module (gnu packages rsync)
52 #:use-module (gnu packages version-control))
53
54 (define-public apply-refact
55 (package
56 (name "apply-refact")
57 (version "0.6.0.0")
58 (source
59 (origin
60 (method url-fetch)
61 (uri (string-append
62 "https://hackage.haskell.org/package/apply-refact/apply-refact-"
63 version ".tar.gz"))
64 (sha256
65 (base32
66 "0p2mqgjcqr1zcmk8zgr0yq7g8z1agsa6l493lkj6g3ya9lyhxgig"))))
67 (build-system haskell-build-system)
68 (inputs
69 `(("ghc-refact" ,ghc-refact)
70 ("ghc-exactprint" ,ghc-exactprint)
71 ("ghc-syb" ,ghc-syb)
72 ("ghc-temporary" ,ghc-temporary)
73 ("ghc-filemanip" ,ghc-filemanip)
74 ("ghc-unix-compat" ,ghc-unix-compat)
75 ("ghc-optparse-applicative"
76 ,ghc-optparse-applicative)))
77 (native-inputs
78 `(("ghc-tasty" ,ghc-tasty)
79 ("ghc-tasty-golden" ,ghc-tasty-golden)
80 ("ghc-tasty-expected-failure"
81 ,ghc-tasty-expected-failure)
82 ("ghc-silently" ,ghc-silently)))
83 (home-page "https://hackage.haskell.org/package/apply-refact")
84 (synopsis "Perform refactorings specified by the refact library")
85 (description
86 "This package lets you perform refactorings specified by the refact
87 library. It is primarily used with HLint's @code{--refactor} flag.")
88 (license license:bsd-3)))
89
90 ;; In Stackage LTS 14, this package is at 2.4.1.0. However, that
91 ;; version requires version 2.4.1.0 of the 'Cabal' package, which is
92 ;; provided by GHC 8.6.5 at version 2.4.0.1. Hence, we use an older
93 ;; version to match the compiler's library.
94 (define-public cabal-install
95 (package
96 (name "cabal-install")
97 (version "2.4.0.0")
98 (source
99 (origin
100 (method url-fetch)
101 (uri (string-append
102 "https://hackage.haskell.org/package/cabal-install/cabal-install-"
103 version
104 ".tar.gz"))
105 (sha256
106 (base32 "1xmyl0x8wqfrnray6ky5wy0g0samv4264fbdlzxhqsvk9dbfja8k"))))
107 (build-system haskell-build-system)
108 (arguments
109 `(#:cabal-revision
110 ("2" "1xil5pim6j1ckqj61zz6l7xpfxxr3rkw2hvpws2f7pr9shk645dl")
111 #:phases
112 (modify-phases %standard-phases
113 (add-before 'configure 'update-constraints
114 (lambda _
115 (substitute* "cabal-install.cabal"
116 (("zip-archive >= 0\\.3\\.2\\.5 && < 0\\.4,")
117 "zip-archive >= 0.3.2.5 && <= 0.4.1,"))
118 #t)))))
119 (inputs
120 `(("ghc-async" ,ghc-async)
121 ("ghc-base16-bytestring" ,ghc-base16-bytestring)
122 ("ghc-cryptohash-sha256" ,ghc-cryptohash-sha256)
123 ("ghc-echo" ,ghc-echo)
124 ("ghc-edit-distance" ,ghc-edit-distance)
125 ("ghc-hackage-security" ,ghc-hackage-security)
126 ("ghc-hashable" ,ghc-hashable)
127 ("ghc-http" ,ghc-http)
128 ("ghc-network-uri" ,ghc-network-uri)
129 ("ghc-network" ,ghc-network)
130 ("ghc-random" ,ghc-random)
131 ("ghc-resolv" ,ghc-resolv)
132 ("ghc-tar" ,ghc-tar)
133 ("ghc-zip-archive" ,ghc-zip-archive)
134 ("ghc-zlib" ,ghc-zlib)))
135 (home-page "https://www.haskell.org/cabal/")
136 (synopsis "Command-line interface for Cabal and Hackage")
137 (description
138 "The cabal command-line program simplifies the process of managing
139 Haskell software by automating the fetching, configuration, compilation and
140 installation of Haskell libraries and programs.")
141 (license license:bsd-3)))
142
143 (define-public corrode
144 (let ((commit "b6699fb2fa552a07c6091276285a44133e5c9789"))
145 (package
146 (name "corrode")
147 (version (string-append "0.0.1-" (string-take commit 7)))
148 (source
149 (origin
150 (method git-fetch)
151 (uri (git-reference
152 (url "https://github.com/jameysharp/corrode")
153 (commit "b6699fb2fa552a07c6091276285a44133e5c9789")))
154 (file-name (git-file-name name version))
155 (sha256
156 (base32 "02v0yyj6sk4gpg2222wzsdqjxn8w66scbnf6b20x0kbmc69qcz4r"))))
157 (build-system haskell-build-system)
158 (inputs
159 `(("ghc-language-c" ,ghc-language-c)
160 ("ghc-markdown-unlit" ,ghc-markdown-unlit)))
161 (home-page "https://github.com/jameysharp/corrode")
162 (synopsis "Automatic semantics-preserving translation from C to Rust")
163 (description
164 "This program reads a C source file and prints an equivalent module in
165 Rust syntax. It is intended to be useful for two different purposes:
166
167 @enumerate
168 @item Partial automation for migrating legacy code that was implemented in C.
169 @item A new, complementary approach to static analysis for C programs.
170 @end enumerate\n")
171 (license license:gpl2+))))
172
173 (define-public cpphs
174 (package
175 (name "cpphs")
176 (version "1.20.8")
177 (source
178 (origin
179 (method url-fetch)
180 (uri (string-append
181 "https://hackage.haskell.org/package/" name "/"
182 name "-" version ".tar.gz"))
183 (sha256
184 (base32
185 "1bh524asqhk9v1s0wvipl0hgn7l63iy3js867yv0z3h5v2kn8vg5"))))
186 (build-system haskell-build-system)
187 (inputs
188 `(("ghc-polyparse" ,ghc-polyparse)
189 ("ghc-old-locale" ,ghc-old-locale)
190 ("ghc-old-time" ,ghc-old-time)))
191 (home-page "http://projects.haskell.org/cpphs/")
192 (synopsis "Liberalised re-implementation of cpp, the C pre-processor")
193 (description "Cpphs is a re-implementation of the C pre-processor that is
194 both more compatible with Haskell, and itself written in Haskell so that it
195 can be distributed with compilers. This version of the C pre-processor is
196 pretty-much feature-complete and compatible with traditional (K&R)
197 pre-processors. Additional features include: a plain-text mode; an option to
198 unlit literate code files; and an option to turn off macro-expansion.")
199 (license (list license:lgpl2.1+ license:gpl3+))))
200
201 ;; Darcs has no https support:
202 ;; http://darcs.net/manual/Configuring_darcs.html#SECTION00440070000000000000
203 ;; and results of search engines will show that if the protocol is http, https
204 ;; is never mentioned.
205 (define-public darcs
206 (package
207 (name "darcs")
208 (version "2.14.2")
209 (source
210 (origin
211 (method url-fetch)
212 (uri (string-append "https://hackage.haskell.org/package/darcs/"
213 "darcs-" version ".tar.gz"))
214 (sha256
215 (base32
216 "0zm2486gyhiga1amclbg92cd09bvki6vgh0ll75hv5kl72j61lb5"))
217 (modules '((guix build utils)))
218 ;; Remove time-dependent code for reproducibility.
219 (snippet
220 '(begin
221 (substitute* "darcs/darcs.hs"
222 (("__DATE__") "\"1970-01-01\"")
223 (("__TIME__") "\"00:00:00\""))
224 #t))))
225 (build-system haskell-build-system)
226 (arguments
227 `(#:cabal-revision
228 ("1" "0xl7j5cm704pbl2ms0dkydh7jvrz0ym76d725ifpg4h902m1zkhg")
229 #:configure-flags '("-fpkgconfig" "-fcurl" "-flibiconv" "-fthreaded"
230 "-fnetwork-uri" "-fhttp" "--flag=executable"
231 "--flag=library")
232 #:phases
233 (modify-phases %standard-phases
234 (add-after 'patch-source-shebangs 'patch-sh
235 (lambda _
236 (substitute* "tests/issue538.sh"
237 (("/bin/sh") (which "sh")))
238 #t))
239 (add-before 'configure 'update-constraints
240 (lambda _
241 (substitute* "darcs.cabal"
242 (("QuickCheck >= 2\\.8\\.2 && < 2\\.13,")
243 "QuickCheck >= 2.8.2 && < 2.14,"))
244 #t)))))
245 (inputs
246 `(("ghc-cmdargs" ,ghc-cmdargs)
247 ("ghc-split" ,ghc-split)
248 ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
249 ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
250 ("ghc-test-framework" ,ghc-test-framework)
251 ("ghc-quickcheck" ,ghc-quickcheck)
252 ("ghc-findbin" ,ghc-findbin)
253 ("ghc-hunit" ,ghc-hunit)
254 ("ghc-async" ,ghc-async)
255 ("ghc-attoparsec" ,ghc-attoparsec)
256 ("ghc-base16-bytestring" ,ghc-base16-bytestring)
257 ("ghc-bytestring-builder" ,ghc-bytestring-builder)
258 ("ghc-cryptohash" ,ghc-cryptohash)
259 ("ghc-data-ordlist" ,ghc-data-ordlist)
260 ("ghc-fgl" ,ghc-fgl)
261 ("ghc-system-filepath" ,ghc-system-filepath)
262 ("ghc-graphviz" ,ghc-graphviz)
263 ("ghc-hashable" ,ghc-hashable)
264 ("ghc-html" ,ghc-html)
265 ("ghc-mmap" ,ghc-mmap)
266 ("ghc-old-time" ,ghc-old-time)
267 ("ghc-random" ,ghc-random)
268 ("ghc-regex-applicative" ,ghc-regex-applicative)
269 ("ghc-regex-compat-tdfa" ,ghc-regex-compat-tdfa)
270 ("ghc-sandi" ,ghc-sandi)
271 ("ghc-shelly" ,ghc-shelly)
272 ("ghc-tar" ,ghc-tar)
273 ("ghc-transformers-compat" ,ghc-transformers-compat)
274 ("ghc-unix-compat" ,ghc-unix-compat)
275 ("ghc-utf8-string" ,ghc-utf8-string)
276 ("ghc-vector" ,ghc-vector)
277 ("ghc-zip-archive" ,ghc-zip-archive)
278 ("ghc-zlib" ,ghc-zlib)
279 ("ghc-http" ,ghc-http)
280 ("curl" ,curl)
281 ("ghc" ,ghc)
282 ("ncurses" ,ncurses)
283 ("perl" ,perl)
284 ("libiconv" ,libiconv)
285 ("ghc-network" ,ghc-network)
286 ("ghc-network-uri" ,ghc-network-uri)))
287 (native-inputs
288 `(("pkg-config" ,pkg-config)))
289 (home-page "http://darcs.net")
290 (synopsis "Distributed Revision Control System")
291 (description
292 "Darcs is a revision control system. It is:
293
294 @enumerate
295 @item Distributed: Every user has access to the full command set, removing boundaries
296 between server and client or committer and non-committers.
297 @item Interactive: Darcs is easy to learn and efficient to use because it asks you
298 questions in response to simple commands, giving you choices in your work flow.
299 You can choose to record one change in a file, while ignoring another. As you update
300 from upstream, you can review each patch name, even the full diff for interesting
301 patches.
302 @item Smart: Originally developed by physicist David Roundy, darcs is based on a
303 unique algebra of patches called @url{http://darcs.net/Theory,Patchtheory}.
304 @end enumerate")
305 (license license:gpl2)))
306
307 (define-public ghcid
308 (package
309 (name "ghcid")
310 (version "0.8.4")
311 (source
312 (origin
313 (method url-fetch)
314 (uri (string-append "https://hackage.haskell.org/package/ghcid/"
315 "ghcid-" version ".tar.gz"))
316 (sha256
317 (base32
318 "0wpm4ikrm1krz1ckzwk0srng091yh2skjal4fh95iz1hq3dw6qlw"))))
319 (build-system haskell-build-system)
320 (inputs
321 `(("ghc-extra" ,ghc-extra)
322 ("ghc-ansi-terminal" ,ghc-ansi-terminal)
323 ("ghc-cmdargs" ,ghc-cmdargs)
324 ("ghc-fsnotify" ,ghc-fsnotify)
325 ("ghc-terminal-size" ,ghc-terminal-size)))
326 (native-inputs
327 `(("ghc-tasty" ,ghc-tasty)
328 ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
329 (home-page
330 "https://github.com/ndmitchell/ghcid#readme")
331 (synopsis "GHCi based bare bones IDE")
332 (description
333 "Either \"GHCi as a daemon\" or \"GHC + a bit of an IDE\". A very simple Haskell
334 development tool which shows you the errors in your project and updates them whenever
335 you save. Run @code{ghcid --topmost --command=ghci}, where @code{--topmost} makes the
336 window on top of all others (Windows only) and @code{--command} is the command to start
337 GHCi on your project (defaults to @code{ghci} if you have a @file{.ghci} file, or else
338 to @code{cabal repl}).")
339 (license license:bsd-3)))
340
341 (define-public git-annex
342 (package
343 (name "git-annex")
344 (version "8.20200810")
345 (source
346 (origin
347 (method url-fetch)
348 (uri (string-append "https://hackage.haskell.org/package/"
349 "git-annex/git-annex-" version ".tar.gz"))
350 (sha256
351 (base32 "1wy6ckcf5f6m94gakg1504h1zryail3mmj85sglq03s45vawjcg6"))))
352 (build-system haskell-build-system)
353 (arguments
354 `(#:configure-flags
355 '("--flags=-Android -Assistant -Pairing -Webapp -WebDAV")
356 #:phases
357 (modify-phases %standard-phases
358 (add-before 'configure 'patch-shell-for-tests
359 (lambda _
360 ;; Shell.hs defines "/bin/sh" that is used in Git hooks. We
361 ;; shouldn't patch hooks with Guix's current bash because the
362 ;; hooks can exist after that bash is garbage collected, but
363 ;; let's temporarily patch it so that we can run the tests.
364 (copy-file "Utility/Shell.hs" "/tmp/Shell.hs")
365 (substitute* "Utility/Shell.hs"
366 (("/bin/sh") (which "sh")))
367 #t))
368 (add-before 'configure 'factor-setup
369 (lambda _
370 ;; Factor out necessary build logic from the provided
371 ;; `Setup.hs' script. The script as-is does not work because
372 ;; it cannot find its dependencies, and there is no obvious way
373 ;; to tell it where to look.
374 (call-with-output-file "PreConf.hs"
375 (lambda (out)
376 (format out "import qualified Build.Configure as Configure~%")
377 (format out "main = Configure.run Configure.tests~%")))
378 (call-with-output-file "Setup.hs"
379 (lambda (out)
380 (format out "import Distribution.Simple~%")
381 (format out "main = defaultMain~%")))
382 #t))
383 (add-before 'configure 'pre-configure
384 (lambda _
385 (invoke "runhaskell" "PreConf.hs")
386 #t))
387 (add-after 'build 'build-manpages
388 (lambda _
389 ;; The Setup.hs rewrite above removed custom code for building
390 ;; the man pages. In addition to that code, git-annex's source
391 ;; tree has a file that's not included in the tarball but is used
392 ;; by the Makefile to build man pages. Copy the core bits here.
393 (call-with-output-file "Build/MakeMans.hs"
394 (lambda (out)
395 (format out "module Main where~%")
396 (format out "import Build.Mans~%")
397 (format out "main = buildMansOrWarn~%")))
398 (invoke "runhaskell" "Build/MakeMans.hs")))
399 (replace 'check
400 (lambda _
401 ;; We need to set the path so that Git recognizes
402 ;; `git annex' as a custom command.
403 (setenv "PATH" (string-append (getenv "PATH") ":"
404 (getcwd) "/dist/build/git-annex"))
405 (with-directory-excursion "dist/build/git-annex"
406 (symlink "git-annex" "git-annex-shell"))
407 (invoke "git-annex" "test")
408 #t))
409 (add-after 'check 'unpatch-shell-and-rebuild
410 (lambda args
411 ;; Undo `patch-shell-for-tests'.
412 (copy-file "/tmp/Shell.hs" "Utility/Shell.hs")
413 (apply (assoc-ref %standard-phases 'build) args)))
414 (add-after 'install 'install-manpages
415 (lambda* (#:key outputs #:allow-other-keys)
416 (let ((man (string-append (assoc-ref outputs "out")
417 "/man/man1/")))
418 (mkdir-p man)
419 (for-each (lambda (file) (install-file file man))
420 (find-files "man")))
421 #t))
422 (add-after 'install 'install-symlinks
423 (lambda* (#:key outputs #:allow-other-keys)
424 (let* ((out (assoc-ref outputs "out"))
425 (bin (string-append out "/bin")))
426 (symlink (string-append bin "/git-annex")
427 (string-append bin "/git-annex-shell"))
428 (symlink (string-append bin "/git-annex")
429 (string-append bin "/git-remote-tor-annex"))
430 #t))))))
431 (inputs
432 `(("curl" ,curl)
433 ("ghc-aeson" ,ghc-aeson)
434 ("ghc-async" ,ghc-async)
435 ("ghc-aws" ,ghc-aws)
436 ("ghc-bloomfilter" ,ghc-bloomfilter)
437 ("ghc-byteable" ,ghc-byteable)
438 ("ghc-case-insensitive" ,ghc-case-insensitive)
439 ("ghc-concurrent-output" ,ghc-concurrent-output)
440 ("ghc-crypto-api" ,ghc-crypto-api)
441 ("ghc-cryptonite" ,ghc-cryptonite)
442 ("ghc-data-default" ,ghc-data-default)
443 ("ghc-disk-free-space" ,ghc-disk-free-space)
444 ("ghc-dlist" ,ghc-dlist)
445 ("ghc-edit-distance" ,ghc-edit-distance)
446 ("ghc-esqueleto" ,ghc-esqueleto)
447 ("ghc-exceptions" ,ghc-exceptions)
448 ("ghc-feed" ,ghc-feed)
449 ("ghc-filepath-bytestring" ,ghc-filepath-bytestring)
450 ("ghc-free" ,ghc-free)
451 ("ghc-hslogger" ,ghc-hslogger)
452 ("ghc-http-client" ,ghc-http-client)
453 ("ghc-http-conduit" ,ghc-http-conduit)
454 ("ghc-http-types" ,ghc-http-types)
455 ("ghc-ifelse" ,ghc-ifelse)
456 ("ghc-magic" ,ghc-magic)
457 ("ghc-memory" ,ghc-memory)
458 ("ghc-monad-control" ,ghc-monad-control)
459 ("ghc-monad-logger" ,ghc-monad-logger)
460 ("ghc-network" ,ghc-network)
461 ("ghc-old-locale" ,ghc-old-locale)
462 ("ghc-optparse-applicative" ,ghc-optparse-applicative)
463 ("ghc-persistent" ,ghc-persistent)
464 ("ghc-persistent-sqlite" ,ghc-persistent-sqlite)
465 ("ghc-persistent-template" ,ghc-persistent-template)
466 ("ghc-quickcheck" ,ghc-quickcheck)
467 ("ghc-random" ,ghc-random)
468 ("ghc-regex-tdfa" ,ghc-regex-tdfa)
469 ("ghc-resourcet" ,ghc-resourcet)
470 ("ghc-safesemaphore" ,ghc-safesemaphore)
471 ("ghc-sandi" ,ghc-sandi)
472 ("ghc-securemem" ,ghc-securemem)
473 ("ghc-socks" ,ghc-socks)
474 ("ghc-split" ,ghc-split)
475 ("ghc-stm-chans" ,ghc-stm-chans)
476 ("ghc-tagsoup" ,ghc-tagsoup)
477 ("ghc-unix-compat" ,ghc-unix-compat)
478 ("ghc-unordered-containers" ,ghc-unordered-containers)
479 ("ghc-utf8-string" ,ghc-utf8-string)
480 ("ghc-uuid" ,ghc-uuid)
481 ("git" ,git)
482 ("rsync" ,rsync)))
483 (native-inputs
484 `(("ghc-tasty" ,ghc-tasty)
485 ("ghc-tasty-hunit" ,ghc-tasty-hunit)
486 ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
487 ("ghc-tasty-rerun" ,ghc-tasty-rerun)
488 ("perl" ,perl)))
489 (home-page "https://git-annex.branchable.com/")
490 (synopsis "Manage files with Git, without checking in their contents")
491 (description "This package allows managing files with Git, without
492 checking the file contents into Git. It can store files in many places,
493 such as local hard drives and cloud storage services. It can also be
494 used to keep a folder in sync between computers.")
495 ;; The main author has released all his changes under AGPLv3+ as of March
496 ;; 2019 (7.20190219-187-g40ecf58d4). These are also licensed under the
497 ;; original GPLv3+ license, but going forward new changes will be under
498 ;; only AGPLv3+. The other licenses below cover code written by others.
499 ;; See git-annex's COPYRIGHT file for details on each file.
500 (license (list license:agpl3+
501 license:gpl3+
502 license:bsd-2
503 license:expat
504 license:gpl2))))
505
506 (define-public hlint
507 (package
508 (name "hlint")
509 (version "2.1.26")
510 (source
511 (origin
512 (method url-fetch)
513 (uri (string-append
514 "https://hackage.haskell.org/package/" name
515 "/" name "-" version ".tar.gz"))
516 (sha256
517 (base32
518 "16zkkpbfrd69853cdqf597fva969lirfc86b039i9zd7ghlrcayc"))))
519 (build-system haskell-build-system)
520 (inputs
521 `(("cpphs" ,cpphs)
522 ("ghc-unordered-containers" ,ghc-unordered-containers)
523 ("ghc-yaml" ,ghc-yaml)
524 ("ghc-vector" ,ghc-vector)
525 ("ghc-data-default" ,ghc-data-default)
526 ("ghc-cmdargs" ,ghc-cmdargs)
527 ("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
528 ("ghc-haskell-src-exts-util" ,ghc-haskell-src-exts-util)
529 ("ghc-uniplate" ,ghc-uniplate)
530 ("ghc-ansi-terminal" ,ghc-ansi-terminal)
531 ("ghc-extra" ,ghc-extra)
532 ("ghc-refact" ,ghc-refact)
533 ("ghc-aeson" ,ghc-aeson)
534 ("ghc-lib-parser" ,ghc-lib-parser)
535 ("hscolour" ,hscolour)))
536 (home-page "https://github.com/ndmitchell/hlint")
537 (synopsis "Suggest improvements for Haskell source code")
538 (description "HLint reads Haskell programs and suggests changes that
539 hopefully make them easier to read. HLint also makes it easy to disable
540 unwanted suggestions, and to add your own custom suggestions.")
541 (license license:bsd-3)))
542
543 (define-public hoogle
544 (package
545 (name "hoogle")
546 (version "5.0.17.11")
547 (source
548 (origin
549 (method url-fetch)
550 (uri
551 (string-append
552 "https://hackage.haskell.org/package/hoogle/hoogle-"
553 version ".tar.gz"))
554 (sha256
555 (base32
556 "1svp8z9pad8z2j386pr0dda0ds8ddxab0salnz4gm51q877w93p1"))))
557 (build-system haskell-build-system)
558 (inputs
559 `(("ghc-quickcheck" ,ghc-quickcheck)
560 ("ghc-aeson" ,ghc-aeson)
561 ("ghc-blaze-html" ,ghc-blaze-html)
562 ("ghc-blaze-markup" ,ghc-blaze-markup)
563 ("ghc-cmdargs" ,ghc-cmdargs)
564 ("ghc-conduit" ,ghc-conduit)
565 ("ghc-conduit-extra" ,ghc-conduit-extra)
566 ("ghc-connection" ,ghc-connection)
567 ("ghc-extra" ,ghc-extra)
568 ("ghc-foundation" ,ghc-foundation)
569 ("ghc-old-locale" ,ghc-old-locale)
570 ("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
571 ("ghc-http-conduit" ,ghc-http-conduit)
572 ("ghc-http-types" ,ghc-http-types)
573 ("ghc-js-flot" ,ghc-js-flot)
574 ("ghc-js-jquery" ,ghc-js-jquery)
575 ("ghc-mmap" ,ghc-mmap)
576 ("ghc-process-extras" ,ghc-process-extras)
577 ("ghc-resourcet" ,ghc-resourcet)
578 ("ghc-storable-tuple" ,ghc-storable-tuple)
579 ("ghc-tar" ,ghc-tar)
580 ("ghc-uniplate" ,ghc-uniplate)
581 ("ghc-utf8-string" ,ghc-utf8-string)
582 ("ghc-vector" ,ghc-vector)
583 ("ghc-wai" ,ghc-wai)
584 ("ghc-wai-logger" ,ghc-wai-logger)
585 ("ghc-warp" ,ghc-warp)
586 ("ghc-warp-tls" ,ghc-warp-tls)
587 ("ghc-zlib" ,ghc-zlib)))
588 (home-page "https://hoogle.haskell.org/")
589 (synopsis "Haskell API Search")
590 (description "Hoogle is a Haskell API search engine, which allows
591 you to search many standard Haskell libraries by either function name,
592 or by approximate type signature.")
593 (license license:bsd-3)))
594
595 (define-public hscolour
596 (package
597 (name "hscolour")
598 (version "1.24.4")
599 (source
600 (origin
601 (method url-fetch)
602 (uri (string-append
603 "https://hackage.haskell.org/package/hscolour/hscolour-"
604 version
605 ".tar.gz"))
606 (sha256
607 (base32
608 "079jwph4bwllfp03yfr26s5zc6m6kw3nhb1cggrifh99haq34cr4"))))
609 (build-system haskell-build-system)
610 (home-page "https://hackage.haskell.org/package/hscolour")
611 (synopsis "Script to colourise Haskell code")
612 (description "HSColour is a small Haskell script to colourise Haskell
613 code. It currently has six output formats: ANSI terminal codes (optionally
614 XTerm-256colour codes), HTML 3.2 with font tags, HTML 4.01 with CSS, HTML 4.01
615 with CSS and mouseover annotations, XHTML 1.0 with inline CSS styling, LaTeX,
616 and mIRC chat codes.")
617 (license license:bsd-3)))
618
619 (define-public kmonad
620 (package
621 (name "kmonad")
622 (version "0.3.0")
623 (source
624 (origin
625 (method git-fetch)
626 (uri (git-reference
627 (url "https://github.com/david-janssen/kmonad")
628 (commit version)))
629 (file-name (git-file-name name version))
630 (sha256
631 (base32 "1g40nkpldih6h1rlxjx5yf9iavr3qs1f2b6j0gd8135p5hkg8d8n"))))
632 (build-system haskell-build-system)
633 (arguments
634 `(#:phases
635 (modify-phases %standard-phases
636 (delete 'haddock) ; Haddock fails to generate docs
637 (add-after 'install 'install-udev-rules
638 (lambda* (#:key outputs #:allow-other-keys)
639 (let* ((out (assoc-ref outputs "out"))
640 (rules (string-append out "/lib/udev/rules.d")))
641 (mkdir-p rules)
642 (call-with-output-file (string-append rules "/70-kmonad.rules")
643 (lambda (port)
644 (display
645 (string-append
646 "KERNEL==\"uinput\", MODE=\"0660\", "
647 "GROUP=\"input\", OPTIONS+=\"static_node=uinput\"\n")
648 port)))
649 #t)))
650 (add-after 'install-udev-rules 'install-documentation
651 (lambda* (#:key outputs #:allow-other-keys)
652 (let* ((out (assoc-ref outputs "out"))
653 (doc (string-append out "/share/doc/kmonad-" ,version)))
654 (install-file "README.md" doc)
655 (copy-recursively "doc" doc)
656 (copy-recursively "example" (string-append doc "/example"))
657 #t))))))
658 (inputs
659 `(("ghc-cereal" ,ghc-cereal)
660 ("ghc-exceptions" ,ghc-exceptions)
661 ("ghc-hashable" ,ghc-hashable)
662 ("ghc-lens" ,ghc-lens)
663 ("ghc-megaparsec" ,ghc-megaparsec)
664 ("ghc-optparse-applicative" ,ghc-optparse-applicative)
665 ("ghc-unagi-chan" ,ghc-unagi-chan)
666 ("ghc-unliftio" ,ghc-unliftio)
667 ("ghc-unordered-containers" ,ghc-unordered-containers)))
668 (home-page "https://github.com/david-janssen/kmonad")
669 (synopsis "Advanced keyboard manager")
670 (description "KMonad is a keyboard remapping utility that supports
671 advanced functionality, such as custom keymap layers and modifiers, macros,
672 and conditional mappings that send a different keycode when tapped or held.
673 By operating at a lower level than most similar tools, it supports X11,
674 Wayland, and Linux console environments alike.")
675 (license license:expat)))
676
677 (define-public raincat
678 (package
679 (name "raincat")
680 (version "1.2.1")
681 (source
682 (origin
683 (method url-fetch)
684 (uri (string-append "mirror://hackage/package/Raincat/"
685 "Raincat-" version ".tar.gz"))
686 (sha256
687 (base32
688 "10y9zi22m6hf13c9h8zd9vg7mljpwbw0r3djb6r80bna701fdf6c"))))
689 (build-system haskell-build-system)
690 (arguments
691 `(#:phases
692 (modify-phases %standard-phases
693 (add-after 'install 'wrap-executable
694 (lambda* (#:key inputs outputs #:allow-other-keys)
695 (let ((out (assoc-ref outputs "out")))
696 (wrap-program (string-append out "/bin/raincat")
697 `("LD_LIBRARY_PATH" ":" =
698 (,(string-append (assoc-ref inputs "freeglut")
699 "/lib"))))
700 #t))))))
701 (inputs
702 `(("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
703 ("ghc-random" ,ghc-random)
704 ("ghc-glut" ,ghc-glut)
705 ("freeglut" ,freeglut)
706 ("ghc-opengl" ,ghc-opengl)
707 ("ghc-sdl2" ,ghc-sdl2)
708 ("ghc-sdl2-image" ,ghc-sdl2-image)
709 ("ghc-sdl2-mixer" ,ghc-sdl2-mixer)))
710 (home-page "https://www.gamecreation.org/games/raincat")
711 (synopsis "Puzzle game with a cat in lead role")
712 (description "Project Raincat is a game developed by Carnegie Mellon
713 students through GCS during the Fall 2008 semester. Raincat features game
714 play inspired from classics Lemmings and The Incredible Machine. The project
715 proved to be an excellent learning experience for the programmers. Everything
716 is programmed in Haskell.")
717 (license license:bsd-3)))
718
719 (define-public scroll
720 (package
721 (name "scroll")
722 (version "1.20180421")
723 (source
724 (origin
725 (method url-fetch)
726 (uri (string-append
727 "https://hackage.haskell.org/package/scroll/scroll-"
728 version ".tar.gz"))
729 (sha256
730 (base32
731 "0apzrvf99rskj4dbmn57jjxrsf19j436s8a09m950df5aws3a0wj"))))
732 (build-system haskell-build-system)
733 (inputs
734 `(("ghc-case-insensitive" ,ghc-case-insensitive)
735 ("ghc-data-default" ,ghc-data-default)
736 ("ghc-ifelse" ,ghc-ifelse)
737 ("ghc-monad-loops" ,ghc-monad-loops)
738 ("ghc-ncurses" ,ghc-ncurses)
739 ("ghc-optparse-applicative" ,ghc-optparse-applicative)
740 ("ghc-random" ,ghc-random)
741 ("ghc-vector" ,ghc-vector)))
742 (home-page "https://joeyh.name/code/scroll/")
743 (synopsis "scroll(6), a roguelike game")
744 (description
745 "You're a bookworm that's stuck on a scroll. You have to dodge between
746 words and use spells to make your way down the page as the scroll is read. Go
747 too slow and you'll get wound up in the scroll and crushed.")
748 (license license:gpl2)))
749
750 (define-public shellcheck
751 (package
752 (name "shellcheck")
753 (version "0.7.0")
754 (source
755 (origin
756 (method url-fetch)
757 (uri (string-append
758 "https://hackage.haskell.org/package/ShellCheck/ShellCheck-"
759 version ".tar.gz"))
760 (sha256
761 (base32 "1vx895cp5k5h0680xfwj74lk97m9y627n965x6srds0gfnbkzy9s"))
762 (file-name (string-append name "-" version ".tar.gz"))))
763 (build-system haskell-build-system)
764 (inputs
765 `(("ghc-aeson" ,ghc-aeson)
766 ("ghc-diff" ,ghc-diff)
767 ("ghc-quickcheck" ,ghc-quickcheck)
768 ("ghc-regex-tdfa" ,ghc-regex-tdfa)))
769 (home-page "https://www.shellcheck.net/")
770 (synopsis "Static analysis for shell scripts")
771 (description "@code{shellcheck} provides static analysis for
772 @command{bash} and @command{sh} shell scripts.
773 It gives warnings and suggestions in order to:
774
775 @enumerate
776 @item Point out and clarify typical beginner's syntax issues that cause
777 a shell to give cryptic error messages.
778 @item Point out and clarify typical intermediate level semantic problems
779 that cause a shell to behave strangely and counter-intuitively.
780 @item Point out subtle caveats, corner cases and pitfalls that may cause an
781 advanced user's otherwise working script to fail under future circumstances.
782 @end enumerate")
783 (license license:gpl3+)))
784
785 (define-public shelltestrunner
786 (package
787 (name "shelltestrunner")
788 (version "1.9")
789 (source (origin
790 (method url-fetch)
791 (uri (string-append "mirror://hackage/package/shelltestrunner-"
792 version "/shelltestrunner-" version ".tar.gz"))
793 (sha256
794 (base32
795 "1a5kzqbwg6990249ypw0cx6cqj6663as1kbj8nzblcky8j6kbi6b"))))
796 (build-system haskell-build-system)
797 (arguments
798 '(#:phases
799 (modify-phases %standard-phases
800 (delete 'check)
801 (add-after 'install 'check
802 (lambda* (#:key outputs tests? parallel-tests? #:allow-other-keys)
803 ;; This test is inspired by the Makefile in the upstream
804 ;; repository, which is missing in the Hackage release tarball
805 ;; along with some of the tests. The Makefile would not work
806 ;; anyway as it ties into the 'stack' build tool.
807 (let* ((out (assoc-ref outputs "out"))
808 (shelltest (string-append out "/bin/shelltest"))
809 (numjobs (if parallel-tests?
810 (number->string (parallel-job-count))
811 "1")))
812 (if tests?
813 (invoke shelltest (string-append "-j" numjobs)
814 "tests/examples")
815 (format #t "test suite not run~%"))
816 #t))))))
817 (inputs
818 `(("ghc-diff" ,ghc-diff)
819 ("ghc-cmdargs" ,ghc-cmdargs)
820 ("ghc-filemanip" ,ghc-filemanip)
821 ("ghc-hunit" ,ghc-hunit)
822 ("ghc-pretty-show" ,ghc-pretty-show)
823 ("ghc-regex-tdfa" ,ghc-regex-tdfa)
824 ("ghc-safe" ,ghc-safe)
825 ("ghc-utf8-string" ,ghc-utf8-string)
826 ("ghc-test-framework" ,ghc-test-framework)
827 ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)))
828 (home-page "https://github.com/simonmichael/shelltestrunner")
829 (synopsis "Test CLI programs")
830 (description
831 "shelltestrunner (executable: @command{shelltest}) is a command-line tool
832 for testing command-line programs, or general shell commands. It reads simple
833 test specifications defining a command to run, some input, and the expected
834 output, stderr, and exit status.")
835 (license license:gpl3+)))
836
837 (define-public stylish-haskell
838 (package
839 (name "stylish-haskell")
840 (version "0.9.2.2")
841 (source
842 (origin
843 (method url-fetch)
844 (uri
845 (string-append
846 "mirror://hackage/package/stylish-haskell/"
847 "stylish-haskell-" version ".tar.gz"))
848 (sha256
849 (base32
850 "1zs624xqp6j8vrl6pfv18dm8vz8hvz25grri65ximxhcizgwhnax"))))
851 (build-system haskell-build-system)
852 (inputs
853 `(("ghc-aeson" ,ghc-aeson)
854 ("ghc-file-embed" ,ghc-file-embed)
855 ("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
856 ("ghc-semigroups" ,ghc-semigroups)
857 ("ghc-syb" ,ghc-syb)
858 ("ghc-yaml" ,ghc-yaml)
859 ("ghc-strict" ,ghc-strict)
860 ("ghc-optparse-applicative" ,ghc-optparse-applicative)
861 ("ghc-hunit" ,ghc-hunit)
862 ("ghc-test-framework" ,ghc-test-framework)
863 ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)))
864 (home-page "https://github.com/jaspervdj/stylish-haskell")
865 (synopsis "Haskell code prettifier")
866 (description "Stylish-haskell is a Haskell code prettifier. The goal is
867 not to format all of the code in a file, to avoid \"getting in the way\".
868 However, this tool can e.g. clean up import statements and help doing various
869 tasks that get tedious very quickly. It can
870 @itemize
871 @item
872 Align and sort @code{import} statements
873 @item
874 Group and wrap @code{{-# LANGUAGE #-}} pragmas, remove (some) redundant
875 pragmas
876 @item
877 Remove trailing whitespaces
878 @item
879 Align branches in @code{case} and fields in records
880 @item
881 Convert line endings (customisable)
882 @item
883 Replace tabs by four spaces (turned off by default)
884 @item
885 Replace some ASCII sequences by their Unicode equivalent (turned off by
886 default)
887 @end itemize")
888 (license license:bsd-3)))
889
890 (define-public ghc-stylish-haskell
891 (deprecated-package "ghc-stylish-haskell" stylish-haskell))